Subject: Re: [Secdispatch] Call for agenda items at IETF 103

From: Daniel Van Geest <[email-masked]>
Date: Sun, 14 Oct 2018 02:55:05 +0000

I’d like this to be added to the agenda:

https://tools.ietf.org/html/draft-vangeest-x509-hash-sigs-01

It was posted to the LAMPS mailing list (https://mailarchive.ietf.org/arch/browse/spasm/?gbt=1&index=5ZvLCxo3HTakvUZnv5KzkMzlqGE) with some discussion, and Russ suggested it should go through secdispatch, with a discussion at the end of the LAMPS session as well, if time allows.

The draft defines algorithm identifiers for HSS and XMSS(^MT) hash-based signature schemes for use in X.509 certificates.  Hash-based signatures are a well-studied class of quantum-safe signature algorithms which can be deployed now for roots of trust and code signing.  My employer has seen interest in these signature schemes for X.509 certificates and is implementing support for them.  I know of at least one other company doing the same and we’d like to standardize on a set of publicly accepted algorithm identifiers.

The desired next steps would be to have this added to the LAMPS charter.

Thanks,
Daniel

On 2018-10-03, 8:48 AM, "Secdispatch on behalf of Roman Danyliw" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hello!

SecDispatch will be meeting at IETF 103 (at a time yet to be determined).  If you would like time on the agenda, send your request to the mailing list.  Helpful items to include in your request (if known/applicable) are:

(1) pointers to a draft(s)
(2) pointers to ongoing/prior discussions
(3) pointers to implementations
(4) pointers to any other background materials
(5) summarizing prior engagement with existing WGs
(6) summarizing who would want to advance this work
(7) desired next steps

If needed, precedence will be given to documents that have demonstrated interest in the form of active drafts and list discussion.

If you have questions, please reach out to the co-chairs.

Regards,
Roman and Richard

_______________________________________________
Secdispatch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/secdispatch

---

From: Hirotaka NAKAJIMA <[email-masked]>
Date: Fri, 19 Oct 2018 09:03:01 +0900

Hi,

I’d like to add this to be added to the agenda.
https://datatracker.ietf.org/doc/draft-vcgtf-crypto-assets-security-considerations/

This draft is to propose a security considerations for crypto assets custodians including management of private key for crypto assets (e.g. Bitcoin)
We(Authors) are not sure which working group in IETF would be suitable for this draft but we believe Security Area is one of an area should be involved.

Desired next step would be finding a working group in IETF and discuss this document in WG.

Best,
Hiro

--
Hirotaka NAKAJIMA
Senior Research Engineer, Mercari, Inc.
[email-masked]