Subject: [Secdispatch] I would like to present draft-housley-cms-mts-hash-sig in London

From: Russ Housley <[email-masked]>
Date: Tue, 20 Feb 2018 16:36:27 -0500

I would like to  present draft-housley-cms-mts-hash-sig during the SecDispatch session in London.

https://datatracker.ietf.org/doc/draft-housley-cms-mts-hash-sig/

I understand that presentations are expected to be about 10 minutes.  I plan to cover the problem that the draft is trying to solve, the proposed solution, and the desired next step.   Then should be plenty of time in the 10 minutes for open mic, allowing folks in the room voice agreement or offer other suggestions.

Russ

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 20 Feb 2018 14:58:51 -0800

On Tue, Feb 20, 2018 at 1:36 PM, Russ Housley <[email-masked]> wrote:

> I understand that presentations are expected to be about 10 minutes.  I
> plan to cover the problem that the draft is trying to solve, the proposed
> solution, and the desired next step.

I think it would be helpful if you said what that is, as it sounds like you
know.

-Ekr

>  Then should be plenty of time in the 10 minutes for open mic, allowing
> folks in the room voice agreement or offer other suggestions.
>
> Russ
>
> _______________________________________________
> Secdispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/secdispatch
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 21 Feb 2018 11:16:28 -0500

> https://datatracker.ietf.org/doc/draft-housley-cms-mts-hash-sig/ <https://datatracker.ietf.org/doc/draft-housley-cms-mts-hash-sig/>
> 
> I understand that presentations are expected to be about 10 minutes.  I plan to cover the problem that the draft is trying to solve, the proposed solution, and the desired next step. 
> 
> I think it would be helpful if you said what that is, as it sounds like you know.

I am pushing hash-based signatures on software and firmware downloads for two reasons.  First, we need to deploy a quantum-safe signature long before there is large-scale quantum computer, otherwise we will not be able to deploy the next generation of cryptographic algorithms without physically touching every device.  Second, the signature validation code in the bootloader is small and fast.  Verification being small and fast makes this attractive in the IoT environment.

The relationship to CMS makes LAMPS a reasonable place to proceed with this document.

The relationship to IoT firmware makes SUIT a reasonable place to proceed with this document.

Russ