Subject: [secdir] Secdir last call review of draft-ietf-rtgwg-yang-vrrp-07

From: Rich Salz <[email-masked]>
Date: Tue, 05 Dec 2017 10:59:42 -0800

Reviewer: Rich Salz
Review result: Ready

I did this review for the Security Directorate (SECDIR) to help the Security
AD's.

This document is ready.

Section 1.2 gives an augmented diagram syntax; is that common? Should it be
added to "yang proper"?

The security considerations is short and to the point. This document describes
a data model, so the security considerations properly point call out
requirements on any transport mechanism used.  Calling out particularly
vulnerable nodes is good practice. Perhaps add a sentence saying that
"implemented should review all the nodes for security concerns" might be useful.

---

From: Xufeng Liu <[email-masked]>
Date: Sat, 16 Dec 2017 03:10:33 +0000

Hi Rich,

Thanks for the review. We have posted an updated version of the draft https://tools.ietf.org/html/draft-ietf-rtgwg-yang-vrrp-08 to address your comments.

Thanks,
- Xufeng

> -----Original Message-----
> From: Rich Salz [mailto:[email-masked]]
> Sent: Tuesday, December 5, 2017 2:00 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Secdir last call review of draft-ietf-rtgwg-yang-vrrp-07
> 
> Reviewer: Rich Salz
> Review result: Ready
> 
> I did this review for the Security Directorate (SECDIR) to help the Security AD's.
> 
> This document is ready.
> 

[Xufeng] This section in the previous version used an older convention to describe the diagram syntax. Because of the new available draft-ietf-netmod-yang-tree-diagrams-02, we have updated this section to use the new convention.

> 
> The security considerations is short and to the point. This document describes a
> data model, so the security considerations properly point call out requirements
> on any transport mechanism used.  Calling out particularly vulnerable nodes is
> good practice. Perhaps add a sentence saying that "implemented should review
> all the nodes for security concerns" might be useful.

[Xufeng] Added the sentence as suggested.

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 16 Dec 2017 07:46:03 +0000

Looks good to me thanks!

On 12/16/17, 3:10 AM, "Xufeng Liu" <[email-masked]> wrote:

    Hi Rich,

    Thanks,
    - Xufeng