Subject: [secdir] Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

From: Daniel Migault <[email-masked]>
Date: Thu, 07 Dec 2017 18:33:24 -0800

Reviewer: Daniel Migault
Review result: Ready

Hi, 

I have reviewed this document as part of the security directorate's 
ongoing effort to review all IETF documents being processed by the 
IESG.  These comments were written primarily for the benefit of the 
security area directors.  Document editors and WG chairs should treat 
these comments just like any other last call comments.

The summary of the review is Ready

Some comments / questions:

1.  Introduction

   This specification specifies how the URN namespace reserved for 3GPP2
   identities and its NSS for the MEID as specified in draft-atarius-
   dispatch-meid-urn [8] can be used as an instance-id as specified in
   RFC 5626 [2] and also as used by RFC 5627 [3].

<mglt> I think it would be good to have the acronyms (URN, 3GPP2, NSS,
MEID) expanded in the introduction section as it is being done in the
abstract.</mglt> 

   3GPP2 defines High Rate Packet Data (HRPD) with high data rates and
   it dispenses with the 1x Circuit Switched (1xCS) infrastructure.
   This means that with HRPD networks, voice calls will need to be
   conducted using IP and IMS.  However, the transition to all IP, SIP
   based IMS networks worldwide will take a great many years from the
   time of this writing and mobile devices will need to operate in both
   IP/SIP/IMS mode and circuit switched mode.  This means that calls and
   sessions will need to be handed over between IP/SIP/IMS mode and
   circuit switched mode mid-call or mid-session.  To achieve this the
   mobile device needs to be simultaneously attached via both the
   IP/SIP/IMS domain and the circuit switched domain.

<mglt> I am questioning whether "registered" would not be better
appropriated than "attached". My reading of attached is a dual 
radio case while "register" seems to include the single radio. 
I might be wrong as well.</mglt>

---

From: Andrew Allen <[email-masked]>
Date: Fri, 8 Dec 2017 17:37:09 +0000

Daniel

When talking about SIP and IMS Registered has a specific connotation means SIP registered.

The is no SIP Registration between the mobile device and the CS domain so using registered might be misleading. 

You are right that in the single radio case the mobile device is not simultaneously attached to both the IMS and CS domain. It would be in the dual radio case.

Maybe change that last sentence to

To achieve this the mobile device needs to communicate via both the IP/SIP/IMS domain and the circuit switched domain.

Andrew

-----Original Message-----
From: Daniel Migault [mailto:[email-masked]] 
Sent: Thursday, December 7, 2017 9:33 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Reviewer: Daniel Migault
Review result: Ready

Hi, 

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

1.  Introduction

<mglt> I think it would be good to have the acronyms (URN, 3GPP2, NSS,
MEID) expanded in the introduction section as it is being done in the abstract.</mglt> 

<mglt> I am questioning whether "registered" would not be better appropriated than "attached". My reading of attached is a dual radio case while "register" seems to include the single radio. 
I might be wrong as well.</mglt>

---

From: Daniel Migault <[email-masked]>
Date: Fri, 8 Dec 2017 17:39:35 +0000

Thanks the addresses fully my minor comment. 
Yours, 
Daniel

-----Original Message-----
From: Andrew Allen [mailto:[email-masked]] 
Sent: Friday, December 08, 2017 12:37 PM
To: Daniel Migault <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Daniel

Andrew

-----Original Message-----
From: Daniel Migault [mailto:[email-masked]] 
Sent: Thursday, December 7, 2017 9:33 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Reviewer: Daniel Migault
Review result: Ready

Hi, 

1.  Introduction

---

From: R Atarius <[email-masked]>
Date: Mon, 18 Dec 2017 22:20:04 +0000 (UTC)

Daniel and Andrew,
Note that "simultaneously" was omitted in Andrew's proposal which was agreed by Daniel. However, I think this wording should be kept in the sentence. Therefore, I am suggesting to keep "simultaneously"  in the sentence and have it as 
"To achieve this the mobile device needs to simultaneously communicate via both the IP/SIP/IMS domain and the circuit switched domain."

ThanksRoozbeh
      From: Daniel Migault <[email-masked]>
 To: Andrew Allen <[email-masked]>; "[email-masked]" <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
 Sent: Friday, December 8, 2017 9:39 AM
 Subject: RE: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

-----Original Message-----
From: Andrew Allen [mailto:[email-masked]] 
Sent: Friday, December 08, 2017 12:37 PM
To: Daniel Migault <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Daniel

Andrew

-----Original Message-----
From: Daniel Migault [mailto:[email-masked]] 
Sent: Thursday, December 7, 2017 9:33 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Reviewer: Daniel Migault
Review result: Ready

Hi, 

1.  Introduction

---

From: Daniel Migault <[email-masked]>
Date: Mon, 18 Dec 2017 22:34:26 +0000

This works for me.

Yours,
Daniel

From: R Atarius [mailto:[email-masked]]
Sent: Monday, December 18, 2017 5:20 PM
To: Daniel Migault <[email-masked]>; Andrew Allen <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Daniel and Andrew,

Thanks
Roozbeh

________________________________
From: Daniel Migault <[email-masked]<mailto:[email-masked]>>
To: Andrew Allen <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Friday, December 8, 2017 9:39 AM
Subject: RE: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

-----Original Message-----
From: Andrew Allen [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, December 08, 2017 12:37 PM
To: Daniel Migault <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Daniel

Andrew

-----Original Message-----
From: Daniel Migault [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, December 7, 2017 9:33 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Secdir last call review of draft-atarius-dispatch-meid-urn-as-instanceid-05

Reviewer: Daniel Migault
Review result: Ready

Hi,

1.  Introduction