Subject: [secdir] secdir review of draft-ietf-ippm-alt-mark-13

From: Taylor Yu <[email-masked]>
Date: Thu, 26 Oct 2017 01:50:04 +0000

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

The summary of the review is Ready.

The Security Considerations section seems reasonable.  I mostly agree
that

  "The privacy concerns of network measurement are limited because the
   method only relies on information contained in the IP header without
   any release of user data."

I would add that although information in the IP header is metadata that
can be used to compromise the privacy of users, the limited marking
technique in this document seems unlikely to substantially increase the
existing privacy risks from IP header metadata.  I also think it's
reasonable to consider this detail to be already addressed by the
wording "privacy concerns... are limited".

It might be theoretically possible to modulate the marking to serve as a
covert channel, but I think it would have a very low data rate if it is
to avoid adversely affecting the measurement systems that monitor the
marking.  It's probably not worth mentioning this possibility in the
document.

Best regards,

-Taylor

---

From: Fioccola Giuseppe <[email-masked]>
Date: Thu, 26 Oct 2017 09:14:13 +0000

Hi Taylor,
I appreciate your good opinion of the document and I agree with your notes.

Thanks,

Giuseppe

-----Messaggio originale-----
Da: Taylor Yu [mailto:[email-masked]] 
Inviato: giovedì 26 ottobre 2017 03:50
A: [email-masked]; [email-masked]; [email-masked]
Oggetto: secdir review of draft-ietf-ippm-alt-mark-13

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

The Security Considerations section seems reasonable.  I mostly agree that

I would add that although information in the IP header is metadata that can be used to compromise the privacy of users, the limited marking technique in this document seems unlikely to substantially increase the existing privacy risks from IP header metadata.  I also think it's reasonable to consider this detail to be already addressed by the wording "privacy concerns... are limited".

It might be theoretically possible to modulate the marking to serve as a covert channel, but I think it would have a very low data rate if it is to avoid adversely affecting the measurement systems that monitor the marking.  It's probably not worth mentioning this possibility in the document.

Best regards,

-Taylor

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.