Subject: [secdir] Secdir last call review of draft-ietf-teas-pce-central-control-04

From: Matthew Miller <[email-masked]>
Date: Wed, 30 Aug 2017 08:22:04 -0700

Reviewer: Matthew Miller
Review result: Has Nits

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should
treat these comments just like any other last call comments.

Document:
Reviewer: Matthew A. Miller
Review Date: 2017-08-30
IETF LC End Date: 2017-08-25
IESG Telechat date: 2017-08-31

Summary:

This document is ready for publication as Informational, with one potential nit.

This document describes an overall architecture (with some variants) utilizing
central PCE-based controller for SDN, and its implication on PCEP.  The
document notes the tradeoffs between the variants, including some of the
vulnerabilities.

My nit is in the Security Considerations; I'm not sure how likely in practice
a central controller architecture will be operated with "higher level of
security", and therefore not sure it's worth calling out like this.

I can see how a central controller makes management easier, and that has a
potential benefit of better visibility into the network's operation and
finding problems (including security-related) sooner and better.

Otherwise I think the rest of this section addresses the concerns that a
central controller architecture has.

---

From: Adrian Farrel <[email-masked]>
Date: Wed, 30 Aug 2017 18:11:04 +0000

Thanks Matthew,

The point I was aiming for is that control planes are often operated with a "domain of trust" or "chain of trust" model (for better or worse) but that management systems are often operated with secure channels between management station and managed node.

I think, in other words, that the point covered by the text is true in today's networks.

Best,
Adrian

-----Original Message-----
From: Matthew Miller [mailto:[email-masked]] 
Sent: 30 August 2017 16:22
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir last call review of draft-ietf-teas-pce-central-control-04

Reviewer: Matthew Miller
Review result: Has Nits

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

Document:

Summary:

This document describes an overall architecture (with some variants) utilizing central PCE-based controller for SDN, and its implication on PCEP.  The document notes the tradeoffs between the variants, including some of the vulnerabilities.

My nit is in the Security Considerations; I'm not sure how likely in practice a central controller architecture will be operated with "higher level of security", and therefore not sure it's worth calling out like this.

I can see how a central controller makes management easier, and that has a potential benefit of better visibility into the network's operation and finding problems (including security-related) sooner and better.

Otherwise I think the rest of this section addresses the concerns that a central controller architecture has.