Subject: [secdir] Review of draft-ietf-v6ops-unique-ipv6-prefix-per-host

From: Watson Ladd <[email-masked]>
Date: Sun, 4 Jun 2017 22:10:08 -0700

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG.  These
comments were written primarily for the benefit of the security area
directors.  Document editors and WG chairs should treat these comments just
like any other last call comments.

The summary of the review is that this document is has one substantial
issue plus a formatting nit: the author names are running into the title.
Perhaps this can be fixed

The substantial comment is that the interaction of privacy addresses with
giving each subscriber a unique IPv6 address prefix space is not discussed
in this document at all. This seems like a security issue that should be
addressed as it reduces privacy compared to a shared prefix for all users.
(Or maybe I am completely wrong: I do not know IPv6 in great detail). At
minimum it should be discussed in the security considerations section, even
if explicitly dismissed.

Sincerely,
Watson

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 26 Jun 2017 11:40:41 +0000

Hi Watson,

My apologies for the delay in answer. Its been a hectic time for me. Many thanks for your review.

I modified the text in the security considerations to include your suggestion to make the correlation between both more clear.

<>
                <t>The mechanics of IPv6 privacy extensions <xref target="RFC4941">RFC4941</xref>
                  is compatible with assignment of an Unique IPv6 Prefix per Host.
                  The combination of both IPv6 privacy extensions
                  and operator based assignment of a Unique IPv6 Prefix per Host provides
                  each implementing operator a tool to manage and provide subscriber services
                  and hence reduces the experienced privacy within each operator controlled domain.
                  However, beyond the operator controlled domain, IPv6 privacy extensions provide
                  the desired privacy as documented in <xref target="RFC4941">RFC4941</xref>.</t>
<>

Thanks and take care,

G/

From: Watson Ladd <[email-masked]>
Date: Monday, 5 June 2017 at 07:10
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Review of draft-ietf-v6ops-unique-ipv6-prefix-per-host
Resent-From: <[email-masked]>, <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, Ron Bonica <[email-masked]>, <[email-masked]>
Resent-Date: Monday, 5 June 2017 at 07:34

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

The summary of the review is that this document is has one substantial issue plus a formatting nit: the author names are running into the title. Perhaps this can be fixed

The substantial comment is that the interaction of privacy addresses with giving each subscriber a unique IPv6 address prefix space is not discussed in this document at all. This seems like a security issue that should be addressed as it reduces privacy compared to a shared prefix for all users. (Or maybe I am completely wrong: I do not know IPv6 in great detail). At minimum it should be discussed in the security considerations section, even if explicitly dismissed.

Sincerely,
Watson