Subject: [secdir] secdir review of draft-ietf-curdle-cms-ecdh-new-curves-07

From: Charlie Kaufman <[email-masked]>
Date: Sat, 27 May 2017 00:26:54 +0000

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. Document editors and WG chairs should treat these comments just like any other last call comments.

This document specifies the syntactic details for encrypting and signing CMS documents using two additional cryptographic algorithms. This syntax appears consistent with the patterns set in RFC 5652, and I could find no errors (even nits).

Unless other more critical eyes than mine can find issues, I believe this document is ready to be advanced.

My only complaint - and it is probably not with this document - is that it should not take 16 pages to specify a handful of IANA registrations. I'm not sure why it was necessary, but my guess is that RFC 5652 was not forward looking enough to allow the use of future algorithms to be specified with just a few table entries, so subsequent documents have to include lots of information duplicating one another. But that is not a criticism of the technical content.

---

From: Daniel Migault <[email-masked]>
Date: Sat, 27 May 2017 01:29:59 +0000

Thanks you Charlie for your review.
Yours,
Daniel

From: secdir [mailto:[email-masked]] On Behalf Of Charlie Kaufman
Sent: Friday, May 26, 2017 8:27 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [secdir] secdir review of draft-ietf-curdle-cms-ecdh-new-curves-07