Subject: Re: [secdir] secdir review of draft-ietf-sipcore-status-unwanted

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 20 Apr 2017 23:31:20 +0000

Thank you for your review and comments.

A bit of background: "reporting to government authorities" typically means that this is reported via the complaint interface to, in the US, the Federal Trade Commission (FTC) or the FCC (Federal Communications Commission). In addition to complaints entered via web forms, this is actually currently done by a number of commercial call spam blocking applications. The FTC gets hundreds of thousand of such complaints and the FCC tens of thousand per month. Needless to say, a single complaint is unlikely to trigger a search warrant. (Indeed, the 'unwanted' mechanism, in this case, essentially just short-circuits the process by avoiding consumers having to fill out the web form.)

I didn't want to get into these country-specific details, but if a different formulation, e.g., with a bit more detail, would be useful, let me know. I'll add the notion of a complaint database, to make clear that this isn't, by itself (say) a criminal complaint.

[FTC statistics are at https://www.ftc.gov/news-events/press-releases/2017/03/ftc-releases-annual-summary-consumer-complaints]

Henning

________________________________
From: Adam Montville <[email-masked]>
Sent: Friday, March 10, 2017 4:21:16 PM
To: The IESG; [email-masked]; [email-masked]
Subject: secdir review of draft-ietf-sipcore-status-unwanted

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This draft is ready with (possible) issues.

This draft defines a new SIP response code, 666 "Unwanted", which allows called parties to indicate when a call is unwanted.  The intent of the Unwanted response code is to provide feedback to global or user-specific filtering algorithms (implemented by carriers) from the context of a SIP-initiated call.

>From a security perspective, there's nothing wrong with the draft, and the Security Considerations section addresses what one might expect (denial of service, relying on the code only when authenticated caller identities are in play, etc.)  It seems that the biggest risk is false blocks, callers having their feelings hurt, or folks not getting the calls they may expect -- but implementers are made aware of these.

A potential issue can be seen by taking these two sentences together: "Implementations will have to make appropriate trade-offs between falsely labeling a caller as unwanted and delivering unwanted calls", "The service provider...MAY report the calling party identity to government authorities".  This gives rise to the possibility that a mislabeled caller could be reported to authorities, when there is no real reason for such.

Either way, I found the document to be clear and well-written.  And while I list the draft as "ready with issues" here, it may be the case that there are no issues from the perspective of the ADs for whom I have performed this review.

Kind regards,

Adam

---

From: Adam Montville <[email-masked]>
Date: Fri, 21 Apr 2017 00:00:07 +0000

Thanks for the clarification. Should be good.
On Thu, Apr 20, 2017 at 6:31 PM Henning Schulzrinne <
[email-masked]> wrote:

> A bit of background: "reporting to government authorities" typically means
> that this is reported via the complaint interface to, in the US, the
> Federal Trade Commission (FTC) or the FCC (Federal Communications
> Commission). In addition to complaints entered via web forms, this is
> actually currently done by a number of commercial call spam blocking
> applications. The FTC gets hundreds of thousand of such complaints and the
> FCC tens of thousand per month. Needless to say, a single complaint is
> unlikely to trigger a search warrant. (Indeed, the 'unwanted' mechanism, in
> this case, essentially just short-circuits the process by avoiding
> consumers having to fill out the web form.)
>
>
> I didn't want to get into these country-specific details, but if a
> different formulation, e.g., with a bit more detail, would be useful, let
> me know. I'll add the notion of a complaint database, to make clear that
> this isn't, by itself (say) a criminal complaint.
>
>
> [FTC statistics are at
> https://www.ftc.gov/news-events/press-releases/2017/03/ftc-releases-annual-summary-consumer-complaints
> ]
>
>
> Henning
> ------------------------------
> *From:* Adam Montville <[email-masked]>
> *Sent:* Friday, March 10, 2017 4:21:16 PM
> *To:* The IESG; [email-masked];
> [email-masked]
> *Subject:* secdir review of draft-ietf-sipcore-status-unwanted
>
> I have reviewed this document as part of the security directorate's
> ongoing effort to review all IETF documents being processed by the IESG.
> These comments were written primarily for the benefit of the security area
> directors.  Document editors and WG chairs should treat these comments just
> like any other last call comments.
>
> This draft defines a new SIP response code, 666 "Unwanted", which allows
> called parties to indicate when a call is unwanted.  The intent of the
> Unwanted response code is to provide feedback to global or user-specific
> filtering algorithms (implemented by carriers) from the context of a
> SIP-initiated call.
>
> From a security perspective, there's nothing wrong with the draft, and the
> Security Considerations section addresses what one might expect (denial of
> service, relying on the code only when authenticated caller identities are
> in play, etc.)  It seems that the biggest risk is false blocks, callers
> having their feelings hurt, or folks not getting the calls they may expect
> -- but implementers are made aware of these.
>
> A potential issue can be seen by taking these two sentences together:
> "Implementations will have to make appropriate trade-offs between falsely
> labeling a caller as unwanted and delivering unwanted calls", "The service
> provider...MAY report the calling party identity to government
> authorities".  This gives rise to the possibility that a mislabeled caller
> could be reported to authorities, when there is no real reason for such.
>
> Either way, I found the document to be clear and well-written.  And while
> I list the draft as "ready with issues" here, it may be the case that there
> are no issues from the perspective of the ADs for whom I have performed
> this review.
>
> Kind regards,
>
> Adam
>