Subject: [secdir] review of draft-ietf-grow-large-communities-usage-06

From: Klaas Wierenga <[email-masked]>
Date: Fri, 21 Apr 2017 09:57:38 +0200

Hi,

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments. 

This document presents examples of how operators may use BGP large communities to support some typical use-cases.

In general the document is well written and I have no major issues, and I consider it: ready with nits (see below)

My one nit is that even though I think that the statement in the security considerations "Operators should note the recommendations in Section 11(https://tools.ietf.org/html/draft-ietf-grow-large-communities-usage-06#section-11) of BGP
Operations and Security [RFC7454(https://tools.ietf.org/html/rfc7454)]” is largely true, it would be useful if the authors would expand a little on that, not being an expert in this field, I am wondering if the use-cases you describe in one way or the other influence the RFC7454 considerations.

Klaas

---

From: Job Snijders <[email-masked]>
Date: Fri, 21 Apr 2017 10:05:50 +0200

On Fri, Apr 21, 2017 at 09:57:38AM +0200, Klaas Wierenga wrote:
> I have reviewed this document as part of the security directorate's
> ongoing effort to review all IETF documents being processed by the
> IESG. These comments were written primarily for the benefit of the
> security area directors. Document editors and WG chairs should treat
> these comments just like any other last call comments. 
> 
> This document presents examples of how operators may use BGP large
> communities to support some typical use-cases.
> 
> In general the document is well written and I have no major issues,
> and I consider it: ready with nits (see below)
> 
> Operations and Security
> [RFC7454(https://tools.ietf.org/html/rfc7454)]” is largely true, it
> would be useful if the authors would expand a little on that, not
> being an expert in this field, I am wondering if the use-cases you
> describe in one way or the other influence the RFC7454 considerations.

In -07 - following the GenART review we expanded the security section,
does that address your nit?

https://tools.ietf.org/rfcdiff?url2=draft-ietf-grow-large-communities-usage-07.txt

Kind regards,

Job

---

From: Klaas Wierenga <[email-masked]>
Date: Fri, 21 Apr 2017 10:12:10 +0200

Hi Job,

Yes it does (and apologies for not spotting the 07 version). 

Klaas

On 21 April 2017 at 10:05:43, Job Snijders ([email-masked]) wrote:

Kind regards,  

Job

---

From: Job Snijders <[email-masked]>
Date: Fri, 21 Apr 2017 08:12:47 +0000

Well, to be fair -07 is less then a day old ;-)

Thank you for your review!

Job

On Fri, 21 Apr 2017 at 10:12, Klaas Wierenga <[email-masked]> wrote:

> > My one nit is that even though I think that the statement in the
> security considerations "Operators should note the recommendations in
> Section 11(
> https://tools.ietf.org/html/draft-ietf-grow-large-communities-usage-06#section-11)
> of BGP
> > Operations and Security