Subject: [secdir] SECDIR review of draft-ietf-isis-auto-conf-04

From: Radia Perlman <[email-masked]>
Date: Tue, 28 Mar 2017 21:50:19 -0700

I have reviewed this document as part of the security directorate's ongoing
effort to review all IETF documents being processed by the IESG. These
comments were written primarily for the benefit of the security area
directors. Document editors and WG chairs should treat these comments just
like any other last call comments.

This document describes a touchless (autoconfiguring) implementation of
IS-IS.  I don't have any security comments, but I have some other comments.

They use the term "Double-Duplication". I don't know what that is. I think
they mean "both the system ID and router fingerprint are duplicated". To me
"double duplicate" would be that there were 3 or more systems with the same
information.

The terminology "NET" and "NSAP" have always been very confusing to most
IETF'ers (including me!). Might it be possible to stop using those terms?
Of course, it's not fair to pick on this document to start doing that. In
the early days of IS-IS, some implementations decided that NET should be
the NSAP minus the last byte. Others thought it should be a full size NSAP,
but with the last byte 0. The formal ISO definition in CLNP did not clarify
this sort of thing, at least to me. Anyway, is there an IETF IS-IS document
that explains what NET and NSAPs are, as opposed to saying (as in this
document) that "an NET is a type of NSAP", which I find very confusing.

In section 3.4.2, it says " Routers operating in auto-configuration mode
MUST NOT form adjacencies with routers which are NOT operating in
auto-configuration
mode. "

Why is that? I'd think it would be easier to deploy if you could gradually
introduce autoconfiguring routers in with existing implementations that
don't know about the A bit. Are you concerned about an actual area 0?

Other than those (mostly) editorial comments, which are only suggestions
anyway, this is ready for publication. I haven't been following IS-IS
recently, and I'm actually surprised that there hasn't been totally
autoconfiguring implementations up until now.

Radia

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 29 Mar 2017 12:18:06 +0000

Radia –

Thanx for the review.
Responses inline.

From: Radia Perlman [mailto:[email-masked]]
Sent: Tuesday, March 28, 2017 9:50 PM
To: The IESG; [email-masked]; [email-masked]
Subject: SECDIR review of draft-ietf-isis-auto-conf-04

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes a touchless (autoconfiguring) implementation of IS-IS.  I don't have any security comments, but I have some other comments.

They use the term "Double-Duplication". I don't know what that is. I think they mean "both the system ID and router fingerprint are duplicated". To me "double duplicate" would be that there were 3 or more systems with the same information.

[Les:] You are correct  - the term “double-duplication” means duplicate system id AND fingerprint.
I would be happy to remove the term “double-duplication” and simply say “duplication of system-id and fingerprint”. I think this would be clarifying.
If this satisfies you and my co-authors agree we can make this change.

The terminology "NET" and "NSAP" have always been very confusing to most IETF'ers (including me!). Might it be possible to stop using those terms? Of course, it's not fair to pick on this document to start doing that. In the early days of IS-IS, some implementations decided that NET should be the NSAP minus the last byte. Others thought it should be a full size NSAP, but with the last byte 0. The formal ISO definition in CLNP did not clarify this sort of thing, at least to me. Anyway, is there an IETF IS-IS document that explains what NET and NSAPs are, as opposed to saying (as in this document) that "an NET is a type of NSAP", which I find very confusing.

[Les:] The terms are used in ISO 10589. I think the most precise reference is ISO 10589 Section 7.1.5:

“All of the IS’s manualAreaAddresses, when combined with the IS’s systemID, are valid network entity titles for the IS.”

I think the draft’s use of the term is consistent with ISO 10589 and I am not inclined to change it.

Of course there is no IETF document regarding NETs/NSAPs. Why would we want to delve into such dark waters? ☺

In section 3.4.2, it says " Routers operating in auto-configuration mode MUST NOT form adjacencies with routers which are NOT operating in auto-configuration mode. "

Why is that? I'd think it would be easier to deploy if you could gradually introduce autoconfiguring routers in with existing implementations that don't know about the A bit. Are you concerned about an actual area 0?

[Les:] The target for these extensions is defined in Section 2:

“IS-IS auto-configuration is primarily intended for use in small (i.e.
   10s of devices) and unmanaged deployments.  It allows IS-IS to be
   used without the need for any configuration by the user.  It is not
   recommended for larger deployments.”

I think there are many good reasons for that – the primary one being that when one starts deploying more than a minimum set of features there are many more options and it becomes problematical to select a default setting than will be satisfactory in all deployments. Determining level is one easy example – assuming L1 isn’t appropriate for larger deployments. Autoconfig of area address is another.

So this restriction is intentional.

   Les

Other than those (mostly) editorial comments, which are only suggestions anyway, this is ready for publication. I haven't been following IS-IS recently, and I'm actually surprised that there hasn't been totally autoconfiguring implementations up until now.

Radia

---

From: "Liubing (Leo)" <[email-masked]>
Date: Wed, 29 Mar 2017 15:33:41 +0000

Thanks for Radia’s review and comments again.
Few minor comments inline, starting with “[Bing]”.

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Wednesday, March 29, 2017 7:18 AM
To: Radia Perlman; The IESG; [email-masked]; [email-masked]
Subject: RE: SECDIR review of draft-ietf-isis-auto-conf-04

Radia –

Thanx for the review.
Responses inline.

From: Radia Perlman [mailto:[email-masked]]
Sent: Tuesday, March 28, 2017 9:50 PM
To: The IESG; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: SECDIR review of draft-ietf-isis-auto-conf-04

[Bing] As a co-author, I also agree to change it to “duplication of system-id and fingerprint”, which could eliminate confusion.

[Bing] As Les said, this restriction is intentional. At the beginning, we actually thought about the possibilities of using the auto-conf mechanism not only in small networks. But later we agreed that it might be better to be less ambitious that to guarantee it can do the job well for small networks first.  For incremental deployment and larger deployment, these are definitely some interesting problems to be solved. If we could figure out some good ideas in the future, we can consider to initiate some new work.

   Les

Other than those (mostly) editorial comments, which are only suggestions anyway, this is ready for publication. I haven't been following IS-IS recently, and I'm actually surprised that there hasn't been totally autoconfiguring implementations up until now.
[Bing] There is an open source implementation, which is based on an earlier version of this document, and integrating source routing function for home network scenarios. Link: https://git-us.netdef.org/projects/OSR/repos/openwrt-isis-hnet/commits .

Best regards,
Bing

Radia