Subject: [secdir] secdir review of draft-ietf-conex-mobile-05

From: "Xialiang (Frank)" <[email-masked]>
Date: Fri, 11 Sep 2015 00:49:24 +0000

Hi,
I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comment.

This memo describes a mobile communications use case for congestion exposure (ConEx) with a particular focus on those mobile communication networks that are architecturally similar to the 3GPP Evolved Packet System (EPS).

I have the following comments:

l  1. It should be helpful to consider the communication security between the ConEx senders and receivers such as the Confidentiality, data integrity and peer entity authentication in the security considerations part. Because in general, the corresponding risks are still possible to exist.

l  2. The authentication mechanism among all the elements of ConEx solution should also be considered to handle the condition of faked messages or invalid peer elements.

Recommendation:  Ready With Issues

B.R.
Frank

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Fri, 11 Sep 2015 09:20:17 +0000

Hi Dirk,
Thank you for quick response.
I reviewed the drafts you mentioned below. I agree that they already discussed the general security issues I am concerned, especially in the draft-conex-abstract-mech-13 and its reference.

So, in general, my concerns are addressed. But I still have a little bit doubts about possibly new security issues for the use cases of using ConEx protocol over the mobile communication networks. I am not an expert in this area, can you clarify me?

Thanks!

B.R.
Frank

发件人: Dirk Kutscher [mailto:[email-masked]]
发送时间: 2015年9月11日 16:52
收件人: Xialiang (Frank); secdir; [email-masked]; [email-masked]
主题: RE: secdir review of draft-ietf-conex-mobile-05

Hi Frank,

thanks for the review.

The security issues you mentioned would apply to ConEx in general. The corresponding documents are discussing potential security issues:

https://tools.ietf.org/html/draft-ietf-conex-abstract-mech-13#page-24 (also see the references)
https://tools.ietf.org/html/draft-ietf-conex-destopt-09#page-10
https://tools.ietf.org/html/draft-ietf-conex-tcp-modifications-04#page-11

We’d therefore rather not duplicate that discussion in conex-mobile.

Regarding the security risks you mentioned, I’d say it is questionable whether ConEx introduces additional issues for confidentiality (compared to IP alone).

Thanks,
Dirk

From: Xialiang (Frank) [mailto:[email-masked]]
Sent: Freitag, 11. September 2015 02:49
To: secdir; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: secdir review of draft-ietf-conex-mobile-05

Hi,

B.R.
Frank

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 11 Sep 2015 08:51:48 +0000

Hi Frank,

thanks for the review.

We'd therefore rather not duplicate that discussion in conex-mobile.

Regarding the security risks you mentioned, I'd say it is questionable whether ConEx introduces additional issues for confidentiality (compared to IP alone).

Thanks,
Dirk

From: Xialiang (Frank) [mailto:[email-masked]]
Sent: Freitag, 11. September 2015 02:49
To: secdir; [email-masked]; [email-masked]
Subject: secdir review of draft-ietf-conex-mobile-05

Hi,

B.R.
Frank

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 11 Sep 2015 09:48:49 +0000

Hi Frank,

In general, the ConEx-related risks regarding manipulating congestion notification/exposure can apply to mobile networks, too.

What could perhaps be said is that mobile networks (UMTS, LTE) employ a virtual-circuit-like bearer model for the access, i.e., users in a cell can generally not see other users’ traffic – so that would rule out some threats. Also, authentication is part of the bearer establishment, so the network generally knows the user and device identity.

Now, assuming that mobile networks can be subject to passive monitoring, one could claim that this would enable attackers to collect information about a user’s congestion contribution (also over time), but that threat seems less critical (compared to exposing the payload itself).

Best regards,
Dirk

From: Xialiang (Frank) [mailto:[email-masked]]
Sent: Freitag, 11. September 2015 11:20
To: Dirk Kutscher
Cc: secdir; [email-masked]; [email-masked]
Subject: Re: secdir review of draft-ietf-conex-mobile-05

Hi Dirk,

Thanks!

B.R.
Frank

发件人: Dirk Kutscher [mailto:[email-masked]]
发送时间: 2015年9月11日 16:52
收件人: Xialiang (Frank); secdir; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: secdir review of draft-ietf-conex-mobile-05

Hi Frank,

thanks for the review.

Thanks,
Dirk

Hi,

B.R.
Frank

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Mon, 14 Sep 2015 01:26:38 +0000

Hi Dirk,
I see. Thanks for your detailed clarification.

B.R.
Frank

发件人: Dirk Kutscher [mailto:[email-masked]]
发送时间: 2015年9月11日 17:49
收件人: Xialiang (Frank)
抄送: secdir; [email-masked]; [email-masked]
主题: RE: secdir review of draft-ietf-conex-mobile-05

Hi Frank,

Best regards,
Dirk

From: Xialiang (Frank) [mailto:[email-masked]]
Sent: Freitag, 11. September 2015 11:20
To: Dirk Kutscher
Cc: secdir; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: secdir review of draft-ietf-conex-mobile-05

Hi Dirk,

Thanks!

B.R.
Frank

Hi Frank,

thanks for the review.

Thanks,
Dirk

Hi,

B.R.
Frank