Subject: [secdir] Secdir review of draft-ietf-sidr-algorithm-agility-08

From: Brian Weis <[email-masked]>
Date: Thu, 13 Dec 2012 18:00:41 -0800

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors. Document editors and WG chairs should treat these comments just like any other last call comments.

This document describes a mandatory algorithm transition procedure for the RPKI. It describes a single method, comprised of four phases and six milestones. Each phase discusses a strategy for rollback of the new algorithm. The algorithm transition procedure seems complete, and the security considerations section is adequate.

One statement in the discussion of Phase 4 is confusing (Section 4.7). It first states:

  "RPs MAY validate signed product sets
   using Suite C. However, RPs SHOULD NOT assume that the collection of
   Suite C product sets is complete."

Later it notes that Suite A could be deprecated, and states:

  "At this stage, RPs are still capable of processing Suite
   C signed products, so the RPKI is still viable."

But if the Suite C product sets may be incomplete, how is the RPKI still viable? This should be clarified.

Nits:
- Section 3, "Corresponds" definition: s/Resoureces/Resources/
- Section 4.1, "End Of Life (EOL) Date definition: s/is MUST/MUST/
- Section 7, last paragraph. The final sentence would be clearer if it read "Since Suite C products are being deprecated during Phase 4, a CA may revoke certificates issued under Suite C without revoking them under Suite A." Ignore if you don't agree.

Brian

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Fri, 14 Dec 2012 11:25:37 +0000

Hi Brian,

Thanks for your review. See my answers inline.

Cheers!
Roque

On Dec 14, 2012, at 3:00 AM, Brian Weis wrote:

One clarification is that the first piece of text that you quoted is the normal agility process while the second quoted sentence refers to what to do when the new algorithm suite is deemed unsuitable and the algorithm change process needs to be canceled.

That said, what about this clarification text?

If the Algorithm Suite A (former Algorithm
   Suite B) is deemed unsuitable, the algorithm transition timeline and
   the algorithm specification documents MUST be replaced, the
   Algorithm Suite A MUST be deprecated using the process described in
   Section 10<http://tools.ietf.org/html/draft-ietf-sidr-algorithm-agility-08#section-10> and CAs MUST NOT remove Suite C product sets. At this stage, RPs are still capable of processing Suite C signed products, so the RPKI is still viable.

Nits:

Thanks! Will Change for next version.

Brian

---

From: Brian Weis <[email-masked]>
Date: Fri, 14 Dec 2012 10:05:00 -0800

Hi Roque,

Replies are inline below.

On Dec 14, 2012, at 3:25 AM, Roque Gagliano (rogaglia) <[email-masked]> wrote:

>    Section 10 and CAs MUST NOT remove Suite C product sets. At this stage, RPs are still capable of processing Suite C signed products, so the RPKI is still viable.

This sounds like a good clarification. Whereas Suite C product sets may be incomplete (due to expiration of certificates) they are still considered valid until Phase 4 has completed. The only suggestion I might have is to change "remove" to "remove or revoke".

Thanks,
Brian

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Mon, 17 Dec 2012 16:02:57 +0000

Hi Brian,

> This sounds like a good clarification. Whereas Suite C product sets may be incomplete (due to expiration of certificates) they are still considered valid until Phase 4 has completed. The only sugge…

We normally use the term "remove" only as there are too many combinations for revocation in this case. Please note that Algorithm C will only be deprecated at the next phase, so we are not even asking for the revocation of the material anyways.

Regards,
Roque

---

From: Brian Weis <[email-masked]>
Date: Mon, 17 Dec 2012 10:20:52 -0800

Hi Roque,

> We normally use the term "remove" only as there are too many combinations for revocation in this case. Please note that Algorithm C will only be deprecated at the next phase, so we are not even ask…

I take your point that Algorithm C isn't deprecated until the next phase ... your original wording is fine.

Thanks,
Brian