Subject: [secdir] secdir review of draft-ietf-pwe3-redundancy-06

From: Radia Perlman <[email-masked]>
Date: Mon, 19 Mar 2012 15:22:21 -0700

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

This is a requirements document (intended as informational) for a
routing protocol.

At this level of abstraction, I don’t think there are any interesting
security issues. There are some messages in the protocol that need to
be communicated securely, and the security considerations section
references some other RFCs and says the new messages will “inherit at
least the same security properties” as the messages in those other
RFCs. I didn’t look up what kind of protection existed there.

The interesting routing protocol issue has to do with nesting of
routing algorithms and the needed multipliers in timeouts. It would
appear that pseudo-wires run over a conventional routed infrastructure
and also connect parts of a conventional routed infrastructure. The
spec assumes that failures within the inner routed infrastructure will
heal themselves quickly enough to not be noticed by the pwe3
redundancy protocol (if they are capable of healing at all), and that
pseudo-wire failover (triggered by this inner failure) will happen
quickly enough to not disrupt the routing protocol that is running
over the pseudo-wires.

But that requirement is not explicitly acknowledged in the document,
and it intuitively seems like a significant challenge.

Micro-level issues:

In terminology (section 2), the Primary PW is defined as the one that
will be used when any one will do, and that if it goes down and comes
back the PW will revert to it. But it also defines non-revertive
protection switching as an option where the traffic will not switch
back to the primary unless the secondary fails, and in section 4.1 it
says that non-revertive protection MUST be supported and revertive is
optional.

Typos:

Section 4.1:

besupported -> be supported

suported -> supported

Section 4.2:

Orphaned bullet

---

From: Tina TSOU <[email-masked]>
Date: Sat, 24 Mar 2012 06:10:55 +0000

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG. These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

Some comments which may not be from security aspects only are below.

1) One missing OAM function

I compared the OAM functions listed in this draft and those required in RFC5860 and find out one OAM function named Client Failure Indication (Section 2.2.10 of [RFC 5860]) is missing. I cannot see a reason for this. Since this is an informational analysis document, it is recommended to give a whole view. Specific clarifications are appreciated in the document. 

2) Lack of analysis about the compatibility with existing tools

It is said in this document that compatibility with the existing tools has been maintained. But there is no detailed analysis which IMHO might be of great interest to the industry and should form an important part of this analysis document.

3) 1.1 Scope

In the middle of this section, under the "three objectives", the first bullet reads  

   o  The OAM toolset should be developed based on existing MPLS
      architecture, technology, and toolsets.

However, in the following paragraph it is written as

   o  ITU-T OAM for Ethernet toolset as defined in [Y.1731].  This has
      been used for functionality guidelines for the performance
      measurement tools that were not previously supported in MPLS.

There seem to be conflicts between the objective (should...existing MPLS....) and the toolset development (...tools...not...supported in MPLS). [RFC 5860] says that "...the MPLS-TP design, SHOULD as far as reasonably possible, reuse existing MPLS standards." which looks more appropriate to me as the objective. Please clarify this point.

4) 1.1 Scope

The third one of the "three objectives" in this draft reads 

   o  The OAM toolset developed for MPLS based transport networks needs
      to be fully inter-operable with existing MPLS OAM tools as
      documented in [RFC 5860].

I may be wrong but I find [RFC 5860] only requires OAM interoperability between distinct domains (w/wo IP capabilities). The original description is as follows:

   It is REQUIRED that OAM interoperability is achieved between distinct
   domains materializing the environments described in Section 2.1.4.
 
My understanding of the "OAM interoperability" mentioned here refers to MPLS-TP OAM interoperable in different domains, but not MPLS-TP OAM and MPLS OAM interoperability. 

5) MPLS-TP v.s. MPLS based transport networks
The draft uses both "MPLS-TP" and "MPLS based transport networks". E.g. is it "MPLS-TP OAM" or OAM toolset developed for MPLS based transport networks? 
Are they the same? Or what is the relationship between them?

Tina