Subject: [secdir] review of draft-ietf-hip-via-01.txt

From: Catherine Meadows <[email-masked]>
Date: Thu, 3 Jun 2010 16:37:33 -0400

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

This document concerns extensions to the Host Identity Protocol (HIP) to provide multi-hop routing.
The first is that a host sending a HIP packet can define a set of hosts the packet should traverse.
The other allows a HIP packet to carry and record the list of hosts that forwarded it.

The only security concern mentioned is the possibility of malicious hosts creating forwarding loops.
However, it appears to me that their are also the usual problems of malicious hosts tampering
with and spoofing packets.  

It's not clear to me though why issues such as malicious hosts spoofing or tampering with routing
lists is not addressed, especially since HIP is a security protocol.  Are there features of HIP or other
HIP documents where this is addressed?  If so, they should be pointed to here.  If not, this should be pointed out,
and if possible, other recommendations made.

Catherine Meadows
Naval Research Laboratory
Code 5543
4555 Overlook Ave., S.W.
Washington DC, 20375
phone: 202-767-3490
fax: 202-404-7942
email: [email-masked]

---

From: Ari Keränen <[email-masked]>
Date: Wed, 09 Jun 2010 18:59:00 +0300

Hi Catherine,

Thanks for the review and comments!

Most of the usual attacks are taken care of by the standard HIP 
mechanisms (e.g., signatures, puzzles, and the ENCRYPTED parameter), but 
you're right that the Destination and Via lists could be tampered with 
in an attempt to do a (fairly low impact) DoS attack.

I added text about this kind of attacks and recommendations on how to 
mitigate them to the security considerations section. A new version of 
the draft is available here:
http://users.piuha.net/akeranen/drafts/draft-ietf-hip-via-02-pre1.txt
(only the section 6 has changed)

Comments are welcome.

Cheers,
Ari

On 06/03/2010 11:37 PM, Catherine Meadows wrote:
> I have reviewed this document as part of the security directorate's 
> ongoing effort to review all IETF documents being processed by the IESG. 
>  These comments were written primarily for the benefit of the security 
> area directors.  Document editors and WG chairs should treat these 
> comments just like any other last call comments.
> 
> 
> HIP documents where this is addressed?  If so, they should be pointed to 
> here.  If not, this should be pointed out,
> <mailto:[email-masked]>
>