Subject: [secdir] secdir review of draft-ietf-v6ops-rogue-ra

From: Samuel Weiler <[email-masked]>
Date: Thu, 3 Jun 2010 01:06:52 -0400 (EDT)

I have reviewed this document as part of the security directorate's
ongoing effort to review all IETF documents being processed by the
IESG.  These comments were written primarily for the benefit of the
security area directors.  Document editors and WG chairs should treat
these comments just like any other last call comments.

This expired doc has been in the secdir queue for some time.  It's not 
clear what the current state is, but I gave it a once-over now and 
will look at it again if it's ever revived.

While the security considerations sectional is minimal, that's 
generally fine for an informational doc such as this.

That said, I would like to see more thought given to malicious RAs and 
whether each of these methods could be effectively applied against 
them (e.g. how easy is each to subvert?).  And if none of the methods 
are applicable, as the current security considerations says, then also 
call that out in the abstract and intro.

Second, I'm surprised that the only end-host based solutions are 
staticly-configured packet filters (3.7) and delays (3.9).  Why not 
simply "try, try again": accept multiple RAs, see which ones work, and 
discard (or at least don't use) the rest?

Lastly, the table in section 4 is a little unclear: does "Y" mean 
"helps (somewhat)" or "is completely sufficient"?  I think it means 
the former, but clarity would be good.

---

From: Tim Chown <[email-masked]>
Date: Thu, 3 Jun 2010 13:30:32 +0100

Hi,

The document was originally being pushed through alongside Gunter's RA guard draft, with the Rogue RA text as the problem statement and Gunter's text as a/one solution.   Both have been somewhere in the upwards pipe towards publication for a year or so now, hence the expiry.   The RA guard draft was 'tickled' to keep it rom expiring, see http://tools.ietf.org/html/draft-ietf-v6ops-ra-guard-05, so if Stig and I need to do the same for our draft, please let us know.

Regarding your comment on malicious attacks, that's a good observation, but the text was steered away from that direction in previous updates based on feedback from the WG (specifically the chart in Section 4 used to have a 'Malicious RA' column, which was later removed), so personally I'd rather not put that perspective back in the text and risk reopening the (same) WG discussion.

On your second point, yes, in theory, but you're pretty much stepping into multihomed host solutions which are rather out of scope for this draft.   For genuine multiple RAs (or RAs with multiple prefixes) there's also RFC3484 address selection.   What our draft basically says is that unintended RAs can cause 'badness', and here are some solutions to them that enterprise administrators could apply. 

On the third point, yes, your assumption is correct.  We could make that more explicit.

It would be really great to get this text published, as it's been queued for quite a while, and it gets cited quite frequently along with RA Guard in various mailing list discussions.

Tim

On 3 Jun 2010, at 06:06, Samuel Weiler wrote:

> This expired doc has been in the secdir queue for some time.  It's not clear what the current state is, but I gave it a once-over now and will look at it again if it's ever revived.
> 
> While the security considerations sectional is minimal, that's generally fine for an informational doc such as this.
> 
> That said, I would like to see more thought given to malicious RAs and whether each of these methods could be effectively applied against them (e.g. how easy is each to subvert?).  And if none of the methods are applicable, as the current security considerations says, then also call that out in the abstract and intro.
> 
> Second, I'm surprised that the only end-host based solutions are staticly-configured packet filters (3.7) and delays (3.9).  Why not simply "try, try again": accept multiple RAs, see which ones work, and discard (or at least don't use) the rest?
> 
> Lastly, the table in section 4 is a little unclear: does "Y" mean "helps (somewhat)" or "is completely sufficient"?  I think it means the former, but clarity would be good.

---

From: Samuel Weiler <[email-masked]>
Date: Wed, 9 Jun 2010 13:01:13 -0400 (EDT)

Thanks for the explanation re: why the malicious RA text was removed.

On Thu, 3 Jun 2010, Tim Chown wrote:

[reordering text for ease of reading]

>> simply "try, try again": accept multiple RAs, see which ones work, 
>> and discard (or at least don't use) the rest?
>
> On your second point, yes, in theory, but you're pretty much 
> stepping into multihomed host solutions which are rather out of 
> scope for this draft.  For genuine multiple RAs (or RAs with 
> multiple prefixes) there's also RFC3484 address selection.  What our 
> draft basically says is that unintended RAs can cause 'badness', and 
> here are some solutions to them that enterprise administrators could 
> apply.

I'm not convinced that "test before use" is necessarily equivalent to 
multihoming.  And the doc is already covering some host-based 
mitigations (in 3.7 and 3.9).  Why discard this one?

-- Sam

---

From: Tim Chown <[email-masked]>
Date: Thu, 10 Jun 2010 14:11:54 +0100

On 9 Jun 2010, at 18:01, Samuel Weiler wrote:

> I'm not convinced that "test before use" is necessarily equivalent to multihoming.  And the doc is already covering some host-based mitigations (in 3.7 and 3.9).  Why discard this one?

Fair point Sam.   I think 3.9 (wait before use) was a suggestion from one IETF WG meeting, which really isn't that practical, so could actually be quite reasonably dropped.   The original aim of the draft was to cite practical steps an administrator could take, but 3.2 (RA snooping/RA Guard), 3.4 (use SeND) and 3.11 (add options to DHCPv6) are all methods that are also, as yet, not available.   So we could add your suggestion.

One consideration in 'test before use' though is that connectivity might work, from a user/application perspective, but it might not work as intended or with undesirable consequences/side effects, e.g. via an unintended VLAN or router.

Tim