Subject: [secdir] Secdir review of draft-ietf-sip-hitchhikers-guide-05.txt

From: Charlie Kaufman <[email-masked]>
Date: Thu, 9 Oct 2008 14:16:35 -0700

I am reviewing this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments. Feel free to forward to any appropriate forum.

This document lists and categorizes all of the RFCs and Internet Drafts concerning SIP with a goal of helping someone who is trying to find the right document do so. It contains a short paragraph summarizing each document.

As such this document raises no new security considerations (and says so, pointing readers at the security considerations sections of the underlying documents). In the context of this document, that seems entirely appropriate.

Note to authors and WG chairs: There is a problem with this document in that it will quickly become out of date as RFCs are updated, I-Ds are promoted to RFC or abandoned, and new I-Ds are created. I could imagine the RFC editor blocking its promotion until all of the referenced I-Ds are either promoted or abandoned, by which time it would certainly be obsolete. It might be that this document will need to "permanently" be an I-D unless at some point in the future activity in the SIP space drops off dramatically. I don't know whether there is precedent for such a document. There probably should be such a document for each area or sub-area.

Typo: p5 "identifes"-> "identifies"

        --Charlie

_______________________________________________
secdir mailing list
[email-masked]
https://mailman.mit.edu/mailman/listinfo/secdir
_______________________________________________
secdir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/secdir

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 10 Oct 2008 03:38:44 +0200

The agreement in the SIP group was that we would try and update this document every 12 - 18 months. 

So we certainly do not want the document held by the RFC editor to complete these references. We will always fix that in a revision.

Regards

Keith 

> -----Original Message-----
> From: Charlie Kaufman [mailto:[email-masked]] 
> Sent: Thursday, October 09, 2008 10:17 PM
> To: [email-masked]; [email-masked]; 
> [email-masked]; DRAGE, Keith (Keith)
> Subject: Secdir review of draft-ietf-sip-hitchhikers-guide-05.txt
> 
> I am reviewing this document as part of the security 
> directorate's ongoing effort to review all IETF documents 
> being processed by the IESG.  These comments were written 
> primarily for the benefit of the security area directors.  
> Document editors and WG chairs should treat these comments 
> just like any other last call comments. Feel free to forward 
> to any appropriate forum.
> 
> This document lists and categorizes all of the RFCs and 
> Internet Drafts concerning SIP with a goal of helping someone 
> who is trying to find the right document do so. It contains a 
> short paragraph summarizing each document.
> 
> As such this document raises no new security considerations 
> (and says so, pointing readers at the security considerations 
> sections of the underlying documents). In the context of this 
> document, that seems entirely appropriate.
> 
> Note to authors and WG chairs: There is a problem with this 
> document in that it will quickly become out of date as RFCs 
> are updated, I-Ds are promoted to RFC or abandoned, and new 
> I-Ds are created. I could imagine the RFC editor blocking its 
> promotion until all of the referenced I-Ds are either 
> promoted or abandoned, by which time it would certainly be 
> obsolete. It might be that this document will need to 
> "permanently" be an I-D unless at some point in the future 
> activity in the SIP space drops off dramatically. I don't 
> know whether there is precedent for such a document. There 
> probably should be such a document for each area or sub-area.
>

---

From: Charlie Kaufman <[email-masked]>
Date: Fri, 10 Oct 2008 10:51:24 -0700

That should probably be mentioned in the introduction. Is that concept cleared with the RFC Editor? Generally, RFCs can't reference I-Ds, but clearly in this case that's what you want.

        --Charlie

-----Original Message-----
From: DRAGE, Keith (Keith) [mailto:[email-masked]]
Sent: Thursday, October 09, 2008 6:39 PM
To: Charlie Kaufman; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Secdir review of draft-ietf-sip-hitchhikers-guide-05.txt

Regards

Keith

---

From: Barry Leiba <[email-masked]>
Date: Fri, 10 Oct 2008 14:43:49 -0400

> That should probably be mentioned in the introduction. Is that concept cleared
> with the RFC Editor? Generally, RFCs can't reference I-Ds, but clearly in this
> case that's what you want.

Standards-track RFCs can't mention I-Ds normatively.  This is not on the 
standards track, nor are the references normative.

Barry