Subject: [saag] TLS signing request software other than openssl

From: "John Levine" <[email-masked]>
Date: 25 Apr 2019 16:22:11 -0400

I know how to use "openssl req" to make a signing request.

Is there any other library or package that's used at all widely
to create requests?  Tnx.

-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Apr 2019 16:59:54 -0400

https://www.namecheap.com/support/knowledgebase/article.aspx/467/67/how-to-generate-csr-certificate-signing-request-code

> On Apr 25, 2019, at 4:22 PM, John Levine <[email-masked]> wrote:
> 
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: Peter Gutmann <[email-masked]>
Date: Fri, 26 Apr 2019 01:56:03 +0000

John Levine <[email-masked]> writes:

>Is there any other library or package that's used at all widely to create
>requests?  Tnx.

There's lots, take your pick, OpenSSL obviously, Bouncy Castle, JDK, my own
cryptlib, even an online tool, https://csrgenerator.com/.

Alternatively, use the link below:

http://lmgtfy.com/?q=create+pkcs+%2310

Peter.

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 25 Apr 2019 22:40:25 -0400

On Fri, Apr 26, 2019, at 11:56, Peter Gutmann wrote:
> https://csrgenerator.com/

That's probably OK, but it produces a private key in a context you don't want.  Use it for demonstration purposes only.

Add NSS `certutil -R` to the list.

---

From: Watson Ladd <[email-masked]>
Date: Fri, 26 Apr 2019 19:16:10 -0700

I've always used https://github.com/cloudflare/cfssl at work (not
surprisingly) and found it gets the job done.

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.