Subject: [saag] Fw: [internet-draft-draft] ParrotTalk: Anonymous P2P encryption

From: Bob <[email-masked]>
Date: Fri, 03 Nov 2017 09:07:06 -0400

Good morning,

I am forwarding this announcement of the ParrotTalk v3.6 specification and 2 reference implementations, in Squeak/Pharo and Java, to the SAAG list. I was advised that this mailing list regarding the Security Area is the correct home for this announcement. Below, I corrected the version of the Squeak/Pharo ParrotTalk code to version 11, interoperable with the Java version. I am proceeding to work on the Internet-Draft and I hope some discussion builds around this work.

Thank you.
---
Robert

> -------- Original Message --------
> Subject: [internet-draft-draft] ParrotTalk: Anonymous P2P encryption
> Local Time: November 2, 2017 9:19 PM
> UTC Time: November 3, 2017 1:19 AM
> From: [email-masked]
> To: IETF <[email-masked]>
>
> I have developed the ParrotTalk Protocol, and am starting an internet draft document[1] for submission to the process at IETF.
>
> ParrotTalk Protocol is documented in part here[2], while I have two implementations: 1 in Squeak/Pharo[3 a/b] and the other in Java[4 a/b]. The particulars of MAC key and ivSequence derivation, as well as constrained traffic signing, are the implementations, yet missing from the specification. They will be added to the internet-draft.
>
> How do I go about submitting a specification for ParrotTalk for IETF review and consideration?
>
> Thank you.
>
> - Robert
>
> [1] IETF I-D draft - http://jmp.sh/VRejS2g
>
> [2] ParrotTalk Frame Design - http://jmp.sh/OqlYpyg
>
> [3 a] Squeak/Pharo Cryptography library - http://www.squeaksource.com/Cryptography/Cryptography-HenryHouse.113.mcz
> [3 b] Squeak/Pharo ParrotTalk v3.6 - [http://www.squeaksource.com/Cryptography/ParrotTalk-HenryHouse.11.mcz](http://www.squeaksource.com/Cryptography/ParrotTalk-HenryHouse.9.mcz)
>
> [4 a] Java ASN1 framework - https://github.com/ZiroZimbarra/ASN1
> [4 b] Java ParrotTalk v3.6 - https://github.com/ZiroZimbarra/ParrotTalk

---

From: Bob <[email-masked]>
Date: Sat, 04 Nov 2017 13:56:36 -0400

I updated the I-D located here: http://jmp.sh/VRejS2g

Thank you for your consideration,
---
Robert

> Subject: [saag] Fw: [internet-draft-draft] ParrotTalk: Anonymous P2P encryption
> Local Time: November 3, 2017 9:07 AM
> UTC Time: November 3, 2017 1:07 PM
> From: [email-masked]
> To: SAAG <[email-masked]>
>
> Good morning,
>