Subject: [saag] Guidance for writing Internet-Drafts?

From: Peter Alexander <[email-masked]>
Date: Tue, 3 Oct 2017 10:07:12 -0400

Greetings!

Some years ago myself, and another individual drafted a patent application
for a novel use of IPSec which enhanced security between endpoints. Since
then the application has been rejected, and the company has been
dismantled. My co-author at the time mentioned how cool it would be if we
could turn the idea into an RFC eventually. I have finally decided to begin
looking into that.

Having never written an Internet-Draft I would greatly appreciate some
guidance (beyond the Guidelines to Authors of Internet-Drafts) regarding a
formal submission.

I do hope that I have found the correct place for this discussion.

Cheers,

Peter Alexander

---

From: Yoav Nir <[email-masked]>
Date: Tue, 3 Oct 2017 20:10:21 +0300

Hi, Peter

1. Find some draft that looks like what you want.  For example, let’s pick https://tools.ietf.org/html/draft-nir-ipsecme-eddsa-01 <https://tools.ietf.org/html/draft-nir-ipsecme-eddsa-01>
2. Click that “XML” tag at the top. You’ll get https://tools.ietf.org/id/draft-nir-ipsecme-eddsa-01.xml <https://tools.ietf.org/id/draft-nir-ipsecme-eddsa-01.xml>
3, Download the file and rename it to something like draft-alexander-ipsecme-enhanced-security-00.xml
4. The format is not too complicated. You can edit it to have your content.
5. Either install the utility xml2rfc or use the online converter at https://xml2rfc.tools.ietf.org <https://xml2rfc.tools.ietf.org/>
6. Repeat until you like what it looks like.
7. Submit on the draft submission page: https://datatracker.ietf.org/submit/ <https://datatracker.ietf.org/submit/>

Then, when there’s a draft, you can start a thread about the content either here on on the IPsec mailing list: https://www.ietf.org/mailman/listinfo/ipsec <https://www.ietf.org/mailman/listinfo/ipsec>

HTH

Yoav

> On 3 Oct 2017, at 17:07, Peter Alexander <[email-masked]> wrote:
> 
> Greetings!
> 
> Some years ago myself, and another individual drafted a patent application for a novel use of IPSec which enhanced security between endpoints. Since then the application has been rejected, and the company has been dismantled. My co-author at the time mentioned how cool it would be if we could turn the idea into an RFC eventually. I have finally decided to begin looking into that.
> 
> Having never written an Internet-Draft I would greatly appreciate some guidance (beyond the Guidelines to Authors of Internet-Drafts) regarding a formal submission.
> 
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: Peter Alexander <[email-masked]>
Date: Tue, 3 Oct 2017 13:46:33 -0400

Yoav,

Thank you for this.
I will start digging around to see if I can find something similar.

Pete

On Tue, Oct 3, 2017 at 1:10 PM, Yoav Nir <[email-masked]> wrote:

> Hi, Peter
>
> 1. Find some draft that looks like what you want.  For example, let’s pick
> https://tools.ietf.org/html/draft-nir-ipsecme-eddsa-01
> 2. Click that “XML” tag at the top. You’ll get https://tools.ietf.org/id/
> draft-nir-ipsecme-eddsa-01.xml
> 3, Download the file and rename it to something like
> draft-alexander-ipsecme-enhanced-security-00.xml
> 5. Either install the utility xml2rfc or use the online converter at
> https://xml2rfc.tools.ietf.org
> 7. Submit on the draft submission page: https://datatracker.
> ietf.org/submit/
>
> Then, when there’s a draft, you can start a thread about the content
> either here on on the IPsec mailing list: https://www.ietf.org/
> mailman/listinfo/ipsec
>
> HTH
>
> Yoav
>