Subject: [saag] Ledger BoF

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Thu, 14 Jul 2016 16:05:16 +0000

Hello all,

This is to let you all know about the Ledger BoF. This is a non-working group forming BoF to introduce the InterLedger protocol and crypto conditions work started in W3C Web Payments. It's on Thursday 21 July at Afternoon II (16:20 - 18:20) in Potsdam I.

The Interledger protocol is an open and neutral protocol for making payments between disconnected payment networks and ledgers. It defines schemes and primitives for dealing with addressing of ledgers, fragmentation of payment networks, and cryptographically secured validation of transfer conditions and fulfillments.

Initially started within a W3C community group in October 2015, the purpose of this non-working group forming BoF is to introduce Interledger and the underlying protocols to attendees and discuss how this work might progress at the IETF.

The W3C Community where this work originated is at < https://www.w3.org/community/interledger/ >.

The relevant drafts are:

* The Interledger Protocol < https://tools.ietf.org/html/draft-thomas-interledger-00 >
* Crypto-Conditions < https://tools.ietf.org/html/draft-thomas-crypto-conditions-00 >

Thank you,

--
- m&m

Matt Miller
Cisco Systems, Inc.

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Fri, 15 Jul 2016 13:52:44 +0200

Hey Matt,

There is also a lot of info on the project website https://interledger.org
<http://interledger.org> and everything (markdown versions of the Internet
Drafts, reference code etc) is in the GitHub repo:
https://github.com/interledger/

As first timers to an IETF meeting my colleagues and I will be at the
training and meetup on Sunday so we'll be at IETF the whole week and would
love to meet anyone that's keen to chat before the BoF.

If you read https://tools.ietf.org/html/draft-thomas-interledger-00 you'll
see that we've got a lot of the classical networking issues to still figure
out on top of this basic protocol like routing (and a variation on that,
quoting). We've got some proposals but are keen to get input on those.

We're hoping to spend a lot of time next week talking to folks that are
especially knowledgeable in those areas so any suggestions or introductions
are welcome.

With regard to crypto-conditions, we'd also like to hear from anyone that
thinks they have a use case that would benefit from something like
crypto-conditions. We developed it specifically for our use case but it has
pretty general applicability as a drop in replacement for signatures but
with a bunch of additional features.

Looking forward to meeting you all!

Adrian

On Thursday, July 14, 2016, Matt Miller (mamille2) <[email-masked]>
wrote:

> Hello all,
>
> This is to let you all know about the Ledger BoF. This is a non-working
> group forming BoF to introduce the InterLedger protocol and crypto
> conditions work started in W3C Web Payments. It's on Thursday 21 July at
> Afternoon II (16:20 - 18:20) in Potsdam I.
>
> The Interledger protocol is an open and neutral protocol for making
> payments between disconnected payment networks and ledgers. It defines
> schemes and primitives for dealing with addressing of ledgers,
> fragmentation of payment networks, and cryptographically secured validation
> of transfer conditions and fulfillments.
>
> Initially started within a W3C community group in October 2015, the
> purpose of this non-working group forming BoF is to introduce Interledger
> and the underlying protocols to attendees and discuss how this work might
> progress at the IETF.
>
> The W3C Community where this work originated is at <
> https://www.w3.org/community/interledger/ >.
>
> The relevant drafts are:
>
> * The Interledger Protocol <
> https://tools.ietf.org/html/draft-thomas-interledger-00 >
> * Crypto-Conditions <
> https://tools.ietf.org/html/draft-thomas-crypto-conditions-00 >
>
>
> Thank you,
>
> --
> - m&m
>
> Matt Miller
> Cisco Systems, Inc.
>
>