Subject: Re: [saag] Open Trust Protocol

From: Ira McDonald <[email-masked]>
Date: Mon, 25 Jul 2016 13:58:00 -0400

Hi Hannes,

Could you comment on the relationship between this Open
Trust Protocol (OTrP) and the Global Platform TEE Management
Framework spec (meant to do similar things, I think) that just
finished a public review phase on 20 June 2016?

I was aware of the GP TMF because the Trusted Computing
Group mobile work groups (MPWG and TMS) were asked to
write comments.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Jul 25, 2016 at 12:55 PM, Hannes Tschofenig <
[email-masked]> wrote:

> Hi all,
>
> FYI: I had planned to talk about the 'Open Trust Protocol' in the T2TRG
> meeting but unfortunately due to the lack of time this was not possible.
> Hence, I am sending an email around instead.
>
>    The Open Trust Protocol (OTrP) allows to install, update, and delete
>    applications and to manage security configuration in a Trusted
>    Execution Environment (TEE).
>
>    TEEs are used in environments where security functionality should be
>    isolated from a regular operating system (often called rich OS).
>    This form of compartmentalization grants a smaller codebase access to
>    security sensitive services and restricts communication from the rich
>    OS to those security services via mediated access.
>
> Here is the draft:
> https://tools.ietf.org/html/draft-pei-opentrustprotocol-01
>
> Here are my slides:
> https://github.com/t2trg/2016-ietf96/blob/master/slides/70_OTrP-IETF93.pdf
>
> Please let me know if you find this work interesting and have further
> questions.
>
> Ciao
> Hannes
>
>
>
>
>
>
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
>
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 26 Jul 2016 18:37:25 +0200

Hi Ira,

they were developed independently with OTrP being a combination of PKI
based architecture and a simplified design using state-of-the-art IETF
protocols (based on work done in the JOSE working group).

OTrP may be attractive to IoT use cases that want to use hardware
security technology and leans on deployed architectures with a focus on
low protocol complexity.  OTrP was designed to be compatible with TEE
but could be used for other technologies as well.

I put my co-worker Rob on CC since he is participates in Global Platform
while I don't.

Ciao
Hannes

On 07/25/2016 07:58 PM, Ira McDonald wrote:
> mailto: [email-masked] <mailto:[email-masked]>
> On Mon, Jul 25, 2016 at 12:55 PM, Hannes Tschofenig
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi all,
> 
>     [email-masked] <mailto:[email-masked]>