Subject: [saag] FW: New Version Notification for draft-hy-gue-4-secure-transport-02.txt

From: Lucy yong <[email-masked]>
Date: Thu, 21 May 2015 19:45:00 +0000

Hello,

FYI. Generic UDP Encapsulation (GUE) protocol is now under development in NVO3 WG in Routing Area. GUE can be used for network tunnel encapsulation or transport layer encapsulation. GUE contains basic encapsulation schema with some optional capabilities.

GUE designates two options for secure transport purpose. One option is for GUE header integrity protection and authentication; another option is for GUE payload encryption.

This draft specifies these two options. We like to adapt existing security mechanisms and seek some comment/suggestion on this proposal. Welcome some security expert to joint work on the solution. 

Thanks,
Lucy  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, May 21, 2015 2:04 PM
To: Tom Herbert; Tom Herbert; Lucy yong; Lucy yong
Subject: New Version Notification for draft-hy-gue-4-secure-transport-02.txt

A new version of I-D, draft-hy-gue-4-secure-transport-02.txt
has been successfully submitted by Lucy Yong and posted to the IETF repository.

Name:		draft-hy-gue-4-secure-transport
Revision:	02
Title:		Generic UDP Encapsulation (GUE) for Secure Transport
Document date:	2015-05-20
Group:		Individual Submission
Pages:		11
URL:            https://www.ietf.org/internet-drafts/draft-hy-gue-4-secure-transport-02.txt
Status:         https://datatracker.ietf.org/doc/draft-hy-gue-4-secure-transport/
Htmlized:       https://tools.ietf.org/html/draft-hy-gue-4-secure-transport-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-hy-gue-4-secure-transport-02

Abstract:
   This document specifies the ability of Generic UDP Encapsulation
   (GUE) [GUE] to provide secure transport over IP networks and the
   Internet, including GUE header integrity protection and origin
   authentication and GUE payload encryption. These are optional
   features of GUE.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Lucy yong <[email-masked]>
Date: Thu, 21 May 2015 19:50:03 +0000

Here is the information about GUE: https://tools.ietf.org/html/draft-ietf-nvo3-gue-00

-----Original Message-----
From: Lucy yong 
Sent: Thursday, May 21, 2015 2:46 PM
To: [email-masked]'
Subject: FW: New Version Notification for draft-hy-gue-4-secure-transport-02.txt

Hello,

Thanks,
Lucy  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, May 21, 2015 2:04 PM
To: Tom Herbert; Tom Herbert; Lucy yong; Lucy yong
Subject: New Version Notification for draft-hy-gue-4-secure-transport-02.txt

Abstract:

The IETF Secretariat