Subject: [saag] draft-smith-encrypted-traffic-management

From: "Smith, Kevin, (R&D) Vodafone Group" <[email-masked]>
Date: Fri, 8 May 2015 15:35:15 +0000

Dear all,

I've posted a draft on 'Network management of encrypted traffic' [1]. This follows up from the acknowledgement in both the 'Pervasive Monitoring is an attack' BCP [2] and the  IAB statement on Internet confidentiality [3] to strike a balance that allows non-intrusive network management to continue to operate. The aim of the draft is to list ways to enable this, including new work (such as SPUD) looking into the problem. As such it intends to provide privacy-aware solutions to the effects of encryption raised in [2].

All comments and feedback very welcome. Thanks for your time!

Kevin

Kevin Smith, Vodafone R&D

[1] https://datatracker.ietf.org/doc/draft-smith-encrypted-traffic-management/ 
[2] https://tools.ietf.org/html/rfc7258 
[3] https://www.iab.org/2014/11/14/iab-statement-on-internet-confidentiality/ 
[4] https://datatracker.ietf.org/doc/draft-mm-wg-effect-encrypt/

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 08 May 2015 17:01:28 +0100

Hi Kevin,

Thanks for writing that up. I think Kathleen's maybe travelling
now (or just about to) so it might be a day or so but I'm sure
she'll get back about possibly merging bits of this text with [4].

Cheers,
S.

On 08/05/15 16:35, Smith, Kevin, (R&D) Vodafone Group wrote:
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
> 
>

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Fri, 8 May 2015 20:55:23 +0000

Hi Kevin,
I just wanted to point out a couple of similar to SPUD options. The PCP Flowdata option that was proposed in https://tools.ietf.org/html/draft-wing-pcp-flowdata-00 is another option that operates in the same context of the endpoint communicating with the network to give context about the flows without compromising privacy. Also https://tools.ietf.org/html/draft-martinsen-tram-discuss-02 is in the same context viable only for UDP.
Panos

-----Original Message-----
From: saag [mailto:[email-masked]] On Behalf Of Stephen Farrell
Sent: Friday, May 08, 2015 12:01 PM
To: Smith, Kevin, (R&D) Vodafone Group; [email-masked]
Subject: Re: [saag] draft-smith-encrypted-traffic-management

Hi Kevin,

Thanks for writing that up. I think Kathleen's maybe travelling now (or just about to) so it might be a day or so but I'm sure she'll get back about possibly merging bits of this text with [4].

Cheers,
S.

On 08/05/15 16:35, Smith, Kevin, (R&D) Vodafone Group wrote:
> [1] 
> https://datatracker.ietf.org/doc/draft-smith-encrypted-traffic-managem
> ent/ [2] https://tools.ietf.org/html/rfc7258
> [3] 
> https://www.iab.org/2014/11/14/iab-statement-on-internet-confidentiali
> ty/ [4] https://datatracker.ietf.org/doc/draft-mm-wg-effect-encrypt/
> 
> 
>

---

From: "Smith, Kevin, (R&D) Vodafone Group" <[email-masked]>
Date: Tue, 12 May 2015 15:25:11 +0000

Hi Panos,

Thanks for the feedback. I have added these as issues to the git repo at:

https://github.com/Kevsy/encrypted-traffic-management/

...and I will be releasing a revised version of the I-D with these suggestions (and others) incorporated in a couple of weeks.

All best
Kevin 

-----Original Message-----
From: Panos Kampanakis (pkampana) [mailto:[email-masked]] 
Sent: 08 May 2015 21:55
To: Smith, Kevin, (R&D) Vodafone Group; [email-masked]
Subject: RE: [saag] draft-smith-encrypted-traffic-management

Hi Kevin,

-----Original Message-----
From: saag [mailto:[email-masked]] On Behalf Of Stephen Farrell
Sent: Friday, May 08, 2015 12:01 PM
To: Smith, Kevin, (R&D) Vodafone Group; [email-masked]
Subject: Re: [saag] draft-smith-encrypted-traffic-management

Hi Kevin,

Cheers,
S.