Subject: [saag] PKCS#5

From: Simon Josefsson <[email-masked]>
Date: Wed, 04 Feb 2015 17:28:16 +0100

Hi.

RFC 2898 (PKCS#5 v2.0) has not been updated for SHA2 in the RFC series,
and PBKDF2 is often used with HMAC-SHA256 these days.  RSA/EMC appears
to have published version 2.1 of PKCS#5 at some point, but the links on
the following page are dead.  I believe HMAC-SHA2 was included in this
update.

http://www.emc.com/emc-plus/rsa-labs/standards-initiatives/pkcs-5-password-based-cryptography-standard.htm

Is there interest in updating RFC 2898 to include HMAC-SHA256, possibly
matching version 2.1 of PKCS#5?  It would be useful to add test vectors
for this.

One problematic aspect may be this quote in RFC 2898:

   This memo represents a republication of PKCS #5 v2.0 from RSA
   Laboratories' Public-Key Cryptography Standards (PKCS) series, and
   change control is retained within the PKCS process.

Change control for several other PKCS documents have been turned over to
the IETF, so I'm hoping this can be resolved.

I'm not certain SAAG is the best group for this discussion, but I
couldn't think of any more appropriate list.

/Simon

---

From: Anoosh Saboori <[email-masked]>
Date: Thu, 5 Feb 2015 16:14:30 +0000

Hello,

You can find the link to v2.1 of PKCS#5 below:

http://www.emc.com/collateral/white-papers/h11302-pkcs5v2-1-password-based-cryptography-standard-wp.pdf 

Microsoft supports this effort. 

As for control issues, PKCS#12 was recently converted to RFC so it should be an easy to task to take v2.1 of PKCS#5 and update RFC 2898. Below is RFC 7292 that corresponds to PKCS#12.

http://www.rfc-editor.org/rfc/rfc7292.txt 

-----Original Message-----
From: saag [mailto:[email-masked]] On Behalf Of Simon Josefsson
Sent: Wednesday, February 4, 2015 8:28 AM
To: [email-masked]
Subject: [saag] PKCS#5

Hi.

RFC 2898 (PKCS#5 v2.0) has not been updated for SHA2 in the RFC series, and PBKDF2 is often used with HMAC-SHA256 these days.  RSA/EMC appears to have published version 2.1 of PKCS#5 at some point, but the links on the following page are dead.  I believe HMAC-SHA2 was included in this update.

Is there interest in updating RFC 2898 to include HMAC-SHA256, possibly matching version 2.1 of PKCS#5?  It would be useful to add test vectors for this.

Change control for several other PKCS documents have been turned over to the IETF, so I'm hoping this can be resolved.

I'm not certain SAAG is the best group for this discussion, but I couldn't think of any more appropriate list.

/Simon

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 5 Feb 2015 11:57:21 -0500

Hi,

This is something I was working on, getting PKCS#1 and #5 over to the
IETF.  This is pending on some internal stuff, really just management
changes.  I had the approval from execs that are no longer with us and
got it right before they left...  I'll restart the internal process.
Basically, we would do the same thing as #12, publish a version, then
more changes happen in a subsequent iteration.

On Thu, Feb 5, 2015 at 11:14 AM, Anoosh Saboori <[email-masked]> wrote:
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

-- 

Best regards,
Kathleen