Subject: [saag] Fwd: New Version Notification for draft-os-ietf-sshfp-ecdsa-sha2-00.txt

From: Ondřej Surý <[email-masked]>
Date: Thu, 16 Jun 2011 16:56:36 +0200

Dear colleagues,

since it was brought up in some discussion about SSHFP (and DNSSEC) as
missing I took a liberty of updating DNS SSHFP Resource Records with
ECDSA algorithm (as described in RFC 5656) and also updated the hash
algorithms to include SHA-256.

It's my first security area individual submission, so please be gentle :).

The source XML is here:

http://www.ietf.org/id/draft-os-ietf-sshfp-ecdsa-sha2-00.xml

And you can find TXT here:

http://www.ietf.org/id/draft-os-ietf-sshfp-ecdsa-sha2-00.txt

Thanks for your time,
Ondrej

-------- Original Message --------
Subject: New Version Notification for draft-os-ietf-sshfp-ecdsa-sha2-00.txt
Date: Thu, 16 Jun 2011 07:51:23 -0700
From: [email-masked]
To: [email-masked]
CC: [email-masked]

A new version of I-D, draft-os-ietf-sshfp-ecdsa-sha2-00.txt has been
successfully submitted by Ondrej Sury and posted to the IETF repository.

Filename:	 draft-os-ietf-sshfp-ecdsa-sha2
Revision:	 00
Title:		 Use of SHA-256 Algorithm with RSA, DSA and ECDSA in SSHFP
Resource Records
Creation date:	 2011-06-16
WG ID:		 Individual Submission
Number of pages: 9

Abstract:
   This document defines how to store Secure Shell (SSH) ECDSA public
   keys and SHA-256 fingerprints in SSHFP Resource Records.

The IETF Secretariat

-- 
 Ondřej Surý
 vedoucí výzkumu/Head of R&D department
 -------------------------------------------
 CZ.NIC, z.s.p.o.    --    Laboratoře CZ.NIC
 Americka 23, 120 00 Praha 2, Czech Republic
 mailto:[email-masked]    http://nic.cz/
 tel:+420.222745110       fax:+420.222745112
 -------------------------------------------

---

From: Ondřej Surý <[email-masked]>
Date: Thu, 16 Jun 2011 17:48:43 +0200

One more note...  I also wrote an implementation as a patch over OpenSSH
portable (Debian version, but applies to vanilla as well).

So if you feel playful, here's the patch:
https://git.nic.cz/redmine/projects/ietf/repository/revisions/master/entry/ssh-sshfp-ecdsa.patch

The ssh-keygen -r works, I am not so sure about the verification routines.

O.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 21 Jun 2011 09:50:52 +0100

Hi All,

Ondřej's asking us to AD sponsor this. Any opinions on that
would be appreciated. For now, just a +/-1 is enough, if we
take it on there'll be a chance to comment on the detail.

Ta,
S.

---

From: Warren Kumari <[email-masked]>
Date: Wed, 22 Jun 2011 10:01:31 +0900

On Jun 21, 2011, at 5:50 PM, Stephen Farrell wrote:

> 
> Hi All,
> 
> Ondřej's asking us to AD sponsor this.

+1

> Any opinions on that
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag