Subject: [RTG-DIR] Routing directorate review of draft-ietf-pals-vpls-pim-snooping-04.txt

From: "Hejia (Jia)" <[email-masked]>
Date: Sun, 12 Mar 2017 15:14:49 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ?http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document:draft-ietf-pals-vpls-pim-snooping-04.txt
Reviewer: Jia He
Review Date: 2017-03-10
IETF LC End Date: -
Intended Status: Informational

Summary:
This document is basically well written, the nits listed below are tiny which in my opinion should not block further procedures.

Comments:
I found the examples in the appendix helped a lot to understand the procedures of PIM snooping and PIM proxying for VPLS as described in this draft.

Major Issues:
No major issues found.

Minor Issues:
1) Section 1.1, beginning of Page 5,

"Notice that traffic is always sent on ports that have point-to-point
   connections to routers ot that are attached to a LAN on which there
   is a router, even those on which there are no snooped group
   memberships, because IGMP snooping alone can not determine if there
   are interested receivers beyond those routers."

I found this sentence difficult to read. It is recommended to reorganize the sentence.

Nits:
1) Section 2.2.1, Page 7, s/MUSTforward/MUST forward
2) Sections 2.6.3 & 2.6.4, Figures 1 &2, add (PP) as the abbreviation after Prune-Pend  similar to NoInfo r(NI) and Join (J)
3) Appendix B, Page 31, add "Figure 3" before the title "An example Network for Triggering Assert"

B.R.
Jia

---

From: Olivier Dornon <[email-masked]>
Date: Mon, 13 Mar 2017 10:29:50 +0100

Jia,

Thank you for you review.

I found all your remarks valid, I'll publish an updated version shortly.

Thanks,
Olivier.

On 03/12/2017 04:14 PM, Hejia (Jia) wrote:
>
> Hello,
>
> I have been selected as the Routing Directorate reviewer for this 
> draft. The Routing Directorate seeks to review all routing or 
> routing-related drafts as they pass through IETF last call and IESG 
> review, and sometimes on special request. The purpose of the review is 
> to provide assistance to the Routing ADs. For more information about 
> the Routing Directorate, please see 
> ?http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
>
> Although these comments are primarily for the use of the Routing ADs, 
> it would be helpful if you could consider them along with any other 
> IETF Last Call comments that you receive, and strive to resolve them 
> through discussion or by updating the draft.
>
> This document is basically well written, the nits listed below are 
> tiny which in my opinion should not block further procedures.
>
> Comments:
>
> I found the examples in the appendix helped a lot to understand the 
> procedures of PIM snooping and PIM proxying for VPLS as described in 
> this draft.
>
> Major Issues:
>
> No major issues found.
>
> Minor Issues:
>
> 2) Sections 2.6.3 & 2.6.4, Figures 1 &2, add (PP) as the 
> abbreviation after Prune-Pend  similar to NoInfo r(NI) and Join (J)
>