Subject: [rtcweb] JSEP examples need to be aligned with latest version of BUNDLE

From: Christer Holmberg <[email-masked]>
Date: Fri, 8 Dec 2017 12:08:35 +0000

Hi,

At some point some of the examples in section 7 of JSEP need to be updated, in order to align with the latest version of BUNDLE.

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Fri, 8 Dec 2017 08:31:48 -0800

Christer, can you summarize the differences? I will file an issue against
JSEP.

On Fri, Dec 8, 2017 at 4:08 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> At some point some of the examples in section 7 of JSEP need to be
> updated, in order to align with the latest version of BUNDLE.
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 8 Dec 2017 19:33:16 +0000

Hi,

>Christer, can you summarize the differences? I will file an issue against JSEP.

The initial offer is as before, i.e., you assign a unique address, SDP attributes etc to each bundled m- section.

But, in the answer, and in every subsequent offer/answer, you only assign the BUNDLE port to the bundled m- section represented by the offerer/answerer BUNDLE-tag. To every other m- section you assign a zero port value and a bundle-only attribute (previously the bundle-only attribute was only defined for offers).

Regards,

Christer

On Fri, Dec 8, 2017 at 4:08 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 8 Dec 2017 19:35:12 +0000

Note that I did NOT check whether other changes are needed in JSEP due to the changes in BUNDLE – I only checked the examples.

Regards,

Christer

From: rtcweb [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 08 December 2017 21:33
To: Justin Uberti <[email-masked]>
Cc: [email-masked]
Subject: Re: [rtcweb] JSEP examples need to be aligned with latest version of BUNDLE

Hi,

Regards,

Christer

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Sat, 9 Dec 2017 17:41:26 -0800

https://github.com/rtcweb-wg/jsep/issues/843

On Fri, Dec 8, 2017 at 11:35 AM, Christer Holmberg <
[email-masked]> wrote:

> Note that I did NOT check whether other changes are needed in JSEP due to
> the changes in BUNDLE – I only checked the examples.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From:* rtcweb [mailto:[email-masked]] *On Behalf Of *Christer
> Holmberg
> *Sent:* 08 December 2017 21:33
> *To:* Justin Uberti <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [rtcweb] JSEP examples need to be aligned with latest
> version of BUNDLE
>
>
>
> Hi,
>
>
>
> The initial offer is as before, i.e., you assign a unique address, SDP
> attributes etc to each bundled m- section.
>
>
>
> But, in the answer, and in every subsequent offer/answer, you only assign
> the BUNDLE port to the bundled m- section represented by the
> offerer/answerer BUNDLE-tag. To every other m- section you assign a zero
> port value and a bundle-only attribute (previously the bundle-only
> attribute was only defined for offers).
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
>
>