Subject: [rtcweb] BUNDLE: Disallowing moving an m- section between BUNDLE groups within a single SDP offer

From: Christer Holmberg <[email-masked]>
Date: Sat, 18 Nov 2017 05:40:22 +0000

(CC:ing RTCWEB, but please reply on the MMUSIC list)

Hi,

Would anyone object to not allowing moving m- sections between BUNDLE groups within a single O/A transaction? The documentation of that is a little more complicated than I thought, and there is a risk the text becomes more confusing than it already is.

Note, that one could still send an offer where an m- section is moved out of a BUNDLE group, and then send another offer where the m- line is added to another BUNDLE group (following the normal procedures for adding an m- section to a BUNDLE group). But, one would not be allowed to remove and add within the same offer.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 18 Nov 2017 17:16:56 +0000

The change below would look something like this:

https://github.com/cdh4u/draft-sdp-bundle/pull/44

(Also contains a few spelling fixes)

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 18 November 2017 07:40
To: mmusic <[email-masked]>
Cc: RTCWeb IETF <[email-masked]>
Subject: [MMUSIC] BUNDLE: Disallowing moving an m- section between BUNDLE groups within a single SDP offer

Hi,

Regards,

Christer

---

From: Nils Ohlmeier <[email-masked]>
Date: Sat, 18 Nov 2017 12:18:35 -0800

I’m in favor of your proposed change, because the use case is small, there is a work around, and the code for handling this (hopefully rare) use case is really complex.

Best regards
  Nils Ohlmeier

> On Nov 18, 2017, at 09:16, Christer Holmberg <[email-masked]> wrote:
> 
> https://github.com/cdh4u/draft-sdp-bundle/pull/44 <https://github.com/cdh4u/draft-sdp-bundle/pull/44>
> 
>   <>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 19 Nov 2017 04:37:47 +0000

Thanks Nils!

Unless someone objects, the plan is to merge the PR and submit a new version of the draft next week. Then we can hopefully do the pub req.

Regards,

Christer

Sent from my iPhone

On 18 Nov 2017, at 23.18, Nils Ohlmeier <[email-masked]<mailto:[email-masked]>> wrote:

Best regards
  Nils Ohlmeier

On Nov 18, 2017, at 09:16, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 18 November 2017 07:40
To: mmusic <[email-masked]<mailto:[email-masked]>>
Cc: RTCWeb IETF <[email-masked]<mailto:[email-masked]>>
Subject: [MMUSIC] BUNDLE: Disallowing moving an m- section between BUNDLE groups within a single SDP offer

Hi,

Regards,

Christer
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb