Subject: Re: [rtcweb] draft-ietf-rtcweb-ip-handling: Mode 2 and VPN scenarios

From: James Pearce <[email-masked]>
Date: Fri, 10 Nov 2017 15:36:34 +0000

Hi All,

Apologies for resurrecting this topic from August. Has anything been
decided regarding this? Has it been rolled into other changes, or is it
still being considered?

Many thanks,

James

On 1 September 2017 at 14:57, Cullen Jennings <[email-masked]> wrote:

>
> > On Aug 23, 2017, at 3:06 PM, James Pearce <[email-masked]> wrote:
> >
> >
> > The obvious solution seems to be to change the behaviour of mode 2.
> Rather than using the default route in all cases, we should use the route
> that was used to fetch the origin. This seems to resolve both the usability
> and privacy concerns without reducing existing security.
>
> I agree this is a significant problem and your proposal does seems like a
> better solution that the current text. We should get people to think about
> the implications of that change.
>
>
>

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 13 Nov 2017 12:05:35 -1000

My recollection is that we agreed to do this but the draft has not been updated with this yet. 

> On Nov 10, 2017, at 5:36 AM, James Pearce <[email-masked]> wrote:
> 
> Hi All, 
> 
> Apologies for resurrecting this topic from August. Has anything been decided regarding this? Has it been rolled into other changes, or is it still being considered?
> 
> Many thanks,
> 
> James
> 
> On 1 September 2017 at 14:57, Cullen Jennings <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > On Aug 23, 2017, at 3:06 PM, James Pearce <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >
> > The obvious solution seems to be to change the behaviour of mode 2. Rather than using the default route in all cases, we should use the route that was used to fetch the origin. This seems to resolve both the usability and privacy concerns without reducing existing security.
> 
> I agree this is a significant problem and your proposal does seems like a better solution that the current text. We should get people to think about the implications of that change.
> 
> 
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Justin Uberti <[email-masked]>
Date: Tue, 14 Nov 2017 11:20:53 -0800

Yes - tracked in https://github.com/juberti/draughts/issues/87.

---

From: James Pearce <[email-masked]>
Date: Wed, 15 Nov 2017 09:47:57 +0000

Perfect. Thanks!

On 14 November 2017 at 19:20, Justin Uberti <[email-masked]> wrote:

>>> I agree this is a significant problem and your proposal does seems like
>>> a better solution that the current text. We should get people to think
>>> about the implications of that change.
>>>
>>>
>>>