Subject: Re: [rtcweb] Referring to 5245bis or 5245?

From: Flemming Andreasen <[email-masked]>
Date: Fri, 2 Jun 2017 09:40:01 -0400

Please note that we have several drafts in MMUSIC that normatively 
reference 5245bis, and some of those drafts are RTCWeb dependencies AFAIK.

Thanks

-- Flemming (as MMUSIC co-chair)

On 5/22/17 6:52 PM, Cullen Jennings wrote:
> Note that I don't think the timeline is the major issue (it is an issue) ... they key issue is that 5245bis does not seem to be needed for any technical reason by WebRTC.
>
>
>> On May 18, 2017, at 11:03 AM, Christer Holmberg <[email-masked]> wrote:
>>
>> Hi,
>>
>>   
>>
>> In general, if people have issues with referencing 5245bis because they are afraid it will hold up publication of RTCWEB specs, note that I have indicated to the ICE WG chairs that I think 5245bis is getting ready for WGLC.
>>
>>   
>>
>> Regards,
>>
>>   
>>
>> Christer
>>
>>   
>>
>> From: rtcweb [mailto:[email-masked]] On Behalf Of Bernard Aboba
>> Sent: 18 May 2017 18:50
>> To: Sean Turner <[email-masked]>
>> Cc: RTCWeb IETF <[email-masked]>
>> Subject: Re: [rtcweb] Referring to 5245bis or 5245?
>>
>>   
>>
>> Sean said:
>>
>>   
>>
>> "draft-ietf-rtcweb-transports: Likewise, the chairs believer that a reference to RFC 5245 is also appropriate in transports.  This draft was changed in version -17 to refer to 5245bis.  From GH: "The drafts -bundle and -dualstack-fairness both depend on 5245bis according to Cullen's chart in 'rtcweb-deps-13', and we already have a normative dependency from -transport on these.  So consistency of the bundle is improved by referencing 5245bis.".
>>
>> [BA] draft-ietf-rtcweb-overview has a normative reference to draft-ietf-rtcweb-transports which has a normative reference to draft-ietf-ice-dualstack-fairness which in turn has a normative reference to draft-ietf-ice-rfc5245bis.  So even if you remove the normative reference to RFC5245bis from overview and transports, publication of overview will still be held up until publication of RFC 5245bis, which will obsolete RFC 5245.
>>
>>   
>>
>> On Thu, May 18, 2017 at 8:37 AM, Sean Turner <[email-masked]> wrote:
>>
>>
>>> On May 18, 2017, at 11:35, Sean Turner <[email-masked]> wrote:
>>>
>>>
>>>> On May 18, 2017, at 10:54, Martin Thomson <[email-masked]> wrote:
>>>>
>>>> I'm really confused about the statement regarding -transports.  You
>>>> say that 5245 is sufficient, then follow with justification for the
>>>> opposite position.
>>> Sorry the change from 5425 to 5245bis was included in the latest version using that rationale.  This shows to me that it was “nice” to get alignment and point to 5245bis not that it is necessary to point 5245.  I.e., it’d be just fine to switch it back to referring to 5245.
>> Whoops:
>>
>> This shows to me that it was “nice” to get alignment and point to 5245bis not that it is necessary to point 5245bis.  I.e., it’d be just fine to switch it back to referring to 5245.
>>
>>
>>>> If we have as large a dependency as bundle that refers to 5245bis,
>>>> then we are taking a transitive dependency on 5245bis and might as
>>>> well refer to that.
>>>>
>>>> A lot of this comes down to what bundle says.  Now, I see that bundle
>>>> depends on both 5245 and its -bis, which seems pretty inconsistent.  I
>>>> don't immediately see any strong reason for bundle to refer to the
>>>> -bis, though it does refer to the ice-sip-sdp draft, which might be
>>>> sufficiently implicated as to make the change necessary.  We should
>>>> ask Christer to confirm this.
>>>>
>>>> I think that if we clarify that either way, then the reference in
>>>> -dualstack-fairness seems less of a concern; that document doesn't
>>>> need to reference 5245bis, though it would be nice if it could.
>>> Exactly!
>>>
>>> spt
>>>
>>>> On 18 May 2017 at 10:12, Sean Turner <[email-masked]> wrote:
>>>>> ekr’s discuss on draft-ietf-rtcweb-overview has raised whether drafts should refer to RFC 5245 or draft-ietf-ice-rfc5245bis.  We only need to normatively refer to 5245bis if a technical part of 5245bis needs to be read and implemented in order to implement the referring draft.  We have 7 drafts that refer to RFC 5245 and 2  that refer to draft-ietf-rfc5245bis:
>>>>>
>>>>> draft-ietf-rtcweb-overview: As noted in my response to ekr’s discuss position [0], the chairs believe that the reference to “ICE” in the ICE Agent definition should be to RFC 5245.
>>>>>
>>>>> draft-ietf-rtcweb-transports: Likewise, the chairs believer that a reference to RFC 5245 is also appropriate in transports.  This draft was changed in version -17 to refer to 5245bis.  From GH: "The drafts -bundle and -dualstack-fairness both depend on 5245bis according to Cullen's chart in 'rtcweb-deps-13', and we already have a normative dependency from -transport on these.  So consistency of the bundle is improved by referencing 5245bis."
>>>>>
>>>>> spt
>>>>>
>>>>> [0] https://mailarchive.ietf.org/arch/msg/rtcweb/GWdXRIO68FZwVtzzqugnELKeaY8
>>>>> _______________________________________________
>>>>> rtcweb mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/rtcweb
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
>>
>>   
>>
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 5 Jun 2017 14:43:57 +0200

Do you have the names of those drafts to hand?

On Fri, Jun 2, 2017 at 3:40 PM, Flemming Andreasen <[email-masked]>
wrote:

>> Note that I don't think the timeline is the major issue (it is an issue)
>> ... they key issue is that 5245bis does not seem to be needed for any
>> technical reason by WebRTC.
>>
>>
>>> In general, if people have issues with referencing 5245bis because they
>>> are afraid it will hold up publication of RTCWEB specs, note that I have
>>> indicated to the ICE WG chairs that I think 5245bis is getting ready for
>>> WGLC.
>>>
>>>
>>> Regards,
>>>
>>>
>>> Christer
>>>
>>>
>>> "draft-ietf-rtcweb-transports: Likewise, the chairs believer that a
>>> reference to RFC 5245 is also appropriate in transports.  This draft was
>>> changed in version -17 to refer to 5245bis.  From GH: "The drafts -bundle
>>> and -dualstack-fairness both depend on 5245bis according to Cullen's chart
>>> in 'rtcweb-deps-13', and we already have a normative dependency from
>>> -transport on these.  So consistency of the bundle is improved by
>>> referencing 5245bis.".
>>>
>>> [BA] draft-ietf-rtcweb-overview has a normative reference to
>>> draft-ietf-rtcweb-transports which has a normative reference to
>>> draft-ietf-ice-dualstack-fairness which in turn has a normative
>>> reference to draft-ietf-ice-rfc5245bis.  So even if you remove the
>>> normative reference to RFC5245bis from overview and transports, publication
>>> of overview will still be held up until publication of RFC 5245bis, which
>>> will obsolete RFC 5245.
>>>
>>>
>>>> Sorry the change from 5425 to 5245bis was included in the latest
>>>> version using that rationale.  This shows to me that it was “nice” to get
>>>> alignment and point to 5245bis not that it is necessary to point 5245.
>>>> I.e., it’d be just fine to switch it back to referring to 5245.
>>>>
>>> Whoops:
>>>
>>> This shows to me that it was “nice” to get alignment and point to
>>> 5245bis not that it is necessary to point 5245bis.  I.e., it’d be just fine
>>> to switch it back to referring to 5245.
>>>
>>>
>>>>>> ekr’s discuss on draft-ietf-rtcweb-overview has raised whether drafts
>>>>>> should refer to RFC 5245 or draft-ietf-ice-rfc5245bis.  We only need to
>>>>>> normatively refer to 5245bis if a technical part of 5245bis needs to be
>>>>>> read and implemented in order to implement the referring draft.  We have 7
>>>>>> drafts that refer to RFC 5245 and 2  that refer to draft-ietf-rfc5245bis:
>>>>>>
>>>>>> draft-ietf-rtcweb-overview: As noted in my response to ekr’s discuss
>>>>>> position [0], the chairs believe that the reference to “ICE” in the ICE
>>>>>> Agent definition should be to RFC 5245.
>>>>>>
>>>>>> draft-ietf-rtcweb-transports: Likewise, the chairs believer that a
>>>>>> reference to RFC 5245 is also appropriate in transports.  This draft was
>>>>>> changed in version -17 to refer to 5245bis.  From GH: "The drafts -bundle
>>>>>> and -dualstack-fairness both depend on 5245bis according to Cullen's chart
>>>>>> in 'rtcweb-deps-13', and we already have a normative dependency from
>>>>>> -transport on these.  So consistency of the bundle is improved by
>>>>>> referencing 5245bis."
>>>>>>
>>>>>> spt
>>>>>>

---

From: Peter Thatcher <[email-masked]>
Date: Wed, 07 Jun 2017 14:49:55 +0000

It's not an MMUSIC dependency, but JSEP relies on trickle-ice and
trickle-ice relies on 5245bis, and there are definite technical reasons for
both of those dependencies.  So I don't see how JSEP can avoid depending on
5245bis, at least indirectly.

On Mon, Jun 5, 2017 at 5:44 AM Eric Rescorla <[email-masked]> wrote:

>>>> draft-ietf-ice-dualstack-fairness which in turn has a normative reference
>>>> to draft-ietf-ice-rfc5245bis.  So even if you remove the normative
>>>> reference to RFC5245bis from overview and transports, publication of
>>>> overview will still be held up until publication of RFC 5245bis, which will
>>>> obsolete RFC 5245.
>>>>
>>>>
>>>>>>> ekr’s discuss on draft-ietf-rtcweb-overview has raised whether
>>>>>>> drafts should refer to RFC 5245 or draft-ietf-ice-rfc5245bis.  We only need
>>>>>>> to normatively refer to 5245bis if a technical part of 5245bis needs to be
>>>>>>> [0]
>>>>>>> https://mailarchive.ietf.org/arch/msg/rtcweb/GWdXRIO68FZwVtzzqugnELKeaY8

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 7 Jun 2017 18:09:46 +0200

On Wed, Jun 7, 2017 at 4:49 PM, Peter Thatcher <[email-masked]> wrote:

> both of those dependencies.
>

What's the reason for trickle depending on bis

-Ekr

> So I don't see how JSEP can avoid depending on 5245bis, at least
> indirectly.
>
>
>>>> Note that I don't think the timeline is the major issue (it is an
>>>> issue) ... they key issue is that 5245bis does not seem to be needed for
>>>> any technical reason by WebRTC.
>>>>
>>>>
>>>>> In general, if people have issues with referencing 5245bis because
>>>>> they are afraid it will hold up publication of RTCWEB specs, note that I
>>>>> have indicated to the ICE WG chairs that I think 5245bis is getting ready
>>>>> for WGLC.
>>>>>
>>>>>
>>>>> Regards,
>>>>>
>>>>>
>>>>> Christer
>>>>>
>>>>>
>>>>>>>> draft-ietf-rtcweb-overview: As noted in my response to ekr’s
>>>>>>>> discuss position [0], the chairs believe that the reference to “ICE” in the
>>>>>>>> ICE Agent definition should be to RFC 5245.
>>>>>>>>

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 7 Jun 2017 16:45:22 -0400

Based on 
https://datatracker.ietf.org/doc/draft-ietf-ice-rfc5245bis/referencedby/ 
(or you can take a look at 
https://datatracker.ietf.org/doc/draft-jennings-rtcweb-deps/):

draft-ietf-mmusic-dtls-sdp 
<https://datatracker.ietf.org/doc/draft-ietf-mmusic-dtls-sdp/>

draft-ietf-mmusic-ice-sip-sdp 
<https://datatracker.ietf.org/doc/draft-ietf-mmusic-ice-sip-sdp/>

draft-ietf-mmusic-sdp-bundle-negotiation 
<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-bundle-negotiation/>

You will also have an issue with trickle-ice (and hence 
draft-ietf-mmusic-trickle-ice-sip).

I think that's it from an MMUSIC point of view.

Thanks

-- Flemming

On 6/5/17 8:43 AM, Eric Rescorla wrote:
> On Fri, Jun 2, 2017 at 3:40 PM, Flemming Andreasen <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>         Note that I don't think the timeline is the major issue (it is
>         an issue) ... they key issue is that 5245bis does not seem to
>         be needed for any technical reason by WebRTC.
>
>
>             On May 18, 2017, at 11:03 AM, Christer Holmberg
>             <[email-masked]
>             <mailto:[email-masked]>> wrote:
>
>             Hi,
>
>
>             In general, if people have issues with referencing 5245bis
>             because they are afraid it will hold up publication of
>             RTCWEB specs, note that I have indicated to the ICE WG
>             chairs that I think 5245bis is getting ready for WGLC.
>
>
>             Regards,
>
>
>             Christer
>
>
>             From: rtcweb [mailto:[email-masked]
>             <mailto:[email-masked]>] On Behalf Of Bernard Aboba
>             Sent: 18 May 2017 18:50
>             To: Sean Turner <[email-masked] <mailto:[email-masked]>>
>             Cc: RTCWeb IETF <[email-masked] <mailto:[email-masked]>>
>             "draft-ietf-rtcweb-transports: Likewise, the chairs
>             believer that a reference to RFC 5245 is also appropriate
>             in transports.  This draft was changed in version -17 to
>             refer to 5245bis.  From GH: "The drafts -bundle and
>             -dualstack-fairness both depend on 5245bis according to
>             Cullen's chart in 'rtcweb-deps-13', and we already have a
>             normative dependency from -transport on these.  So
>             consistency of the bundle is improved by referencing
>             5245bis.".
>
>             [BA] draft-ietf-rtcweb-overview has a normative reference
>             to draft-ietf-rtcweb-transports which has a normative
>             reference to draft-ietf-ice-dualstack-fairness which in
>             turn has a normative reference to
>             draft-ietf-ice-rfc5245bis.  So even if you remove the
>             normative reference to RFC5245bis from overview and
>             transports, publication of overview will still be held up
>             until publication of RFC 5245bis, which will obsolete RFC
>             5245.
>
>
>             On Thu, May 18, 2017 at 8:37 AM, Sean Turner
>             <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>                 On May 18, 2017, at 11:35, Sean Turner <[email-masked]
>                 <mailto:[email-masked]>> wrote:
>
>
>                     On May 18, 2017, at 10:54, Martin Thomson
>                     <[email-masked]
>                     <mailto:[email-masked]>> wrote:
>
>                 Sorry the change from 5425 to 5245bis was included in
>                 the latest version using that rationale.  This shows
>                 to me that it was “nice” to get alignment and point to
>                 5245bis not that it is necessary to point 5245.  I.e.,
>                 it’d be just fine to switch it back to referring to 5245.
>
>             Whoops:
>
>             This shows to me that it was “nice” to get alignment and
>             point to 5245bis not that it is necessary to point
>             5245bis.  I.e., it’d be just fine to switch it back to
>             referring to 5245.
>
>
>                     On 18 May 2017 at 10:12, Sean Turner
>                     <[email-masked] <mailto:[email-masked]>> wrote:
>
>                         ekr’s discuss on draft-ietf-rtcweb-overview
>                         has raised whether drafts should refer to RFC
>                         5245 or draft-ietf-ice-rfc5245bis.  We only
>                         need to normatively refer to 5245bis if a
>                         technical part of 5245bis needs to be read and
>                         implemented in order to implement the
>                         referring draft.  We have 7 drafts that refer
>                         to RFC 5245 and 2  that refer to
>                         draft-ietf-rfc5245bis:
>
>                         draft-ietf-rtcweb-overview: As noted in my
>                         response to ekr’s discuss position [0], the
>                         chairs believe that the reference to “ICE” in
>                         the ICE Agent definition should be to RFC 5245.
>
>                         draft-ietf-rtcweb-transports: Likewise, the
>                         chairs believer that a reference to RFC 5245
>                         is also appropriate in transports.  This draft
>                         was changed in version -17 to refer to
>                         5245bis.  From GH: "The drafts -bundle and
>                         -dualstack-fairness both depend on 5245bis
>                         according to Cullen's chart in
>                         'rtcweb-deps-13', and we already have a
>                         normative dependency from -transport on
>                         these.  So consistency of the bundle is
>                         improved by referencing 5245bis."
>
>                         spt
>
>                         [0]
>                         <https://mailarchive.ietf.org/arch/msg/rtcweb/GWdXRIO68FZwVtzzqugnELKeaY8>
>                         [email-masked] <mailto:[email-masked]>
>                         <https://www.ietf.org/mailman/listinfo/rtcweb>
>
>             [email-masked] <mailto:[email-masked]>
>             <https://www.ietf.org/mailman/listinfo/rtcweb>
>
>
>             [email-masked] <mailto:[email-masked]>
>             <https://www.ietf.org/mailman/listinfo/rtcweb>
>
>         [email-masked] <mailto:[email-masked]>
>         <https://www.ietf.org/mailman/listinfo/rtcweb>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/rtcweb>
>
>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 8 Jun 2017 04:38:54 +0200

On Wed, Jun 7, 2017 at 10:45 PM, Flemming Andreasen <[email-masked]>
wrote:

> Based on https://datatracker.ietf.org/doc/draft-ietf-ice-rfc5245bis/
> referencedby/ (or you can take a look at https://datatracker.ietf.org/
> doc/draft-jennings-rtcweb-deps/):
>

I don't see why any of these would require ICE-bis except through trickle.

I appreciate that the document reference graph shows a lot of dependencies
on ICE-bis, but what's not clear to me is what the *technical* dependencies
are.
-Ekr

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Jun 2017 07:21:11 +0000

Hi,

I think one question is what is meant by “technical”.

As I’ve said before, most (if not all) of the non-editorial changes in 5245bis have been done based on claims (mostly from the RTCWEB community!) that there are features in legacy ICE that don’t work good, can cause congestion etc. So, while legacy ICE may not be broken, in my opinion the changes in 5245bis for sure are more than "nice-to-have" ones.

Regards,

Christer

From: Eric Rescorla <[email-masked]<mailto:[email-masked]>>
Date: Thursday 8 June 2017 at 05:38
To: Flemming Andreasen <[email-masked]<mailto:[email-masked]>>
Cc: Cullen Jennings <[email-masked]<mailto:[email-masked]>>, Christer Holmberg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] Referring to 5245bis or 5245?

On Wed, Jun 7, 2017 at 10:45 PM, Flemming Andreasen <[email-masked]<mailto:[email-masked]>> wrote:
Based on https://datatracker.ietf.org/doc/draft-ietf-ice-rfc5245bis/referencedby/ (or you can take a look at https://datatracker.ietf.org/doc/draft-jennings-rtcweb-deps/):

draft-ietf-mmusic-dtls-sdp<https://datatracker.ietf.org/doc/draft-ietf-mmusic-dtls-sdp/>

draft-ietf-mmusic-ice-sip-sdp<https://datatracker.ietf.org/doc/draft-ietf-mmusic-ice-sip-sdp/>

draft-ietf-mmusic-sdp-bundle-negotiation<https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-bundle-negotiation/>

I appreciate that the document reference graph shows a lot of dependencies on ICE-bis, but what's not clear to me is what the *technical* dependencies are.
-Ekr

You will also have an issue with trickle-ice (and hence draft-ietf-mmusic-trickle-ice-sip).

Thanks

-- Flemming

On Fri, Jun 2, 2017 at 3:40 PM, Flemming Andreasen <[email-masked]<mailto:[email-masked]>> wrote:
Please note that we have several drafts in MMUSIC that normatively reference 5245bis, and some of those drafts are RTCWeb dependencies AFAIK.

Thanks

On May 18, 2017, at 11:03 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Christer

From: rtcweb [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Bernard Aboba
Sent: 18 May 2017 18:50
To: Sean Turner <[email-masked]<mailto:[email-masked]>>
Cc: RTCWeb IETF <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rtcweb] Referring to 5245bis or 5245?

Sean said:

On Thu, May 18, 2017 at 8:37 AM, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:

On May 18, 2017, at 11:35, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:

On May 18, 2017, at 10:54, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

spt

On 18 May 2017 at 10:12, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:
ekr’s discuss on draft-ietf-rtcweb-overview has raised whether drafts should refer to RFC 5245 or draft-ietf-ice-rfc5245bis.  We only need to normatively refer to 5245bis if a technical part of 5245bis needs to be read and implemented in order to implement the referring draft.  We have 7 drafts that refer to RFC 5245 and 2  that refer to draft-ietf-rfc5245bis:

spt

[0] https://mailarchive.ietf.org/arch/msg/rtcweb/GWdXRIO68FZwVtzzqugnELKeaY8
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 8 Jun 2017 09:14:26 -0400

On 6/7/17 10:38 PM, Eric Rescorla wrote:
>
>
> On Wed, Jun 7, 2017 at 10:45 PM, Flemming Andreasen 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Based on
>     <https://datatracker.ietf.org/doc/draft-ietf-ice-rfc5245bis/referencedby/>
>     https://datatracker.ietf.org/doc/draft-jennings-rtcweb-deps/
>     <https://datatracker.ietf.org/doc/draft-jennings-rtcweb-deps/>):
>
> I appreciate that the document reference graph shows a lot of 
> dependencies on ICE-bis, but what's not clear to me is what the 
> *technical* dependencies are.
The MMUSIC list would be the best place to discuss that further and if 
you want to make changes, then I'd suggest a thread per draft to 
understand the technical dependencies.

FYI, the MMUSIC chairs, ICE chairs and our AD (Ben Campbell) did have a 
discussion around this issue about a year ago in the context of bundle. 
At the time, we did identify references to new 5245bis behavior in the 
bundle draft that some people had asked for explicitly.

Thanks

-- Flemming

>>     On Fri, Jun 2, 2017 at 3:40 PM, Flemming Andreasen
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         Please note that we have several drafts in MMUSIC that
>>         normatively reference 5245bis, and some of those drafts are
>>         RTCWeb dependencies AFAIK.
>>
>>         Thanks
>>
>>             Note that I don't think the timeline is the major issue
>>             (it is an issue) ... they key issue is that 5245bis does
>>             not seem to be needed for any technical reason by WebRTC.
>>
>>
>>                 In general, if people have issues with referencing
>>                 5245bis because they are afraid it will hold up
>>                 publication of RTCWEB specs, note that I have
>>                 indicated to the ICE WG chairs that I think 5245bis
>>                 is getting ready for WGLC.
>>
>>
>>                 Regards,
>>
>>
>>                 Christer
>>
>>
>>                 believer that a reference to RFC 5245 is also
>>                 appropriate in transports.  This draft was changed in
>>                 version -17 to refer to 5245bis.  From GH: "The
>>                 drafts -bundle and -dualstack-fairness both depend on
>>                 5245bis according to Cullen's chart in
>>                 'rtcweb-deps-13', and we already have a normative
>>                 dependency from -transport on these.  So consistency
>>                 of the bundle is improved by referencing 5245bis.".
>>
>>                 [BA] draft-ietf-rtcweb-overview has a normative
>>                 reference to draft-ietf-rtcweb-transports which has a
>>                 normative reference to
>>                 draft-ietf-ice-dualstack-fairness which in turn has a
>>                 normative reference to draft-ietf-ice-rfc5245bis.  So
>>                 even if you remove the normative reference to
>>                 RFC5245bis from overview and transports, publication
>>                 of overview will still be held up until publication
>>                 of RFC 5245bis, which will obsolete RFC 5245.
>>
>>
>>                     On May 18, 2017, at 11:35, Sean Turner
>>                     Sorry the change from 5425 to 5245bis was
>>                     included in the latest version using that
>>                     rationale. This shows to me that it was “nice” to
>>                     get alignment and point to 5245bis not that it is
>>                     necessary to point 5245.  I.e., it’d be just fine
>>                 This shows to me that it was “nice” to get alignment
>>                 and point to 5245bis not that it is necessary to
>>                 point 5245bis.  I.e., it’d be just fine to switch it
>>                 back to referring to 5245.
>>
>>
>>                             ekr’s discuss on
>>                             draft-ietf-rtcweb-overview has raised
>>                             whether drafts should refer to RFC 5245
>>                             or draft-ietf-ice-rfc5245bis.  We only
>>                             technical part of 5245bis needs to be
>>                             draft-ietf-rtcweb-overview: As noted in
>>                             my response to ekr’s discuss position
>>                             [0], the chairs believe that the
>>                             reference to “ICE” in the ICE Agent
>>                             definition should be to RFC 5245.
>>
>>                             draft-ietf-rtcweb-transports: Likewise,
>>                             the chairs believer that a reference to
>>                             RFC 5245 is also appropriate in
>>                             transports.  This draft was changed in
>>                             version -17 to refer to 5245bis.  From
>>                             GH: "The drafts -bundle and
>>                             -dualstack-fairness both depend on
>>                             5245bis according to Cullen's chart in

---

From: Sean Turner <[email-masked]>
Date: Thu, 8 Jun 2017 16:32:09 +0200

> On Jun 8, 2017, at 15:14, Flemming Andreasen <[email-masked]> wrote:
> 
> 
> 
>> On Wed, Jun 7, 2017 at 10:45 PM, Flemming Andreasen <[email-masked]> wrote:
> The MMUSIC list would be the best place to discuss that further and if you want to make changes, then I'd suggest a thread per draft to understand the technical dependencies. 
> 
> FYI, the MMUSIC chairs, ICE chairs and our AD (Ben Campbell) did have a discussion around this issue about a year ago in the context of bundle. At the time, we did identify references to new 5245bis behavior in the bundle draft that some people had asked for explicitly. 
> 
> Thanks 
> 
> -- Flemming 

Flemming,

I have to ask if those conversation happened on list?  If not, it seems to me like the shorter path might be to share those 5245bis behaviors you identified.

spt

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 8 Jun 2017 10:48:31 -0400

> I have to ask if those conversation happened on list?  If not, it seems to me like the shorter path might be to share those 5245bis behaviors you identified.
They were off-list. There is a reference to "ice-pwd" as part of a note 
that was added following list discussion. There is also a reference to 
ice-sip-sdp, which in turn would depend on 5245bis - there might be more 
(we did not do an exhaustive investigation at the time, but those two 
were noted).

In any case, if you want to advocate changes in the MMUSIC drafts, those 
changes should be discussed on the MMUSIC list.

Thanks

-- Flemming

> spt.