Subject: Re: [rtcweb] Eric Rescorla's Discuss on draft-ietf-rtcweb-overview-18: (with DISCUSS and COMMENT)

From: Christer Holmberg <[email-masked]>
Date: Thu, 11 May 2017 07:44:00 +0000

Hi,

What is the status regarding this?

Regards,

Christer

On 26/04/17 06:02, "Sean Turner" <[email-masked]> wrote:

>
>> On Apr 23, 2017, at 14:44, Christer Holmberg
>><[email-masked]> wrote:
>> 
>> Hi,
>> 
>>> ----------------------------------------------------------------------
>>> DISCUSS:
>>> ----------------------------------------------------------------------
>>> 
>>> Your citation to ICE is to 5245-bis, but at least the JSEP editor
>>>consensus was that WebRTC depended on 5245, so this needs to be
>>>resolved one way or the other.
>> 
>> Keep in mind that, no matter what draft-rtcweb-overview and
>>draft-rtcweb-jsep explicitly say, both specs reference 5245bis
>>*IMPLICITLY*, e.g., via draft-mmusic-bundle, draft-ice-trickle etc... As
>>I have indicated in the past, it would cause confusion to reference both.
>> 
>> So, I think we shall reference 5245-bis everywhere (I also thought we
>>already decided no that in the past)-
>> 
>> Regards,
>> 
>> Christer
>
>/* bike shed alert:
>/* 
>/* Assuming you¹re of the mind that a bis/updates draft is
>/* signaling to all implementors of the original RFC that the
>/* intention is that all implementations be updated then it¹s
>/* a bit more than implicit.
>
>spt
>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 11 May 2017 06:43:51 -0700

Question for the chairs.

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 12 May 2017 17:54:55 -0600

Let me try and answer with the caveat that I may get this wrong and need to be corrected by my co-chairs...

TL;DR - The chairs recommend changing the ref in overview to point at 5245 instead of 5245-bis

here is the longer version.... 

First a side note on how we got here. Some of the reasons we set up dependencies  like they are is that many years ago we made guess about what order work would get completed on and, shockingly, some predictions of standards developments timelines were less than perfect. We also assumed that some new work was going to require changes in ICE but as that work went progressed, we largely figured out ways to make it work with existing ICE implementations. 

We are confident that overview does not actually depend on anything in 5245-bis but instead just depends on 5245. 

Next lets discuss trickle-ice. The WebRTC set of specs currently normatively depends on trickle ICE. There is some questions if trickle ICE might depend on 5245-bis. Some of the trickle ICE  authors do not think it does. One of the authors said the chairs asked them to ref 5245 instead of 5245bis as both tickle ICE and 5245bis would be done around the same time. In general, the webrtc chairs would prefer to make the WebRTC dependency cluster as small as possible. If trickle ice actually gets done before 5245bis, and it does not depend on any 5245bis features, then clearly is should be changed to just depend on 5245. The WG responsible for 5245bis and trickle ICE can figure out what they want to do as both theses drafts progress. Given there is a strong possibility that trickle ice will only reference 5245, we think it would be better if overview did not bring 5245bis into the WebRTC dependency cluster. If on the other hand, trickle ICE does end up depending on 5245bis, there is no harm, and no need to change overview to point at 5245. 

There are other drafts that are normative dependencies of JSEP and the WebRTC cluster that also point at 5245bis. When we consider the technical things these drafts need, it seems likely they can also reference 5245 instead of 5245bis. For example draft-ietf-ice-dualstack-fairness, draft-ietf-mmusic-ice-sip-sdp, draft-ietf-mmusic-sdp-bundle-negotiation, and draft-ietf-rtcweb-transports (which is with the RFC Editor). The argument for the others is roughly the same as it is with trickle ICE. 

Cullen (without review from my co-chairs but trying to represent what we discussed on our chair call)

PS - if you are trying to figure out some of the dependencies for the WebRTC cluster, you might find https://datatracker.ietf.org/doc/draft-jennings-rtcweb-deps/?include_text=1 useful but it is not 100% accurate. 

> On May 11, 2017, at 7:43 AM, Eric Rescorla <[email-masked]> wrote:
> 
> Question for the chairs.
> 
> On Thu, May 11, 2017 at 12:44 AM, Christer Holmberg <[email-masked]> wrote:
> Hi,
>

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 13 May 2017 07:54:06 +0000

Hi,

As co-chair of a number of the dependencies, we have been discussing what to reference a number of times, and we have also changed the references. We can't keep changing back and forth. 

In addition, I don't think WG X can decide what the drafts of WG Y reference. There needs to be a collaborative decision.

"We also assumed that some new work was going to require changes in ICE but as that work went progressed, we largely figured out ways to make it work with existing ICE implementations."

Is this "discovery" documented somewhere?

"If trickle ice actually gets done before 5245bis, and it does not depend on any 5245bis features, then clearly is should be changed to just depend on 5245."

First, we need to agree on whether trickle depends on 5245bis features or not.

Second, as co-author of 5245bis, I have asked the chairs to initiate the road towards WGLC, so I would hope both 5245bis and trickle-ice could be done more or less at the same time.

Regards,

Christer

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]] 
Sent: 13 May 2017 01:55
To: Eric Rescorla <[email-masked]>; Christer Holmberg <[email-masked]>
Cc: Sean Turner <[email-masked]>; The IESG <[email-masked]>; [email-masked]; RTCWeb IETF <[email-masked]>; [email-masked]
Subject: Re: [rtcweb] Eric Rescorla's Discuss on draft-ietf-rtcweb-overview-18: (with DISCUSS and COMMENT)

> >>*IMPLICITLY*, e.g., via draft-mmusic-bundle, draft-ice-trickle 
> >>etc... As I have indicated in the past, it would cause confusion to reference both.
> >>
> >> So, I think we shall reference 5245-bis everywhere (I also thought 
> >>we already decided no that in the past)-
> >>
> >> Regards,
> >>
> >> Christer
> >
> >/* bike shed alert:
> >/*

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 13 May 2017 07:42:04 -0600

OK, so let me try to give some really clear guidance here ... if you are writing a draft that does not need to normatively depend on another draft, it should not normatively depended on that draft. 

I really doubt anyone is going to argue with that so lets make it so. 

> On May 13, 2017, at 1:54 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 13 May 2017 17:31:35 +0000

Hi,

So, if the changes done in 5245bis aren't needed, why are we working on 5245bis to begin with??? We did we spend all that time on modifying Ta etc???

Regards,

Christer

Sent from my iPhone

> On 13 May 2017, at 16.42, Cullen Jennings <[email-masked]> wrote:
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 13 May 2017 10:49:03 -0700

On Sat, May 13, 2017 at 10:31 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> So, if the changes done in 5245bis aren't needed, why are we working on
> 5245bis to begin with??? We did we spend all that time on modifying Ta
> etc???
>

I don't think anyone is saying that 5245 bis isn't a good thing, merely
that one can implement JSEP and trickle without reading it.

-Ekr

> > OK, so let me try to give some really clear guidance here ... if you are
> writing a draft that does not need to normatively depend on another draft,
> it should not normatively depended on that draft.
> >
> >> As co-chair of a number of the dependencies, we have been discussing
> what to reference a number of times, and we have also changed the
> references. We can't keep changing back and forth.
> >>
> >> In addition, I don't think WG X can decide what the drafts of WG Y
> reference. There needs to be a collaborative decision.
> >>
> >> "We also assumed that some new work was going to require changes in ICE
> but as that work went progressed, we largely figured out ways to make it
> work with existing ICE implementations."
> >>
> >> "If trickle ice actually gets done before 5245bis, and it does not
> depend on any 5245bis features, then clearly is should be changed to just
> depend on 5245."
> >>
> >> Second, as co-author of 5245bis, I have asked the chairs to initiate
> the road towards WGLC, so I would hope both 5245bis and trickle-ice could
> be done more or less at the same time.
> >>
> >> Regards,
> >>
> >> Christer
> >>
> >>
> >> Cc: Sean Turner <[email-masked]>; The IESG <[email-masked]>;
> [email-masked]; RTCWeb IETF <[email-masked]>;
> [email-masked]
> >> Subject: Re: [rtcweb] Eric Rescorla's Discuss on
> draft-ietf-rtcweb-overview-18: (with DISCUSS and COMMENT)
> >>
> >>
> >> First a side note on how we got here. Some of the reasons we set up
> dependencies  like they are is that many years ago we made guess about what
> order work would get completed on and, shockingly, some predictions of
> standards developments timelines were less than perfect. We also assumed
> that some new work was going to require changes in ICE but as that work
> went progressed, we largely figured out ways to make it work with existing
> ICE implementations.
> >>
> >> We are confident that overview does not actually depend on anything in
> 5245-bis but instead just depends on 5245.
> >>
> >> Next lets discuss trickle-ice. The WebRTC set of specs currently
> normatively depends on trickle ICE. There is some questions if trickle ICE
> might depend on 5245-bis. Some of the trickle ICE  authors do not think it
> does. One of the authors said the chairs asked them to ref 5245 instead of
> 5245bis as both tickle ICE and 5245bis would be done around the same time.
> In general, the webrtc chairs would prefer to make the WebRTC dependency
> cluster as small as possible. If trickle ice actually gets done before
> 5245bis, and it does not depend on any 5245bis features, then clearly is
> should be changed to just depend on 5245. The WG responsible for 5245bis
> and trickle ICE can figure out what they want to do as both theses drafts
> progress. Given there is a strong possibility that trickle ice will only
> reference 5245, we think it would be better if overview did not bring
> 5245bis into the WebRTC dependency cluster. If on the other hand, trickle
> ICE does end up depending on 5245bis, there is no harm, and no need to
> change overview to point at 5245.
> >>
> >> There are other drafts that are normative dependencies of JSEP and the
> WebRTC cluster that also point at 5245bis. When we consider the technical
> things these drafts need, it seems likely they can also reference 5245
> instead of 5245bis. For example draft-ietf-ice-dualstack-fairness,
> draft-ietf-mmusic-ice-sip-sdp, draft-ietf-mmusic-sdp-bundle-negotiation,
> and draft-ietf-rtcweb-transports (which is with the RFC Editor). The
> argument for the others is roughly the same as it is with trickle ICE.
> >>
> >> PS - if you are trying to figure out some of the dependencies for the
> WebRTC cluster, you might find https://datatracker.ietf.org/
> doc/draft-jennings-rtcweb-deps/?include_text=1 useful but it is not 100%
> accurate.
> >>
> >>
> >>

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 13 May 2017 17:57:03 +0000

Hi,

>I don't think anyone is saying that 5245 bis isn't a good thing, merely that one can implement JSEP and trickle without reading it.

This isn't about JSEP and trickle, it's about rtcweb-overview- which is supposed to give some overview of what people need to implement. 

So, *IF* we decide to reference RFC 5245 in rtcweb-overview, I think that we at least should indicate that some dependencies might require 5245bis, and refer to individual dependencies for details. That way we can progress rtcweb-overview, but still keep the door open for 5245bis where/if it's needed.

Regards,

Christer

Sent from my iPhone

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 13 May 2017 11:00:28 -0700

On Sat, May 13, 2017 at 10:57 AM, Christer Holmberg <
[email-masked]> wrote:

> This isn't about JSEP and trickle, it's about rtcweb-overview- which is
> supposed to give some overview of what people need to implement.
>

Yes, and rtcweb-overview references 5245-bis:

1. Directly
2. Transitively through other documents, which are primarily JSEP and
trickle.

And my point is that to implement those other documents, you need not
implement
5245-bis.

So, *IF* we decide to reference RFC 5245 in rtcweb-overview, I think that
> we at least should indicate that some dependencies might require 5245bis,
> and refer to individual dependencies for details. That way we can progress
> rtcweb-overview, but still keep the door open for 5245bis where/if it's
> needed.
>

That just seems like kicking the can down the road. To the best of my
knowledge,
there is no technical reason why an rtcweb implementation needs to know
about
5245-bis (whatever the structure of the normative references in the
documents
happens to be). Are you aware of such a reason?

-Ekr

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 13 May 2017 18:14:11 +0000

Hi,

>2. Transitively through other documents, which are primarily JSEP and trickle.
>
>And my point is that to implement those other documents, you need not implement
>5245-bis.

And everyone agree on that (especially regarding trickle)?

>>So, *IF* we decide to reference RFC 5245 in rtcweb-overview, I think that we at least should
>>indicate that some dependencies might require 5245bis, and refer to individual dependencies 
>>for details. That way we can progress rtcweb-overview, but still keep the door open for 5245bis 
>>where/if it's needed.
>
>That just seems like kicking the can down the road. To the best of my knowledge,
>there is no technical reason why an rtcweb implementation needs to know about
>5245-bis (whatever the structure of the normative references in the documents

Unless trickle requires 5245bis, then no.

I am, however, aware that a number of dependencies do refer 5245bis. Maybe they don't need to, but my point is that I think all dependencies should reference the same ICE spec - RFC 5245 *OR* 5245bis. And I think RTCWEB, MMUSIC and ICE should agree on which spec. Since more or less the same people participate in all those groups, I don't think it should be a difficult thing to achieve. 

Regards,

Christer

Sent from my iPhone

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 15 May 2017 06:48:40 -1000

> On May 13, 2017, at 8:14 AM, Christer Holmberg <[email-masked]> wrote:
> 
> 

I feel very strongly that unless one can show there is technical part of draft X you need to read to implement draft Y, then Y should not normatively reference X. 

Perhaps there is something in ICEbis that is needed by one of the RTCweb specs and if so, we should discuss this but so far I'm not aware of any.

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 May 2017 18:24:54 +0000

Hi,

So, we should check and confirm with the affected WGs whether 5245bis is required within the RTCWEB dependencies that currently reference 5245bis.

Regards,

Christer

From: Cullen Jennings [mailto:[email-masked]]
Sent: 15 May 2017 18:49
To: Christer Holmberg <[email-masked]>
Cc: Eric Rescorla <[email-masked]>; Sean Turner <[email-masked]>; The IESG <[email-masked]>; [email-masked]; RTCWeb IETF <[email-masked]>; [email-masked]
Subject: Re: [rtcweb] Eric Rescorla's Discuss on draft-ietf-rtcweb-overview-18: (with DISCUSS and COMMENT)

On May 13, 2017, at 8:14 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

---

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 12:37:03 -0400

> On Apr 22, 2017, at 07:16, Eric Rescorla <[email-masked]> wrote:
> 
> 
> consensus was that WebRTC depended on 5245, so this needs to be resolved
> one way or the other.

The chairs believe that the overview draft should refer to RFC5245.  There’s nothing in overview that requires a reference to 5245-bis (aka ICE-bis); it’s a definition for an "ICE Agent”.  And, let’s face it overview is going directly into cluster 238.  So instead of arguing about whether to refer ICE or ICE-bis now when overview is going to get stuck anyway let’s let the process run it’s course: if trickle-ICE is going to get done about the same time as ICE-bis then great we can update the references in AUTH48 and if not we can figure out plan B.

I’ve submitted the following PR to change the reference to 5245:

https://github.com/rtcweb-wg/rtcweb-overview/pull/37

> COMMENT:

I haven’t yet completed the editorial changes as a result of ekr's comments so I’ll address that in another email.

spt