Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-sdp-05.txt

From: [email-masked]
Date: Sun, 09 Apr 2017 21:22:59 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Real-Time Communication in WEB-browsers of the IETF.

        Title           : SDP for the WebRTC
        Authors         : Suhas Nandakumar
                          Cullen Jennings
	Filename        : draft-ietf-rtcweb-sdp-05.txt
	Pages           : 107
	Date            : 2017-04-09

Abstract:
   The Real-Time Communications in WEB-browsers (Rtcweb) working group
   is charged to provide protocol support for direct interactive rich
   communication using audio, video and data between two peers' web
   browsers.  With in the Rtcweb framework, Session Description protocol
   (SDP) is used for negotiating session capabilities between the peers.
   Such a negotiation happens based on the SDP Offer/Answer exchange
   mechanism.

   This document provides an informational reference in describing the
   role of SDP and the Offer/Answer exchange mechanism for the most
   common Rtcweb use-cases.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtcweb-sdp/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rtcweb-sdp-05
https://datatracker.ietf.org/doc/html/draft-ietf-rtcweb-sdp-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-sdp-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Suhas Nandakumar <[email-masked]>
Date: Sun, 9 Apr 2017 21:25:35 -0700

Hello All

  I submitted version-05 that includes:
     - IPv6 examples
     - fix idnits errors

look forward for your feedback

cheers
Suhas

---------- Forwarded message ----------
From: <[email-masked]>
Date: Sun, Apr 9, 2017 at 9:22 PM
Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-sdp-05.txt
To: [email-masked]
Cc: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Real-Time Communication in WEB-browsers of
the IETF.

Abstract:

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 10 Apr 2017 16:21:30 +0000

Not to start a bikeshed, but the title “SDP for the WebRTC” isn’t very good.

First of all, “WebRTC” doesn’t usually take an article.

Secondly, the title doesn’t make clear that this contains annotated examples.

I’d suggest something like “Annotated Example SDP for WebRTC.” (or perhaps "for JSEP”).

On Apr 10, 2017, at 12:25 AM, Suhas Nandakumar <[email-masked]<mailto:[email-masked]>> wrote:

Hello All

cheers
Suhas

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Sun, Apr 9, 2017 at 9:22 PM
Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-sdp-05.txt
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 10 Apr 2017 09:38:30 -0700

Hi Jonathan

   You are right on the article part and happy to change it. I like  “Annotated
Example SDP for WebRTC." or " “Annotated Example SDP for RtcWeb"  or
replace WebRTC/RtcWeb with JSEP ..

Let's finalize one and I can make the updates

Cheers
Suhas

On Mon, Apr 10, 2017 at 9:21 AM, Jonathan Lennox <[email-masked]> wrote:

> On Apr 10, 2017, at 12:25 AM, Suhas Nandakumar <[email-masked]>
> wrote:
>
> Hello All
>

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 10 Apr 2017 16:43:47 +0000

I like “Annotated Example SDP for WebRTC”, since I think that’ll be the clearest for the intended audience, but since you're document editor I think this is ultimately your decision.

On Apr 10, 2017, at 12:38 PM, Suhas Nandakumar <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jonathan

   You are right on the article part and happy to change it. I like  “Annotated Example SDP for WebRTC." or " “Annotated Example SDP for RtcWeb"  or replace WebRTC/RtcWeb with JSEP ..

Cheers
Suhas

On Mon, Apr 10, 2017 at 9:21 AM, Jonathan Lennox <[email-masked]<mailto:[email-masked]>> wrote:
Not to start a bikeshed, but the title “SDP for the WebRTC” isn’t very good.

Hello All

cheers
Suhas

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Sun, Apr 9, 2017 at 9:22 PM
Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-sdp-05.txt
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>

Abstract:

---

From: Suhas Nandakumar <[email-masked]>
Date: Mon, 10 Apr 2017 10:00:28 -0700

Thanks Jonathan .. Just submitted version -06 with the title change

./Suhas

On Mon, Apr 10, 2017 at 9:43 AM, Jonathan Lennox <[email-masked]> wrote:

> I like “Annotated Example SDP for WebRTC”, since I think that’ll be the
> clearest for the intended audience, but since you're document editor I
> think this is ultimately your decision.
>
> On Apr 10, 2017, at 12:38 PM, Suhas Nandakumar <[email-masked]>
> wrote:
>
> Hi Jonathan
>

---

From: Justin Uberti <[email-masked]>
Date: Fri, 14 Apr 2017 15:46:34 -0700

Suhas, have you verified that these examples are aligned with those in JSEP
(i.e. include the same attribs in the same order?)

---

From: Suhas Nandakumar <[email-masked]>
Date: Tue, 18 Apr 2017 11:08:11 -0700

Hello Justin

 Sorry for the delayed response. The attributes in the examples do match
JSEP (other than few human errors) but the order might not exactly match.

I am happy to rework to match the order of the attributes, if needed.
Please let me know

Cheers
Suhas

On Fri, Apr 14, 2017 at 3:46 PM, Justin Uberti <[email-masked]> wrote:

> Suhas, have you verified that these examples are aligned with those in
> JSEP (i.e. include the same attribs in the same order?)
>