Subject: [rtcweb] Alexey Melnikov's No Objection on draft-ietf-rtcweb-overview-18: (with COMMENT)

From: Alexey Melnikov <[email-masked]>
Date: Thu, 20 Apr 2017 15:35:37 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-rtcweb-overview-18: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-rtcweb-overview/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Last time I checked the document is referencing normatively 2 expired
drafts (security considerations and security architecture). What is the
plan for completing them?

---

From: Ted Hardie <[email-masked]>
Date: Thu, 20 Apr 2017 15:40:56 -0700

They both went through WG last call and then got put aside until the work
on JSEP finished.   We should have changed the status so that they did not
expire, but failed to do that.  My apologies for the oversight.

Refreshing them is on the top of the WG list after JSEP moves to the IESG
(currently being updated after Adam's AD review).

Ted

---

From: Sean Turner <[email-masked]>
Date: Thu, 20 Apr 2017 20:55:33 -0400

> On Apr 20, 2017, at 18:40, Ted Hardie <[email-masked]> wrote:
> 
> On Thu, Apr 20, 2017 at 3:35 PM, Alexey Melnikov <[email-masked]> wrote:
> 
> They both went through WG last call and then got put aside until the work on JSEP finished.   We should have changed the status so that they did not expire, but failed to do that.  My apologies for the oversight.
> 
> Refreshing them is on the top of the WG list after JSEP moves to the IESG (currently being updated after Adam's AD review).

Alexey thanks for making this a comment.

I am hoping that the IESG will help us get RTCWEB done in stages.  We could back up the draft truck and dump a couple of hundred pages on y’all but that wouldn’t be nice.  Our bottle neck is obviously editor cycles and I’m really hoping that you share the prioritization of TLS1.3 and JSEP followed by the two RTCWEB security drafts.  Appointing another editor at this point isn’t really realistic.  And do note that though expired they are available for your viewing pleasure on github:
  https://github.com/rtcweb-wg/security
  http://rtcweb-wg.github.io/security-arch/
and tools:
  https://tools.ietf.org/html/draft-ietf-rtcweb-security-arch-12
  https://tools.ietf.org/html/draft-ietf-rtcweb-security-08

spt

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 21 Apr 2017 07:49:03 +0100

> On 21 Apr 2017, at 01:55, Sean Turner <[email-masked]> wrote:
> 
> I am hoping that the IESG will help us get RTCWEB done in stages.

Sure.
> We could back up the draft truck and dump a couple of hundred pages on y’all but that wouldn’t be nice.  Our bottle neck is obviously editor cycles and I’m really hoping that you share the prioritization of TLS1.3 and JSEP followed by the two RTCWEB security drafts.  Appointing another editor at this point isn’t really realistic.  And do note that though expired they are available for your viewing pleasure on github:

That is fine. I just couldn't figure out from datatracker what is the status of 2 documents.