Subject: Re: [rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE

From: Christer Holmberg <[email-masked]>
Date: Fri, 17 Mar 2017 07:50:29 +0000

Are people ok with the text?

Regards,

Christer

From: rtcweb <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Monday 13 March 2017 at 15:45
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, mmusic <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE

Hi,

I have created a pull request, where the Appendix B text of draft-jsep-19 is moved into draft-bundle.

https://github.com/cdh4u/draft-sdp-bundle/pull/28

Please review and comment. And, let’s use the MMUSIC list for discussions.

I assume Appendix B will be removed from the next version of JSEP.

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Fri, 17 Mar 2017 09:11:19 -0700

As one of the authors of the new text, I approve of this move.

On Fri, Mar 17, 2017 at 12:50 AM, Christer Holmberg <
[email-masked]> wrote:

> From: rtcweb <[email-masked]> on behalf of Christer Holmberg <
> [email-masked]>
> To: "[email-masked]" <[email-masked]>, mmusic <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 17 Mar 2017 21:14:12 +0000

Hi,

As I indicated on GitHub, the outcome of the ongoing BYE/ssrc discussion will most likely impact the text.

Regards,

Christer

From: Justin Uberti [mailto:[email-masked]]
Sent: 17 March 2017 18:11
To: Christer Holmberg <[email-masked]>
Cc: [email-masked]; mmusic <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE

On Fri, Mar 17, 2017 at 12:50 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Are people ok with the text?

Regards,

Christer

Hi,

Regards,

Christer

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Peter Thatcher <[email-masked]>
Date: Fri, 24 Mar 2017 21:33:27 +0000

I also agree that JSEP Appendix B should be merged into the BUNDLE spec.

It seems like the only thing blocking it is the BYE/SSRC discussion.  And
it seems like Magnus's approach of adding a delay might be a good way to
resolve it.  So, I created a PR for that (in JSEP).  If you'd like me to
copy that over to the BUNDLE PR, I can do that:

https://github.com/rtcweb-wg/jsep/pull/627

On Fri, Mar 17, 2017 at 2:15 PM Christer Holmberg <
[email-masked]> wrote:

> *From:* Justin Uberti [mailto:[email-masked]]
> *Sent:* 17 March 2017 18:11
> *To:* Christer Holmberg <[email-masked]>
> *Cc:* [email-masked]; mmusic <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* Re: [rtcweb] Pull request: JSEP-19 Appendix B text moved to
> BUNDLE
>
>
>
> *From: *rtcweb <[email-masked]> on behalf of Christer Holmberg <
> *Date: *Monday 13 March 2017 at 15:45
> *To: *"[email-masked]" <[email-masked]>, mmusic <[email-masked]
> >
> *Cc: *"[email-masked]" <[email-masked]>, "
> *Subject: *[rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE
>
>
>
> Hi,
>
>
>

---

From: Peter Thatcher <[email-masked]>
Date: Fri, 24 Mar 2017 21:43:20 +0000

FYI, there may have been another blocker in that Magnus was asking for the
PT-based demux limitation of SSRCs not being able to "move" between m-lines
to be more explicit.  If the WG(s) agree(s) that we should address this, I
have made JSEP PR to address it:

https://github.com/rtcweb-wg/jsep/pull/628

Again, if we want, I can make a BUNDLE version of the PR.

---

From: Magnus Westerlund <[email-masked]>
Date: Sun, 26 Mar 2017 10:32:20 -0500

Den 2017-03-24 kl. 16:43, skrev Peter Thatcher:
> FYI, there may have been another blocker in that Magnus was asking for
> the PT-based demux limitation of SSRCs not being able to "move" between
> m-lines to be more explicit.  If the WG(s) agree(s) that we should
> address this, I have made JSEP PR to address it:
>

To be clear I am all for moving appendix B to BUNDLE spec at this point.

I have commenteded on the pull request.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Media Technologies, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 26 Mar 2017 17:33:09 +0000

Hold on...

Which PR are we going to work on?

The JSEP PR mentioned below, or the BUNDLE PR created by Peter?

https://github.com/cdh4u/draft-sdp-bundle/pull/29/

Since everyone seem to agree that the text shall be moved to BUNDLE, my suggestion is to work on the BUNDLE PR.

Regards,

Christer

-----Original Message-----
From: Magnus Westerlund 
Sent: 26 March 2017 18:32
To: Peter Thatcher <[email-masked]>; Christer Holmberg <[email-masked]>; Justin Uberti <[email-masked]>
Cc: [email-masked]; [email-masked]; mmusic <[email-masked]>; [email-masked]
Subject: Re: [rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE

Den 2017-03-24 kl. 16:43, skrev Peter Thatcher:
> the PT-based demux limitation of SSRCs not being able to "move" 
> between m-lines to be more explicit.  If the WG(s) agree(s) that we 
> should address this, I have made JSEP PR to address it:
>

Cheers

Magnus Westerlund

---

From: Peter Thatcher <[email-masked]>
Date: Tue, 28 Mar 2017 01:33:08 +0000

There are a few options for merging:

Option A:

1.  Merge your BUNDLE PR (https://github.com/cdh4u/draft-sdp-bundle/pull/28/)
without the updates about RTCP BYEs and PT demux limitations.
2.  Create a subsequent PR or two for the updates about RTCP BYEs and PT
demux limitations.

Options B:

Merge my BUNDLE PR (https://github.com/cdh4u/draft-sdp-bundle/pull/29) that
has the updates about RTCP BYEs and PT demux.

Option C:

1. Merge the two JSEP PRs (https://github.com/rtcweb-wg/jsep/pull/627/files
, https://github.com/rtcweb-wg/jsep/pull/628/files)

2.  Update your BUNDLE PR (
https://github.com/cdh4u/draft-sdp-bundle/pull/28/) to be include those two
PRs (at which point it looks just like mine).

I think option A makes the most sense.

On Sun, Mar 26, 2017 at 10:34 AM Christer Holmberg <
[email-masked]> wrote:

Hold on...

Since everyone seem to agree that the text shall be moved to BUNDLE, my
suggestion is to work on the BUNDLE PR.

Regards,

Christer

-----Original Message-----
From: Magnus Westerlund
Sent: 26 March 2017 18:32
To: Peter Thatcher <[email-masked]>; Christer Holmberg <
[email-masked]>; Justin Uberti <[email-masked]>
Cc: [email-masked]; [email-masked]; mmusic <[email-masked]>;
[email-masked]
Subject: Re: [rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Media Technologies, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
<+46%2010%20714%2082%2087>
Färögatan 6                 | Mobile +46 73 0949079
<+46%2073%20094%2090%2079>
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Mar 2017 01:47:26 +0000

Hi,

My intention is to merge YOUR BUNDLE PR (Option B). I will close my PR.

But, I don’t think we should work on the JSEP PRs anymore, because they will not be automatically reflected in your BUNDLE PR.

Regards,

Christer

From: Peter Thatcher [mailto:[email-masked]]
Sent: 28 March 2017 04:33
To: Christer Holmberg <[email-masked]>; Magnus Westerlund <[email-masked]>; Justin Uberti <[email-masked]>
Cc: [email-masked]; [email-masked]; mmusic <[email-masked]>; [email-masked]
Subject: Re: [rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE

Option A:

1.  Merge your BUNDLE PR (https://github.com/cdh4u/draft-sdp-bundle/pull/28/) without the updates about RTCP BYEs and PT demux limitations.
2.  Create a subsequent PR or two for the updates about RTCP BYEs and PT demux limitations.

Options B:

Merge my BUNDLE PR (https://github.com/cdh4u/draft-sdp-bundle/pull/29) that has the updates about RTCP BYEs and PT demux.

Option C:

1. Merge the two JSEP PRs (https://github.com/rtcweb-wg/jsep/pull/627/files, https://github.com/rtcweb-wg/jsep/pull/628/files)

2.  Update your BUNDLE PR (https://github.com/cdh4u/draft-sdp-bundle/pull/28/) to be include those two PRs (at which point it looks just like mine).

On Sun, Mar 26, 2017 at 10:34 AM Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hold on...

Regards,

Christer

-----Original Message-----
From: Magnus Westerlund
Sent: 26 March 2017 18:32
To: Peter Thatcher <[email-masked]<mailto:[email-masked]>>; Christer Holmberg <[email-masked]<mailto:[email-masked]>>; Justin Uberti <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; mmusic <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] Pull request: JSEP-19 Appendix B text moved to BUNDLE

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Media Technologies, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287<tel:+46%2010%20714%2082%2087>
Färögatan 6                 | Mobile +46 73 0949079<tel:+46%2073%20094%2090%2079>
SE-164 80 Stockholm, Sweden | mailto: [email-masked]<mailto:[email-masked]>
----------------------------------------------------------------------

---

From: Peter Thatcher <[email-masked]>
Date: Tue, 28 Mar 2017 04:19:48 +0000

SGTM

On Mon, Mar 27, 2017 at 6:47 PM Christer Holmberg <
[email-masked]> wrote:

> But, I don’t think we should work on the JSEP PRs anymore, because they
> will not be automatically reflected in your BUNDLE PR.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From:* Peter Thatcher [mailto:[email-masked]]
> *Sent:* 28 March 2017 04:33
> *To:* Christer Holmberg <[email-masked]>; Magnus
> Westerlund <[email-masked]>; Justin Uberti <
> [email-masked]>
>
>
> *Cc:* [email-masked]; [email-masked]; mmusic <
> [email-masked]>; [email-masked]
> 1.  Merge your BUNDLE PR (
> https://github.com/cdh4u/draft-sdp-bundle/pull/28/) without the updates
> about RTCP BYEs and PT demux limitations.
>
> Merge my BUNDLE PR (https://github.com/cdh4u/draft-sdp-bundle/pull/29)
> that has the updates about RTCP BYEs and PT demux.
>
>
>
> Option C:
>
>
>
> 1. Merge the two JSEP PRs (
> https://github.com/rtcweb-wg/jsep/pull/627/files,
> https://github.com/rtcweb-wg/jsep/pull/628/files)
>
>
>
> https://github.com/cdh4u/draft-sdp-bundle/pull/28/) to be include those
> two PRs (at which point it looks just like mine).
>
>
>
>
>
>
>
> Cc: [email-masked]; [email-masked]; mmusic <
> [email-masked]>; [email-masked]