Subject: [rtcweb] Describe parsing of SDP identity, and how multiple identities are handled, in security-architecture

From: Stefan Håkansson LK <[email-masked]>
Date: Thu, 16 Feb 2017 10:09:07 +0000

Hi,

after some discussing in in W3C webrtc-pc [1] and JSEP [2][3][4] github 
repos it seems the conclusion is that how identity is handled carried in 
the SDP, and how identity in the SDP is parsed, and how multiple 
identity attributes (if we are to support that) should be describe in 
draft-ietf-rtcweb-security-arch [5].

Identity in the SDP is currently described in 
draft-ietf-rtcweb-security-arch, but only for a single identity 
attribute, and parsing is not described, so it needs to be updated.

I decided to send this to the list as the activity level at the github 
repo [6] for draft-ietf-rtcweb-security-arch seems to be low (indicating 
the action happens elsewhere).

Stefan

[1] https://github.com/w3c/webrtc-pc/issues/964
[2] https://github.com/rtcweb-wg/jsep/issues/546
[3] 
https://github.com/rtcweb-wg/jsep/commit/a40fb5101ae530e97cea2073b507d7b417df9e49
[4] https://github.com/rtcweb-wg/jsep/issues/601
[5] https://tools.ietf.org/html/draft-ietf-rtcweb-security-arch
[6] https://github.com/rtcweb-wg/security-arch

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 16 Feb 2017 07:20:16 -0800

> the action happens elsewhere).

No, it's just that I'm too busy doing JSEP and TLS to do anything here.

-Ekr

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Stefan Håkansson LK <[email-masked]>
Date: Thu, 16 Feb 2017 16:02:03 +0000

Thanks Ekr, I'll create a github Issue then.

On 16/02/17 16:22, Eric Rescorla wrote:
>
>
> On Thu, Feb 16, 2017 at 2:09 AM, Stefan Håkansson LK
> <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     <https://github.com/w3c/webrtc-pc/issues/964>
>     <https://github.com/rtcweb-wg/jsep/issues/546>
>     [3]
>     <https://github.com/rtcweb-wg/jsep/commit/a40fb5101ae530e97cea2073b507d7b417df9e49>
>     <https://github.com/rtcweb-wg/jsep/issues/601>
>     <https://tools.ietf.org/html/draft-ietf-rtcweb-security-arch>
>     <https://github.com/rtcweb-wg/security-arch>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/rtcweb>
>
>