Subject: Re: [rtcweb] [MMUSIC] Change Alert [Re: Modifying an approved document: MSID]

From: Flemming Andreasen <[email-masked]>
Date: Fri, 3 Feb 2017 08:55:19 -0500

Based on the feedback received, it seems fine to make this change.

Thanks

-- Flemming (as MMUSIC co-chair)

On 1/30/17 8:28 AM, Victor Pascual Avila wrote:
> fine with me
>
> On Fri, Jan 27, 2017 at 7:20 PM, Bernard Aboba <[email-masked]> wrote:
>> I am in favor of the change.
>>
>> On Thu, Jan 26, 2017 at 5:54 AM, Flemming Andreasen <[email-masked]>
>> wrote:
>>> Hi Harald
>>>
>>> Since the document is not yet in Auth48 and the change is relatively
>>> minor, it is possible to update it during Auth48.
>>>
>>> However, from an MMUSIC chair point of view, I would like to get positive
>>> confirmation from some of the stakeholders that this change is indeed
>>> desired. Similarly, if anybody has any concerns with the suggested change,
>>> please send an e-mail to that effect.
>>>
>>> Thanks
>>>
>>> -- Flemming (as MMUSIC co-chair)
>>>
>>>
>>>
>>> On 1/23/17 10:18 AM, Harald Alvestrand wrote:
>>>> Den 19. jan. 2017 13:31, skrev Harald Alvestrand:
>>>>> Ted pointed out to me that I sent this to the wrong group.
>>>>>
>>>>> Chairs and members, please advise.
>>>> My proposed change is here:
>>>>
>>>> https://github.com/alvestrand/rtcweb-msid/pull/16
>>>>
>>>> The filed issue is here:
>>>>
>>>> https://github.com/alvestrand/rtcweb-msid/issues/15
>>>>
>>>> (CCing RTCWEB - please keep discussion, if any, on mmusic)
>>>>
>>>>>
>>>>> -------- Forwarded Message --------
>>>>> Subject:        [rtcweb] Modifying an approved document: MSID
>>>>> Date:   Wed, 18 Jan 2017 23:22:14 +0100
>>>>> From:   Harald Alvestrand <[email-masked]>
>>>>> To:     [email-masked] <[email-masked]>
>>>>>
>>>>>
>>>>>
>>>>> When reviewing the implications of the PeerConnection API change to
>>>>> support AddTrack rather than AddStream, I found an issue.
>>>>>
>>>>> This issue concerns draft-ietf-rtcweb-msid, which is currently in
>>>>> REF-WAIT state (I believe).
>>>>>
>>>>> The issue is that it is possible to add a track without specifying a
>>>>> stream. Since the track's ID needs to be carried, we have to send an
>>>>> "a=msid" line, but the track's ID is the *second* field on that line,
>>>>> with the first being the stream's ID.
>>>>>
>>>>> This creates a problem.
>>>>>
>>>>> Suggested fix: Insert two lines in the document:
>>>>>
>>>>> 1) On SDP generation:
>>>>>
>>>>> "If there is no stream associated with the track, use the reserved ID
>>>>> value '-'"
>>>>>
>>>>> 2) On SDP parsing
>>>>>
>>>>> "If the stream ID is the reserved value '-', the track is not associated
>>>>> with a stream, and no stream is signalled or created."
>>>>>
>>>>> If this is OK with the community, I'll issue an updated draft with this
>>>>> change.
>>>>>
>>>>>
>>>>> --
>>>>> Surveillance is pervasive. Go Dark.
>>>>>
>>>>> _______________________________________________
>>>>> rtcweb mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/rtcweb
>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> mmusic mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/mmusic
>>>>>
>>>> _______________________________________________
>>>> mmusic mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/mmusic
>>>> .
>>>>
>>> _______________________________________________
>>> mmusic mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/mmusic
>>
>>
>> _______________________________________________
>> mmusic mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/mmusic
>>
>
>

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 7 Feb 2017 14:19:38 +0100

> Based on the feedback received, it seems fine to make this change.

Thank you; I've submitted -16 with this change.