Subject: [rtcweb] Working Group Last Call: JSEP

From: Ted Hardie <[email-masked]>
Date: Fri, 21 Oct 2016 12:25:59 -0700

The chairs would like to start a working group last call on
draft-ietf-rtcweb-jset-17 to end on November 9th, 2016, 17:00 KST.

Please review thoroughly, as working through the last comments will be the
major effort of our working group meeting in Seoul.

>From a process perspective, we will be working through the comments as
issues against the github repo.  In order to accommodate folks who do not
use github, the chairs will enter a new issue for any issue raised on the
mailing list.  That means that if you are raising a new issue, please send
it to the list with a new subject line so that the chairs catch it.

If you prefer, you may also enter the issues at
https://github.com/rtcweb-wg/jsep.  If you do so, please send a copy of the
issue to the mailing list so that conversation and resolution occurs here.

This has been a long road, but this a very major milestone.  Thanks to the
authors for their work so far.

regards,

Ted, Cullen, Sean

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Real-Time Communication in WEB-browsers of
the IETF.

        Title           : Javascript Session Establishment Protocol
        Authors         : Justin Uberti
                          Cullen Jennings
                          Eric Rescorla
        Filename        : draft-ietf-rtcweb-jsep-17.txt
        Pages           : 94
        Date            : 2016-10-21

Abstract:
   This document describes the mechanisms for allowing a Javascript
   application to control the signaling plane of a multimedia session
   via the interface specified in the W3C RTCPeerConnection API, and
   discusses how this relates to existing signaling protocols.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtcweb-jsep/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-rtcweb-jsep-17

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-jsep-17

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Colin Perkins <[email-masked]>
Date: Tue, 25 Oct 2016 18:42:32 +0100

Hi,

This is a well written draft. I think Section 6 needs work, along the lines of the recent discussion and updates to BUNDLE, but the rest of the document seems to be in good shape.

Section 6 says:

   Note: The following algorithm does not yet have WG consensus but is
   included here as something concrete for the working group to discuss.

I don’t think what’s written here is right yet. The RTP specification has rules for forming RTP packets into RTP streams based on their SSRC, and for associating RTCP packets with RTP streams. Similarly, BUNDLE, as of -35, has rules for mapping RTP streams to m= sections based on the MID. This section seems to be trying to replicate these, rather than building on them. 

I think this section should leave the mapping from RTP/RTCP packets to RTP streams to RTP, and the mapping from RTP streams to m= sections to SDP (and BUNDLE, if used). It should talk instead about how RTP streams associated with m= sections are mapped onto RtpSenders and RtpReceivers. This may sound like just a terminology difference, but I think it’s important to get the layering and division of responsibilities right, if the protocol is to be maintainable and extensible.

I also had some minor nits on the rest of the document:

- Section 5.1.1, 1st paragraph: The list of mandatory to implement standards is “derived from the requirements outlined in [I-D.ietf-rtcweb-rtp-usage]”. Should the draft say somewhere that “RTP media transport MUST be implemented according to [I-D.ietf-rtcweb-rtp-usage]”? 

- Section 5.1.1: It’s easy to skim-read R-5 this as “MUST”, since all the other requirements are MUST. It might be more visually distinct if written as  “SHALL NOT” rather than “MUST NOT”.

- Section 5.1.1: R-16 should be removed.

- Section 5.2.1, top of page 38: The header extension is in Section 14 of BUNDLE, not Section 11 (also second bullet point on page 39).

- Section 5.8, 3rd bullet on page 60: I suggest changing “If the MID header extension is supported, prepare to demux RTP data intended for this media section“ to “…prepare to demux RTP streams intended…”, to match the recent discussion around terminology in BUNDLE.

Colin

> On 21 Oct 2016, at 20:25, Ted Hardie <[email-masked]> wrote:
> 
> The chairs would like to start a working group last call on draft-ietf-rtcweb-jset-17 to end on November 9th, 2016, 17:00 KST.
>   
> Please review thoroughly, as working through the last comments will be the major effort of our working group meeting in Seoul.
> 
> From a process perspective, we will be working through the comments as issues against the github repo.  In order to accommodate folks who do not use github, the chairs will enter a new issue for any issue raised on the mailing list.  That means that if you are raising a new issue, please send it to the list with a new subject line so that the chairs catch it.
> 
> If you prefer, you may also enter the issues at https://github.com/rtcweb-wg/jsep <https://github.com/rtcweb-wg/jsep>.  If you do so, please send a copy of the issue to the mailing list so that conversation and resolution occurs here.
> 
> This has been a long road, but this a very major milestone.  Thanks to the authors for their work so far.
> 
> regards,
> 
> Ted, Cullen, Sean
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Real-Time Communication in WEB-browsers of the IETF.
> 
> https://datatracker.ietf.org/doc/draft-ietf-rtcweb-jsep/ <https://datatracker.ietf.org/doc/draft-ietf-rtcweb-jsep/>
> 
> https://tools.ietf.org/html/draft-ietf-rtcweb-jsep-17 <https://tools.ietf.org/html/draft-ietf-rtcweb-jsep-17>
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-jsep-17 <https://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-jsep-17>
> 
> 
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rtcweb <https://www.ietf.org/mailman/listinfo/rtcweb>
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 25 Oct 2016 11:03:27 -0700

Colin said:

"I don’t think what’s written here is right yet. The RTP specification has
rules for forming RTP packets into RTP streams based on their SSRC, and for
associating RTCP packets with RTP streams. Similarly, BUNDLE, as of -35,
has rules for mapping RTP streams to m= sections based on the MID. This
section seems to be trying to replicate these, rather than building on
them."

I think this section should leave the mapping from RTP/RTCP packets to RTP
streams to RTP, and the mapping from RTP streams to m= sections to SDP (and
BUNDLE, if used). It should talk instead about how RTP streams associated
with m= sections are mapped onto RtpSenders and RtpReceivers. This may
sound like just a terminology difference, but I think it’s important to get
the layering and division of responsibilities right, if the protocol is to
be maintainable and extensible."

[BA] The advice given in the JSEP document is more detailed than what is
provided in BUNDLE and also covers situations (overlapping payload types)
that BUNDLE mandates packet drops for.  So I don't believe that the
material is entirely overlapping.

On Tue, Oct 25, 2016 at 10:42 AM, Colin Perkins <[email-masked]> wrote:

> Hi,
>
> This is a well written draft. I think Section 6 needs work, along the
> lines of the recent discussion and updates to BUNDLE, but the rest of the
> document seems to be in good shape.
>
> Section 6 says:
>
> I don’t think what’s written here is right yet. The RTP specification has
> rules for forming RTP packets into RTP streams based on their SSRC, and for
> associating RTCP packets with RTP streams. Similarly, BUNDLE, as of -35,
> has rules for mapping RTP streams to m= sections based on the MID. This
> section seems to be trying to replicate these, rather than building on
> them.
>
> I think this section should leave the mapping from RTP/RTCP packets to RTP
> streams to RTP, and the mapping from RTP streams to m= sections to SDP (and
> BUNDLE, if used). It should talk instead about how RTP streams associated
> with m= sections are mapped onto RtpSenders and RtpReceivers. This may
> sound like just a terminology difference, but I think it’s important to get
> the layering and division of responsibilities right, if the protocol is to
> be maintainable and extensible.
>
>
> - Section 5.1.1, 1st paragraph: The list of mandatory to implement
> standards is “derived from the requirements outlined in
> [I-D.ietf-rtcweb-rtp-usage]”. Should the draft say somewhere that “RTP
> media transport MUST be implemented according to
> [I-D.ietf-rtcweb-rtp-usage]”?
>
> - Section 5.1.1: It’s easy to skim-read R-5 this as “MUST”, since all the
> other requirements are MUST. It might be more visually distinct if written
> as  “SHALL NOT” rather than “MUST NOT”.
>
> - Section 5.2.1, top of page 38: The header extension is in Section 14 of
> BUNDLE, not Section 11 (also second bullet point on page 39).
>
> - Section 5.8, 3rd bullet on page 60: I suggest changing “If the MID
> header extension is supported, prepare to demux RTP data intended for this
> media section“ to “…prepare to demux RTP streams intended…”, to match the
> recent discussion around terminology in BUNDLE.
>
> Colin
>
>
>
>
> https://github.com/rtcweb-wg/jsep.  If you do so, please send a copy of
> the issue to the mailing list so that conversation and resolution occurs
> here.
>

---

From: Ted Hardie <[email-masked]>
Date: Tue, 25 Oct 2016 11:11:42 -0700

Hi Colin,

> be maintainable and extensible.
I've entered the above as an issue in the tracker:
https://github.com/rtcweb-wg/jsep/issues/364 .

Further commentary on the list, please.

> recent discussion around terminology in BUNDLE.
I've entered these as a single editorial issue, at the moment,
https://github.com/rtcweb-wg/jsep/issues/365 .  If any need further
discussion, we can break the relevant pieces out.

Thanks for your review!

Ted