Subject: [rtcweb] AD evaluation: draft-ietf-rtcweb-transports-14

From: Alissa Cooper <[email-masked]>
Date: Thu, 7 Jul 2016 14:33:46 -0700

I have reviewed this document in preparation for IETF last call. It is in good shape and I have requested the last call.

While the last call is ongoing, I would like to double-check that this document (particularly Section 4) raises no new security considerations that should be documented in Section 6. I'm wondering if there are scenarios where a malicious application could try to game the priority scheme to some ill effect? draft-ietf-tsvwg-rtcweb-qos talks a bit about this, so I'm wondering if anything needs to be said here.

And I found a couple of nits to be resolved together with any LC comments:

- Sec 3.2 - Please update the citation to point to draft-ietf-mmusic-ice-dualstack-fairness-02.

- Sec 3.4 -

"Third, using TCP only between the endpoint and its relay may result
   in less issues with TCP in regards to real-time constraints, e.g. due
   to head of line blocking."
   
This is awkwardly phrased. I would suggest something like "Third, using TCP between the client's TURN server and its peer may result in more performance problems (due to head-of-line blocking) than using UDP."

Alissa

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 7 Jul 2016 15:05:08 -0700

And one bit I left out — if text is to be added to reference draft-ietf-rtcweb-return, that should be done together with addressing nits and LC comments.

> On Jul 7, 2016, at 2:33 PM, Alissa Cooper <[email-masked]> wrote:
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 9 Jul 2016 23:27:41 +0200

Thank you - I have filed this review as
https://github.com/rtcweb-wg/rtcweb-transport/issues/21 and will address
it after the Last Call ends.