Subject: Re: [rtcweb] which bandwidth modifiers need to be supported?

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 11 May 2016 15:55:31 +0000

I was also looking at this again my assumption is that TIAS is what a WebRTC endpoint should generate TIAS as Philipp stated this is hinted at in the W3C spec but probably also should be specified in JSEP and an example in https://tools.ietf.org/html/draft-ietf-rtcweb-sdp-01#section-5.2.2 would also be useful.

For parsing then both TIAS and AS needs to be supported this is specified in https://tools.ietf.org/html/draft-ietf-rtcweb-jsep-14#section-5.8. 

Regards
Andy

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of Philipp
> Hancke
> Sent: 25 April 2016 10:24
> To: [email-masked]
> Subject: [rtcweb] which bandwidth modifiers need to be supported?
> 
> which bandwidth modifiers for b= lines does a client need to support?
> 
> Chrome currently supports b=AS, however the implementation is closer to
> TIAS semantically. Firefox does not implement either currently.
> 
> http://w3c.github.io/webrtc-pc/#widl-RTCRtpEncodingParameters-
> maxBitrate
> uses TIAS as a definition.
> 
> For parsing, supporting both is fine (for a while at least).
> For serialization I would prefer picking one (TIAS) to having to track
> which variant a peer supports.
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 23 May 2016 08:42:16 -0700

I’m not sure there is a requirement for a WebRTC endpoint to generate them but if there is, agree that we should say TIAS is preferred. 

> On May 11, 2016, at 8:55 AM, Hutton, Andrew <[email-masked]> wrote:
>