Subject: Re: [rtcweb] Clarification in draft-ietf-rtcweb-transports-11

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Fri, 29 Apr 2016 14:57:10 +0000

Github says this was fixed in version -10 - See https://github.com/rtcweb-wg/rtcweb-transport/issues/12

But it does not seem to be in the -10 draft or latest draft so I'm wondering if it got lost along the way somewhere. 

> On Feb 8, 2016, at 12:46 AM, Harald Alvestrand <[email-masked]> wrote:
> 
> This seems reasonable.
> 
> Filed https://github.com/rtcweb-wg/rtcweb-transport/issues/12 so as to not forget.
> 
>> 
>> 
>> On Wed, Feb 3, 2016 at 7:16 AM, Cullen Jennings <[email-masked]> wrote:
>> I think we need to make the ALPN a bit more explicit. We agreed to include the ALPN header so that a proxy knows it might receive video packet rates tunnelled across it. However the text on this is not 100% clear. Right now it says
>> 
>>    If it does so, it MUST support the "ALPN" header as
>>    specified in [RFC7639],
>> 
>> But some people have posted out including this header is optional in 7639 so there might be some ubiquity here about what is meant. I think we should change the word “support” to “include” to make it clear this needs to be sent to the proxy so that it would read
>> 
>>     If it does so, it MUST include the "ALPN" header as
>>    specified in [RFC7639],
>> 
>> I believe that correctly reflects what we intended on this. There is no requirement for the proxy to understand or do anything with this header. Old proxies will just ignore it and cary on as if it was not there.
>> 
>> I wouldn't have a problem with this if it were restricted to browsers. However,
>> we don't want to careful about retroactively branding endpoints which aren't
>> browsers but can talk to WebRTC clients as noncompliant. Maybe this
>> is like codecs where they are "WebRTC Compatible"?
>> 
>> -Ekr
>> 
>> Cullen
>> 
>> (with my individual contributor hat on)
>> 
>> 
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
>> 
>> 
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
>> 
>> 
>> 
>> _______________________________________________
>> rtcweb mailing list
>> 
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
> 
> 
> -- 
> Surveillance is pervasive. Go Dark.
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 29 Apr 2016 17:17:07 +0200

> But it does not seem to be in the -10 draft or latest draft so I'm wondering if it got lost along the way somewhere. 

You're right. I reopened the issue.