Subject: [rtcweb] Plan B and SDP with different payload numbers pointing to the same codec

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 28 Jan 2016 21:05:31 +0100

Hi,

In Plan B [*] if a SFU receives VP8 tracks from 3 peers, using each
peer a different
SSRC and payload type/number: Can the SFU generate a SDP containing a
single m=video line with 3 different payload numbers pointing to the
same VP8 codec?

The draft seems to assume that the SFU/server will translate/override
the payloadType of the incoming sources and make them the same.

Thanks a lot.

[*] https://tools.ietf.org/html/draft-uberti-rtcweb-plan-00

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Adam Roach <[email-masked]>
Date: Thu, 28 Jan 2016 15:28:03 -0600

Um... the working group decided not to move forward with this mechanism. 
I'm not sure it was ever fully formed enough to be able answer your 
question.

Put another way: you're implementing a non-standard solution. 
Interoperability is a matter of between you and other people wanting to 
implement your proprietary approach.

/a

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 28 Jan 2016 22:34:27 +0100

2016-01-28 22:28 GMT+01:00 Adam Roach <[email-masked]>:
> Um... the working group decided not to move forward with this mechanism. I'm
> not sure it was ever fully formed enough to be able answer your question.
>

Hi Adam,

I don't want Plan A, Plan B or Unified-Plan. But... SDP + Plan B is
what current Google's libwebrtc implements so I need to interop with
it.

Said that, I agree that Plan B is an abandoned draft so I shouldn't
expect a specific response to my question.

Thanks a lot.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Peter Thatcher <[email-masked]>
Date: Thu, 28 Jan 2016 13:41:00 -0800

This isn't the right form to talk about Plan B.  Perhaps
[email-masked] would be.

On Thu, Jan 28, 2016 at 1:34 PM, Iñaki Baz Castillo <[email-masked]> wrote:

> I'm
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>