Subject: [rtcweb] WG adoption: draft-proust-rtcweb-audio-codecs-for-interop

From: Sean Turner <[email-masked]>
Date: Tue, 16 Sep 2014 17:09:49 -0400

Howdy,

After reviewing the working group discussion at our last face-to-face meeting and the subsequent on-list discussion, the chairs believe that there is rough consensus to adopt draft-proust-rtcweb-audio-codecs-for-interop as an Informational document aiming to identify which codecs may allow transcoding-free interoperability with deployed systems.  All normative requirements for which codecs WebRTC implementations must support will remain in  draft-ietf-rtcweb-audio-codec.

Ted, Cullen, Sean

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 17 Sep 2014 01:24:57 +0000

OK, so could I have an explanation of what the following means:

"All normative requirements for which codecs WebRTC implementations must support will remain in  draft-ietf-rtcweb-audio-codec."

Does this refer to the codecs that webrtc MUST support only, or does it also refer to mandatory requirements of a specific codec that is supported (but not mandatory to implement). 

And do any optional requirements of mandatory to implement codecs remain in draft-ietf-rtcweb-audio-codec, or do they go to the new document.

Regards

Keith

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of Sean Turner
> Sent: 16 September 2014 22:10
> To: [email-masked]
> Subject: [rtcweb] WG adoption: 
> draft-proust-rtcweb-audio-codecs-for-interop
> 
> Howdy,
> 
> After reviewing the working group discussion at our last 
> face-to-face meeting and the subsequent on-list discussion, 
> the chairs believe that there is rough consensus to adopt 
> draft-proust-rtcweb-audio-codecs-for-interop as an 
> Informational document aiming to identify which codecs may 
> allow transcoding-free interoperability with deployed 
> systems.  All normative requirements for which codecs WebRTC 
> implementations must support will remain in  
> draft-ietf-rtcweb-audio-codec.
> 
> Ted, Cullen, Sean
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Ted Hardie <[email-masked]>
Date: Tue, 16 Sep 2014 23:28:58 -0400

On Tue, Sep 16, 2014 at 9:24 PM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> "All normative requirements for which codecs WebRTC implementations must
> support will remain in  draft-ietf-rtcweb-audio-codec."
>
> Does this refer to the codecs that webrtc MUST support only, or does it
> also refer to mandatory requirements of a specific codec that is supported
> (but not mandatory to implement).
>
> ​
It means that if the working group decides that a WebRTC implementation
must support a specific codec, it will write that down in
draft-ietf-rtcweb-audio-codec.​

> And do any optional requirements of mandatory to implement codecs remain
> in draft-ietf-rtcweb-audio-codec, or do they go to the new document.
>
>
​"optional requirements"?

If a specific set of knob twists to a mandatory codec gives you
transcoding-free ​interoperability with a deployed set of systems, you
would document that in the new informational doc (which knob twists and
what systems).

Any other sorts of knob twists for the mandatory codecs and their effects
might go into draft-ietf-rtcweb-audio-codec as advisory text if the working
group wanted ("Set it to 11 and the bit rate doubles!"), but it would
require working group consensus and some pretty good reasons.

My take, in any case, without consulting the other chairs.

Ted

---

From: <[email-masked]>
Date: Mon, 29 Sep 2014 16:02:58 +0000

Dear all,

Following the announcement from the Chairs that "draft-proust-rtcweb-audio-codecs-for-interop" is adopted as Working Group informational draft, I have submitted an updated version renamed "draft-ietf-rtcweb-audio-codecs-for-interop" (and renumbered 00)
In addition to this renaming, one statement in introduction needed to be removed:
>> The purpose of this 01 version is to maintain the draft alive.  The authors will submit a 02 version before IETF-91, which will take into account the comments received at IETF-90"

I have then replaced it with the following statement that intends to make this work as open and consensual as possible by strictly focusing on interoperability issues and opening it to possible other codecs:

>> The codecs considered in this document are recommended to be supported and included in the Offer only for WebRTC clients for which interoperability with other non WebRTC end points and non WebRTC based services is relevant as described in sections 5.1.2, 5.2.2 and 5.3.2. Other use cases may justify offering other additional codecs to avoid transcodings. It is the intent of this document to inventory and document any other additional interoperability use cases and codecs if needed.

I hope we can now progress the WG Draft in that spirit.

Best regards

Stéphane

-----Message d'origine-----
De : rtcweb [mailto:[email-masked]] De la part de Sean Turner
Envoyé : mardi 16 septembre 2014 23:10
À : [email-masked]
Objet : [rtcweb] WG adoption: draft-proust-rtcweb-audio-codecs-for-interop

Howdy,

Ted, Cullen, Sean

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.