Subject: [rtcweb] WebRTC gateway - draft-ietf-rtcweb-overview-11.txt

From: Jeremy Fuller <[email-masked]>
Date: Thu, 21 Aug 2014 20:24:09 +0000

Hi Harald,

With regard to your addition of the WebRTC gateway in the rtcweb overview. I appreciate signalling is out of scope for WebRTC, but as you say in your draft alvestrand-rtcweb-gateways-00.txt "any practical gateway needs to deal with signalling". Without getting into too much detail or any implementation constraints, would it be possible to add a reference to signalling when introducing the WebRTC gateway?

I have suggested some modified text below for your consideration:

Current Text  (section 1):
"A WebRTC gateway is something that mediates media traffic to non-WebRTC entities.  It is like a device, but has certain restrictiions on where it can operate, which means that some of the requirements can be relaxed."

Proposed Text (section 1):
"A WebRTC gateway is something that mediates media traffic, or signalling, or both, to non-WebRTC entities.  It is like a device, but has certain restrictions on where it can operate, which means that some of the requirements can be relaxed."

Regards,
Jeremy

-----Original Message-----
Date: Mon, 18 Aug 2014 04:19:16 -0700
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-overview-11.txt
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="utf-8"

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.

        Title           : Overview: Real Time Protocols for Browser-based Applications
        Author          : Harald T. Alvestrand
	Filename        : draft-ietf-rtcweb-overview-11.txt
	Pages           : 22
	Date            : 2014-08-18

Abstract:
   This document gives an overview and context of a protocol suite
   intended for use with real-time applications that can be deployed in
   browsers - "real time communication on the Web".

   It intends to serve as a starting and coordination point to make sure
   all the parts that are needed to achieve this goal are findable, and
   that the parts that belong in the Internet protocol suite are fully
   specified and on the right publication track.

   This document is an Applicability Statement - it does not itself
   specify any protocol, but specifies which other specifications RTCWEB
   compliant implementations are supposed to follow.

   This document is a work item of the RTCWEB working group.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtcweb-overview/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-rtcweb-overview-11

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-overview-11

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 21 Aug 2014 23:15:44 +0200

> "A WebRTC gateway is something that mediates media traffic, or signalling, or both, to non-WebRTC entities.  It is like a device, but has certain restrictions on where it can operate, which means t…

This does not work for me. A WebRTC gateway has to handle media, because 
it's the transport of media that WebRTC specifies. A pure signalling 
gateway would just transform the signalling between two WebRTC-capable 
endpoints (WebRTC endpoints?); this is what an application does, not 
what a WebRTC gateway does.

There might be a need to name the class of applications that transform 
signalling; I'm not sure.

---

From: Jeremy Fuller <[email-masked]>
Date: Fri, 22 Aug 2014 08:34:32 +0000

Hi Harald, 

It would be good to have something which explains to the reader that there exists functionality for transforming signalling. I am reasonably flexible on the term used. I proposed associating this functionality with the term WebRTC Gateway to reduce the proliferation of new terms.  

Regards,
Jeremy

-----Original Message-----
From: Harald Alvestrand [mailto:[email-masked]] 
Sent: 21 August 2014 22:16
To: Jeremy Fuller
Cc: [email-masked]
Subject: Re: WebRTC gateway - draft-ietf-rtcweb-overview-11.txt

> "A WebRTC gateway is something that mediates media traffic, or signalling, or both, to non-WebRTC entities.  It is like a device, but has certain restrictions on where it can operate, which means t…

This does not work for me. A WebRTC gateway has to handle media, because it's the transport of media that WebRTC specifies. A pure signalling gateway would just transform the signalling between two WebRTC-capable endpoints (WebRTC endpoints?); this is what an application does, not what a WebRTC gateway does.

There might be a need to name the class of applications that transform signalling; I'm not sure.

---

From: Barry Dingle <[email-masked]>
Date: Sat, 23 Aug 2014 09:53:02 +1000

Hi Harald,

I see Jeremy's point.

Gateways between a WebRTC environment and non-WebRTC environments need to
convert BOTH media and signalling. Media-only Gateways are usually referred
to as 'Media Gateways'. In draft-alvestrand-rtcweb-gateways-00 Section 1
paragraph 2, the description of 'the Gateway' refers only to the 'media'.

As the document later refers to the Signaling Model, I suggest that the
Introduction should also refer to 'Signalling' briefly also.

I suggest a new second paragraph in Section 1 that says:

*' When communicating between a WebRTC environment and non-WebRTC
environments, interworking of both the media and signaling is required. As
signaling protocols are outside the scope of WebRTC, this document only
considers signaling interworking at a high level'. *

To avoid confusion, when referring to 'Media only' functionality, the
document should use the term 'WebRTC *media* gateway' instead of 'WebRTC
gateway'.

Cheers,
/Barry Dingle

On Fri, Aug 22, 2014 at 6:34 PM, Jeremy Fuller <[email-masked]>
wrote:

> Hi Harald,
>
> It would be good to have something which explains to the reader that there
> exists functionality for transforming signalling. I am reasonably flexible
> on the term used. I proposed associating this functionality with the term
> WebRTC Gateway to reduce the proliferation of new terms.
>
> Regards,
> Jeremy
>
> > With regard to your addition of the WebRTC gateway in the rtcweb
> overview. I appreciate signalling is out of scope for WebRTC, but as you
> say in your draft alvestrand-rtcweb-gateways-00.txt "any practical gateway
> needs to deal with signalling". Without getting into too much detail or any
> implementation constraints, would it be possible to add a reference to
> signalling when introducing the WebRTC gateway?
> >
> > "A WebRTC gateway is something that mediates media traffic to non-WebRTC
> entities.  It is like a device, but has certain restrictiions on where it
> can operate, which means that some of the requirements can be relaxed."
> >
> > "A WebRTC gateway is something that mediates media traffic, or
> signalling, or both, to non-WebRTC entities.  It is like a device, but has
> certain restrictions on where it can operate, which means that some of the
> requirements can be relaxed."
>
> endpoints (WebRTC endpoints?); this is what an application does, not what a
> WebRTC gateway does.
>
> > Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> >
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Jeremy Fuller <[email-masked]>
Date: Tue, 26 Aug 2014 10:10:04 +0000

I like Barry’s proposal for text.

From: Barry Dingle [mailto:[email-masked]]
Sent: 23 August 2014 00:53
To: Jeremy Fuller
Cc: Harald Alvestrand; [email-masked]
Subject: Re: [rtcweb] WebRTC gateway - draft-ietf-rtcweb-overview-11.txt

Hi Harald,

I see Jeremy's point.

Gateways between a WebRTC environment and non-WebRTC environments need to convert BOTH media and signalling. Media-only Gateways are usually referred to as 'Media Gateways'. In draft-alvestrand-rtcweb-gateways-00 Section 1 paragraph 2, the description of 'the Gateway' refers only to the 'media'.

As the document later refers to the Signaling Model, I suggest that the Introduction should also refer to 'Signalling' briefly also.

' When communicating between a WebRTC environment and non-WebRTC environments, interworking of both the media and signaling is required. As signaling protocols are outside the scope of WebRTC, this document only considers signaling interworking at a high level'.

To avoid confusion, when referring to 'Media only' functionality, the document should use the term 'WebRTC media gateway' instead of 'WebRTC gateway'.
Cheers,
/Barry Dingle

On Fri, Aug 22, 2014 at 6:34 PM, Jeremy Fuller <[email-masked]<mailto:[email-masked]>> wrote:
Hi Harald,

Regards,
Jeremy

-----Original Message-----
From: Harald Alvestrand [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 21 August 2014 22:16
To: Jeremy Fuller
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: WebRTC gateway - draft-ietf-rtcweb-overview-11.txt

> From: [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
> Message-ID: <[email-masked]<mailto:[email-masked]>>
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb