Subject: [rtcweb] draft-ietf-rtcweb-alpn-00 - in what way is WebRTC an application?

From: Paul Kyzivat <[email-masked]>
Date: Tue, 05 Aug 2014 14:35:27 -0400

Why is WebRTC considered an application? It provides a 
platform/layer/transport in support of applications.

Applications ride on top of it. I guess Meetecho or Webex++ or Skype++ 
would be plausible applications.

Of course this is a constantly changing game. We keep adding layers to 
the stack, and each time we do what used to be an application becomes 
just a transport for the next layer.

But AFAIK WebRTC is *never* an application in its own right.

ISTM that it would be more appropriate if the application identifier 
identified the complete protocol stack that is riding on top of the 
layer (in this case DTLS) that is carrying the identifier.

E.g. "meetecho/webex"

	Thanks,
	Paul

---

From: Ted Hardie <[email-masked]>
Date: Tue, 5 Aug 2014 12:59:47 -0700

Hi Paul,

Think of it this way:  ALPN tokens identify application layer protocols.
WebRTC may support a raft of applications, but it is a common application
layer.

Attempting to negotiate each one of the potential applications which might
use the layer would be thoroughly unworkable, given the ability of a
developer to mint one at will.  Thus, it is more important to signal the
common aspect--that this application is built on WebRTC protocols and
expectations.

regards,

Ted Hardie

On Tue, Aug 5, 2014 at 11:35 AM, Paul Kyzivat <[email-masked]> wrote:

> Of course this is a constantly changing game. We keep adding layers to the
> stack, and each time we do what used to be an application becomes just a
> transport for the next layer.
>
> identified the complete protocol stack that is riding on top of the layer
> (in this case DTLS) that is carrying the identifier.
>
> E.g. "meetecho/webex"
>
>         Thanks,
>         Paul
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 5 Aug 2014 13:15:30 -0700

> WebRTC may support a raft of applications, but it is a common application

We commonly say the same thing about HTTP as an application layer
protocol.  I don't think that anyone is going to suggest that nothing
else goes on above HTTP either.

---

From: Christian Groves <[email-masked]>
Date: Wed, 06 Aug 2014 11:27:30 +1000

The draft defines "webrtc" mixed media and data communications using 
SRTP and data channels. Does there need to be a value that describes the 
use of "webrtc data channel only"? E.g. An endpoint may establish a data 
channel for multiple applications (CLUE, BFCP etc.) without using WebRTC 
media.

Regards, Christian

On 23/07/2014 11:32 PM, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>   This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.
>
>          Title           : Application Layer Protocol Negotiation for Web Real-Time Communications (WebRTC)
>          Author          : Martin Thomson
> 	Filename        : draft-ietf-rtcweb-alpn-00.txt
> 	Pages           : 7
> 	Date            : 2014-07-23
>
> Abstract:
>     Application Layer Protocol Negotiation (ALPN) labels are defined for
>     use in identifying Web Real-Time Communications (WebRTC) usages of
>     Datagram Transport Layer Security (DTLS).  Labels are provided for
>     identifying a session that uses a combination of WebRTC compatible
>     media and data, and for identifying a session requiring
>     confidentiality protection.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-rtcweb-alpn/
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-rtcweb-alpn-00
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>