Subject: [rtcweb] POF/PAN in JSEP?

From: Christer Holmberg <[email-masked]>
Date: Thu, 24 Jul 2014 02:37:53 +0000

Hi,
Are we still planning to incorporate support of POF/PAN (partial offers/answers) into JSEP?

AFAIK, the work on POF/PAN hasn't progressed. In addition, I believe (please correct me if I'm wrong) it would have a major impact on the JSEP state machine, as it currently is defined to deal with complete SDPs - not individual parts of SDP.
If JSEP will not support POF/PAN, perhaps it would be good to have explicit text indicating that.

Thanks!
Regards,
Christer

---

From: Justin Uberti <[email-masked]>
Date: Wed, 23 Jul 2014 23:49:57 -0400

Not in 1.0.

On Wed, Jul 23, 2014 at 10:37 PM, Christer Holmberg <
[email-masked]> wrote:

> AFAIK, the work on POF/PAN hasn’t progressed. In addition, I believe
> (please correct me if I’m wrong) it would have a major impact on the JSEP
> state machine, as it currently is defined to deal with complete SDPs – not
> individual parts of SDP.
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 24 Jul 2014 11:08:45 +0000

I support that. But, do we have a WG decision on such approach? I would not want this to pop up in the last minute, during WGLC etc...

Regards,

Christer

Sent from my Sony Ericsson Xperia arc S

Justin Uberti <[email-masked]> wrote:

Not in 1.0.

On Wed, Jul 23, 2014 at 10:37 PM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,
Are we still planning to incorporate support of POF/PAN (partial offers/answers) into JSEP?

AFAIK, the work on POF/PAN hasn’t progressed. In addition, I believe (please correct me if I’m wrong) it would have a major impact on the JSEP state machine, as it currently is defined to deal with complete SDPs – not individual parts of SDP.
If JSEP will not support POF/PAN, perhaps it would be good to have explicit text indicating that.

Thanks!
Regards,
Christer

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb