Subject: [rtcweb] Interim meeting - Transports Conclusions

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 8 Jul 2014 15:01:41 +0000

There has been no discussion on the list regarding what was discussed at the May interim regarding what to say in http://tools.ietf.org/html/draft-ietf-rtcweb-transports-05#section-3.4 regarding HTTP Proxies.  Unfortunately the discussion is missing from the draft minutes however the discussion is recorded and can be found 0:45:45 in to https://www.youtube.com/watch?v=sTuJfuI3zHk&list=UU8dtK9njBLdFnBahHFp0eZQ.  

In summary what was discussed was the issue of RTCWEB browsers using HTTP Connect for TURN and ICE-TCP traffic in the presence of proxies. My interpretation of the conclusion was that there was a need to write a draft to provide an indication in the HTTP Connect request to indicate that this is the purpose for generating the request.

Justin, Martin, and I therefore created http://tools.ietf.org/html/draft-hutton-httpbis-connect-protocol-00 thinking that this would hopefully replace the current reference and text relating to draft-hutton-rtcweb-nat-firewall-considerations in the transports draft and hopefully therefore be a step closer to getting the transports draft finished.

I will present the new draft in the HTTPBis session at IETF90 but of course in rtcweb we need consensus on what to put in to the transports draft.

I am really hoping this is not too controversial and I realize that discussion on -firewalls- should be on the PNTAW list but this mail really relates to what to say in -transports- so I think needs to be on the rtcweb list.  Currently I am thinking that I will let draft-hutton-rtcweb-nat-firewall-considerations expire.

Regards
Andy

From: rtcweb [mailto:[email-masked]] On Behalf Of Hutton, Andrew
Sent: 17 June 2014 16:54
To: Ted Hardie; Cullen Jennings; Sean Turner
Cc: [email-masked]
Subject: Re: [rtcweb] Minutes and videos from the Interim meeting

I could not find anything in the minutes regarding our discussion on the transports draft (http://www.ietf.org/proceedings/interim/2014/05/19/rtcweb/slides/slides-interim-2014-rtcweb-1-2.pdf).

Not had time to download the video yet but I think we discussed this on the Monday morning.

Regards
Andy

From: rtcweb [mailto:[email-masked]] On Behalf Of Ted Hardie
Sent: 12 June 2014 16:56
To: [email-masked]; Cullen Jennings; Sean Turner
Subject: [rtcweb] Minutes and videos from the Interim meeting

Dear Working Group,

Attached is a draft set of minutes from the meeting.  The secretariat is currently working on moving the videos of the meeting to the IETF channel at Youtube; the sources videos are available at https://drive.google.com/#folders/0B-1skjUwD-8EakhmY2pFdV85dHM if you would like to download them, but please be aware that they are very large.
Comments and corrections on the minutes to the list please,

Ted, Cullen, Sean

---

From: Martin Thomson <[email-masked]>
Date: Tue, 8 Jul 2014 10:25:19 -0700

On 8 July 2014 08:01, Hutton, Andrew <[email-masked]> wrote:
> in rtcweb we need consensus on what to put in to the transports draft.

That's right.  My hope is that we can decide to adopt
draft-thomson-rtcweb-alpn and use the labels that we defined there.

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 8 Jul 2014 14:38:55 -0700

Martin said:

"That's right.  My hope is that we can decide to adopt
draft-thomson-rtcweb-alpn and use the labels that we defined there."

[BA] Maybe my memory is faulty... but didn't we discuss adoption
previously???

On Tue, Jul 8, 2014 at 10:25 AM, Martin Thomson <[email-masked]>
wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 15 Jul 2014 08:07:26 +0000

> draft-thomson-rtcweb-alpn and use the labels that we defined there.

I also hope we can do this looks like draft-thomson-rtcweb-alpn will be adopted so then assuming draft-hutton-httpbis-connect-protocol is also adopted we can add some text to -transports- referencing these drafts and describing the use of the alpn tokens with regard to middleboxes and then we are hopefully done with -transports-.

Andy