Subject: [rtcweb] Questions on draft-ietf-rtcweb-rtp-usage-15

From: Paul Kyzivat <[email-masked]>
Date: Thu, 17 Jul 2014 23:04:40 -0400

I have a couple of questions after reading this draft:

Section 4.9 says:

    Taking the discussion in Section 11 into account, a WebRTC end-point
    MUST NOT use more than one RTCP CNAME in the RTP sessions belonging
    to single RTCPeerConnection (that is, an RTCPeerConnection forms a
    synchronisation context).

and then Section 11 says:

    ... This is motivating the
    strong recommendation in Section 4.9 to only use a single CNAME.

       The requirement on using the same CNAME for all SSRCs that
       originate from the same end-point, does not require a middlebox
       that forwards traffic from multiple end-points to only use a
       single CNAME.

So one is MUST strength, and the other seems to be SHOULD strength. 
Which is it?

And isn't this "middlebox" a WebRTC end-point? If so then that is 
another conflict.

Is it really that WebRTC *browsers* must use one CNAME, while other 
WebRTC *devices* have more freedom? That seems to make sense since an 
RTCPeerConnection is only a browser thing.

	Thanks,
	Paul

---

From: Colin Perkins <[email-masked]>
Date: Tue, 22 Jul 2014 19:13:14 -0400

On 17 Jul 2014, at 23:04, Paul Kyzivat <[email-masked]> wrote:
> So one is MUST strength, and the other seems to be SHOULD strength. Which is it?
> 
> And isn't this "middlebox" a WebRTC end-point? If so then that is another conflict.

End Point is used in the sense of draft-ietf-avtext-rtp-grouping-taxonomy-02, and I assumed that excluded middleboxes. This is maybe something that should be clarified in the taxonomy.

> Is it really that WebRTC *browsers* must use one CNAME, while other WebRTC *devices* have more freedom? That seems to make sense since an RTCPeerConnection is only a browser thing.

I think that’s essentially what’s meant. Middleboxes can send data with multiple CNAMEs (and have to, in many cases). 

Browsers, and other end systems, ought to use only a single CNAME. Whether that’s SHOULD or MUST use only a single CNAME I don’t have a strong opinion on.

-- 
Colin Perkins
http://csperkins.org/