Subject: Re: [rtcweb] New Version Notification for draft-guduru-rtcweb-codec-preferences-01.txt

From: franklin blek <[email-masked]>
Date: Sun, 13 Jul 2014 10:41:55 +0900

Hi,
The draft seems to explain codec preferences in a good way.
I think this has a good potenitial to be a part of WebRTC1.0.

On Sat, Jul 5, 2014 at 10:26 AM, Kiran Kumar Guduru <
[email-masked]> wrote:

>  Hi,
>
> A new version of codec preferences draft has been published, by modifying
> as per the review comments received.
>
> Please review and let me know your comments.
>
>
>
> Thanks & Regards,
>
> Kiran.
>
>
>
> ------- *Original Message* -------
>
> *Sender* : [email-masked]<[email-masked]>
>
> *Date* : Jul 02, 2014 18:28 (GMT+09:00)
>
> *Title* : New Version Notification for
> draft-guduru-rtcweb-codec-preferences-01.txt
>
>
>
> A new version of I-D, draft-guduru-rtcweb-codec-preferences-01.txt
> has been successfully submitted by Kiran Kumar Guduru and posted to the
> IETF repository.
>
> Name: draft-guduru-rtcweb-codec-preferences
> Revision: 01
> Title: WebRTC Codec Preferences
> Document date: 2014-07-02
> Group: Individual Submission
> Pages: 7
> URL:
> http://www.ietf.org/internet-drafts/draft-guduru-rtcweb-codec-preferences-01.txt
> Status:
> https://datatracker.ietf.org/doc/draft-guduru-rtcweb-codec-preferences/
> Htmlized:
> http://tools.ietf.org/html/draft-guduru-rtcweb-codec-preferences-01
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-guduru-rtcweb-codec-preferences-01
>
> Abstract:
>    WebRTC specifies to implement a minimum set of required codecs to
>    ensure guaranteed interoperability between WebRTC peers.  WebRTC
>    allows browser implementers to support vendor specific codecs apart
>    from mandatory codecs.  This document specifies the way for
>    JavaScript applications to give preferences for media codecs in
>    WebRTC context out of the available codecs in browser for creating
>    the offer / answer.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
>
>
>
>

---

From: Justin Uberti <[email-masked]>
Date: Sun, 20 Jul 2014 23:30:19 -0400

This seems like a pretty big hammer to solve a fairly small problem. This
proposal adds 6 new API points for the purpose of changing the order of
codecs in createOffer, which seems like a high cost-benefit ratio. And
while the use cases listed here are helpful, they seem somewhat contrived
to me, since it seems unlikely that the application can make better choices
about bandwidth or power consumption than the browser.

Without a specific, concrete example, I remain unconvinced that this is
worth doing in the 1.0 timeframe. Post-1.0, we can probably find a way to
provide this sort of lower-level control.

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 21 Jul 2014 09:24:03 -0400

I agree with Justin that this draft is not a useful addition. Codecs are
only one aspect of capability discovery, and so cannot be treated in
isolation.  So I would argue that the approach is problematic as well.

On Sun, Jul 20, 2014 at 11:30 PM, Justin Uberti <[email-masked]> wrote:

>>> A new version of codec preferences draft has been published, by
>>> modifying as per the review comments received.
>>>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>