Subject: Re: [rtcweb] Continous consent when no media is sent

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 3 Jun 2014 12:23:52 +0000

Hi

Agree. I will remove the “recvonly” keyword from that sentence. Then I believe it will cover for all cases where a endpoint is only receiving media and not sending. Is that sufficient ?

Regards,
Ram

From: Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 3 June 2014 1:25 pm
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [rtcweb] Continous consent when no media is sent

Hi,

Section 4.1 of draft-ietf-rtcweb-stun-consent-freshness-03 says:

“An endpoint that is only receiving application traffic (recvonly)
                does not need to obtain consent which can slightly conserve its
                resources.”

I think it would be good to be more generic, and talk about cases where the sender does not send media. That is obviously true in case of “recvonly”, but it could also be true in other cases.

In addition, I guess the no-need-to-send-consent rule also applies to “inactive” streams.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Jun 2014 12:29:33 +0000

Hi,

>Agree. I will remove the "recvonly" keyword from that sentence. Then I believe it will cover for all cases where a endpoint is only receiving media and not sending. Is that sufficient ?

If the stream is inactive, the endpoint won't receive either, so I think you only need to talk about sending. Whether the endpoint receives media or not is irrelevant, isn't it?

Regards,

Christer

From: Christer Holmberg <[email-masked]>
Date: Tuesday, 3 June 2014 1:25 pm
To: "[email-masked]" <[email-masked]>
Subject: [rtcweb] Continous consent when no media is sent

Hi,

       "An endpoint that is only receiving application traffic (recvonly)
                does not need to obtain consent which can slightly conserve its
                resources."
 
I think it would be good to be more generic, and talk about cases where the sender does not send media. That is obviously true in case of "recvonly", but it could also be true in other cases.
 
In addition, I guess the no-need-to-send-consent rule also applies to "inactive" streams.
 
Regards,
 
Christer

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 3 Jun 2014 12:39:50 +0000

Agree. I think checking for sending is good enough. If both the endpoints
are not sending media they won¹t do consent with their peers.
That will take care of all the cases

Regards,
Ram
-----Original Message-----
From: Christer Holmberg <[email-masked]>
Date: Tuesday, 3 June 2014 5:59 pm
To: Ram Mohan Ravindranath <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: RE: [rtcweb] Continous consent when no media is sent

>Hi,
>
>>Agree. I will remove the "recvonly" keyword from that sentence. Then I
>>believe it will cover for all cases where a endpoint is only receiving
>>media and not sending. Is that sufficient ?
>
>If the stream is inactive, the endpoint won't receive either, so I think
>you only need to talk about sending. Whether the endpoint receives media
>or not is irrelevant, isn't it?
>
>Regards,
>
>Christer
>
>
>
>
>
>
>I think it would be good to be more generic, and talk about cases where
>the sender does not send media. That is obviously true in case of
>"recvonly", but it could also be true in other cases.
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Jun 2014 12:42:11 +0000

And, we of course also need to make sure that the remote endpoint does not expect to receive cont.cons. in such cases :)

Regards,

Christer

-----Original Message-----
From: Ram Mohan R (rmohanr) [mailto:[email-masked]] 
Sent: 3. kesäkuuta 2014 15:40
To: Christer Holmberg; [email-masked]
Subject: Re: [rtcweb] Continous consent when no media is sent

Agree. I think checking for sending is good enough. If both the endpoints are not sending media they won¹t do consent with their peers.
That will take care of all the cases

Regards,
Ram
-----Original Message-----
From: Christer Holmberg <[email-masked]>
Date: Tuesday, 3 June 2014 5:59 pm
To: Ram Mohan Ravindranath <[email-masked]>, "[email-masked]"
<[email-masked]>

>If the stream is inactive, the endpoint won't receive either, so I 
>think you only need to talk about sending. Whether the endpoint 
>receives media or not is irrelevant, isn't it?
>
>Regards,
>
>Christer
>
>
>
>
>
>