Subject: [rtcweb] DTLS version

From: Michael Tuexen <[email-masked]>
Date: Tue, 1 Jul 2014 01:44:42 +0200

Dear all,

based on a comment from EKR, I would like to bring up a question:
RTCWeb uses DTLS for deriving the keys for SRTP on the one hand and
for transporting SCTP on the other hand.
The SRTP related documents refer to DTLS version 1.0 as specified in
http://tools.ietf.org/html/rfc4347
The SCTP over DTLS document currently refers to DTLS version 1.2 as specified in
http://tools.ietf.org/html/rfc6347

I think we need to use a single version of DTLS for RTCWeb. RFC 4347 is obsoleted
by RFC 6347. Wouldn't that imply that it makes sense to use DTLS 1.2 in all documents?

Best regards
Michael

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 30 Jun 2014 16:48:57 -0700

"Wouldn't that imply that it makes sense to use DTLS 1.2 in all documents?"

[BA] Not necessarily.  As I understand it, existing implementations only
support 1.0 - and if we were to mandate only 1.2 ciphersuites, then this
would create an interoperability problem.

On Mon, Jun 30, 2014 at 4:44 PM, Michael Tuexen <
[email-masked]> wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 1 Jul 2014 01:55:09 +0200

On 01 Jul 2014, at 01:48, Bernard Aboba <[email-masked]> wrote:

> [BA] Not necessarily.  As I understand it, existing implementations only support 1.0 - and if we were to mandate only 1.2 ciphersuites, then this would create an interoperability problem. 
There are also several clarifications and corrections to handshake issues. This
really helps in interoperability....

Best regards
Michael
> 
> 
> On Mon, Jun 30, 2014 at 4:44 PM, Michael Tuexen <[email-masked]> wrote:
> Dear all,
>

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Jun 2014 17:20:56 -0700

> really helps in interoperability....

Bernard is right.  But there are several advantages to an update to
referencing (D)TLS 1.2.  For one, we get better ciphersuites (AES-GCM
and all the AEAD modes).

That said, there are enough implementations out there already that
*requiring* 1.2 might be too aggressive.  I think that I'd prefer that
(so that we can make modern ciphersuite recommendations to fit), but
if someone has a strong need for 1.0, I don't have a problem
suggesting that 1.0 be accepted.

p.s., DTLS 1.2 is coming in Firefox.  As it turns out, NSS supported
it, but it hadn't been turned on.