Subject: [rtcweb] Review of draft-ietf-rtcweb-data-protocol-05

From: Doug Leonard <[email-masked]>
Date: Mon, 2 Jun 2014 10:22:59 -0600

A1. Section 4, 1st paragraph

I think the full name of the protocol better establishes context. It
should be used as a section's first reference to the protocol. Then
subsequent references may be less explicit. (see A4)

I would change "This protocol..." to "The Data Channel Establishment
Protocol..."

A2. Section 4, first bullet

Should be simplified to read: Reliable or unreliable message
transmission. In the case of unreliable transmissions, the same level
of unreliability is used.

A3. Section 4, second bullet

Should be simplified to read: In-order or out-of- order message
delivery.

A4. Section 4, third paragraph

Change the subsequent reference of "The Data Channel Establishment
Protocol..." to "This protocol..."

A5. Section 4, third paragraph

"...uses a two way handshake to open a data channel by combining two
SCTP streams, one in each direction, with the same SCTP stream
identifier."

For more clarity change to:

"...uses a two way handshake to open a data channel. The handshake
pairs one incoming and one outgoing SCTP stream, each having an
identical stream identifier, into a single bidirectional channel."

A6. Section 4, third paragraph

I think the sentence that begins "Please note" should be separated out
into a new paragraph and labeled as a note as follows:

Note: The opening side can only send user messages before the
DATA_CHANNEL_ACK is received.

A7. Section 4, fourth paragraph

I think we should formally reference the title of Internet- Drafts
and then link to their location, rather than using the link as the
subject of sentences. I would change the sentence that begins "When
using [I-D.ietf-tsvwg-sctp-dtls-encaps], the method..." to the
following:

“When using SCTP over DTLS [I-D.ietf-tsvwg-sctp-dtls-encaps], the method…”

-- 
Doug Leonard
Developer  |  Jive Communications, Inc.
Jive.com  |  dleonard at getjive . com

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 3 Jun 2014 18:37:36 +0200

On 02 Jun 2014, at 18:22, Doug Leonard <[email-masked]> wrote:
Hi Doug,

thanks a lot for your review. See my comments inline.

Best regards
Michael
> 
> -----BEGIN PGP SIGNED MESSAGE----- 
> Hash: SHA256 
> 
> 
Done.
> of unreliability is used.
Done with using reliable instead of Reliable.
> Should be simplified to read: In-order or out-of- order message
Done with using in-order instead of In-order.
> Protocol..." to "This protocol..."
Done.
> identical stream identifier, into a single bidirectional channel."
I would prefer:
The handshake pairs one incoming and one outgoing SCTP stream, both having the
same SCTP stream identifier, into a single bidirectional channel.
> DATA_CHANNEL_ACK is received.
Why did you insert an "only"?
If you want the note to be in a separate paragraph, I would move it to
the end of the 4th paragraph.
> “When using SCTP over DTLS [I-D.ietf-tsvwg-sctp-dtls-encaps], the method…”
Done.

Best regards
Michael
> -----BEGIN PGP SIGNATURE----- 
> Version: OpenPGP.js v0.5.1 
> Comment: http://openpgpjs.org 
> 
> wsBcBAEBCAAQBQJTjKTaCRA6BPqvovvpGQAAPwMH/2Tp1sx9diRh48WhVELN
> 0uA0HxU4ITI5sUbbHdpwbGZm2EmEB/enbrW74yBXdaSAk4ouXh5Kz11akFU5
> r50X8shgLSeziIOxSuJNuA5re11vLcdnRZ3fMDGPKbTsFDvJgNT+kwO8buKS
> 6CLpQxCDxoNOyUN4KZqS1QBeUlVP49+a/ms0Pg/97oiSPAvipMknVB7KUFg6
> lppN8HuqOxxAKTFrU05tuXucIW/937FL5iTcDv6cdNTW+xiKmUXOOgoTTQtN
> y7PfB8Bc01TnLpy2xFDAmkeKTAZ5REIXax0v80ASy8W4JFIopzCtSyS+XniG
> 6oyeTLz02IMv1R8lUyVbbaA= 
> =notY 
> -----END PGP SIGNATURE----- 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb