Subject: [rtcweb] Fwd: New Version Notification for draft-ietf-rtcweb-overview-10.txt

From: Harald Alvestrand <[email-masked]>
Date: Tue, 17 Jun 2014 15:12:14 +0200

The most important new words are definitions of terms "WebRTC Browser" 
and "WebRTC Device", and using these as requirement categories - which 
then support a new scattering of MUSTs on the references.

Comments welcome!

Harald

-------- Original Message --------
Subject: 	New Version Notification for draft-ietf-rtcweb-overview-10.txt
Date: 	Tue, 17 Jun 2014 05:59:18 -0700
From: 	[email-masked]
To: 	Harald T. Alvestrand <[email-masked]>, Harald T. Alvestrand 
<[email-masked]>

A new version of I-D, draft-ietf-rtcweb-overview-10.txt
has been successfully submitted by Harald T. Alvestrand and posted to the
IETF repository.

Name:		draft-ietf-rtcweb-overview
Revision:	10
Title:		Overview: Real Time Protocols for Browser-based Applications
Document date:	2014-06-17
Group:		rtcweb
Pages:		20
URL:            http://www.ietf.org/internet-drafts/draft-ietf-rtcweb-overview-10.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-rtcweb-overview/
Htmlized:       http://tools.ietf.org/html/draft-ietf-rtcweb-overview-10
Diff:           http://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-overview-10

Abstract:
    This document gives an overview and context of a protocol suite
    intended for use with real-time applications that can be deployed in
    browsers - "real time communication on the Web".

    It intends to serve as a starting and coordination point to make sure
    all the parts that are needed to achieve this goal are findable, and
    that the parts that belong in the Internet protocol suite are fully
    specified and on the right publication track.

    This document is an Applicability Statement - it does not itself
    specify any protocol, but specifies which other specifications RTCWEB
    compliant implementations are supposed to follow.

    This document is a work item of the RTCWEB working group.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Hutton, Andrew" <[email-masked]>
Date: Tue, 24 Jun 2014 15:30:38 +0000

Section 4 now states “WebRTC devices MUST implement the transport protocols described in [I-D.ietf-rtcweb-transports<http://tools.ietf.org/html/draft-ietf-rtcweb-overview-10#ref-I-D.ietf-rtcweb-transports>]”

This might be a comment on –transports- more than –overview- but section 3.4 of transports states that “The implementation MUST be a full ICE implementation, not ICE-Lite”. This is however not true for “WebRTC devices” only for “WebRTC browsers” since ICE-Lite is sufficient for “WebRTC devices”.

Regards

Andy

From: rtcweb [mailto:[email-masked]] On Behalf Of Harald Alvestrand
Sent: 17 June 2014 14:12
To: [email-masked]
Subject: [rtcweb] Fwd: New Version Notification for draft-ietf-rtcweb-overview-10.txt

The most important new words are definitions of terms "WebRTC Browser" and "WebRTC Device", and using these as requirement categories - which then support a new scattering of MUSTs on the references.

Comments welcome!

Harald

-------- Original Message --------
Subject:

New Version Notification for draft-ietf-rtcweb-overview-10.txt

Date:

Tue, 17 Jun 2014 05:59:18 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Harald T. Alvestrand <[email-masked]><mailto:[email-masked]>, Harald T. Alvestrand <[email-masked]><mailto:[email-masked]>

IETF repository.

Revision:     10

Group:        rtcweb

Pages:        20

Abstract:

The IETF Secretariat

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 24 Jun 2014 18:08:29 +0200

On 06/24/2014 05:28 PM, Hutton, Andrew wrote:
> Section 4 now states “WebRTC devices MUST implement the transport protocols described in [I-D.ietf-rtcweb-transports <http://tools.ietf.org/html/draft-ietf-rtcweb-overview-10#ref-I-D.ietf-rtcweb-transports>]”
>
>  
>

Good point. -transports- was last updated before I invented "WebRTC
devices", it uses "devices" and "browsers" interchangeably.

Will make them consistent next round, if WG signs off on the split.

> Regards
> Andy
>
>  
>
>  
>
>  
>
>  
>
> *From:*rtcweb [mailto:[email-masked]] *On Behalf Of *Harald
> Alvestrand
> *Sent:* 17 June 2014 14:12
> *To:* [email-masked]
> *Subject:* [rtcweb] Fwd: New Version Notification for
> draft-ietf-rtcweb-overview-10.txt
>
>  
>
> *Subject: *
> *Date: *
> *From: *
> [email-masked] <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> Harald T. Alvestrand <[email-masked]>
> <mailto:[email-masked]>, Harald T. Alvestrand
> <[email-masked]> <mailto:[email-masked]>
>
>  
>

-- 
Surveillance is pervasive. Go Dark.