Subject: [rtcweb] Usage of draft-ietf-rtcweb-overview

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 3 Jun 2014 13:34:05 +0000

I was working through this document, and assessing whether it could form a conformance assessment for a rtcweb implementation.

I came to the conclusion that it could not as it currently stands.

While it is standards track, it seems to be missing RFC 2119 language completely.

As such I end up wondering whether some of the referenced drafts are mandatory to implement, optional to implement (or could just be ignored - unlikely).

So what is the philosophy here - Would I be right in considering that the intent is that all the referenced normative references are mandatory, i.e. all implementations implement all these documents?

But if that is the case, how do I treat text in the document that references draft-cbran-rtcweb-codec, which is an informative reference, but which the text treats with equal weight as other normative references?

Regards

Keith

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 03 Jun 2014 16:05:17 +0200

> As such I end up wondering whether some of the referenced drafts are mandatory to implement, optional to implement (or could just be ignored - unlikely).
In that case, the language is unclear, and needs fixing.
I'll review the document with this in mind; doing things like changing

    The data transport protocols used by RTCWEB are described in
    [I-D.ietf-rtcweb-transports].

into

    An RTCWEB implementation MUST implement the data transport protocols 
described in
    [I-D.ietf-rtcweb-transports].

is pretty mechanical.
> So what is the philosophy here - Would I be right in considering that the intent is that all the referenced normative references are mandatory, i.e. all implementations implement all these document…

The intent of the normative references is that the referenced RFCs have 
to be read, and the implications understood, in order to correctly 
implement an RTCWEB system.

I believe that's the definition of a normative reference. Many of these 
(RFC 2119 being the prime example) are, by definition, unimplementable.

Some of them are classified wrongly, like -data-protocol, which should 
be normative. (or deleted, since we now have a reference to it in 
-transport).

I'm not sure where the W3C API documents should be placed; for browsers, 
they're normative, but I'm not sure having a normative reference to them 
in this document is the Right Thing. Opinions?

> But if that is the case, how do I treat text in the document that references draft-cbran-rtcweb-codec, which is an informative reference, but which the text treats with equal weight as other normat…

The reference to draft-cbran is due to be deleted, since that draft is 
(I believe) dead. This is a placeholder for a decision on the MTI video 
codec discussion.

The particular sentence referencing this draft is:

    The mandatory to implement codecs, as well as any profiling
    requirements for both mandatory and optional codecs, is described in
    <WORKING GROUP DRAFT "MEDIA PROCESSING"> (candidate draft:
    [I-D.cbran-rtcweb-codec].

When I wrote this, I thought it was pretty clear that an implementation 
MUST implement the mandatory to implement codecs, but that the draft 
specifying them did not exist yet (and the reference to the 
wannabe-decision therefore had to be informative). But if you read it as 
"treat with equal weight", I guess that wasn't written clearly enough?

> Regards
>
> Keith
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 5 Jun 2014 00:47:23 +0000

That works for me.

At least getting RFC 2119 language on the ones we know must implement within the scope of RTCWEB helps.

In terms of implementability of such RFC 2119 language, I think that is an issue for the referenced documents, not the overview document. All such terminology really says in that the implementation MUST conform to the MUSTs, the SHOULDs and the MAYs in the referenced documents.

I agree how to handle the API documents is a difficult question, and as such I do not have an answer at the moment. I suggest you leave those as is until we get further input.

If "data formats" is ultimately meant to contain the codec requirements, why is the audio codec reference elsewhere in the document?

regards

Keith 

> -----Original Message-----
> From: rtcweb [mailto:[email-masked]] On Behalf Of 
> Harald Alvestrand
> Sent: 03 June 2014 15:05
> To: [email-masked]
> Subject: Re: [rtcweb] Usage of draft-ietf-rtcweb-overview
> 
> > I was working through this document, and assessing whether 
> it could form a conformance assessment for a rtcweb implementation.
> >
> > As such I end up wondering whether some of the referenced 
> drafts are mandatory to implement, optional to implement (or 
> could just be ignored - unlikely).
>     An RTCWEB implementation MUST implement the data 
> transport protocols described in
> > So what is the philosophy here - Would I be right in 
> considering that the intent is that all the referenced 
> normative references are mandatory, i.e. all implementations 
> implement all these documents?
> 
> The intent of the normative references is that the referenced 
> RFCs have to be read, and the implications understood, in 
> order to correctly implement an RTCWEB system.
> 
> I believe that's the definition of a normative reference. 
> Many of these (RFC 2119 being the prime example) are, by 
> definition, unimplementable.
> 
> Some of them are classified wrongly, like -data-protocol, 
> which should be normative. (or deleted, since we now have a 
> reference to it in -transport).
> 
> I'm not sure where the W3C API documents should be placed; 
> for browsers, they're normative, but I'm not sure having a 
> normative reference to them in this document is the Right 
> Thing. Opinions?
> 
> >
> > But if that is the case, how do I treat text in the 
> document that references draft-cbran-rtcweb-codec, which is 
> an informative reference, but which the text treats with 
> equal weight as other normative references?
>

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 05 Jun 2014 10:36:44 +0200

> If "data formats" is ultimately meant to contain the codec requirements, why is the audio codec reference elsewhere in the document?

Because I messed up when inserting it :-)
Will fix.