Subject: Re: [rtcweb] When are ICE candidates added to the SDP

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 5 Jun 2014 15:18:14 +0200

2014-05-19 13:18 GMT+02:00 Harald Alvestrand <[email-masked]>:
> The onicecandidate(NULL) always seemed inelegant to me; it wasn't supplying
> a candidate, it was indicating something else.
>
> I'd be happy with replacing it with an iceGatheringState change callback (if
> we can ensure that this will do the Right Thing in all cases...)

+1

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Thu, 05 Jun 2014 15:43:55 +0200

>> we can ensure that this will do the Right Thing in all cases...)
+1 to onicegatheringstatechange

BR
Sergio

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Thu, 5 Jun 2014 15:48:37 +0200

>> we can ensure that this will do the Right Thing in all cases...)

And the opposite is a bug in the spec because if the iceGatheringState
does not fire when indeed the "ICE gathering" status has changed to
"ended", what is it supposed to do?

-- 
Iñaki Baz Castillo
<[email-masked]>