Subject: Re: [rtcweb] Query Regarding Mandatory audio codecs draft

From: Steev James <[email-masked]>
Date: Mon, 28 Apr 2014 14:55:55 +0530

Means you say that G.711 uses less bandwidth than Opus at the expense of
complexity.

Am I right ?

On Mon, Apr 28, 2014 at 11:23 AM, Jean-Marc Valin <[email-masked]>wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> So, if the other endpoint only supports G.711 (legacy), then it
> doesn't matter which codec you offer first. The the other endpoint
> supports both Opus and G.711, but only at 8 kHz, then it comes down to
> which of complexity or bandwidth is more important. On a corporate LAN
> you'd likely want to use G.711 while for chatting from your home,
> you'd usually want Opus. This is why the draft makes has no SHOULD
> when it comes to narrowband.
>
>         Jean-Marc
>
> On 28/04/14 12:40 AM, Steev James wrote:
> > Paul, What do you say, if another end point is using both G.711 and
> > Opus at 8kHz and why ?
> >
> > Steev.
> >
> >
> >
> >>> Is that means spec is recommending G.711 (PCMA/PCMU) for
> >>> sampling
> > rate
> >>> less than or equal to 8 kHz?
> >>
> >> No. Opus is still a good idea for 8 kHz, but it's not 2119
> >> RECOMMENDED since there are valid (mostly complexity-related)
> >> reasons to use G.711 despite the higher bit-rate.
> >>
> >> Jean-Marc
> >
> > Opus isn't a good idea for 8 KHz if you are trying to inter-operate
> > with another end-point using G.711.
> >
> > ...Paul
> >
> >
> >
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>
> iQEcBAEBAgAGBQJTXezkAAoJEJ6/8sItn9q9DfEIAKy6ZPCE7o/dyBFhpt5tGpds
> XRDUiR++S89H4blgJOsR5nzzmkGwN+onN4cwBfz4Tbvi0Q7Q/UyzdlBePekC4gwL
> wrQL2/fwxfTnB0T6yfn2rrCd+i7jVWf2xJz0xJIY2qYAxYVg469PzeGMHTJK1+1x
> S1BDRZHZp4X/nSShthdthHvkfHrVPq5pDzexCfBc2h56+9Z3K1COdQlVZD/UJwQy
> twp8p6755LzucV4KdvN5NM5w9rjySBTAaUElU0WkyMPfRppowAkFhJunoJCTeIW9
> 8Stsm5yrAeasQhe9mlubceIYsTyjGfKkoO1RVkQUB2YwzctqyMnK14ZYJQbg8Us=
> =Ys9g
> -----END PGP SIGNATURE-----
>

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 28 Apr 2014 14:14:22 +0200

On 04/28/2014 11:25 AM, Steev James wrote:
> Means you say that G.711 uses less bandwidth than Opus at the expense 
> of complexity.

G.711 gives very low audio quality. The larger complexity of Opus means 
that it is able to give a much better quality at the same bandwidth.

Personal opinion: The only time I'd be wanting to use G.711 if Opus is 
available is when I'm on a severely underpowered mobile phone. That 
platform is likely also so weak that I couldn't even imagine using video 
on it (video is order-of-magnitude more complex to encode/decode than Opus).

---

From: Stephen Botzko <[email-masked]>
Date: Mon, 28 Apr 2014 08:51:15 -0400

No.  G.711 uses more network bandwidth than OPUS, but OPUS is more complex.

The main benefit of using G.711 is that it can avoid the use of transcoding
in some scenarios.

My view is that the approach in the current text is correct - there is no
need to specify a SHOULD on which codec is offered first.

Stephen

On Mon, Apr 28, 2014 at 5:25 AM, Steev James <[email-masked]>wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Paul Coverdale <[email-masked]>
Date: Mon, 28 Apr 2014 09:46:18 -0400

I think we’re mixing up sampling frequency and bit-rate here.

By definition, G.711 uses a sampling frequency of 8 KHz and encodes each sample with an 8-bit logarithmically companded, encoding law (A or Mu), resulting in an output bit-rate of 64 kbit/s. 

Opus can operate with a number of different sampling frequencies (depending on the desired audio bandwidth) and output bit-rates, including 64 kbit/s.

The point I was trying to make is that, even if both codecs provide the same numerical bit-rate, they are not compatible between end-points. If a legacy end-point can only support G.711, it’s no good sending it anything else but G.711.

...Paul

From: Steev James [mailto:[email-masked]] 
Sent: Monday, April 28, 2014 5:26 AM
To: Jean-Marc Valin
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re:Query Regarding Mandatory audio codecs draft

Means you say that G.711 uses less bandwidth than Opus at the expense of complexity.

Am I right ?

On Mon, Apr 28, 2014 at 11:23 AM, Jean-Marc Valin <[email-masked]> wrote:

        Jean-Marc

---

From: Jessie Morris <[email-masked]>
Date: Mon, 28 Apr 2014 09:19:51 -0600

The only situation that it would make sense to use G.711 and video is on 
a weak platform that happens to have hardware decoding capabilities for 
H.264 or VP8 or whatever the video codec is. I don't think there are a 
lot of these currently, but it is possible.

On 2014-04-28, 06:14, Harald Alvestrand wrote:
> G.711 gives very low audio quality. The larger complexity of Opus 
> means that it is able to give a much better quality at the same 
> bandwidth.
>
> platform is likely also so weak that I couldn't even imagine using 
> video on it (video is order-of-magnitude more complex to encode/decode 
> than Opus).
>
--
Jessie A. Morris
Jive Communications, Inc.
[email-masked]

---

From: Stephen Botzko <[email-masked]>
Date: Mon, 28 Apr 2014 14:23:24 -0400

The mandatory codec question for audio is long settled, and personally I am
thinking we really don't want to reopen that discussion.

The original poster was wanting to know if G.711 was preferred over OPUS
for narrow band.  The answer given was "no".  Is there really a need to
discuss this more?

Stephen

On Mon, Apr 28, 2014 at 11:19 AM, Jessie Morris <[email-masked]> wrote:

> The only situation that it would make sense to use G.711 and video is on a
> weak platform that happens to have hardware decoding capabilities for H.264
> or VP8 or whatever the video codec is. I don't think there are a lot of
> these currently, but it is possible.
>
>
>> platform is likely also so weak that I couldn't even imagine using video on
>> it (video is order-of-magnitude more complex to encode/decode than Opus).
>>