Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-data-channel-08.txt

From: [email-masked]
Date: Wed, 09 Apr 2014 03:02:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.

        Title           : WebRTC Data Channels
        Authors         : Randell Jesup
                          Salvatore Loreto
                          Michael Tuexen
	Filename        : draft-ietf-rtcweb-data-channel-08.txt
	Pages           : 15
	Date            : 2014-04-09

Abstract:
   The Real-Time Communication in WEB-browsers working group is charged
   to provide protocol support for direct interactive rich communication
   using audio, video, and data between two peers' web-browsers.  This
   document specifies the non-(S)RTP media data transport aspects of the
   WebRTC framework.  It provides an architectural overview of how the
   Stream Control Transmission Protocol (SCTP) is used in the WebRTC
   context as a generic transport service allowing WEB-browsers to
   exchange generic data from peer to peer.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtcweb-data-channel/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-rtcweb-data-channel-08

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-rtcweb-data-channel-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Colin Perkins <[email-masked]>
Date: Wed, 9 Apr 2014 12:00:43 +0100

>   exchange generic data from peer to peer.

This talks about “(S)RTP” throughout, but the rtp-usage draft requires that SRTP be used for WebRTC, and disallows plain RTP. I think this draft could be simplified by changing “(S)RTP” to “SRTP” throughout.

-- 
Colin Perkins
http://csperkins.org/

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 9 Apr 2014 11:22:59 +0000

Hi,

The WebRTC Data Channel will be used also for non-WebRTC applications (it is e.g. base for the CLUE Data Channel), where the must-use-SRTP rule does not necessarily apply.

Having said that, I DO think that the draft text need to be more generic. WebRTC can be described as a use-case, but it shall be clear that the mechanism can also be used in other environments.

Regards.

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Colin Perkins
Sent: 9. huhtikuuta 2014 14:01
To: [email-masked]
Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-data-channel-08.txt

>   exchange generic data from peer to peer.

This talks about "(S)RTP" throughout, but the rtp-usage draft requires that SRTP be used for WebRTC, and disallows plain RTP. I think this draft could be simplified by changing "(S)RTP" to "SRTP" throughout.

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Barry Dingle <[email-masked]>
Date: Wed, 9 Apr 2014 21:41:25 +1000

Hi,

If "WebRTC Data Channel" is to be used for other use-cases than just
WebRTC, then the Title needs to change.  But what do we call it?

Cheers,
Barry Dingle
Australia

On Wed, Apr 9, 2014 at 9:22 PM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> The WebRTC Data Channel will be used also for non-WebRTC applications (it
> is e.g. base for the CLUE Data Channel), where the must-use-SRTP rule does
> not necessarily apply.
>
> Having said that, I DO think that the draft text need to be more generic.
> WebRTC can be described as a use-case, but it shall be clear that the
> mechanism can also be used in other environments.
>
> Regards.
>
> Christer
>
> This talks about "(S)RTP" throughout, but the rtp-usage draft requires
> that SRTP be used for WebRTC, and disallows plain RTP. I think this draft
> could be simplified by changing "(S)RTP" to "SRTP" throughout.
>
> --
> Colin Perkins
> http://csperkins.org/
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 9 Apr 2014 11:46:21 +0000

Hi,

>If "WebRTC Data Channel" is to be used for other use-cases than just WebRTC, then the Title needs to change.  But what do we call it? 

I think we had this discussion already earlier, and people suggested different new names.

Regards,

Christer

On Wed, Apr 9, 2014 at 9:22 PM, Christer Holmberg <[email-masked]> wrote:
Hi,

Regards.

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Colin Perkins
Sent: 9. huhtikuuta 2014 14:01
To: [email-masked]
Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-data-channel-08.txt

--
Colin Perkins
http://csperkins.org/

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 09 Apr 2014 10:12:18 -0400

SCTP Data Channel, or simply Data Channel.

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 9 Apr 2014 16:20:40 +0200

> This talks about “(S)RTP” throughout, but the rtp-usage draft requires that SRTP be used for WebRTC, and disallows plain RTP. I think this draft could be simplified by changing “(S)RTP” to “SRTP” t…
Hi Colin,

The (S)RTP notion goes back to a comment from Magnus. If I remember it correctly he considers
SRTP a profile of RTP. Since I don't wanted to just use RTP, I ended up with (S)RTP based
on a discussion with Magnus.

However, I'm fine with changing it to SRTP...

Magnus: Any comment?

Best regards
Michael

---

From: Colin Perkins <[email-masked]>
Date: Wed, 9 Apr 2014 15:25:09 +0100

On 9 Apr 2014, at 15:20, Michael Tuexen <[email-masked]> wrote:
> The (S)RTP notion goes back to a comment from Magnus. If I remember it correctly he considers SRTP a profile of RTP. Since I don’t wanted to just use RTP, I ended up with (S)RTP based on a discussion with Magnus.
> 
> However, I’m fine with changing it to SRTP...

SRTP is an RTP profile. My comment was that if this is for WebRTC only, then  only SRTP can be used, and not plain RTP. Using “(S)RTP” rather than “SRTP” in this draft suggests that the secure profile is optional, which isn’t the case in WebRTC. If this is for more general use than WebRTC, then “(S)RTP” is fine.

Colin

-- 
Colin Perkins
http://csperkins.org/

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 9 Apr 2014 16:33:49 +0200

> SRTP is an RTP profile. My comment was that if this is for WebRTC only, then  only SRTP can be used, and not plain RTP. Using “(S)RTP” rather than “SRTP” in this draft suggests that the secure prof…
It is clear that in WebRTC only SRTP is used...

Best regards
Michael

---

From: Colin Perkins <[email-masked]>
Date: Wed, 9 Apr 2014 15:39:40 +0100

> It is clear that in WebRTC only SRTP is used...

I don’t believe your draft is clear on that, due to the use of “(S)RTP” terminology. That’s why I commented.

-- 
Colin Perkins
http://csperkins.org/

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 9 Apr 2014 16:47:06 +0200

> I don’t believe your draft is clear on that, due to the use of “(S)RTP” terminology. That’s why I commented.
I'm happy to change it to SRTP... Let's see what Magnus thinks...

Best regards
Michael

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 9 Apr 2014 17:01:05 +0200

> I'm happy to change it to SRTP... Let's see what Magnus thinks...

I am fine with that!

/Magnus

-- 

Magnus Westerlund

----------------------------------------------------------------------
Services, Media and Network features, Ericsson Research EAB/TXM
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Färögatan 6                 | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 9 Apr 2014 17:10:31 +0200

>> I'm happy to change it to SRTP... Let's see what Magnus thinks...
OK. Next revision used SRTP.

Best regards
Michael

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 9 Apr 2014 18:37:54 +0000

Hi,

If you want to describe the WebRTC usage, I'm fine using SRTP.

But, again, as there are other usages of the data channel than WebRTC, the generic text should not talk about only SRTP.

Regards,

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Michael Tuexen
Sent: 09 April 2014 18:11
To: Magnus Westerlund
Cc: [email-masked]; Colin Perkins
Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-data-channel-08.txt

On 09 Apr 2014, at 17:01, Magnus Westerlund <[email-masked]> wrote:

>>>>>>>> The Real-Time Communication in WEB-browsers working group is 
>>>>>>>> charged to provide protocol support for direct interactive rich 
>>>>>>>> communication using audio, video, and data between two peers' 
>>>>>>>> web-browsers.  This document specifies the non-(S)RTP media 
>>>>>>>> data transport aspects of the WebRTC framework.  It provides an 
>>>>>>>> architectural overview of how the Stream Control Transmission 
>>>>>>>> Protocol (SCTP) is used in the WebRTC context as a generic 
>>>>>>>> transport service allowing WEB-browsers to exchange generic data from peer to peer.
>>>>>>> 
>>>>>> The (S)RTP notion goes back to a comment from Magnus. If I remember it correctly he considers SRTP a profile of RTP. Since I don't wanted to just use RTP, I ended up with (S)RTP based on a discussion with Magnus.
>>>>>> 
>>>>> SRTP is an RTP profile. My comment was that if this is for WebRTC only, then  only SRTP can be used, and not plain RTP. Using "(S)RTP" rather than "SRTP" in this draft suggests that the secure profile is optional, which isn't the case in WebRTC. If this is for more general use than WebRTC, then "(S)RTP" is fine.
>>> I don't believe your draft is clear on that, due to the use of "(S)RTP" terminology. That's why I commented.

Best regards
Michael

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 10 Apr 2014 13:55:22 +0200

> I don’t believe your draft is clear on that, due to the use of “(S)RTP” terminology. That’s why I commented.
Enforcing the SRTP-only rule for WebRTC is not the business of this 
draft, so it's not a normative statement in any way, shape or form.

If it's possible to use these channels outside of WebRTC, and some of 
these places claim to be able to use pure RTP with appropriate security, 
then making use of "SRTP" only in this draft is confusing.

I see arguments both ways, and want to leave it at editors' discretion.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 10 Apr 2014 11:57:49 +0000

Hi,

In BUNDLE we use "RTP-based media" terminology, eventhough BUNDLE will be used in WebRTC environments where SRTP is mandated.

Why can't we use the same here?

Regards,

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Harald Alvestrand
Sent: 10. huhtikuuta 2014 14:55
To: [email-masked]
Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-data-channel-08.txt

On 04/09/2014 04:39 PM, Colin Perkins wrote:
>>>>>> web-browsers.  This document specifies the non-(S)RTP media data 
>>>>>> transport aspects of the WebRTC framework.  It provides an 
Enforcing the SRTP-only rule for WebRTC is not the business of this draft, so it's not a normative statement in any way, shape or form.

If it's possible to use these channels outside of WebRTC, and some of these places claim to be able to use pure RTP with appropriate security, then making use of "SRTP" only in this draft is confusing.

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 11 Apr 2014 08:58:11 +0200

> I see arguments both ways, and want to leave it at editors' discretion.
At least I don't have a strong position. So will edit the document as it is decided by
the WG... (the current version in git uses SRTP, but I'm willing to change that back)
Maybe my co-editors do have a strong position?

Best regards
Michael