Subject: [rtcweb] Question on draft-ietf-rtcweb-use-cases-and-requirements-14

From: [email-masked]
Date: Fri, 18 Apr 2014 10:53:08 -0400

Hi,

  I am new to rtcweb so pl excuse my lack of knowledge. 
  
1)  Refer 
   F33     The browser must be able to initiate and
           accept a media session where the data needed
           for establishment can be carried in SIP.

   In other places in other documents it is stated that browser is 
given freedom to do signaling it likes. Then this requirement will 
be met with signaling gateway. And there is no work in progress for 
that. Whether IETF mandates for browser to understand SIP or not?

2) It will be better if 1-800-Go-Fedex (Fedex call) is referred as 
IVR call and Fedex should be taken out as SKYPE was taken out.

Thanks
Samir

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 19 Apr 2014 19:24:02 +0000

Hi,
  
>   In other places in other documents it is stated that browser is given freedom to do signaling it 
> likes. Then this requirement will be met with signaling gateway. And there is no work in progress 
> for that. Whether IETF mandates for browser to understand SIP or not?

Not.

IETF does mandate the browser to understand SDP, though (as part of JSEP).

>2) It will be better if 1-800-Go-Fedex (Fedex call) is referred as IVR call and Fedex should be taken >out as SKYPE was taken out.

Which version did you look at? Skype has been removed from the latest version (-14). Fedex is still there, though.

Regards,

Christer