Subject: [rtcweb] H.264 as MTI

From: Roman Shpount <[email-masked]>
Date: Fri, 10 Jan 2014 13:53:12 -0500

I hope it should be fairly clear from the responses on this list that there
is a substantial group of people here that will never agree to an IPR
license fee encumbered video codec as an MTI. So, unless H.264 licensing
policy changes, H.264 will never get consensus as video codec MTI. Arguing
about all the other benefits of H.264, like legacy interop, is irrelevant
(I think most of the people on the list agree to them anyway). For a fairly
large group of people having H.264 as MTI video codec will translate into
either ignoring this part of specification or not supporting WebRTC. H.264
codec support is a hard and uncircumventable implementation block. Binary
download offer helps quite a bit but does not address all the issues (like
what happens if Cisco changes policy or disappears).

This being said, if H.264 proponents want it to be the video MTI, they
should work on changing the licensing policy, not on convincing this group
that H.264 is great. I would even argue that if H.264 proponents convinced
their own companies to change IPR policy regarding H.264, we would most
likely have the unencumbered H.264 and I would be the first person argue
for it to become an MIT. But, until H.264 licensing policy changes, all the
arguments for H.264 are a waste of perfectly good electrons.
_____________
Roman Shpount

---

From: "Matthew Kaufman (SKYPE)" <[email-masked]>
Date: Fri, 10 Jan 2014 19:10:30 +0000

Unfortunately, you can substitute VP8 for H.264 and tweak only a little of the language used in the below and have it also be true.

For your convenience using [] to delete and "" to add:

I hope it should be fairly clear from the responses on this list that there is a substantial group of people here that will never agree to [an IPR license fee encumbered video codec] "a codec developed outside of a recognized standards body and with outstanding IETF IPR declarations" as an MTI. So, unless [H.264 licensing policy] "the IPR risk associated with shipping VP8" changes, [H.264] "VP8" will never get consensus as video codec MTI. Arguing about all the other benefits of [H.264, like legacy interop,] "VP8, like the readily available single implementation with no associated license fees" is irrelevant (I think most of the people on the list agree to them anyway). For [a fairly large group of people] "quite a few people, including at least two major browser vendors" having [H.264] "VP8" as MTI video codec will translate into either ignoring this part of specification or not supporting WebRTC. [H.264] "VP8" codec support is a hard and uncircumventable implementation block. "(in both cases because of the lawyers, not the engineers)" Binary download offer helps quite a bit but does not address all the issues (like what happens if [Cisco] "Google" changes policy or disappears).

This being said, if [H.264] "VP8" proponents want it to be the video MTI, they should work on [changing the licensing policy,] "developing their video codec specifications within a recognized standards organization and making multiple implementations available and/or mitigating IPR risk through indemnification" not on convincing this group that [H.264] "VP8" is great. [I would even argue that if H.264 proponents convinced their own companies to change IPR policy regarding H.264, we would most likely have the unencumbered H.264 and I would be the first person argue for it to become an MIT. But, until H.264 licensing policy changes,] all the arguments for [H.264] "any MTI video codec for RTCWEB" are a waste of perfectly good electrons.

Matthew Kaufman

From: rtcweb [mailto:[email-masked]] On Behalf Of Roman Shpount
Sent: Friday, January 10, 2014 10:53 AM
To: [email-masked]
Subject: [rtcweb] H.264 as MTI

I hope it should be fairly clear from the responses on this list that there is a substantial group of people here that will never agree to an IPR license fee encumbered video codec as an MTI. So, unless H.264 licensing policy changes, H.264 will never get consensus as video codec MTI. Arguing about all the other benefits of H.264, like legacy interop, is irrelevant (I think most of the people on the list agree to them anyway). For a fairly large group of people having H.264 as MTI video codec will translate into either ignoring this part of specification or not supporting WebRTC. H.264 codec support is a hard and uncircumventable implementation block. Binary download offer helps quite a bit but does not address all the issues (like what happens if Cisco changes policy or disappears).

This being said, if H.264 proponents want it to be the video MTI, they should work on changing the licensing policy, not on convincing this group that H.264 is great. I would even argue that if H.264 proponents convinced their own companies to change IPR policy regarding H.264, we would most likely have the unencumbered H.264 and I would be the first person argue for it to become an MIT. But, until H.264 licensing policy changes, all the arguments for H.264 are a waste of perfectly good electrons.
_____________
Roman Shpount

---

From: Roman Shpount <[email-masked]>
Date: Fri, 10 Jan 2014 15:14:03 -0500

I would agree to everything your said, and this is the reason I listed VP8
in my straw poll response only as "acceptable" (unlike H.264, my lawyers
find VP8 high but manageable risk). Also, as far as, I know there is an
effort to standardize VP8 within a recognized standards organization (ISO).
If this process is successfully completed it would probably change VP8
codec from "acceptable" to "yes" for me.

_____________
Roman Shpount

On Fri, Jan 10, 2014 at 2:10 PM, Matthew Kaufman (SKYPE) <
[email-masked]> wrote:

>  Unfortunately, you can substitute VP8 for H.264 and tweak only a little
> of the language used in the below and have it also be true.
>
>
>
> For your convenience using [] to delete and “” to add:
>
>
>
> I hope it should be fairly clear from the responses on this list that
> there is a substantial group of people here that will never agree to [an
> IPR license fee encumbered video codec] “a codec developed outside of a
> recognized standards body and with outstanding IETF IPR declarations” as an
> MTI. So, unless [H.264 licensing policy] “the IPR risk associated with
> shipping VP8” changes, [H.264] “VP8” will never get consensus as video
> codec MTI. Arguing about all the other benefits of [H.264, like legacy
> interop,] “VP8, like the readily available single implementation with no
> associated license fees” is irrelevant (I think most of the people on the
> list agree to them anyway). For [a fairly large group of people] “quite a
> few people, including at least two major browser vendors” having [H.264]
> “VP8” as MTI video codec will translate into either ignoring this part of
> specification or not supporting WebRTC. [H.264] “VP8” codec support is a
> hard and uncircumventable implementation block. “(in both cases because of
> the lawyers, not the engineers)” Binary download offer helps quite a bit
> but does not address all the issues (like what happens if [Cisco] “Google”
> changes policy or disappears).
>
>
>
> This being said, if [H.264] “VP8” proponents want it to be the video MTI,
> they should work on [changing the licensing policy,] “developing their
> video codec specifications within a recognized standards organization and
> making multiple implementations available and/or mitigating IPR risk
> through indemnification” not on convincing this group that [H.264] “VP8” is
> great. [I would even argue that if H.264 proponents convinced their own
> companies to change IPR policy regarding H.264, we would most likely have
> the unencumbered H.264 and I would be the first person argue for it to
> become an MIT. But, until H.264 licensing policy changes,] all the
> arguments for [H.264] “any MTI video codec for RTCWEB” are a waste of
> perfectly good electrons.
>
>
>
> Matthew Kaufman
>
>
>
> *From:* rtcweb [mailto:[email-masked]] *On Behalf Of *Roman
> Shpount
> *Sent:* Friday, January 10, 2014 10:53 AM
> *To:* [email-masked]
> *Subject:* [rtcweb] H.264 as MTI
>
>
>
> I hope it should be fairly clear from the responses on this list that
> there is a substantial group of people here that will never agree to an IPR

---

From: David Singer <[email-masked]>
Date: Fri, 10 Jan 2014 16:14:34 -0800

I suspect it’s an artifact of written communications, as it seems you write as if this were not being tried, but I assure you that the effort to do this at MPEG (and elsewhere) is ongoing. Some of us do realize how much this would help the entire industry, and not just this effort.

On Jan 10, 2014, at 10:53 , Roman Shpount <[email-masked]> wrote:

> This being said, if H.264 proponents want it to be the video MTI, they should work on changing the licensing policy, not on convincing this group that H.264 is great. I would even argue that if H.264 proponents convinced their own companies to change IPR policy regarding H.264, we would most likely have the unencumbered H.264 and I would be the first person argue for it to become an MIT. 

David Singer
Multimedia and Software Standards, Apple Inc.

---

From: Roman Shpount <[email-masked]>
Date: Fri, 10 Jan 2014 19:50:29 -0500

I know that making H.264 license free has been tried. As far as I know so
far it has not succeeded. All I am saying that if every person who voted on
this list for H.264 as an MTI managed to convince their company to change
their IPR declaration in MPEG (and I believe it does include Apple), this
monumental effort would be much closer to completion.

_____________
Roman Shpount

On Fri, Jan 10, 2014 at 7:14 PM, David Singer <[email-masked]> wrote:

> I suspect it’s an artifact of written communications, as it seems you
> write as if this were not being tried, but I assure you that the effort to
> do this at MPEG (and elsewhere) is ongoing. Some of us do realize how much
> this would help the entire industry, and not just this effort.
>
>
> for it to become an MIT.

---

From: David Singer <[email-masked]>
Date: Fri, 10 Jan 2014 16:53:18 -0800

On Jan 10, 2014, at 16:50 , Roman Shpount <[email-masked]> wrote:

> I know that making H.264 license free has been tried. As far as I know so far it has not succeeded. All I am saying that if every person who voted on this list for H.264 as an MTI managed to convince their company to change their IPR declaration in MPEG (and I believe it does include Apple), this monumental effort would be much closer to completion.

If you check our IPR declaration against Web Video Coding (the formal name for the standard that isolates H.264 Constrained Baseline into a separate document, to get such separate IPR statements) I think you should find we did that.

One could wish that all who say they want an RF codec to exist had done the same, of course.

David Singer

---

From: Ron <[email-masked]>
Date: Sat, 11 Jan 2014 13:09:32 +1030

On Fri, Jan 10, 2014 at 04:14:34PM -0800, David Singer wrote:
> I suspect it’s an artifact of written communications, as it seems you write
> as if this were not being tried, but I assure you that the effort to do this
> at MPEG (and elsewhere) is ongoing. Some of us do realize how much this would
> help the entire industry, and not just this effort.

Oh some of us are well aware that a subset of the IPR holders have *tried*.
It's the fact that they have persistently *failed* which so spectacularly
highlights the patent disaster which the wise here would not wish to repeat
or to become entangled in if they aren't already up to their necks in it.

Saying, "we're in deep shit, you should come join us here, it's warm!"
isn't a particularly inviting proposition.

But if you like, and if you think it would help, we could apply a little
old fashioned competition pressure and make it a race!

VP8 to get through MPEG, or H.264 to get an RF licence and be compliant
with all the conditions of BCP 79 that it's so far completely ignoring.

Winner takes all.  Everyone wins.

Let's see who has the cojones and conviction in their beliefs to take
on that bet?

  I'm up for it,
  Ron

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 10 Jan 2014 19:50:36 -0800

> Winner takes all.  Everyone wins.

[BA] Not a bad contest - but one whose outcome will not be known for a while.

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 11 Jan 2014 15:38:24 +0100

On 01/10/2014 08:10 PM, Matthew Kaufman (SKYPE) wrote:
>
> Unfortunately, you can substitute VP8 for H.264 and tweak only a
> little of the language used in the below and have it also be true.
>
>  
>
>
> This being said, if [H.264] "VP8" proponents want it to be the video
> MTI, they should work on [changing the licensing policy,] "developing
> their video codec specifications within a recognized standards
> organization
>

Coincidentally, I'm at the MPEG meeting trying to be allowed to develop
a VP8 specification within MPEG, which probably fits the definition of
"a recognized standards organization".

So far, it's been slow going. I've been asked multiple times whether
it's actually worth the effort to continue trying.

Since MPEG's rules are somewhat opaque to me about what I can say in
public about what goes on at MPEG, I'll leave it at that.

---

From: Ron <[email-masked]>
Date: Sun, 12 Jan 2014 03:11:19 +1030

> public about what goes on at MPEG, I'll leave it at that.

That's the fun thing about "tweaking language" to replace something
that is fundamentally relevant with something that is completely
arbitrary and pretending they are the same.

Next they'll tell you that you don't have the right school tie or
some such.

Or that this group couldn't accept a perfectly good existing RFC as
a WG document relevant here.

  Ron

---

From: Mohammed Raad <[email-masked]>
Date: Sun, 12 Jan 2014 03:46:25 +1100

MPEG's management has created an opportunity for the standardization of a
royalty free codec. David is one of the people whose efforts made this
happen.

MPEG has publicly announced that they will be conducting a technical
evaluation of three options that are on the table. One is VP8 (now called
VCB by MPEG), another is AVC/h264, the third is a codec being developed as
an exploration (called IVC).

We will see how genuine the MPEG membership is about allowing royalty free
video coding to be part of the international standardization space this
week. We just have to wait until Friday evening San Jose time.

Mohammed
On Jan 11, 2014 11:14 AM, "David Singer" <[email-masked]> wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Mohammed Raad <[email-masked]>
Date: Sun, 12 Jan 2014 03:57:59 +1100

You know, if all those interested in this topic on this mailing list
contacted their ISO national bodies with the message that there is an
urgent need for the development of a serious codec for the web environment,
perhaps those of us trying to get VP8 standardized would actually find ISO
standardization a less hostile place to operate in.

Mohammed
On Jan 11, 2014 6:11 AM, "Matthew Kaufman (SKYPE)" <

---

From: David Singer <[email-masked]>
Date: Sat, 11 Jan 2014 09:55:41 -0800

On Jan 11, 2014, at 8:57 , Mohammed Raad <[email-masked]> wrote:

> You know, if all those interested in this topic on this mailing list contacted their ISO national bodies with the message that there is an urgent need for the development of a serious codec for the web environment, perhaps those of us trying to get VP8 standardized would actually find ISO standardization a less hostile place to operate in.

Yes, I think it’s clear that the advantages for the industry in general, that having an RF codec would bring, have not reached everyone who has the ability to influence the outcome.  Getting involved, and making a good case (particularly to companies that hold relevant patent portfolios, and their national bodies) would be helpful.

(I would suggest that such cases focus on why it’s not only a ‘good thing’, but why it’s also in the interests of the patent holders to do this.)

> 
> Mohammed
> 
> On Jan 11, 2014 6:11 AM, "Matthew Kaufman (SKYPE)" <[email-masked]> wrote:
> I hope it should be fairly clear from the responses on this list that there is a substantial group of people here that will never agree to [an IPR license fee encumbered video codec] “a codec developed outside of a recognized standards body and with outstanding IETF IPR declarations” as an MTI. So, unless [H.264 licensing policy] “the IPR risk associated with shipping VP8” changes, [H.264] “VP8” will never get consensus as video codec MTI. Arguing about all the other benefits of [H.264, like legacy interop,] “VP8, like the readily available single implementation with no associated license fees” is irrelevant (I think most of the people on the list agree to them anyway). For [a fairly large group of people] “quite a few people, including at least two major browser vendors” having [H.264] “VP8” as MTI video codec will translate into either ignoring this part of specification or not supporting WebRTC. [H.264] “VP8” codec support is a hard and uncircumventable implementation block. “(in both cases because of the lawyers, not the engineers)” Binary download offer helps quite a bit but does not address all the issues (like what happens if [Cisco] “Google” changes policy or disappears).
> 
>  
> 
> This being said, if [H.264] “VP8” proponents want it to be the video MTI, they should work on [changing the licensing policy,] “developing their video codec specifications within a recognized standards organization and making multiple implementations available and/or mitigating IPR risk through indemnification” not on convincing this group that [H.264] “VP8” is great. [I would even argue that if H.264 proponents convinced their own companies to change IPR policy regarding H.264, we would most likely have the unencumbered H.264 and I would be the first person argue for it to become an MIT. But, until H.264 licensing policy changes,] all the arguments for [H.264] “any MTI video codec for RTCWEB” are a waste of perfectly good electrons.
> 
>  
> 
> Matthew Kaufman
> 
>  
> 

David Singer

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Sat, 11 Jan 2014 22:56:31 +0100

* David Singer wrote:
>Yes, I think it’s clear that the advantages for the industry in general, 
>that having an RF codec would bring, have not reached everyone who has 
>the ability to influence the outcome.  Getting involved, and making a 
>good case (particularly to companies that hold relevant patent 
>portfolios, and their national bodies) would be helpful.

Can I assume that it is non-trivial to infer who in particular is in
need of convincing from easily accessibly public records? I do not re-
call anyone handing out lists.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: David Singer <[email-masked]>
Date: Sat, 11 Jan 2014 14:07:09 -0800

> call anyone handing out lists.

One place might be to look at the IPR statements on ISO/IEC 14496-29, Web Video Coding, which is the document that contains constrained baseline of H.264/AVC, of course.  Some of them are straight ‘type 1’;  some are type 2, but be careful, some wrote “but will do type 1 if all others do the same” but that statement is not reflected in the rather weak ISO database.  The ISO patent database (an excel spreadsheet, no less) is easily found by searching.  (That identifies companies; for access to MPEG documents, national body statements, and so on, you’ll need to find which organization in your country forms the national delegation to MPEG.  For the USA, that’s INCITS. This is obviously more work.)

I’m sure there are other starting points. Statements made about other efforts can also probably be found, for example.

David Singer

---

From: Roman Shpount <[email-masked]>
Date: Mon, 13 Jan 2014 17:59:55 -0500

On Sat, Jan 11, 2014 at 5:07 PM, David Singer <[email-masked]> wrote:

>
> One place might be to look at the IPR statements on ISO/IEC 14496-29, Web
> Video Coding, which is the document that contains constrained baseline of
> H.264/AVC, of course.  Some of them are straight ‘type 1’;  some are type
> 2, but be careful, some wrote “but will do type 1 if all others do the
> same” but that statement is not reflected in the rather weak ISO database.
>  The ISO patent database (an excel spreadsheet, no less) is easily found by
> searching.  (That identifies companies; for access to MPEG documents,
> national body statements, and so on, you’ll need to find which organization
> in your country forms the national delegation to MPEG.  For the USA, that’s
> INCITS. This is obviously more work.)
>
>
It is great that Apple and Cisco both are offering straight option 1
license for their IPR used in Web Video Coding, but (grumbling on) what I
cannot figure out are the positions of Alcatel-Lucent, Qualcomm, and last,
but not least, Nokia. I can see that they have IPR declarations against
ISO/IEC 14496-29, but I cannot see if they decided to commit to either
option 1 or even option 2 license. These companies are actively lobbing
H.264 as video MTI. Do they realize that their own IPR declarations
actually prevents this? (grumbling off)
_____________
Roman Shpount

---

From: David Singer <[email-masked]>
Date: Mon, 13 Jan 2014 15:13:12 -0800

On Jan 13, 2014, at 14:59 , Roman Shpount <[email-masked]> wrote:

> It is great that Apple and Cisco both are offering straight option 1 license for their IPR used in Web Video Coding, but (grumbling on) what I cannot figure out are the positions of Alcatel-Lucent, Qualcomm, and last, but not least, Nokia. I can see that they have IPR declarations against ISO/IEC 14496-29, but I cannot see if they decided to commit to either option 1 or even option 2 license. These companies are actively lobbing H.264 as video MTI. Do they realize that their own IPR declarations actually prevents this? (grumbling off)

My turn to grumble.  The ISO database is maddeningly unclear on the statements;  for example, a number show neither type 1 (RF) nor Type 2 (RAND), which implies (I am sure incorrectly), Type 3.  And the statement itself (which might list details) 

We’re trying to get more, um, clarity, here.  In the meantime, there are enough statements explicitly Type 2 to get you started, I hope.  I’m sorry, struggling with the declaration process itself was not something I needed to spend time on.

David Singer