Subject: [rtcweb] RTCWEB data channel protocol: Mandated to use?

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Jan 2014 08:28:28 +0000

Hi,

At the CLUE virtual interim yesterday, we discussed the usage of the RTCWEB data channel also for CLUE. It would allow us to re-use what RTCWEB has done, and it would provide interoperability between CLUE entities and RTCWEB.

Q1: One question that came up is whether RTCWEB MANDATES the usage of the RTCWEB data channel protocol? OR, is it possible to simply establish two SCTP streams (as defined in draft-ietf-rtcweb-data-channel-06), and start using it?

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 28 Jan 2014 16:48:42 +0100

On 01/28/2014 09:28 AM, Christer Holmberg wrote:
>
> Hi,
>
>  
>
> At the CLUE virtual interim yesterday, we discussed the usage of the
> RTCWEB data channel also for CLUE. It would allow us to re-use what
> RTCWEB has done, and it would provide interoperability between CLUE
> entities and RTCWEB.
>
>  
>
> *Q1*: One question that came up is whether RTCWEB *MANDATES* the usage
> of the RTCWEB data channel protocol? OR, is it possible to simply
> establish two SCTP streams (as defined in
> draft-ietf-rtcweb-data-channel-06), and start using it?
>

My understanding has been the latter - externally negotiated data
channels are explicitly permitted.

draft-ietf-rtcweb-data-channel-06 section 6.5:

6.5.  Opening a Channel

   Data channels can be opened by using internal or external
   negotiation.  The details are out of scope of this document.

   A simple protocol for internal negotiation is specified in
   [I-D.ietf-rtcweb-data-protocol] and MUST be supported.

"MUST be supported" is not the same as "MUST be used".

>  
>
> Regards,
>
>  
>
> Christer
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

-- 
Surveillance is pervasive. Go Dark.

---

From: Peter Thatcher <[email-masked]>
Date: Tue, 28 Jan 2014 13:39:01 -0800

Harald is correct.  If you use set "negotiated: true" in
.createDataChannel, then the OPEN message won't be sent.  The JS can
also specify the SID in .createDataChannel, allowing you to use
whatever form of signalling you want with no in-band signalling.

On Tue, Jan 28, 2014 at 7:48 AM, Harald Alvestrand <[email-masked]> wrote:
> At the CLUE virtual interim yesterday, we discussed the usage of the RTCWEB
> data channel also for CLUE. It would allow us to re-use what RTCWEB has
> done, and it would provide interoperability between CLUE entities and
> RTCWEB.
>
>
>
> Q1: One question that came up is whether RTCWEB MANDATES the usage of the
> RTCWEB data channel protocol? OR, is it possible to simply establish two
> SCTP streams (as defined in draft-ietf-rtcweb-data-channel-06), and start
> using it?
>
>
> My understanding has been the latter - externally negotiated data channels
> are explicitly permitted.
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 29 Jan 2014 10:18:48 +0000

Thanks for the clarification, Harald & Peter!

Regards,

Christer

-----Original Message-----
From: rtcweb [mailto:[email-masked]] On Behalf Of Peter Thatcher
Sent: 28. tammikuuta 2014 23:39
To: Harald Alvestrand
Cc: <[email-masked]>
Subject: Re: [rtcweb] RTCWEB data channel protocol: Mandated to use?

Harald is correct.  If you use set "negotiated: true" in .createDataChannel, then the OPEN message won't be sent.  The JS can also specify the SID in .createDataChannel, allowing you to use whatever form of signalling you want with no in-band signalling.

On Tue, Jan 28, 2014 at 7:48 AM, Harald Alvestrand <[email-masked]> wrote:
> Q1: One question that came up is whether RTCWEB MANDATES the usage of 
> the RTCWEB data channel protocol? OR, is it possible to simply