Subject: Re: [rtcweb] Straw Poll on Video Codec Alternatives (David Benham)

From: "David Benham (dbenham)" <[email-masked]>
Date: Fri, 10 Jan 2014 15:57:20 +0000

1.    All entities MUST support H.264
Are you in favor of this option [Yes/No/Acceptable]: YES.

2.    All entities MUST support VP8
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  Does not leverage installed base for direct media interoperability and has much less certainty around patent exposure.

3.    All entities MUST support both H.264 and VP8
Are you in favor of this option [Yes/No/Acceptable]: Acceptable.
Do you have any objections to this option, if so please summarize them: Media interoperability would be assured, making it acceptable, but adds the risks/cons of both choices for little or no extra performance or installed base interoperability upside vs H.264 alone.  

4.    Browsers MUST support both H.264 and VP8, other entities MUST support at least one of H.264 and VP8
Are you in favor of this option [Yes/No/Acceptable]: Acceptable.
Do you have any objections to this option, if so please summarize them:  Media interoperability should be assured, making it acceptable, but adds the risks/cons of both choices for little or no extra performance or installed base interoperability upside and leaves the door open to future, non-browser entities to make a non-interoperability choice between them.

5.    All entities MUST support at least one of H.264 and VP8
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them: Half a chance entities will have the same codec is not a strategy for assured interoperability.

6.    All entities MUST support H.261
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them: WebRTC needs to deliver high quality Video well beyond H.261.

7.   There is no MTI video codec
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them: Interoperability not assured. 

8.    All entities MUST support H.261 and all entities MUST support at least one of H.264 and VP8
Are you in favor of this option [Yes/No/Acceptable]:  NO.
Do you have any objections to this option, if so please summarize them:  H.261 is not high enough quality and this adds the risks/cons of each choice for little or no upside.

9.    All entities MUST support Theora
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  Does not leverage installed base for direct media interoperability.

10.    All entities MUST implement at least two of {VP8, H.264, H.261}
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  H.261 is not high enough quality and this adds the risks/cons of each choice for little or no upside.

11.    All entities MUST implement at least two of {VP8, H.264, H.263} 
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  H.263 is still below desired quality and this adds the risks/cons of each choice for little or no upside.

12.    All entities MUST support decoding using both H.264 and VP8, and MUST support encoding using at least one of H.264 or VP8
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  This adds the risks/cons of both choices for little or no upside vs H.264 alone.

13.    All entities MUST support H.263
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  H.263 is still below desired quality.

14.    All entities MUST implement at least two of {VP8, H.264, Theora}
Are you in favor of this option [Yes/No/Acceptable]:  NO.
Do you have any objections to this option, if so please summarize them:  Adds the risks/cons of each choice for little or no upside vs H.264 alone.

15.    All entities MUST support decoding using Theora. 
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  Does not leverage installed base for direct media interoperability. 

16.    All entities MUST support Motion JPEG
Are you in favor of this option [Yes/No/Acceptable]: NO.
Do you have any objections to this option, if so please summarize them:  Below high quality needed.

---

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 10 Jan 2014 16:33:59 +0000

Like some people answering earlier, I have chosen Steve McFarlin's weights to indicate where in the interval between "Yes" (1.0) and "No" (0.0) an "Acceptable" response would be located.

1) All entities MUST support H.264
a. Are you in favor of this option [Yes/No/Acceptable]: Yes
b. Do you have any objections to this option, if so please summarize them:

2) All entities MUST support VP8
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: VP8 has not been developed in a collaborative process by an SDO, but is owned and controlled by one company. VP8 does not interoperate with most existing equipment and systems, requiring transcoding. 

3) All entities MUST support both H.264 and VP8
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: The additional support of VP8 adds complexity, but does not provide additional technical value compared to H.264, which is widely available in mobile terminals and fixed-line services alike. Additionally, same concerns as with (2).

4) Browsers MUST support both H.264 and VP8, other entities MUST support at least one of H.264 and VP8
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: Distinguishing between browsers and non-browsers may be difficult. Also, this does not achieve interoperability between "non-browsers". For "browsers", same concerns as with (3).

5) All entities MUST support at least one of H.264 and VP8
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: This is what the implementations in the market do anyway, so putting this into specs does not change the current situation. 

6) All entities MUST support H.261
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: H.261 provides inferior quality. It cannot compete with existing video communication solutions. The codec is not supported in current systems, requiring transcoding when interworking with these systems.

7) There is no MTI video codec
a. Are you in favor of this option [Yes/No/Acceptable]: Acceptable (0.5)
b. Do you have any objections to this option, if so please summarize them: Note: Given the fact that there are such strong positions, this corresponds to relying on the market to decide this. 

8) All entities MUST support H.261 and all entities MUST support at least one of H.264 and VP8
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: This means at least a part of the users have to cope with the drawbacks of H.261 - see (6). Additionally, same concerns as with (2).

9) All entities MUST support Theora
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: Unclear licensing situation

10) All entities MUST implement at least two of {VP8, H.264, H.261}
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: This means at least a part of the users have to cope with the drawbacks of H.261 - see (6). Additionally, same concerns as with (2).

11) All entities MUST implement at least two of {VP8, H.264, H.263}
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: Same concerns as with (2).

12) All entities MUST support decoding using both H.264 and VP8, and MUST support encoding using at least one of H.264 or VP8
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: Same concerns as with (2).

13) All entities MUST support H.263
a. Are you in favor of this option [Yes/No/Acceptable]: Acceptable (0.25)
b. Do you have any objections to this option, if so please summarize them: Note: H.263 is an outdated codec, and has recently been removed by 3GPP from their IMS specification. The quality it can provide is however better than that achieved by H.261. So, even though we do not favour this option, as this codec has just been taken out of service in the mobile ecosystem, we believe it may be a viable fallback, complemented by higher quality codec(s) as decided by the market. 

14) All entities MUST implement at least two of {VP8, H.264, Theora}
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: Same concerns as with (2) and (9)

15) All entities MUST support decoding using Theora.
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: This option will not provide interoperability. Additionally, same concerns as with (9).

16) All entities MUST support Motion JPEG
a. Are you in favor of this option [Yes/No/Acceptable]: No
b. Do you have any objections to this option, if so please summarize them: Purely based on intra-frame coding, the quality delivered by Motion JPEG is even worse than that of H.261 at the same bitrate. 

H.264 is a reference to the proposal in https://datatracker.ietf.org/doc/draft-burman-rtcweb-h264-proposal/

VP8 is a reference to the proposal in https://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-vp8/

Theora is a reference to Xiph.org Theora Specification from March 16, 2011 (http://www.xiph.org/theora/doc/Theora_I_spec.pdf) 

H.263 is a reference to profile 0 level 70 defined in annex X of ITU-T rec H.263 (http://www.itu.int/rec/T-REC-H.263/)

H.261 is a reference to http://tools.ietf.org/html/rfc4587 

Motion JPEG is a reference to http://tools.ietf.org/html/rfc2435 

Thanks,

The Chairs