Subject: [rtcweb] RTCWEB data channel protocol: Do both endpoints need to send DATA_CHANNEL_OPEN?

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Jan 2014 08:16:22 +0000

Hi,

As defined in draft-ietf-rtcweb-data-channel-06, a data channel consists of two unidirectional SCTP streams.

draft-ietf-rtcweb-data-protocol-01 says that, if one endpoint wants to open a data channel, it sends a DATA_CHANNEL_OPEN (using a SCTP stream ID value of its choice). Then, the other endpoints sends DATA_CHANNEL_ACK on the same SCTP stream (eventhough it is a unidirectional stream).

Q1: Assuming that both endpoints want to use the data channel, do both endpoints need to send DATA_CHANNEL_OPEN (on separate SCTP streams)? Or, can one of the endpoints, if it has received DCO, start using the data channel (using a SCTP stream of its choice)?

Regards,

Christer

---

From: Salvatore Loreto <[email-masked]>
Date: Tue, 28 Jan 2014 08:30:46 +0000

On Jan 28, 2014, at 10:16 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>>
 wrote:

Hi,

exactly it is a pair of one ingoing and one outgoing stream

not exactly, it says with the same stream identifier

   If a DATA_CHANNEL_OPEN message is received on an unused stream, the
   stream identifier corresponds to the role of the peer and all
   parameters in the DATA_CHANNEL_OPEN message are valid, then a
   corresponding DATA_CHANNEL_ACK message is sent on the stream with the
   same stream identifier as the one the DATA_CHANNEL_OPEN message was
   received on.

that means that means that the outgoing stream should have the same stream identifier of the ingoing one.
I understand is not clear at first read, we will try to clarify better

sorry I don't understand the question.
Are you asking for both endpoints trying to open the same channel and how avoid glare in opening channels
or you are looking in the scenario where both endpoints want to open to different channels?

br
Salvatore

Regards,

Christer

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 28 Jan 2014 08:37:40 +0000

Hi Sal,
 
>> draft-ietf-rtcweb-data-protocol-01 says that, if one endpoint wants to open a data channel, it sends a 
>> DATA_CHANNEL_OPEN (using a SCTP stream ID value of its choice). Then, the other endpoints sends 
>> DATA_CHANNEL_ACK on the same SCTP stream (eventhough it is a unidirectional stream).
>>

Thanks.

I also think it would be good to add some call flows to the draft.

>> Q1: Assuming that both endpoints want to use the data channel, do both endpoints need to send DATA_CHANNEL_OPEN 
>> (on separate SCTP streams)? Or, can one of the endpoints, if it has received DCO, start using the data channel (using a SCTP stream of its choice)?
>

I am not talking about a glare situation.

I am talking about where an endpoint has received a DCO, and replied with a DCA. Then, that endpoint also wants to use the data channel. Does it also have to send a DCO? I assume not, but I think it would be good to make that more clear.

Regards,

Christer

---

From: Salvatore Loreto <[email-masked]>
Date: Tue, 28 Jan 2014 08:46:20 +0000

On Jan 28, 2014, at 10:37 AM, Christer Holmberg <[email-masked]>
 wrote:

> I am talking about where an endpoint has received a DCO, and replied with a DCA. Then, that endpoint also wants to use the data channel.

well a DataChannel is bidirectional then it can be used to send data from both the sides once it is open.

> Does it also have to send a DCO? I assume not, but I think it would be good to make that more clear.

you are right, it has not to do.
OK point taken, we will clarify this point also.

br
Salvatore

---

From: "Chenxin (Xin)" <[email-masked]>
Date: Tue, 28 Jan 2014 09:06:27 +0000

Hi Salvatore
>>>> (on separate SCTP streams)? Or, can one of the endpoints, if it has received
>DCO, start using the data channel (using a SCTP stream of its choice)?
>>>
>> I am talking about where an endpoint has received a DCO, and replied with a
>DCA. Then, that endpoint also wants to use the data channel.
>
Do you means when has the DC been negotiated by out-band way?

Best Reagrds,
   Xin
>[email-masked]