Subject: [rtcweb] Straw Poll on Video Codec Alternatives (Jeremy Fuller)

From: Jeremy Fuller <[email-masked]>
Date: Fri, 10 Jan 2014 16:52:37 +0000

Hi,

Here is my input:

1.    All entities MUST support H.264

      a.    Are you in favor of this option [Yes/No/Acceptable]: Yes

      [The significant volume of existing deployments of H.264 will provide early benefit if this is selected as the mandatory to implement video codec]

      b.    Do you have any objections to this option, if so please summarize them:

2.    All entities MUST support VP8

      a.   Are you in favor of this option [Yes/No/Acceptable]: ---

      b.    Do you have any objections to this option, if so please summarize them:

3.    All entities MUST support both H.264 and VP8

      a.      Are you in favor of this option [Yes/No/Acceptable]: Yes

      b.    Do you have any objections to this option, if so please summarize them:

4.    Browsers MUST support both H.264 and VP8, other entities MUST support at least one of H.264 and VP8

      a.      Are you in favor of this option [Yes/No/Acceptable]: Acceptable

      b.    Do you have any objections to this option, if so please summarize them:

5.    All entities MUST support at least one of H.264 and VP8

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Offers little in terms of guaranteed interoperability

6.    All entities MUST support H.261

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Concerns over performance and existing market support.

7.    There is no MTI video codec

      a.      Are you in favor of this option [Yes/No/Acceptable]: Yes
      [Not ideal, but if we cannot reach a consensus let us allow the market to decide and move on]

      b.    Do you have any objections to this option, if so please summarize them:

8.    All entities MUST support H.261 and all entities MUST support at least one of H.264 and VP8

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Unclear of the value of this over option 6.

9.    All entities MUST support Theora

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Concerns over performance and existing market support.

10.  All entities MUST implement at least two of {VP8, H.264, H.261}

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Increases costs while not allowing for optimised handling of a "lowest common denominator"

11.  All entities MUST implement at least two of {VP8, H.264, H.263}

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Increases costs while not allowing for optimised handling of a "lowest common denominator"

12.  All entities MUST support decoding using both H.264 and VP8, and MUST support encoding using at least one of H.264 or VP8

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Increases costs while not allowing for optimised handling of a "lowest common denominator"

13.  All entities MUST support H.263

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Concerns over performance and existing market support.

14.  All entities MUST implement at least two of {VP8, H.264, Theora}

      b.      Are you in favor of this option [Yes/No/Acceptable]: No

      a.    Do you have any objections to this option, if so please summarize them:
      Increases costs while not allowing for optimised handling of a "lowest common denominator"

15.  All entities MUST support decoding using Theora.

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Concerns over performance and existing market support.

16.  All entities MUST support Motion JPEG

      a.      Are you in favor of this option [Yes/No/Acceptable]: No

      b.    Do you have any objections to this option, if so please summarize them:
      Concerns over performance and existing market support.

Regards,
Jeremy Fuller
GENBAND

---

From: Justin Uberti <[email-masked]>
Date: Fri, 10 Jan 2014 08:56:24 -0800

How should one interpret the "---" answer to #2?

On Fri, Jan 10, 2014 at 8:52 AM, Jeremy Fuller <[email-masked]>wrote:

> a.    Are you in favor of this option [Yes/No/Acceptable]: *Yes*
>
> [The significant volume of existing deployments of H.264 will provide
> early benefit if this is selected as the mandatory to implement video codec]
>
> a.   Are you in favor of this option [Yes/No/Acceptable]: *---*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *Yes*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *Acceptable*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *Yes*
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> Increases costs while not allowing for optimised handling of a “lowest
> common denominator”
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> Increases costs while not allowing for optimised handling of a “lowest
> common denominator”
>
> 12.  All entities MUST support decoding using both H.264 and VP8, and MUST
> support encoding using at least one of H.264 or VP8
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> Increases costs while not allowing for optimised handling of a “lowest
> common denominator”
>
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> b.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> Increases costs while not allowing for optimised handling of a “lowest
> common denominator”
>
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> a.      Are you in favor of this option [Yes/No/Acceptable]: *No*
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: Jeremy Fuller <[email-masked]>
Date: Fri, 10 Jan 2014 17:15:26 +0000

Hi Justin,

Apologies if I followed the wrong convention, --- means I make no comment against this question. Using this marking was an attempt to indicate there was deliberate absence of information, rather than I accidently missed out answering the question.

Regards,
Jeremy

From: Justin Uberti [mailto:[email-masked]]
Sent: 10 January 2014 16:56
To: Jeremy Fuller
Cc: [email-masked]
Subject: Re: [rtcweb] Straw Poll on Video Codec Alternatives (Jeremy Fuller)

On Fri, Jan 10, 2014 at 8:52 AM, Jeremy Fuller <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Here is my input:

b.    Do you have any objections to this option, if so please summarize them:
Increases costs while not allowing for optimised handling of a “lowest common denominator”

b.    Do you have any objections to this option, if so please summarize them:
Increases costs while not allowing for optimised handling of a “lowest common denominator”

b.    Do you have any objections to this option, if so please summarize them:
Increases costs while not allowing for optimised handling of a “lowest common denominator”

a.    Do you have any objections to this option, if so please summarize them:
Increases costs while not allowing for optimised handling of a “lowest common denominator”

Regards,
Jeremy Fuller
GENBAND

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Andrew Allen <[email-masked]>
Date: Fri, 10 Jan 2014 17:17:11 +0000

Jeremy

I take it that means you abstained on proposal 2

Andrew

From: rtcweb [mailto:[email-masked]] On Behalf Of Jeremy Fuller
Sent: Friday, January 10, 2014 12:15 PM
To: Justin Uberti
Cc: [email-masked]
Subject: Re: [rtcweb] Straw Poll on Video Codec Alternatives (Jeremy Fuller)

Hi Justin,

Regards,
Jeremy

From: Justin Uberti [mailto:[email-masked]]
Sent: 10 January 2014 16:56
To: Jeremy Fuller
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] Straw Poll on Video Codec Alternatives (Jeremy Fuller)

Here is my input:

Regards,
Jeremy Fuller
GENBAND

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Jeremy Fuller <[email-masked]>
Date: Fri, 10 Jan 2014 17:18:48 +0000

Yes

From: Andrew Allen [mailto:[email-masked]]
Sent: 10 January 2014 17:17
To: Jeremy Fuller; Justin Uberti
Cc: [email-masked]
Subject: RE: [rtcweb] Straw Poll on Video Codec Alternatives (Jeremy Fuller)

Jeremy

Andrew

Hi Justin,

Regards,
Jeremy

Here is my input:

Regards,
Jeremy Fuller
GENBAND

---

From: "Hutton, Andrew" <[email-masked]>
Date: Fri, 10 Jan 2014 17:34:53 +0000

Are you in favor of this option [Yes/No/Acceptable]:  Yes
Do you have any objections to this option, if so please summarize them:  No Objections

Are you in favor of this option [Yes/No/Acceptable]:  Acceptable
Do you have any objections to this option, if so please summarize them: The fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that it may be too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer.

Are you in favor of this option [Yes/No/Acceptable]:  Acceptable
Do you have any objections to this option, if so please summarize them:  The fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that may be too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer.

Are you in favor of this option [Yes/No/Acceptable]:  No
Do you have any objections to this option, if so please summarize them:  The fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that it may be too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer. There is no mandate/requirements to create separate specifications for different entities.

Are you in favor of this option [Yes/No/Acceptable]: No
Do you have any objections to this option, if so please summarize them: Does not guarantee interoperability.

 Are you in favor of this option [Yes/No/Acceptable]: No
Do you have any objections to this option, if so please summarize them:  Inferior quality and no current implementations in browsers.

Are you in favor of this option [Yes/No/Acceptable]:  Acceptable
Do you have any objections to this option, if so please summarize them:  No

 Are you in favor of this option [Yes/No/Acceptable]: No
Do you have any objections to this option, if so please summarize them: Inferior quality and no current H.261 webrtc implementations. The fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that it is too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer.

Are you in favor of this option [Yes/No/Acceptable]:  No
Do you have any objections to this option, if so please summarize them: No current Theora webrtc implementations and unclear license situation.

Are you in favor of this option [Yes/No/Acceptable]:No
Do you have any objections to this option, if so please summarize them: Inferior quality and no current H.261 webrtc implementations. The fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that it is too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer.

Are you in favor of this option [Yes/No/Acceptable]: No
Do you have any objections to this option, if so please summarize them:Inferior quality and no current H.263 webrtc implementations. The fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that it is too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer.

Are you in favor of this option [Yes/No/Acceptable]: Acceptable
Do you have any objections to this option, if so please summarize them: The fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that it is too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer.

Are you in favor of this option [Yes/No/Acceptable]:No
Do you have any objections to this option, if so please summarize them: Inferior quality and no current H.263 webrtc implementations.
14. All entities MUST implement at least two of {VP8, H.264, Theora}

Are you in favor of this option [Yes/No/Acceptable]: Acceptable.
Do you have any objections to this option, if so please summarize them: Unclear license situation and no current webrtc implementations regarding Theora and the fact that there is a known IPR declaration against VP8 which states the owner is unwilling to license is of course a concern indicating that it is too early to make a decision on making VP8 MTI. I would prefer to wait until the situation is clearer

Are you in favor of this option [Yes/No/Acceptable]:No
Do you have any objections to this option, if so please summarize them: Unclear license situation and no current webrtc implementations.

Are you in favor of this option [Yes/No/Acceptable]:No
Do you have any objections to this option, if so please summarize them: Inferior quality and no current webrtc implementations.

Regards
Andy

---

From: Justin Uberti <[email-masked]>
Date: Fri, 10 Jan 2014 10:53:06 -0800

OK, thanks. Wasn't sure if it was intentional or not.

On Fri, Jan 10, 2014 at 9:15 AM, Jeremy Fuller <[email-masked]>wrote:

>  Hi Justin,
>
>
>
> Apologies if I followed the wrong convention, --- means I make no comment
> against this question. Using this marking was an attempt to indicate there
> was deliberate absence of information, rather than I accidently missed out
> answering the question.
>
>
>
> Regards,
> Jeremy
>
>
>
> *From:* Justin Uberti [mailto:[email-masked]]
> *Sent:* 10 January 2014 16:56
> *To:* Jeremy Fuller
> *Cc:* [email-masked]
> *Subject:* Re: [rtcweb] Straw Poll on Video Codec Alternatives (Jeremy
> Fuller)
>
>
>