Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-stun-consent-freshness-00.txt

From: [email-masked]
Date: Fri, 20 Sep 2013 00:33:31 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.

	Title           : STUN Usage for Consent Freshness
	Author(s)       : Muthu Arul Mozhi Perumal
                          Dan Wing
                          Ram Mohan Ravindranath
                          Tirumaleswar Reddy
	Filename        : draft-ietf-rtcweb-stun-consent-freshness-00.txt
	Pages           : 7
	Date            : 2013-09-19

Abstract:
   Verification of peer consent before sending traffic is necessary in
   WebRTC deployments to ensure that a malicious JavaScript cannot use
   the browser as a platform for launching attacks.  A related problem
   is session liveness.  WebRTC application may want to detect
   connection failure and take appropriate action.

   This document describes how a WebRTC browser can verify peer consent
   to continue sending traffic and detect connection failure.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtcweb-stun-consent-freshness

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-rtcweb-stun-consent-freshness-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 Sep 2013 07:51:37 +0000

Hi,

The draft doesn't mention the case when one entity (e.g. a gateway) is ICE lite. Eventhough ICE already specifies that an ICE lite entity does not send STUN requests, I think it would be good to cover it also for consent refreshness.

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 20. syyskuuta 2013 10:34
To: [email-masked]
Cc: [email-masked]
Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-stun-consent-freshness-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Fri, 20 Sep 2013 08:24:23 +0000

Sure, noted.

This was a resubmit of the -04 individual draft as a WG draft, with minor changes. We'll cover the ICE-lite scenario in the next revision..

Muthu

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
|Sent: Friday, September 20, 2013 1:22 PM
|To: [email-masked]
|Subject: Re: [rtcweb] I-D Action: draft-ietf-rtcweb-stun-consent-freshness-00.txt
|
|Hi,
|
|The draft doesn't mention the case when one entity (e.g. a gateway) is ICE lite. Eventhough ICE
|already specifies that an ICE lite entity does not send STUN requests, I think it would be good to
|cover it also for consent refreshness.
|
|Regards,
|
|Christer
|
|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
|Sent: 20. syyskuuta 2013 10:34
|To: [email-masked]
|Cc: [email-masked]
|Subject: [rtcweb] I-D Action: draft-ietf-rtcweb-stun-consent-freshness-00.txt
|
|
|A New Internet-Draft is available from the on-line Internet-Drafts directories.
| This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.
|
|	Title           : STUN Usage for Consent Freshness
|	Author(s)       : Muthu Arul Mozhi Perumal
|                          Dan Wing
|                          Ram Mohan Ravindranath
|                          Tirumaleswar Reddy
|	Filename        : draft-ietf-rtcweb-stun-consent-freshness-00.txt
|	Pages           : 7
|	Date            : 2013-09-19
|
|Abstract:
|   Verification of peer consent before sending traffic is necessary in
|   WebRTC deployments to ensure that a malicious JavaScript cannot use
|   the browser as a platform for launching attacks.  A related problem
|   is session liveness.  WebRTC application may want to detect
|   connection failure and take appropriate action.
|
|   This document describes how a WebRTC browser can verify peer consent
|   to continue sending traffic and detect connection failure.
|
|
|The IETF datatracker status page for this draft is:
|https://datatracker.ietf.org/doc/draft-ietf-rtcweb-stun-consent-freshness
|
|There's also a htmlized version available at:
|http://tools.ietf.org/html/draft-ietf-rtcweb-stun-consent-freshness-00
|
|
|Please note that it may take a couple of minutes from the time of submission until the htmlized
|version and diff are available at tools.ietf.org.
|
|Internet-Drafts are also available by anonymous FTP at:
|ftp://ftp.ietf.org/internet-drafts/
|
|_______________________________________________
|rtcweb mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/rtcweb
|_______________________________________________
|rtcweb mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 Sep 2013 08:31:01 +0000

Thanks!

-----Original Message-----
From: Muthu Arul Mozhi Perumal (mperumal) [mailto:[email-masked]] 
Sent: 20. syyskuuta 2013 11:24
To: Christer Holmberg; [email-masked]
Subject: RE: [rtcweb] I-D Action: draft-ietf-rtcweb-stun-consent-freshness-00.txt

Sure, noted.

Muthu

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On 
|Behalf Of Christer Holmberg
|Sent: Friday, September 20, 2013 1:22 PM
|To: [email-masked]
|Subject: Re: [rtcweb] I-D Action: 
|draft-ietf-rtcweb-stun-consent-freshness-00.txt
|
|Hi,
|
|The draft doesn't mention the case when one entity (e.g. a gateway) is 
|ICE lite. Eventhough ICE already specifies that an ICE lite entity does 
|not send STUN requests, I think it would be good to cover it also for consent refreshness.
|
|Regards,
|
|Christer
|
|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On 
|Behalf Of [email-masked]
|Sent: 20. syyskuuta 2013 10:34
|To: [email-masked]
|Cc: [email-masked]
|Subject: [rtcweb] I-D Action: 
|draft-ietf-rtcweb-stun-consent-freshness-00.txt
|
|
|A New Internet-Draft is available from the on-line Internet-Drafts directories.
| This draft is a work item of the Real-Time Communication in WEB-browsers Working Group of the IETF.
|
|	Title           : STUN Usage for Consent Freshness
|	Author(s)       : Muthu Arul Mozhi Perumal
|                          Dan Wing
|                          Ram Mohan Ravindranath
|                          Tirumaleswar Reddy
|	Filename        : draft-ietf-rtcweb-stun-consent-freshness-00.txt
|	Pages           : 7
|	Date            : 2013-09-19
|
|Abstract:
|   Verification of peer consent before sending traffic is necessary in
|   WebRTC deployments to ensure that a malicious JavaScript cannot use
|   the browser as a platform for launching attacks.  A related problem
|   is session liveness.  WebRTC application may want to detect
|   connection failure and take appropriate action.
|
|   This document describes how a WebRTC browser can verify peer consent
|   to continue sending traffic and detect connection failure.
|
|
|The IETF datatracker status page for this draft is:
|https://datatracker.ietf.org/doc/draft-ietf-rtcweb-stun-consent-freshne
|ss
|
|There's also a htmlized version available at:
|http://tools.ietf.org/html/draft-ietf-rtcweb-stun-consent-freshness-00
|
|
|Please note that it may take a couple of minutes from the time of 
|submission until the htmlized version and diff are available at tools.ietf.org.
|
|Internet-Drafts are also available by anonymous FTP at:
|ftp://ftp.ietf.org/internet-drafts/
|
|_______________________________________________
|rtcweb mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/rtcweb
|_______________________________________________
|rtcweb mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/rtcweb