Subject: [rtcweb] No a=ice-lite in JSEP-04

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Mon, 30 Sep 2013 15:28:18 +0000

Hi Justin, Cullen,

JSEP-04 prohibits the use of a=ice-lite. It is stated that it is incompatible with I-D.ietf-rtcweb-rtp-usage.
Can you point out which specific aspect of this draft ICE Lite is incompatible with?

In deployments where one endpoint is a browser and another one is a gateway connected to the public Internet, it makes sense to allow ICE lite.

Kind regards,
Uwe

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 30 Sep 2013 17:32:43 +0200

> In deployments where one endpoint is a browser and another one is a gateway connected to the public Internet, it makes sense to allow ICE lite.

Without reading JSEP-04 I expect that it is not allowed for a web
browser to indicate "a=ice-lite", but a server can do that. Anyhow,
AFAIR the usage of ICE lite is fully transparent for the non ICE lite
endpoint.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Justin Uberti <[email-masked]>
Date: Mon, 30 Sep 2013 15:30:08 -0700

Yes. In the offers and answers that WebRTC endpoints create, a=ice-lite is
prohibited, since WebRTC endpoints must support "Full" ICE.

The remote endpoint may of course support only ICE Lite, and WebRTC
implementations must work properly with such endpoints.

This isn't normatively indicated anywhere that I could find, so I plan to
add specifics on this to the next version of JSEP.

On Mon, Sep 30, 2013 at 8:32 AM, Iñaki Baz Castillo <[email-masked]> wrote:

> > JSEP-04 prohibits the use of a=ice-lite. It is stated that it is
> incompatible with I-D.ietf-rtcweb-rtp-usage.
> > In deployments where one endpoint is a browser and another one is a
> gateway connected to the public Internet, it makes sense to allow ICE lite.
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>