Subject: [rtcweb] m=section recycling and a=mid

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 18 Sep 2013 09:44:04 -0700

After thinking about it a bit, I think there are some side effects
associated with changing/not changing mid attribute of a re-cycled m=
section and it being part of a BUNDLE group or not..

example

say , we have these video m=section part of BUNDLE group as below
a=group:BUNDLE 1, 2

m=video .....
a=mid:1
a=inactive

m=video .....
a=mid:2
a=sendrecv

Now If JS user adds a new video track and he wants it to be out of BUNDLE.
If we recycle first video m=section and dont change mid attribute,  we end
up BUNDLing even if the user dint want to

On the other hand, if we allowed mid value to be changed, we might end up
UNBundling a video stream , when the user did want to BUNDLE them

So allowing a mid value to be changed or not should be tied to what the JS
API is asking on behalf of the user

Any thoughts ?

Cheers
Suhas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 19 Sep 2013 16:24:49 +0000

Hi Suhas,

The mid attribute itself does not add an m- line to a BUNDLE group. The attribute value also needs to be listed in the group:BUNDLE attribute mid list.

So, if you want to re-use an m- line and mid attribute, but you don't want the m- line to be in the BUNDLE group, simply remove the mid from the mid list.

Regards,

Christer

________________________________
From: [email-masked] [[email-masked]] on behalf of Suhas Nandakumar [[email-masked]]
Sent: Wednesday, 18 September 2013 7:44 PM
To: [email-masked]
Subject: [rtcweb] m=section recycling and a=mid

After thinking about it a bit, I think there are some side effects associated with changing/not changing mid attribute of a re-cycled m= section and it being part of a BUNDLE group or not..

example

m=video .....
a=mid:1
a=inactive

m=video .....
a=mid:2
a=sendrecv

Now If JS user adds a new video track and he wants it to be out of BUNDLE. If we recycle first video m=section and dont change mid attribute,  we end up BUNDLing even if the user dint want to

On the other hand, if we allowed mid value to be changed, we might end up UNBundling a video stream , when the user did want to BUNDLE them

So allowing a mid value to be changed or not should be tied to what the JS API is asking on behalf of the user

Any thoughts ?

Cheers
Suhas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 19 Sep 2013 16:35:51 +0000

Hi,

Below is some suggested BUNDLE text:

6.4.5.  Moving A Media Description Out Of A BUNDLE Group

   When an Offerer generates an Offer, in which an "m=" line is moved
   out of a BUNDLE group, the Offerer MUST assign a unique address to
   the moved "m=" line.  In addition, the Offerer MUST NOT anymore
   include a mid value, representing the "m=" line, in the SDP
   group:BUNDLE attribute mid list associated with the BUNDLE group.

   Section 11.4 shows an example of an Offer used to move an "m=" line
   out of a BUNDLE group.

Regards,

Christer

________________________________
From: [email-masked] [[email-masked]] on behalf of Christer Holmberg [[email-masked]]
Sent: Thursday, 19 September 2013 7:24 PM
To: Suhas Nandakumar; [email-masked]
Subject: Re: [rtcweb] m=section recycling and a=mid

Hi Suhas,

Regards,

Christer

example

m=video .....
a=mid:1
a=inactive

m=video .....
a=mid:2
a=sendrecv

Any thoughts ?

Cheers
Suhas

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 19 Sep 2013 11:48:05 -0700

Hello Christer

  Completely agree with you

My point with the above examples was

  "recycling of m=line should take into account its existing BUNDLE
membership and JS user's preference on requiring the added media track to
be BUNDLED or not"

This would imply, as suggested by you,

  - remove the mid from a=group:BUNDLE line if the JS user doesn't want the
new track to be BUNDLEd

 - or if the mid value is changed, then add the new mid value to the BUNDLE
group if the JS user want's the new track to be BUNDLED

- or just retain the mid value and its BUNDLE membership for the new track,
if it is going to be BUNDLEd

Cheers
Suhas

On Thu, Sep 19, 2013 at 9:24 AM, Christer Holmberg <
[email-masked]> wrote:

>  Hi Suhas,
>
>
>
> The mid attribute itself does not add an m- line to a BUNDLE group. The
> attribute value also needs to be listed in the group:BUNDLE attribute mid
> list.
>
>
>
> So, if you want to re-use an m- line and mid attribute, but you don't want
> the m- line to be in the BUNDLE group, simply remove the mid from the mid
> list.
>
>
>
> Regards,
>
>
>
> Christer
>
>
>  ------------------------------
> *From:* [email-masked] [[email-masked]] on behalf of
> Suhas Nandakumar [[email-masked]]
> *Sent:* Wednesday, 18 September 2013 7:44 PM
> *To:* [email-masked]
> *Subject:* [rtcweb] m=section recycling and a=mid
>
>  Now If JS user adds a new video track and he wants it to be out of
> BUNDLE. If we recycle first video m=section and dont change mid attribute,
>  we end up BUNDLing even if the user dint want to
>
>  On the other hand, if we allowed mid value to be changed, we might end
> up UNBundling a video stream , when the user did want to BUNDLE them
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 19 Sep 2013 18:52:14 +0000

Correct.

Regards,

Christer

________________________________
From: Suhas Nandakumar [[email-masked]]
Sent: Thursday, 19 September 2013 9:48 PM
To: Christer Holmberg
Cc: [email-masked]
Subject: Re: [rtcweb] m=section recycling and a=mid

Hello Christer

  "recycling of m=line should take into account its existing BUNDLE membership and JS user's preference on requiring the added media track to be BUNDLED or not"

  - remove the mid from a=group:BUNDLE line if the JS user doesn't want the new track to be BUNDLEd

 - or if the mid value is changed, then add the new mid value to the BUNDLE group if the JS user want's the new track to be BUNDLED

- or just retain the mid value and its BUNDLE membership for the new track, if it is going to be BUNDLEd

Cheers
Suhas

On Thu, Sep 19, 2013 at 9:24 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi Suhas,

Regards,

Christer

________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] on behalf of Suhas Nandakumar [[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, 18 September 2013 7:44 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [rtcweb] m=section recycling and a=mid

example

m=video .....
a=mid:1
a=inactive

m=video .....
a=mid:2
a=sendrecv

Any thoughts ?

Cheers
Suhas

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 20 Sep 2013 00:23:56 +0200

I suggest that changing the MID value can be very painful, since it 
modifies the mapping between m-line index and MID.

Is there any other spec that describes changing the MID value?

If not, I'd suggest that we explicitly forbid changing the MID value. If 
we want to add or remove an M-line from a bundle, we should update the 
bundles instead.

On 09/19/2013 08:52 PM, Christer Holmberg wrote:
>
> Correct.
>
> Regards,
>
> Christer
>
> ------------------------------------------------------------------------
> *From:* Suhas Nandakumar [[email-masked]]
> *Sent:* Thursday, 19 September 2013 9:48 PM
> *To:* Christer Holmberg
> *Cc:* [email-masked]
> *Subject:* Re: [rtcweb] m=section recycling and a=mid
>
> Hello Christer
>
> membership and JS user's preference on requiring the added media track 
> to be BUNDLED or not"
>
>  - or if the mid value is changed, then add the new mid value to the 
> BUNDLE group if the JS user want's the new track to be BUNDLED
>
> On Thu, Sep 19, 2013 at 9:24 AM, Christer Holmberg 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Suhas,
>
>     The mid attribute itself does not add an m- line to a BUNDLE
>     group. The attribute value also needs to be listed in the
>     group:BUNDLE attribute mid list.
>
>     So, if you want to re-use an m- line and mid attribute, but you
>     don't want the m- line to be in the BUNDLE group, simply remove
>     the mid from the mid list.
>
>     Regards,
>
>     Christer
>
>     ------------------------------------------------------------------------
>     *From:* [email-masked] <mailto:[email-masked]>
>     [[email-masked] <mailto:[email-masked]>] on
>     behalf of Suhas Nandakumar [[email-masked]
>     <mailto:[email-masked]>]
>     *To:* [email-masked] <mailto:[email-masked]>
>     associated with changing/not changing mid attribute of a re-cycled
>     m= section and it being part of a BUNDLE group or not..
>
>     example
>
>     BUNDLE. If we recycle first video m=section and dont change mid
>     attribute,  we end up BUNDLing even if the user dint want to
>
>     On the other hand, if we allowed mid value to be changed, we might
>     end up UNBundling a video stream , when the user did want to
>     BUNDLE them
>
>     So allowing a mid value to be changed or not should be tied to
>     what the JS API is asking on behalf of the user
>
>
>     Any thoughts ?
>
>     Cheers
>     Suhas
>
>
>
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 19 Sep 2013 15:25:09 -0700

+1

On Thu, Sep 19, 2013 at 3:23 PM, Harald Alvestrand <[email-masked]>wrote:

>> So, if you want to re-use an m- line and mid attribute, but you don't
>> want the m- line to be in the BUNDLE group, simply remove the mid from the
>> mid list.
>>
>>
>>
>> Regards,
>>
>>
>>
>> Christer
>>
>>
> rtcweb mailing [email-masked]://www.ietf.org/mailman/listinfo/rtcweb
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 Sep 2013 06:47:37 +0000

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of Suhas Nandakumar
Sent: 20. syyskuuta 2013 1:25
To: Harald Alvestrand
Cc: [email-masked]
Subject: Re: [rtcweb] m=section recycling and a=mid

+1

On Thu, Sep 19, 2013 at 3:23 PM, Harald Alvestrand <[email-masked]<mailto:[email-masked]>> wrote:
I suggest that changing the MID value can be very painful, since it modifies the mapping between m-line index and MID.

If not, I'd suggest that we explicitly forbid changing the MID value. If we want to add or remove an M-line from a bundle, we should update the bundles instead.

Correct.

Regards,

Christer

________________________________
From: Suhas Nandakumar [[email-masked]<mailto:[email-masked]>]
Sent: Thursday, 19 September 2013 9:48 PM
To: Christer Holmberg
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] m=section recycling and a=mid
Hello Christer

Cheers
Suhas

Hi Suhas,

Regards,

Christer

example

m=video .....
a=mid:1
a=inactive

m=video .....
a=mid:2
a=sendrecv

Any thoughts ?

Cheers
Suhas

rtcweb mailing list

[email-masked]<mailto:[email-masked]>

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb