Subject: [rtcweb] how to control which track plays in a video tag

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 18 Sep 2013 16:01:16 +0000

The issue got raised if there is multiple video tracks in a media stream, how do you control which video track gets played in a video stream

---

From: Suhas Nandakumar <[email-masked]>
Date: Wed, 18 Sep 2013 09:32:23 -0700

Shouldn't this be dealt with a W3C API, say videoelem.src =
mediastream.trackAt(0)

On Wed, Sep 18, 2013 at 9:01 AM, Cullen Jennings (fluffy)
<[email-masked]>wrote:

>
> The issue got raised if there is multiple video tracks in a media stream,
> how do you control which video track gets played in a video stream
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Ami Fischman <[email-masked]>
Date: Wed, 18 Sep 2013 09:53:34 -0700

> how do you control which video track gets played in a video stream

Set the selected<http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html#dom-videotrack-selected>attribute
on a
VideoTrack<http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html#audiotracklist-and-videotracklist-objects>from
HTMLMediaElement.videoTracks<http://www.whatwg.org/specs/web-apps/current-work/multipage/the-video-element.html#media-resources-with-multiple-media-tracks>
?
(though I don't know that it's implemented in any shipping browser today;
e.g. crbug.com/249427)

Cheers,
-a

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 19 Sep 2013 17:26:47 +0000

OMG - that was bad. I meant to send this to webrtc list. I apologize and I will have some chair give me a proper lecture on mailing list use. Please send any replies to webrtc list. 

On Sep 18, 2013, at 9:32 AM, Suhas Nandakumar <[email-masked]> wrote:

> Shouldn't this be dealt with a W3C API, say videoelem.src = mediastream.trackAt(0) 
> 
> 
> On Wed, Sep 18, 2013 at 9:01 AM, Cullen Jennings (fluffy) <[email-masked]> wrote:
>