Subject: [rtcweb] Question about the status of various drafts

From: Cullen Jennings <[email-masked]>
Date: Thu, 4 Jul 2013 17:47:20 -0700

As part of putting together some chair slides for Berlin, I'm trying to get a very rough idea of where things are. I'd like to get folks input on what percent done various drafts are where Done is a published RFC. 

This is nearly impossible to do at any level of accuracy but I do want to get a vague idea. I took a very rough stab below just to have a starting point to get the conversation going. I'm sure my numbers are mostly wrong but I have tried to ask a few people and sort of take the central cluster of the guess. If you think I am way out, please provide some feedback of what you think the number actually is.

I'm happy to get feedback on specific drafts or feedback of the form they are all too low or too high. I do encourage people to realistically look at the data tracker to see how long other drafts have taken for each stage to get a baseline instead of just going with their gut feel. 

Thanks, Cullen

PS - if you are an author and look at the number next to your draft and think it is way off, please please, say something. 

draft-ietf-rtcweb-overview		80
draft-ietf-rtcweb-use-cases-and-requirements	70
http://dev.w3.org/2011/webrtc/editor/getusermedia.html	70
draft-burnett-rtcweb-constraints-registry		80
http://dev.w3.org/2011/webrtc/editor/webrtc.html	50
draft-nandakumar-rtcweb-stun-uri		80
draft-petithuguenin-behave-turn-uris		80
draft-ietf-rtcweb-security		80
draft-ietf-rtcweb-security-arch		80
draft-muthu-behave-consent-freshness-02 	50
draft-ietf-rtcweb-data-channel		70
draft-ietf-mmusic-sctp-sdp		70
draft-jesup-rtcweb-data-protocol 		50
draft-ietf-tsvwg-sctp-dtls-encaps		70
draft-ietf-rtcweb-rtp-usage		40
draft-ietf-avtcore-6222bis		80
draft-ietf-avtcore-avp-codecs		80
draft-ietf-avtcore-srtp-encrypted-header-ext	80
draft-ietf-avtext-multiple-clock-rates		70
draft-lennox-rtcweb-rtp-media-type-mux 		80
draft-ietf-avtcore-rtp-circuit-breakers		70
draft-ietf-avtcore-multi-media-rtp-session 	70
draft-lennox-avtcore-rtp-multi-stream		70
draft-ietf-rtcweb-jsep		50
draft-ietf-mmusic-msid		70
draft-rescorla-mmusic-ice-trickle		25
draft-ietf-mmusic-sdp-bundle-negotiation	50
draft-nandakumar-mmusic-sdp-mux-attributes	25
draft-dhesikan-tsvwg-rtcweb-qos		10 or 90
draft-ietf-rtcweb-audio		50
draft-ietf-payload-rtp-opus		90
draft-ietf-payload-vp8-08		95

---

From: Jonathan Lennox <[email-masked]>
Date: Fri, 5 Jul 2013 12:29:41 -0400

> draft-ietf-avtcore-srtp-encrypted-header-ext	80

RFC 6904 - done.

(Your estimates for the other drafts I'm working on seem reasonable.)

--
Jonathan Lennox
[email-masked]

---

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Fri, 5 Jul 2013 17:12:21 +0000

Hi Cullen,

|draft-muthu-behave-consent-freshness-02 	50

Reasonable assessment. We are working on the next revision.

Muthu

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of Cullen Jennings
|Sent: Friday, July 05, 2013 6:17 AM
|To: [email-masked]
|Subject: [rtcweb] Question about the status of various drafts
|
|
|As part of putting together some chair slides for Berlin, I'm trying to get a very rough idea of where
|things are. I'd like to get folks input on what percent done various drafts are where Done is a
|published RFC.
|
|This is nearly impossible to do at any level of accuracy but I do want to get a vague idea. I took a
|very rough stab below just to have a starting point to get the conversation going. I'm sure my numbers
|are mostly wrong but I have tried to ask a few people and sort of take the central cluster of the
|guess. If you think I am way out, please provide some feedback of what you think the number actually
|is.
|
|I'm happy to get feedback on specific drafts or feedback of the form they are all too low or too high.
|I do encourage people to realistically look at the data tracker to see how long other drafts have
|taken for each stage to get a baseline instead of just going with their gut feel.
|
|Thanks, Cullen
|
|PS - if you are an author and look at the number next to your draft and think it is way off, please
|please, say something.
|
|
|
|draft-ietf-rtcweb-overview		80
|draft-ietf-rtcweb-use-cases-and-requirements	70
|http://dev.w3.org/2011/webrtc/editor/getusermedia.html	70
|draft-burnett-rtcweb-constraints-registry		80
|http://dev.w3.org/2011/webrtc/editor/webrtc.html	50
|draft-nandakumar-rtcweb-stun-uri		80
|draft-petithuguenin-behave-turn-uris		80
|draft-ietf-rtcweb-security		80
|draft-ietf-rtcweb-security-arch		80
|draft-muthu-behave-consent-freshness-02 	50
|draft-ietf-rtcweb-data-channel		70
|draft-ietf-mmusic-sctp-sdp		70
|draft-jesup-rtcweb-data-protocol 		50
|draft-ietf-tsvwg-sctp-dtls-encaps		70
|draft-ietf-rtcweb-rtp-usage		40
|draft-ietf-avtcore-6222bis		80
|draft-ietf-avtcore-avp-codecs		80
|draft-ietf-avtcore-srtp-encrypted-header-ext	80
|draft-ietf-avtext-multiple-clock-rates		70
|draft-lennox-rtcweb-rtp-media-type-mux 		80
|draft-ietf-avtcore-rtp-circuit-breakers		70
|draft-ietf-avtcore-multi-media-rtp-session 	70
|draft-lennox-avtcore-rtp-multi-stream		70
|draft-ietf-rtcweb-jsep		50
|draft-ietf-mmusic-msid		70
|draft-rescorla-mmusic-ice-trickle		25
|draft-ietf-mmusic-sdp-bundle-negotiation	50
|draft-nandakumar-mmusic-sdp-mux-attributes	25
|draft-dhesikan-tsvwg-rtcweb-qos		10 or 90
|draft-ietf-rtcweb-audio		50
|draft-ietf-payload-rtp-opus		90
|draft-ietf-payload-vp8-08		95
|
|
|_______________________________________________
|rtcweb mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 5 Jul 2013 14:25:26 -0700

I think you need to take dependencies into account.   There are several reasons for this: 
   a. Until you've gone through the dependency graph for the items, the full list of documents that need to be tracked isn't known.    b. Estimates of completion are dependent on the progress of normative dependencies (e.g. they can't be published until the dependencies are resolved). 

As an example,  draft-ietf-rtcweb-overview (which is listed as 80 percent complete) has normative references to the following drafts: 
   [I-D.ietf-mmusic-sctp-sdp] 70   [I-D.ietf-rtcweb-audio] 50   [I-D.ietf-rtcweb-data-channel] 70   [I-D.ietf-rtcweb-jsep] 50   [I-D.ietf-rtcweb-rtp-usage] 40   [I-D.ietf-rtcweb-security] 80   [I-D.ietf-rtcweb-security-arch] 80   [I-D.nandakumar-rtcweb-stun-uri] 80   [I-D.tuexen-tsvwg-sctp-dtls-encaps] 70            Since draft-ietf-rtcweb-overview is dependent on a document (rtp usage) which only has an estimate of 40 percent done) I'd say that the estimate is probably closer to 40 than 80. 

> From: [email-masked]
> Date: Thu, 4 Jul 2013 17:47:20 -0700
> To: [email-masked]
> Subject: [rtcweb] Question about the status of various drafts
> 
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 11 Jul 2013 10:28:57 +0200

> draft-ietf-rtcweb-rtp-usage		40

I disagree that that this is as low as 40%. There are some few thorny
issues that might take some discussion to resolve. However, most things
are from an authors perspective quite solid. I would say 60-70%. My main
caveat is that I haven't seen that many reviews.

You can expect an update prior to the deadline resolving some of the
stated open issues and dealing with issues from Bernard's review.

> draft-ietf-avtcore-6222bis		80

I expect this to be approved in a week or two, thus 90

> draft-ietf-avtcore-avp-codecs		80

Approved thus only publication left thus 95

> draft-ietf-avtext-multiple-clock-rates		70

This one is 90 as it is ready for publication request. It is awaiting
the AVTEXT chair to act on it.

> draft-lennox-rtcweb-rtp-media-type-mux 		80

I wonder why this draft is listed here. Isn't the relevant content of
this gone into the AVTCORE drafts:
- draft-ietf-avtcore-multi-media-rtp-session
- draft-ietf-avtcore-rtp-multi-stream
?

> draft-lennox-avtcore-rtp-multi-stream		70

There is a WG version of this document
draft-ietf-avtcore-rtp-multi-stream which in fact is being split into
one recommendation and one optimization part. Updates to be submitted
prior to deadline.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Hutton, Andrew" <[email-masked]>
Date: Thu, 11 Jul 2013 10:19:07 +0000

There are things missing from the list.

For example the charter and the requirements indicate that we need to address the firewall issue so we need a draft for that.

I hope we will adopt draft-hutton-rtcweb-nat-firewall-considerations to cover this and of course assuming we do then I think it is nearly done but others might think differently. 

I have not been through the requirements document to see if there are other things missing.

Regards
Andy

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Cullen Jennings
> Sent: 05 July 2013 01:47
> To: [email-masked]
> As part of putting together some chair slides for Berlin, I'm trying to
> get a very rough idea of where things are. I'd like to get folks input
> on what percent done various drafts are where Done is a published RFC.
> 
> This is nearly impossible to do at any level of accuracy but I do want
> to get a vague idea. I took a very rough stab below just to have a
> starting point to get the conversation going. I'm sure my numbers are
> mostly wrong but I have tried to ask a few people and sort of take the
> central cluster of the guess. If you think I am way out, please provide
> some feedback of what you think the number actually is.
> 
> I'm happy to get feedback on specific drafts or feedback of the form
> they are all too low or too high. I do encourage people to
> realistically look at the data tracker to see how long other drafts
> have taken for each stage to get a baseline instead of just going with
> their gut feel.
> 
> Thanks, Cullen
> 
> PS - if you are an author and look at the number next to your draft and
> think it is way off, please please, say something.
> 
> 
>

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 11 Jul 2013 18:09:26 -0700

On Jul 11, 2013, at 1:28 AM, Magnus Westerlund <[email-masked]> wrote:

> are from an authors perspective quite solid. I would say 60-70%.

Not sure how I got 40 on that one.  60-70 makes sense. (and rest of email but just wanted to reply to this part right away

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 26 Jul 2013 12:09:53 -0600

Yah, I get your point. I will try and find a way to better represent this on the slides. 

On Jul 5, 2013, at 3:25 PM, Bernard Aboba <[email-masked]> wrote:

>    a. Until you've gone through the dependency graph for the items, the full list of documents that need to be tracked isn't known. 
>    b. Estimates of completion are dependent on the progress of normative dependencies (e.g. they can't be published until the dependencies are resolved). 
> 
>    [I-D.ietf-mmusic-sctp-sdp] 70
>    [I-D.ietf-rtcweb-audio] 50
>    [I-D.ietf-rtcweb-data-channel] 70
>    [I-D.ietf-rtcweb-jsep] 50
>    [I-D.ietf-rtcweb-rtp-usage] 40
>    [I-D.ietf-rtcweb-security] 80
>    [I-D.ietf-rtcweb-security-arch] 80
>    [I-D.nandakumar-rtcweb-stun-uri] 80
>    [I-D.tuexen-tsvwg-sctp-dtls-encaps] 70
>             
> Since draft-ietf-rtcweb-overview is dependent on a document (rtp usage) which only has an estimate of 40 percent done) I'd say that the estimate is probably closer to 40 than 80. 
> 
> 
> > From: [email-masked]

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 26 Jul 2013 18:56:38 +0000

Hi Cullen,

I may missed something, but it seems a little strange to me when individual drafts, that haven't even been adopted yet, are indicated as 70-80% complete...

Some drafts have also expired.

Regards,

Christer

Sent from Windows using TouchDown (www.nitrodesk.com)

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 26 Jul 2013 19:35:18 +0000

I'd missed that.

By definition an author draft has 0% completion because no working group has reached consensus on any of the text.

Looks like you (or other RTCWEB chairs) need to start talking to other WG chairs about initiating adoption of drafts as WG items. I don't at the moment see anything in the list that should avoid going the WG route.

Regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 26 July 2013 19:57
To: Cullen Jennings; Bernard Aboba
Cc: rtcweb_ietf.org
Subject: Re: [rtcweb] Question about the status of various drafts

Hi Cullen,

Regards,

Christer

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 26 Jul 2013 13:58:45 -0600

I'm in the process of updating it it all - I'll try and make reasonable estimates. Note some of the individual drafts are planned to be AD sponsored.

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 27 Jul 2013 16:27:35 +0200

On 07/05/2013 11:25 PM, Bernard Aboba wrote:
>    a. Until you've gone through the dependency graph for the items,
> the full list of documents that need to be tracked isn't known. 
>    b. Estimates of completion are dependent on the progress of
> normative dependencies (e.g. they can't be published until the
> dependencies are resolved). 
>
> As an example,  draft-ietf-rtcweb-overview (which is listed as 80
> percent complete) has normative references to the following drafts: 
>
> Since draft-ietf-rtcweb-overview is dependent on a document (rtp
> usage) which only has an estimate of 40 percent done) I'd say that the
> estimate is probably closer to 40 than 80.

I don't know exactly what Cullen meant by the percentages, but I don't
think he intended them to be sequential the way publication dependencies
are.

If, for instance, he was thinking about how many percent of the text
needed to change semantically before it was done, I think 80% for
"overview" may be right (unless we choose to change the approach by some
large delta).

If you want to draw up a dependency graph .... well, since -overview-
was intended to be the one that points to all the others, it's
reasonable to put it last in the graph. That's what it's for.

> > As part of putting together some chair slides for Berlin, I'm trying
> to get a very rough idea of where things are. I'd like to get folks
> input on what percent done various drafts are where Done is a
> published RFC.
> >
> > This is nearly impossible to do at any level of accuracy but I do
> want to get a vague idea. I took a very rough stab below just to have
> a starting point to get the conversation going. I'm sure my numbers
> are mostly wrong but I have tried to ask a few people and sort of take
> the central cluster of the guess. If you think I am way out, please
> provide some feedback of what you think the number actually is.
> >
> > PS - if you are an author and look at the number next to your draft
> and think it is way off, please please, say something.
> >
> >
> >