Subject: [rtcweb] Offer & Answer interworking between JSEP & SIP draft for review

From: "Parthasarathi R" <[email-masked]>
Date: Wed, 12 Jun 2013 23:24:40 +0530

Hi all,

Offer/answer Interworking between JSEP & SIP IETF draft is written as JSEP (O/A) model is different from SIP O/A and there is a need of mapping document. This draft will act  as a building block for developing the O/A interwork between SIP & JSEP. The draft is available at http://www.ietf.org/internet-drafts/draft-partha-rtcweb-jsep-sip-00.txt. Could you please provide your valuable review comments.

Thanks
Partha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, June 12, 2013 11:07 PM
> To: Uwe Rauschenbach; Elangovan Manickam; Parthasarathi Ravindran
> Subject: New Version Notification for draft-partha-rtcweb-jsep-sip-
> 00.txt
> 
> 
> A new version of I-D, draft-partha-rtcweb-jsep-sip-00.txt
> has been successfully submitted by Parthasarathi Ravindran and posted
> to the
> IETF repository.
> 
> Filename:	 draft-partha-rtcweb-jsep-sip
> Revision:	 00
> Title:		 Offer & Answer interworking between JSEP & SIP
> Creation date:	 2013-06-12
> Group:		 Individual Submission
> Number of pages: 13
> URL:             http://www.ietf.org/internet-drafts/draft-partha-
> rtcweb-jsep-sip-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-partha-rtcweb-
> jsep-sip
> Htmlized:        http://tools.ietf.org/html/draft-partha-rtcweb-jsep-
> sip-00
> 
> 
> Abstract:
>    Real time communcation Web (RTCWeb) workgroup defines the real time
>    commmunication using JavaScript Session establishment protocol
> (JSEP)
>    as an offer/answer mechanism.  Session Initiation protocol (SIP) is
>    IETF defined and well deployed protocol for real time communication.
>    This document provides offer & answer interworking between JSEP and
>    SIP.
> 
> 
> 
> 
> The IETF Secretariat

---

From: "Matthew Kaufman (SKYPE)" <[email-masked]>
Date: Wed, 12 Jun 2013 23:11:34 +0000

I have a meta review comment: does the fact that the content of this document is not null mean that the reasoning for choosing SDP O/A as the API surface was faulty?

Matthew Kaufman

(Sent from my iPhone)

On Jun 12, 2013, at 10:55 AM, "Parthasarathi R" <[email-masked]> wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Roman Shpount <[email-masked]>
Date: Wed, 12 Jun 2013 19:27:13 -0400

To be honest, the whole SDP O/A affair reminds me the verse from Haddock's
Eyes song by Lewis Carroll:

But I was thinking of a plan    To dye one's whiskers green,And always use
so large a fan    That they could not be seen.

The whole thing would be easier to use, simpler to standardize, and much
simpler to interop with SIP if instead of O/A underlying C++ API's from
Voice and Video engines were mapped to JavaScript.
_____________
Roman Shpount

On Wed, Jun 12, 2013 at 7:11 PM, Matthew Kaufman (SKYPE) <
[email-masked]> wrote:

> I have a meta review comment: does the fact that the content of this
> document is not null mean that the reasoning for choosing SDP O/A as the
> API surface was faulty?
>
> Matthew Kaufman
>
> (Sent from my iPhone)
>
> > Offer/answer Interworking between JSEP & SIP IETF draft is written as
> JSEP (O/A) model is different from SIP O/A and there is a need of mapping
> document. This draft will act  as a building block for developing the O/A
> interwork between SIP & JSEP. The draft is available at
> http://www.ietf.org/internet-drafts/draft-partha-rtcweb-jsep-sip-00.txt.
> Could you please provide your valuable review comments.
> >
> > Thanks
> > Partha
> >

---

From: Erik Lagerway <[email-masked]>
Date: Wed, 12 Jun 2013 17:17:29 -0700

+1 Roman

*Erik Lagerway <http://ca.linkedin.com/in/lagerway> |
*Hookflash<http://hookflash.com>
* *
****

On Wed, Jun 12, 2013 at 4:27 PM, Roman Shpount <[email-masked]> wrote:

> But I was thinking of a plan    To dye one's whiskers green, And always
> use so large a fan     That they could not be seen.
>

---

From: "Parthasarathi R" <[email-masked]>
Date: Thu, 13 Jun 2013 22:38:22 +0530

Hi all,

This draft is written as per the current JSEP draft. This draft will be
updated inline with future revision of JSEP. 

Thanks

Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Erik Lagerway
Sent: Thursday, June 13, 2013 5:47 AM
To: Roman Shpount
Cc: [email-masked]
Subject: Re: [rtcweb] Offer & Answer interworking between JSEP & SIP draft
for review

+1 Roman

 <http://ca.linkedin.com/in/lagerway> Erik Lagerway |
<http://hookflash.com> Hookflash 

But I was thinking of a plan

    To dye one's whiskers green,

And always use so large a fan

    That they could not be seen.

_____________
Roman Shpount

On Wed, Jun 12, 2013 at 7:11 PM, Matthew Kaufman (SKYPE)
<[email-masked]> wrote:

I have a meta review comment: does the fact that the content of this
document is not null mean that the reasoning for choosing SDP O/A as the API
surface was faulty?

Matthew Kaufman

(Sent from my iPhone)

On Jun 12, 2013, at 10:55 AM, "Parthasarathi R" <[email-masked]>
wrote:

> Hi all,
>
> Offer/answer Interworking between JSEP & SIP IETF draft is written as JSEP
(O/A) model is different from SIP O/A and there is a need of mapping