Subject: [rtcweb] Where Plan A, B, and "no plan" discussions should happen

From: Ted Hardie <[email-masked]>
Date: Fri, 7 Jun 2013 10:49:40 -0700

Howdy,

Several folks have asked for clarification on where plan A, plan B, and "no
plan" discussions should occur. Magnus and Cullen and I have not had much
chance to discuss it, but here is my take:

RTCWEB has made a request of MMUSIC for a standardized way to handle
multiple media flows (for large values of "multiple" in some cases).  Plan
A and Plan B propose specific approaches and syntax to resolve the
request.  Discussions of those approaches and syntax belong in MMUSIC, full
stop.

Discussions of whether we actually need a standardized way to handle that
belong in RTCWEB, because they are essentially an argument to the WG that
we can withdraw the request to MMUSIC and go forward using other pieces of
the WebRTC mechanics to resolve the problem.

Emil's draft has some elements which critique plan A and plan B, and a
proposal that falls into the "no need for a standard here" camp.  For
clarity's sake, it might be easiest if those were split.  The proposal that
a standard isn't needed could be submitted as an RTCWEB relevant draft
(draft-ivov-rtcweb-no-plan-needed, perhaps?).  The critique of Plan A and
Plan B could be submitted as an MMUSIC draft
(draft-ivov-mmusic-plan-a-b-considerations, perhaps?).

At this point, I do not see consensus to withdraw the request to MMUSIC
from RTCWEB, but, as I said, Magnus, Cullen, and I have not had much chance
to coordinate, so this is not a chair decision.

regards,

Ted Hardie

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 7 Jun 2013 12:02:01 -0700

Ted said: 

At this point, I do not see consensus to withdraw the request to MMUSIC from RTCWEB, 
 
[BA] Given the number of messages posted about "the plans" there is clearly some SDP guidance needed, and MMUSIC is the WG that would provide that.  So letting the request to MMUSIC go forward makes sense to me.

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 8 Jun 2013 12:31:26 +0700

On Jun 8, 2013, at 12:49 AM, Ted Hardie <[email-masked]> wrote:

> Howdy,
> 
> Several folks have asked for clarification on where plan A, plan B, and "no plan" discussions should occur. Magnus and Cullen and I have not had much chance to discuss it, but here is my take:
> 
> RTCWEB has made a request of MMUSIC for a standardized way to handle multiple media flows (for large values of "multiple" in some cases).  Plan A and Plan B propose specific approaches and syntax to resolve the request.  Discussions of those approaches and syntax belong in MMUSIC, full stop.
> 
> Discussions of whether we actually need a standardized way to handle that belong in RTCWEB, because they are essentially an argument to the WG that we can withdraw the request to MMUSIC and go forward using other pieces of the WebRTC mechanics to resolve the problem.
> 
> Emil's draft has some elements which critique plan A and plan B, and a proposal that falls into the "no need for a standard here" camp.  For clarity's sake, it might be easiest if those were split.  The proposal that a standard isn't needed could be submitted as an RTCWEB relevant draft (draft-ivov-rtcweb-no-plan-needed, perhaps?).  The critique of Plan A and Plan B could be submitted as an MMUSIC draft (draft-ivov-mmusic-plan-a-b-considerations, perhaps?).
> 
> At this point, I do not see consensus to withdraw the request to MMUSIC from RTCWEB, but, as I said, Magnus, Cullen, and I have not had much chance to coordinate, so this is not a chair decision.
> 
> regards,
> 
> Ted Hardie

100% agree with Ted. Cullen <with my chair hat on>

PS - Ted, Magnus, and I are currently roughly equally separated  each1/3 of the way around the world from the other two people so it's been hard to get the time zones to work for our usual phone calls.