Subject: Re: [rtcweb] Offer & Answer interworking between JSEP & SIP draft for review

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Jun 2013 18:11:29 +0000

Hi,

I have some issues with your way of solving forking.

In sections 5.5 and 5.6, you are mapping SIP Answers to JSEP Offer. I think that is a very bad thing to do, because what happens if something has changed in the associated JSEP Answer? Then you'll have to map that into a SIP Offer, and then again map the associated SIP Answer into a JSEP Offer. Etc etc etc. 

I do like that fact that you are not using PRANSWER, but unfortunately I don't think the suggested way will work :)

My suggestion is still that we should support some kind of "cloning" (I use that as a generic term), in order to support forking.

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: [email-masked] [mailto:[email-masked]] Puolesta Parthasarathi R
Lähetetty: 12. kesäkuuta 2013 20:55
Vastaanottaja: [email-masked]
Kopio: 'Elangovan Manickam'
Aihe: [rtcweb] Offer & Answer interworking between JSEP & SIP draft for review

Hi all,

Offer/answer Interworking between JSEP & SIP IETF draft is written as JSEP (O/A) model is different from SIP O/A and there is a need of mapping document. This draft will act  as a building block for developing the O/A interwork between SIP & JSEP. The draft is available at http://www.ietf.org/internet-drafts/draft-partha-rtcweb-jsep-sip-00.txt. Could you please provide your valuable review comments.

Thanks
Partha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, June 12, 2013 11:07 PM
> To: Uwe Rauschenbach; Elangovan Manickam; Parthasarathi Ravindran
> Subject: New Version Notification for draft-partha-rtcweb-jsep-sip- 
> 00.txt
> 
> 
> A new version of I-D, draft-partha-rtcweb-jsep-sip-00.txt
> has been successfully submitted by Parthasarathi Ravindran and posted 
> to the IETF repository.
> 
> Filename:	 draft-partha-rtcweb-jsep-sip
> Revision:	 00
> Title:		 Offer & Answer interworking between JSEP & SIP
> Creation date:	 2013-06-12
> Group:		 Individual Submission
> Number of pages: 13
> URL:             http://www.ietf.org/internet-drafts/draft-partha-
> rtcweb-jsep-sip-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-partha-rtcweb-
> jsep-sip
> Htmlized:        http://tools.ietf.org/html/draft-partha-rtcweb-jsep-
> sip-00
> 
> 
> Abstract:
>    Real time communcation Web (RTCWeb) workgroup defines the real time
>    commmunication using JavaScript Session establishment protocol
> (JSEP)
>    as an offer/answer mechanism.  Session Initiation protocol (SIP) is
>    IETF defined and well deployed protocol for real time communication.
>    This document provides offer & answer interworking between JSEP and
>    SIP.
> 
> 
> 
> 
> The IETF Secretariat

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Parthasarathi R" <[email-masked]>
Date: Thu, 13 Jun 2013 22:11:16 +0530

Hi Christer,

I understand your concern about forking solution with two O/A and it is
documented in sec 5.5 as 

"  The assumption in Fig 5 is that ANSWER2 and ANSWER4 are same.  In
   case they are different, there is a need of extra offer-answer
   between JSEP-SIP GW and SIP UA3"

As you indicated, "PRANSWER" state is not used in the callflow because 

1) PRANSWER related states don't allow for second "OFFER"
2) SIP Parallel forking is not possible with JSEP as of now

I agree with you that some sort of cloning resolves SIP forking issue.
Unfortunately JSEP does not support cloning which forces to map SIP ANSWER
to JSEP OFFER during forking. 

Thanks
Partha 

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Wednesday, June 12, 2013 11:41 PM
> To: Parthasarathi R; [email-masked]
> Cc: 'Elangovan Manickam'
> Subject: VS: [rtcweb] Offer & Answer interworking between JSEP & SIP
> draft for review
> 
> Hi,
> 
> In sections 5.5 and 5.6, you are mapping SIP Answers to JSEP Offer. I
> think that is a very bad thing to do, because what happens if something
> has changed in the associated JSEP Answer? Then you'll have to map that
> into a SIP Offer, and then again map the associated SIP Answer into a
> JSEP Offer. Etc etc etc.
> 
> I do like that fact that you are not using PRANSWER, but unfortunately
> I don't think the suggested way will work :)
> 
> My suggestion is still that we should support some kind of "cloning" (I
> use that as a generic term), in order to support forking.
> 
> Regards,
> 
> Christer
> 
> 
> Offer/answer Interworking between JSEP & SIP IETF draft is written as
> JSEP (O/A) model is different from SIP O/A and there is a need of
> mapping document. This draft will act  as a building block for
> developing the O/A interwork between SIP & JSEP. The draft is available
> at http://www.ietf.org/internet-drafts/draft-partha-rtcweb-jsep-sip-
> 00.txt. Could you please provide your valuable review comments.
> 
> Thanks
> Partha
>