Subject: [rtcweb] WebRTC service between SPs

From: "Wangyahui (Yahui)" <[email-masked]>
Date: Fri, 28 Jun 2013 07:39:43 +0000

Hi all,
I have followed RTCWeb discussion for some time.
As far as I know, any website can conveniently integrate WebRTC service, particularly social networking websites. It can easily be predicted that many service providers (SPs), especially social networking SPs will release their WebRTC services in the near future. But I am wondering how the users under different SPs can communicate using WebRTC client. Each SP offers different user identity in different domain. Although some mechanisms can support to login multiple websites using a uniform account, such as Persona ID, OpenID or OAuth, they have different Idps, and not all websites apply the same mechanism.
I am not sure whether it is a problem. Thanks for your any comments.

---

From: Jim Barnett <[email-masked]>
Date: Fri, 28 Jun 2013 16:03:27 +0000

As I understand it, it's not just a problem of identities.  WebRTC does not define the signaling protocol, but leaves it  up to the application.  If two users download their applications/JavaScript from the same site, it won't be a problem, because the same application is handling both ends of the call.  But if one user is on site A while the other is on site B, there is no guarantee that either site's application will understand the signaling from the other.

-          Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of Wangyahui (Yahui)
Sent: Friday, June 28, 2013 3:40 AM
To: [email-masked]
Subject: [rtcweb] WebRTC service between SPs

Hi all,

---

From: Moises Silva <[email-masked]>
Date: Fri, 28 Jun 2013 14:25:13 -0400

On Fri, Jun 28, 2013 at 12:03 PM, Jim Barnett <[email-masked]>wrote:

>  As I understand it, it’s not just a problem of identities.  WebRTC does
> not define the signaling protocol, but leaves it  up to the application.
> If two users download their applications/JavaScript from the same site, it
> won’t be a problem, because the same application is handling both ends of
> the call.  But if one user is on site A while the other is on site B, there
> is no guarantee that either site’s application will understand the
> signaling from the other.****
>
> **
>

Unless websites agree to use something standard such as SIP/Jingle for
federation (inter website/domain communication).

-
Moy

---

From: Hrishikesh Kulkarni <[email-masked]>
Date: Sat, 29 Jun 2013 11:47:49 +0530

SIP is an established standard to interoperate domains. We at
OneKlikStreet.com developed a video/audio bridging service for WebRTC.
Although it uses JS/JSON signaling for web based clients. Our server could
very well federate with any other service using SIP. What does need to be
discussed on app to app basis is what kind of federation you are looking
for?
In case of bridging service we could merge calls from both servers or
redirect all the calls to the host service.

regards,
Rishi
Founder, OneKlikStreet.com

On Fri, Jun 28, 2013 at 11:55 PM, Moises Silva <[email-masked]>wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: "Wangyahui (Yahui)" <[email-masked]>
Date: Sat, 29 Jun 2013 09:29:30 +0000

Thanks for your comments.
Yes, we can implement the federation between SPs through using the same signaling protocol (e.g. SIP) or deploying a gateway.

But what I concern is how to compatible with the existing various user id from different SPs. For example, if Google provides WebRTC client, then the users should be able to login using their Gmail address. In the same way, Facebook support the users using FacebookId. So the format of identification may be number, string or email and so on.

The problem is how to handle addressing users of different SPs. Should it be standardized to a unified WebRTC URI?

Yahui

发件人: Hrishikesh Kulkarni [mailto:[email-masked]]
发送时间: 2013年6月29日 14:18
收件人: Moises Silva
抄送: Jim Barnett; Wangyahui (Yahui); [email-masked]
主题: Re: [rtcweb] WebRTC service between SPs

SIP is an established standard to interoperate domains. We at OneKlikStreet.com developed a video/audio bridging service for WebRTC. Although it uses JS/JSON signaling for web based clients. Our server could very well federate with any other service using SIP. What does need to be discussed on app to app basis is what kind of federation you are looking for?
In case of bridging service we could merge calls from both servers or redirect all the calls to the host service.

regards,
Rishi

On Fri, Jun 28, 2013 at 11:55 PM, Moises Silva <[email-masked]<mailto:[email-masked]>> wrote:

On Fri, Jun 28, 2013 at 12:03 PM, Jim Barnett <[email-masked]<mailto:[email-masked]>> wrote:
As I understand it, it’s not just a problem of identities.  WebRTC does not define the signaling protocol, but leaves it  up to the application.  If two users download their applications/JavaScript from the same site, it won’t be a problem, because the same application is handling both ends of the call.  But if one user is on site A while the other is on site B, there is no guarantee that either site’s application will understand the signaling from the other.

Unless websites agree to use something standard such as SIP/Jingle for federation (inter website/domain communication).

-
Moy

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Barry Dingle <[email-masked]>
Date: Sat, 29 Jun 2013 20:26:43 +1000

I had assumed that a DNS NAPTR record could be used to provide all the
alternate "user id's". Am I right?

Cheers,
/Barry

Barry Dingle
Fixed - +61(0)3-9725-3937    Mob - +61(0)41-911-7578
Fellow of University of Melbourne, Electrical and Electronic Eng.,
Australia
> Linux + Android + Apple + Open Source software

On Sat, Jun 29, 2013 at 7:29 PM, Wangyahui (Yahui) <[email-masked]>wrote:

>  Thanks for your comments.****
>
> Yes, we can implement the federation between SPs through using the same
> signaling protocol (e.g. SIP) or deploying a gateway.****
>
> ** **
>
> But what I concern is how to compatible with the existing various user id
> from different SPs. For example, if Google provides WebRTC client, then the
> users should be able to login using their Gmail address. In the same way,
> Facebook support the users using FacebookId. So the format of
> identification may be number, string or email and so on.****
>
> ** **
>
> The problem is how to handle addressing users of different SPs. Should it
> be standardized to a unified WebRTC URI?****
>
> ** **
>
> Yahui****
>
> ** **
>
> *发件人:* Hrishikesh Kulkarni [mailto:[email-masked]]
> *发送时间:* 2013年6月29日 14:18
> *收件人:* Moises Silva
> *抄送:* Jim Barnett; Wangyahui (Yahui); [email-masked]
> *主题:* Re: [rtcweb] WebRTC service between SPs****
>
> ** **
>
> for? ****
> redirect all the calls to the host service.****
>
> ** **
>
> regards,****
>
> Rishi****
>
> Founder, OneKlikStreet.com****
>
> ** **
>
> ** **
>
> ** **
>
> On Fri, Jun 28, 2013 at 11:55 PM, Moises Silva <[email-masked]>
> wrote:****
>
> ** **
>
> On Fri, Jun 28, 2013 at 12:03 PM, Jim Barnett <[email-masked]>
> wrote:****
>
> ** **
> -****
> Moy****
> https://www.ietf.org/mailman/listinfo/rtcweb****
>
> ** **
>