Subject: [rtcweb] Proposed Agenda for Interim

From: Eric Rescorla <[email-masked]>
Date: Wed, 2 Jan 2013 07:12:57 -0800

Chairs,

I've spent some time thinking about the agenda for the interim, and
thought it might be helpful if I sent you a strawman based on the
items that are blocking progress in terms of implementation and
interoperability.

Note:
I am assuming 4 hours each day. The times have been selected with
the objective of giving us enough time to really resolve the
open issues. Honestly, we might even add more time for
the issues on day 1.

Hope this is helpful.

Day 1
2:00    Bundle   [Holmberg]
Objective: select an approach and work out enough
 details that the editors can work to produce a
suitable draft.

 Drafts:
- http://tools.ietf.org/html/draft-ietf-mmusic-sdp-bundle-negotiation
 - http://tools.ietf.org/html/draft-alvestrand-one-rtp
- http://tools.ietf.org/html/draft-holmberg-mmusic-sdp-mmt-negotiation

2:00    Multiple flow SDP representation [Jennings, Alvestrand]
Objective: decide on an architecture for large numbers
 of similar streams (e.g., multiple video streams).

Drafts:
 - http://tools.ietf.org/html/draft-alvestrand-rtcweb-msid
- http://tools.ietf.org/html/draft-alvestrand-mmusic-msid
 - Do we have a "master" document for the single m-line case?
- Multiple m-lines doesn't have a document

Day 2
1:30    Mapping stream/track label concepts SDP identifiers [Alvestrand]
Objective: determine requirements
 1:30    Trickle ICE open issues [Ivov(?), Uberti, Rescorla]
 - Starting checks
- Termination conditions
- Error handling
 Drafts:
http://tools.ietf.org/html/draft-rescorla-mmusic-ice-trickle

1:00    SDP for Datachannels open issues [Jesup, Loreto]
Objective: resolve open issues (post WGLC?)

Drafts:
 http://tools.ietf.org/html/draft-ietf-mmusic-sctp-sdp-02

Day 3
1:00    Other recommended audio codecs [Roach]
 Objective: identify what other audio codecs we intend to
 recommend.

1:00    Process WGLC comments on documents [authors]

0:30    Other business

0:30    Wrapup/next steps [Chairs]

Best,
-Ekr

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 2 Jan 2013 18:18:21 +0000

I'm not really sure what to do here - given a key role of the chairs is largely to facilitate the discussions and meetings that Wg participants want to have,  guidance from participants of both MMUSIC and rtcweb is really important here. 

I agree that 

1) the items in EKR's email do look like the a bunch of the high runner items that need to be resolved soon 

2) the solutions of these problems are likely in to be mostly MMUSIC though, as Ted has pointed out, some amount of the requirements, architecture and other discussion can happen in rtcweb. 

3) if we are going to have an MMUSIC face to face interim meeting, it would need AD approval and 4 weeks notices which puts us very close do the deadline so this needs to get sort out real soon. 

Cullen

On Jan 2, 2013, at 8:24 AM, Bernard Aboba <[email-masked]> wrote:

> This is a good agenda - for an MMUSIC WG interim (only day 3 has any RTCWEB items on it).
> 
> Since there is a notice requirement, can we get MMUSIC on board so the interim can actually take place?
> 
> On Jan 2, 2013, at 7:13, "Eric Rescorla" <[email-masked]> wrote:
> 
>> Chairs,
>> 
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
> <Mail Attachment.txt>_______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Wed, 2 Jan 2013 18:18:21 +0000

I'm not really sure what to do here - given a key role of the chairs is
 largely to facilitate the discussions and meetings that Wg participants want to
 have,  guidance from participants of both MMUSIC and rtcweb is really
 important here. 

I agree that 

1) the items in EKR's email do look like the a bunch of the high runner
 items that need to be resolved soon 

2) the solutions of these problems are likely in to be mostly MMUSIC though,
 as Ted has pointed out, some amount of the requirements, architecture and
 other discussion can happen in rtcweb. 

3) if we are going to have an MMUSIC face to face interim meeting, it would
 need AD approval and 4 weeks notices which puts us very close do the
 deadline so this needs to get sort out real soon. 

Cullen

---

From: Ted Hardie <[email-masked]>
Date: Wed, 2 Jan 2013 10:39:53 -0800

On Wed, Jan 2, 2013 at 10:18 AM, Cullen Jennings (fluffy)
<[email-masked]>wrote:

>
> 2) the solutions of these problems are likely in to be mostly MMUSIC
> though, as Ted has pointed out, some amount of the requirements,
> architecture and other discussion can happen in rtcweb.
>
>
I actually believe it can go beyond requirements and architecture; I
believe that if RTCWEB can come to a firm understanding of what solutions
are best for its use cases, it can communicate that to MMUSIC.  That
doesn't mean the final decision doesn't rest with MMUSIC--it does--but it
does mean that RTCWEB doesn't have to leave the technology discussion
completely off the table.  A good analysis can go to MMUSIC for discussion
and potential resolution in/by Orlando.

> deadline so this needs to get sort out real soon.
There is also the option of a virtual interim, which is (somewhat) less of
a logistical issue.

Ted

> >>      -
> http://tools.ietf.org/html/draft-ietf-mmusic-sdp-bundle-negotiation
> >>      -
> http://tools.ietf.org/html/draft-holmberg-mmusic-sdp-mmt-negotiation
> >>
> >>

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 2 Jan 2013 11:44:53 -0800

Cullen said:

"3) if we are going to have an MMUSIC face to face interim meeting, it would need AD approval and 4 weeks notices which puts us very close do the deadline so this needs to get sort out real soon. "

[BA] I see no particularly good reason why this can't  happen quickly.  In fact, why not schedule two MMUSIC interims, 4-6 weeks apart from each other?  If travel is an issue, they can be virtual.  EKR's
 issue list is a fine starting point, and there is an informal IESG 
telechat tomorrow (3-Jan) as well as one on 10-Jan-2013.  

Ted's suggestion (to cover this in the RTCWEB interim) might do in a pinch, but really, MMUSIC WG has to develop a sense of urgency on this.  If things keep going as they have, by the time we get published RFCs out of MMUSIC,  implementations will have been in the field for years.  

If MMUSIC were a Hollywood Celebrity, we'd be *way* past the time for "tough love" and on the front page of the National Enquirer for the Nth time.

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 2 Jan 2013 14:25:32 -0800

On Wed, Jan 2, 2013 at 11:44 AM, Bernard Aboba <[email-masked]>wrote:

> Cullen said:
>
> "3) if we are going to have an MMUSIC face to face interim meeting, it
> would need AD approval and 4 weeks notices which puts us very close do the
> deadline so this needs to get sort out real soon. "
>
> [BA] I see no particularly good reason why this can't  happen quickly.  In
> fact, why not schedule two MMUSIC interims, 4-6 weeks apart from each
> other?  If travel is an issue, they can be virtual.  EKR's issue list is a
> fine starting point, and there is an informal IESG telechat tomorrow
> (3-Jan) as well as one on 10-Jan-2013.
>

I'm not in principle opposed to "virtual" interims, but my general feeling
is
that we should be using face-to-face time to cover the most important and
intractable issues. ISTM that those are the ones that I listed in my email.

Accordingly, I don't think it makes sense to have virtual MMUSIC interims
to discuss the important stuff and a F2F RTCWEB interim to discuss the
rest...

-Ekr

Ted's suggestion (to cover this in the RTCWEB interim) might do in a pinch,
> but really, MMUSIC WG has to develop a sense of urgency on this.  If things
> keep going as they have, by the time we get published RFCs out of MMUSIC,
> implementations will have been in the field for years.
>
> If MMUSIC were a Hollywood Celebrity, we'd be *way* past the time for
> "tough love" and on the front page of the National Enquirer for the Nth
> time.
>
>
>
>

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 03 Jan 2013 21:03:50 -0500

On 1/2/13 2:44 PM, Bernard Aboba wrote:
> would need AD approval and 4 weeks notices which puts us very close do 
> the deadline so this needs to get sort out real soon. "
>
> [BA] I see no particularly good reason why this can't  happen 
> quickly.  In fact, why not schedule two MMUSIC interims, 4-6 weeks 
> apart from each other?  If travel is an issue, they can be virtual.  
> EKR's issue list is a fine starting point, and there is an informal 
> IESG telechat tomorrow (3-Jan) as well as one on 10-Jan-2013.
>
> Ted's suggestion (to cover this in the RTCWEB interim) might do in a 
> pinch, but really, MMUSIC WG has to develop a sense of urgency on 
> this.  If things keep going as they have, by the time we get published 
> RFCs out of MMUSIC,  implementations will have been in the field for 
> years.
>
The MMUSIC WG is driven by the contributions, discussions, and 
ultimately rough consensus of its participants, just like any other WG. 
The active participants on the topics of interest here seem to be 
largely the same in the two groups, so I'm not sure exactly what you are 
looking for or proposing here, but constructive suggestions are always 
welcome.

Thanks

-- Flemming (MMUSIC co-chair)

> "tough love" and on the front page of the National Enquirer for the 
> Nth time.
>
>
>
>
>

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 03 Jan 2013 21:51:07 -0500

On 1/2/13 5:25 PM, Eric Rescorla wrote:
>
>
> On Wed, Jan 2, 2013 at 11:44 AM, Bernard Aboba 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Cullen said:
>
>     "3) if we are going to have an MMUSIC face to face interim
>     meeting, it would need AD approval and 4 weeks notices which puts
>     us very close do the deadline so this needs to get sort out real
>     soon. "
>
>     apart from each other?  If travel is an issue, they can be
>     virtual.  EKR's issue list is a fine starting point, and there is
>     an informal IESG telechat tomorrow (3-Jan) as well as one on
>     10-Jan-2013.
>
>
> I'm not in principle opposed to "virtual" interims, but my general 
> feeling is
While I agree it would be helpful with more face-to-face time, I don't 
believe in relying on this as a mechanism for making continuous 
progress. These types of meetings are generally most productive when 
coupled with regular interaction among a core set of people that 
represent the different points of view in a particular matter and hence 
I would suggest formation of one or more design teams on select topics 
with regular conference calls (we'll need dedicated volunteers for 
those) - of course the output of these design teams will still need to 
be discussed in the WG at large.

One particular area to start with on the bundle/mmt discussion for 
example is to look at how the different proposals handle all existing 
SDP parameters and attributes to see how important their different 
approach really is.

Thanks

-- Flemming (as Individual)

> -Ekr
>
>
>     Ted's suggestion (to cover this in the RTCWEB interim) might do in
>     a pinch, but really, MMUSIC WG has to develop a sense of urgency
>     on this.  If things keep going as they have, by the time we get
>     published RFCs out of MMUSIC,  implementations will have been in
>     the field for years.
>
>     If MMUSIC were a Hollywood Celebrity, we'd be *way* past the time
>     for "tough love" and on the front page of the National Enquirer
>     for the Nth time.
>
>
>
>
>
>

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 04 Jan 2013 12:39:26 +0100

(cutting back to RTCWEB)

> I'm not really sure what to do here - given a key role of the chairs is largely to facilitate the discussions and meetings that Wg participants want to have,  guidance from participants of both MMU…
I have to disagree on principle - the role of the chairs is to drive the 
WG to complete its charter.
So the chairs have to set the agenda that allows us to make the maximum 
progress towards completing the charter; this is not a debating society.
The chairs serve at the pleasure of the AD, not the WG.
> 3) if we are going to have an MMUSIC face to face interim meeting, it would need AD approval and 4 weeks notices which puts us very close do the deadline so this needs to get sort out real soon.
I think that due to the inaction on this topic in MMUSIC, this ship (for 
physical interims) has sailed.
RTCWEB needs to make its plans for completing its charter accordingly.

---

From: Stefan Håkansson LK <[email-masked]>
Date: Tue, 8 Jan 2013 11:27:57 +0100

(Sorry for cross-posting).

> open issues. Honestly, we might even add more time for

One thing that I think we should discuss when there are protocol _and_ 
API people in the same room is call flows. We touched on it in the Lyon 
W3C meeting, but it was apparent that not everyone had the same view.

Perhaps this could be folded into the "accept/reject" discussion 
proposed in [1].

[1] http://lists.w3.org/Archives/Public/public-webrtc/2013Jan/0000.html