Subject: Re: [rtcweb] Conclusion statement for Recommended Audio Codecs call

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 24 Jan 2013 16:46:45 +0000

We have been running a call for consensus regarding Selecting Recommended Audio Codecs.

At this point the chairs are calling this as "no WG consensus". 

We can however note a strong interest in a non-normative listing of potentially important codecs including a description why they should be considered to be supported in WebRTC implementations. 

In lieu of additional normative text, we believe the WG discussion supports the inclusion of a new section on "Additional Relevant Codecs".  That can contain a list of codecs which are relevant in specific contexts, along with a short description of the context for each. Specifically there seems to be interest in understanding the advantages and costs of G.722, AMR, and AMR-WB. We hope that text would broaden understanding of the WebRTC use case contexts.

The WG chairs
Magnus, Ted and Cullen

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 27 Jan 2013 09:14:23 +0000

Hi WG chairs,

Clarification question: 

> In lieu of additional normative text, we believe the WG discussion
> supports the inclusion of a new section on "Additional Relevant Codecs".

Inclusion where? 

Thanks and Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Cullen Jennings (fluffy)
> Sent: Thursday, January 24, 2013 6:47 PM
> To: [email-masked]
> Subject: Re: [rtcweb] Conclusion statement for Recommended Audio Codecs
> call
> 
> 
> We can however note a strong interest in a non-normative listing of
> potentially important codecs including a description why they should be
> considered to be supported in WebRTC implementations.
> 
> In lieu of additional normative text, we believe the WG discussion
> supports the inclusion of a new section on "Additional Relevant Codecs".
> That can contain a list of codecs which are relevant in specific
> contexts, along with a short description of the context for each.
> Specifically there seems to be interest in understanding the advantages
> and costs of G.722, AMR, and AMR-WB. We hope that text would broaden
> understanding of the WebRTC use case contexts.
> 
> The WG chairs
> Magnus, Ted and Cullen
> 
> 
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Burger Eric <[email-masked]>
Date: Sun, 27 Jan 2013 14:38:39 -0500

A different document would be good. No need to to have an argument over non-normative text hold up publication.

---

From: Andrew Allen <[email-masked]>
Date: Sun, 27 Jan 2013 19:54:35 +0000

Eric

I totally agree.

I think this document as well as being purely informational is also likely to become obsolete long before the mandatory to implement codecs are no longer required to be implemented. As a result making this part of the normative document will likely mean regular updates or obsoletions of the normative document.

I also think such information with a scope as defined by Cullen discussing what codecs are currently used in other deployments and what the costs are is not just relevant to RTCweb but also SIP and MMUSIC as well so maybe this should be RAI area director sponsored and not a RTCweb WG document.

Andrew 

----- Original Message -----
From: Burger Eric [mailto:[email-masked]]
Sent: Sunday, January 27, 2013 01:38 PM Central Standard Time
To: Cullen Jennings (fluffy) <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [rtcweb] Conclusion statement for Recommended Audio Codecs call

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 27 Jan 2013 20:08:26 +0000

+1

Dan

> Of Burger Eric
> Sent: Sunday, January 27, 2013 9:39 PM
> To: Cullen Jennings (fluffy)
> Cc: [email-masked]
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of Cullen Jennings (fluffy)
> >> potentially important codecs including a description why they should
> >> be considered to be supported in WebRTC implementations.
> >>
> >> Specifically there seems to be interest in understanding the
> >> advantages and costs of G.722, AMR, and AMR-WB. We hope that text
> >> would broaden understanding of the WebRTC use case contexts.
> >>
> >> The WG chairs
> >> Magnus, Ted and Cullen
> >>
> >>

---

From: Bernard Aboba <[email-masked]>
Date: Sun, 27 Jan 2013 13:04:21 -0800

I agree.

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 28 Jan 2013 09:12:01 +0100

Hi,

We chairs was considering inclusion in draft-ietf-webrtc-audio, but we
didn't have any strong opinions on this. Based on that several WG
participants thinks this should be an independent document, I thus
decided that we will start out with an independent document. If the WG
feels differently later we can always fold the text into the audio codec
and processing requirements document.

I would recommend that the individuals interested in contributing a
codec writes an independent submission with focus on the codec
considerations around the codec(s) they are interested in. Then we can
merge this into a common WG document.

Cheers

Magnus

-- 

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 28 Jan 2013 07:19:58 -0700

I've received a bunch of emails on this. So just to try and be clear, what the chairs sent out was there was "no consensus" on the questions we asked. The question of what, if any additional MTI audio codecs might get added is not resolved in any way.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 28 Jan 2013 16:29:48 +0100

Tell me how that does not take us back to a position where you have already failed to obtain consensus.

Keith

> Of Bernard Aboba
> Sent: 27 January 2013 21:04
> To: Romascanu, Dan (Dan)
> Cc: Cullen Jennings (fluffy); Burger Eric; [email-masked]
> Behalf
> >> On Jan 27, 2013, at 4:14 AM, "Romascanu, Dan (Dan)"
> <[email-masked]>
> >> wrote:
> >>
> >>> Hi WG chairs,
> >>>
> >>> Clarification question:
> >>>

---

From: <[email-masked]>
Date: Mon, 28 Jan 2013 16:02:56 +0000

Hello,

> We chairs was considering inclusion in draft-ietf-webrtc-audio, but we didn't have any strong opinions on this
> I thus decided that we will start out with an independent document

If the Chairs have still no strong opinion about this, I would request to leave this somewhat editorial issue still open.

It makes more sense that all the relevant information for audio and especially the relevant codecs with their different status be clearly listed in the same "webrtc audio" specification. Especially because we want to address the same interoperability issue.
This will be more consistent and readable.

Then, if more informative text on additional codecs is needed, a separate document can be considered to avoid overloading this webrtc audio document with purely informative text.

Stéphane	

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Magnus Westerlund
Envoyé : lundi 28 janvier 2013 09:12
À : Romascanu, Dan (Dan)
Cc : Cullen Jennings (fluffy); [email-masked]
Objet : Re: [rtcweb] Conclusion statement for Recommended Audio Codecs call

Hi,

We chairs was considering inclusion in draft-ietf-webrtc-audio, but we didn't have any strong opinions on this. Based on that several WG participants thinks this should be an independent document, I thus decided that we will start out with an independent document. If the WG feels differently later we can always fold the text into the audio codec and processing requirements document.

I would recommend that the individuals interested in contributing a codec writes an independent submission with focus on the codec considerations around the codec(s) they are interested in. Then we can merge this into a common WG document.

Cheers

Magnus

-- 

Magnus Westerlund

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 28 Jan 2013 17:11:01 +0100

Hi Stéphane,

Fair points, however, I am strongly believe that what is most relevant
now is that the people interested in this actually generate some text.
Thus having people submit text in individual documents. Then based on
what we have and the WG's reaction to such text(s) we can decide if it
makes more sense to fold it into the existing audio WG document or
create a new WG document.

Cheers

Magnus

-- 

Magnus Westerlund

---

From: Cameron Byrne <[email-masked]>
Date: Mon, 28 Jan 2013 08:54:49 -0800

> A different document would be good. No need to to have an argument over non-normative text hold up publication.

+1 for a different informational document that can wax poetically
about all the possible codecs that MAY be used..  And as always, you
can use whatever codec your peers choose too use.

CB