Subject: Re: [rtcweb] Call for Consensus Regarding Selecting Recommended Audio Codecs

From: Bernard Aboba <[email-masked]>
Date: Wed, 26 Dec 2012 15:52:01 -0800

I quite liked "thawing" actually - since the audio codecs in question are frozen from a distant era :)
________________________________
From: Cullen Jennings (fluffy)<mailto:[email-masked]>
Sent: ‎12/‎26/‎2012 1:14 PM
To: Eric Burger<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [rtcweb] Call for Consensus Regarding Selecting Recommended Audio Codecs

On Dec 26, 2012, at 10:18 AM, Cullen Jennings <[email-masked]> wrote:

>
> On Dec 25, 2012, at 5:29 AM, Eric Burger <[email-masked]> wrote:
>
>>
>> We then either have a nice big section in this present document describing the current state of the art of various networks with various codecs *OR* we have an Informational Implementor's Guide that describes the current state of the art of various networks, as well as the pitfalls of popular but hard codecs, like G.722.
>
> Would someone be willing to summarize a list of codecs that at some people have argued strongly in favor of along with the main advantage of thawing that codec. I'm thinking of a list that looks something like
>
> AMR-WB   Gets you interop with existing 3GPP
>
> Having a list like this would be a handy quick references to discussion.
>
>

Change  "thawing"  to "having" in above

(Curse you autocorrect)

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Eric Burger <[email-masked]>
Date: Thu, 27 Dec 2012 09:31:46 -0500

Bernard said this as a joke, but as many think there is some truth behind every joke, this *is* the issue. By the time we finish the work group, ideally in 2015 (Cullen - thanks for the CDN 100!), *all* of the codecs that someone thinks is really important to have implemented OR ELSE will be passé, obsolete, or their patents expired.

That is why I do not see the value of publishing a long list of SHOULD codecs to implement. It would be much more useful to implementers to explain which codecs go to what and why.

Now, if we can agree on some good codecs that MUST be implemented, I can get behind that.

Happy Holidays,
Eric

On Dec 26, 2012, at 6:52 PM, Bernard Aboba <[email-masked]> wrote:

> From: Cullen Jennings (fluffy)
> To: Eric Burger; [email-masked]

---

From: "Ken Fischer" <[email-masked]>
Date: Thu, 27 Dec 2012 09:10:03 -0700

+1

Ken

On 12/27/12 7:31 AM, "Eric Burger" <[email-masked]> wrote:

>Bernard said this as a joke, but as many think there is some truth 
>behind every joke, this *is* the issue. By the time we finish the work 
>group, ideally in 2015 (Cullen - thanks for the CDN 100!), *all* of the 
>codecs that someone thinks is really important to have implemented OR 
>ELSE will be passé, obsolete, or their patents expired.
>
>That is why I do not see the value of publishing a long list of SHOULD 
>codecs to implement. It would be much more useful to implementers to 
>explain which codecs go to what and why.
>
>> Sent: 12/26/2012 1:14 PM
>> >> We then either have a nice big section in this present document
>>describing the current state of the art of various networks with 
>>various codecs *OR* we have an Informational Implementor's Guide that 
>>describes the current state of the art of various networks, as well as 
>>the pitfalls of popular but hard codecs, like G.722.
>> > 
>> > Would someone be willing to summarize a list of codecs that at some
>>people have argued strongly in favor of along with the main advantage 
>>of thawing that codec. I'm thinking of a list that looks something 
>>like
>> >