Subject: Re: [rtcweb] [MMUSIC] SDP work needed for WebRTC stuff

From: Eric Rescorla <[email-masked]>
Date: Sat, 8 Dec 2012 15:21:06 -0800

+rtcweb

On Sat, Dec 8, 2012 at 2:41 PM, Cullen Jennings (fluffy)
<[email-masked]>wrote:

>
> I was looking over everything that needs to be completed to finish a fist
> cut of the WebRTC related work. There are a handful of big SDP problems
> that are currently blocking some of the WebRTC work and I'd like to figure
> out how to make some progress on them.
>
> Let me loosely characterize them as
>
> 1) If we have several video streams, how do theses map up to 1 or more m
> lines.
>
> 2) if we are doing port multiplexing, what does the SDP look like (the
> bundle problem)
>
> 3) How do we map the RTCWeb track and stream label concepts to identifiers
> in SDP
>
> 3) SDP for application running over SCTP/DTLS
>

I don't want to speak for all the various chairs but I am under the
> impression that most of chairs of related groups in W3C and IETF believe
> these are issues that need to be resolved primarily in the MMUSIC WG and
> that they impact both WebRTC and CLUE as well as the general long term use
> of SDP in SIP and other protocols.
>
> I'd like to get some discussion going on how we can make some progress on
> these. I don't think we are going to solve these in 20 minutes of
> discussion at an IETF meeting so I think we probably need some interim
> (virtual or face to face) to sort this out.
>
> Thoughts?
>

Wow, I'm totally confused here.

I had assumed that the SDP-related issues were going to be the main
topics at the WebRTC/RTCWEB interim in January. Is that not the case?

IMO the lack of clarity around how to encode various media
configurations into SDP is the major thing blocking progress here. In
particular, Firefox has opted not to implement multiplexing of media
streams over the same transport flow (whether of the bundle or
multiple m-line variety) until the SDP for it is well-defined. The
same thing applies to the question of how to map multiple m-lines to
incoming MediaStreams/Tracks.

We really need to cover these issues in the interim.

-Ekr

---

From: Martin Thomson <[email-masked]>
Date: Sat, 8 Dec 2012 15:27:50 -0800

> We really need to cover these issues in the interim.

+1.  I would have said *resolve* rather than cover, but I'm learning
not to be too optimistic in these matters.  Still, an outcome of one
form or other would be nice.

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Sun, 9 Dec 2012 00:19:46 +0000

On Dec 8, 2012, at 4:21 PM, Eric Rescorla <[email-masked]> wrote:

> +rtcweb
> 
> On Sat, Dec 8, 2012 at 2:41 PM, Cullen Jennings (fluffy) <[email-masked]> wrote:
> 
> I was looking over everything that needs to be completed to finish a fist cut of the WebRTC related work. There are a handful of big SDP problems that are currently blocking some of the WebRTC work and I'd like to figure out how to make some progress on them.
> 
> 1) If we have several video streams, how do theses map up to 1 or more m lines.
> 
> 2) if we are doing port multiplexing, what does the SDP look like (the bundle problem)
> 
> 3) How do we map the RTCWeb track and stream label concepts to identifiers in SDP
> 
> I don't want to speak for all the various chairs but I am under the impression that most of chairs of related groups in W3C and IETF believe these are issues that need to be resolved primarily in the MMUSIC WG and that they impact both WebRTC and CLUE as well as the general long term use of SDP in SIP and other protocols.
> 
> I'd like to get some discussion going on how we can make some progress on these. I don't think we are going to solve these in 20 minutes of discussion at an IETF meeting so I think we probably need some interim (virtual or face to face) to sort this out.
> 
> Thoughts?
> 

So far the interim was only talking about being a WebRTC & RTCWeb so this SDP stuff would be out of scope. Perhaps it would be better to have some of the time for mmusic topics?

---

From: Ron Even <[email-masked]>
Date: Sun, 9 Dec 2012 09:10:45 +0200

Hi Cullen,
I agree that we need to put more effort into this work and am willing to be
part of it.
You mentioned CLUE and we have the mapping of RTP streams to CLUE media
captures as a topic, discussed in CLUE.
 We started some work during the Atlanta meeting and it is supposed to be
discussed on the RAI mailing list since it involves multiple RAI WGs but
this is just the formality
Roni Even

On Sunday, December 9, 2012, Cullen Jennings (fluffy) wrote:

>
> On Dec 8, 2012, at 4:21 PM, Eric Rescorla <[email-masked] <javascript:;>>
> wrote:
>
> > +rtcweb
> >
> > On Sat, Dec 8, 2012 at 2:41 PM, Cullen Jennings (fluffy) <
> [email-masked] <javascript:;>> wrote:
> >
> > I was looking over everything that needs to be completed to finish a
> fist cut of the WebRTC related work. There are a handful of big SDP
> problems that are currently blocking some of the WebRTC work and I'd like
> to figure out how to make some progress on them.
> >
> > I'd like to get some discussion going on how we can make some progress
> on these. I don't think we are going to solve these in 20 minutes of
> So far the interim was only talking about being a WebRTC & RTCWeb so this
> SDP stuff would be out of scope. Perhaps it would be better to have some of
> the time for mmusic topics?
>
>
> >
> _______________________________________________
> mmusic mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 10 Dec 2012 14:16:27 +0100

This is not just MMUSIC, there are bits of AVTCORE and AVTEXT responsibility in there as well.

And I don't see how you can suddenly extend the interim of RTCWEB to the scope of other working groups, without even having a discussion with all the relevant chairs.

I'd further note that Jonathan Lennox has an action (with the support of quite a number of other people) to produce an internet draft on trying to sort out the terminology concents that exist within RTP at the moment. This would be the basis for progressing a number of these issues. That would probably have to be an RAI wide draft.

There has been some progress on this - maybe Jonathan can report on where this now is. I know he was waiting on volunteers for some of the sections and on input from others where volunteers already existed.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Cullen Jennings (fluffy)
> Sent: 09 December 2012 00:20
> To: Eric Rescorla
> Cc: <[email-masked]>; mmusic WG; <[email-masked]>
> Subject: Re: [MMUSIC] SDP work needed for WebRTC stuff
> 
> 
> <[email-masked]> wrote:
> >
> SDP stuff would be out of scope. Perhaps it would be better to have some
> of the time for mmusic topics?
> 
> 
> >
> [email-masked]

---

From: Ted Hardie <[email-masked]>
Date: Mon, 10 Dec 2012 09:36:27 -0800

On Mon, Dec 10, 2012 at 5:16 AM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

> And I don't see how you can suddenly extend the interim of RTCWEB to the
> scope of other working groups, without even having a discussion with all
> the relevant chairs.
>
>
That's not how I read the overall sentiment--people are simply saying that
they need this work done and are willing to put in the effort to get it
done.  It would, in fact, be ideal if some of the MMUSIC questions were
resolve *before* an RTCWEB/WEBRTC interim, as we can then work through what
is decided.

Put another way, I take it as encouragement to MMUSIC folks that they would
find a January virtual interim very well received/attended.

Ted

> I'd further note that Jonathan Lennox has an action (with the support of
> quite a number of other people) to produce an internet draft on trying to
> sort out the terminology concents that exist within RTP at the moment. This
> would be the basis for progressing a number of these issues. That would
> probably have to be an RAI wide draft.
>
> There has been some progress on this - maybe Jonathan can report on where
> this now is. I know he was waiting on volunteers for some of the sections
> and on input from others where volunteers already existed.
>
> Keith
>

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 10 Dec 2012 11:31:08 -0800

> This is not just MMUSIC, there are bits of AVTCORE and AVTEXT responsibility in there as well.

can you add a bit on what is needed in these WG just so I can keep track of it all

> And I don't see how you can suddenly extend the interim of RTCWEB to the scope of other working groups, without even having a discussion with all the relevant chairs.

I did not mean to do any such thing - obviously the MMUSIC WG would need to decide what to how it was going to do the work. All I was trying to say is there are some things that I think needs to be done in MMUSIC and I view it as out of scope for rtcweb. This clearly came as a surprise to some people who thought that was the main thing the interim meeting was going to be about. As an individual contributor for to the MMUSIC wg, I think that mmusic needs to figure out a substantial block of face to face time to sort out these SDP issues. I look forward to proposals on how to do that.

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 10 Dec 2012 17:18:17 -0800

I feel like the priorities here are kind of confused.

It seems to me that the purpose of having a physical interim is to resolve
issues that are hard to resolve on the list or teleconferences. As I
mentioned
earlier, the SDP issues are the most important to resolve now and have
also proven to be among the most intractable. How does it make sense
to try to resolve those at a "virtual" interim while having people fly
to a "physical" interim for three days?

I would strongly encourage the chairs to figure out how to have at least
one of the days of this interim devoted solely to resolving the SDP
issues (really, my preference would be to take these issues one at
a time and do nothing else until they are resolved!). I'm not expert
enough at the RAI WG mechanics to know what's required, so perhaps
this requires making this also an MMUSIC interim or a mini-RAI interim,
but if so that's what we should do, even if it means we need to reschedule
or move it.

Best,
-Ekr

On Mon, Dec 10, 2012 at 9:36 AM, Ted Hardie <[email-masked]> wrote:

> Put another way, I take it as encouragement to MMUSIC folks that they
> would find a January virtual interim very well received/attended.
>
> Ted
>
>
>

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Dec 2012 17:29:26 -0800

If there is a way to make this happen, that would be good.  If not, then I
think the only realistic option available to rtcweb would be to drop
bundle, etc... That wouldn't be popular.
On Dec 10, 2012 5:19 PM, "Eric Rescorla" <[email-masked]> wrote:

>> That's not how I read the overall sentiment--people are simply saying
>> that they need this work done and are willing to put in the effort to get
>> it done.  It would, in fact, be ideal if some of the MMUSIC questions were
>>> There has been some progress on this - maybe Jonathan can report on
>>> where this now is. I know he was waiting on volunteers for some of the
>>> sections and on input from others where volunteers already existed.
>>>
>>> Keith
>>>

---

From: Maire Reavy <[email-masked]>
Date: Mon, 10 Dec 2012 22:08:21 -0500

I agree with Ekr on all points.  We have put off resolving the SDP 
issues as long as we can, and the lack of resolution has started to 
impact our WebRTC implementation (in Firefox) already.  I feel we need 
to maximize our chances of resolving the SDP issues as soon as we can.

To me that means meeting in person as soon as possible to hammer this 
stuff out.

Please let's find a way to discuss this in person.  I think it's a big 
mistake if we rely on a virtual meeting only.

Thanks.
-Maire

On 12/10/2012 8:18 PM, Eric Rescorla wrote:
> On Mon, Dec 10, 2012 at 9:36 AM, Ted Hardie <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     On Mon, Dec 10, 2012 at 5:16 AM, DRAGE, Keith (Keith)
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         And I don't see how you can suddenly extend the interim of
>         RTCWEB to the scope of other working groups, without even
>         having a discussion with all the relevant chairs.
>
>
>     That's not how I read the overall sentiment--people are simply
>     saying that they need this work done and are willing to put in the
>     effort to get it done.  It would, in fact, be ideal if some of the
>     MMUSIC questions were resolve *before* an RTCWEB/WEBRTC interim,
>     as we can then work through what is decided.
>
>     Put another way, I take it as encouragement to MMUSIC folks that
>     they would find a January virtual interim very well received/attended.
>
>     Ted
>
>         I'd further note that Jonathan Lennox has an action (with the
>         support of quite a number of other people) to produce an
>         internet draft on trying to sort out the terminology concents
>         that exist within RTP at the moment. This would be the basis
>         for progressing a number of these issues. That would probably
>         have to be an RAI wide draft.
>
>         There has been some progress on this - maybe Jonathan can
>         report on where this now is. I know he was waiting on
>         volunteers for some of the sections and on input from others
>         where volunteers already existed.
>
>         Keith
>
>         > From: [email-masked]
>         <mailto:[email-masked]>
>         [mailto:[email-masked]
>         <mailto:[email-masked]>] On Behalf
>         > Cc: <[email-masked] <mailto:[email-masked]>>; mmusic WG;
>         <[email-masked] <mailto:[email-masked]>>
>         > On Dec 8, 2012, at 4:21 PM, Eric Rescorla <[email-masked]
>         <mailto:[email-masked]>> wrote:
>         >
>         > > +rtcweb
>         > >
>         > <[email-masked] <mailto:[email-masked]>> wrote:
>         > >
>         > [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]>
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 10 Dec 2012 21:01:52 -0800

I do not think that a single meeting, virtual or actual, will suffice to get
things back on track.  We need a fundamental change of approach. 

The basic problem is that WebRTC work items have been dispersed between a
number of WGs other than RTCWEB.  Within these WGs, WebRTC is only a
sideline. 

As a result, work items such as BUNDLE (which require non-trivial analysis
and discussion) have found themselves a needle in a haystack of other items,
getting a fraction of the attention that they need to move forward.  

While allocating some substantial time at an in-person RTCWEB/MMUSIC interim
can help, for that time to be well spent will require substantial
preparation.  As an example, I could see a virtual AVTEXT interim being
scheduled for mid-January at which Jonathan Lennox's hierarchy draft could
be given substantial time and an MMUSIC virtual interim in the same time
frame which could be devoted to one or two important topics (e.g. BUNDLE,
SCTP).

If that is done, then the issues requiring additional intensive work might
be narrowed to the point where an in-person meeting in early February might
be able to finish some of them off, with others handled another round of
virtual interims two weeks later. 

Bernard "MARTINI was hell - but it only lasted a year" Aboba

I'm not expert enough at the RAI WG mechanics to know what's required, so
perhaps

or move it.

---

From: Stefan Hakansson LK <[email-masked]>
Date: Tue, 11 Dec 2012 11:59:29 +0100

On 12/11/2012 06:01 AM, Bernard Aboba wrote:
> I do not think that a single meeting, virtual or actual, will suffice to
> get things back on track.  We need a fundamental change of approach.
>
> The basic problem is that WebRTC work items have been dispersed between
> a number of WGs other than RTCWEB.  Within these WGs, WebRTC is only a
> sideline.
>
> As a result, work items such as BUNDLE (which require non-trivial
> analysis and discussion) have found themselves a needle in a haystack of
> other items, getting a fraction of the attention that they need to move
> forward.

I'd say that Bundle is something that comes on top of more fundamental 
things (such as the representation of multiple streams and transports in 
SDP) needing resolution. If I have to prioritize I would do the 
fundamentals first and worry about Bundle later.

>
> While allocating some substantial time at an in-person RTCWEB/MMUSIC
> interim can help, for that time to be well spent will require
> substantial preparation.  As an example, I could see a virtual AVTEXT
> interim being scheduled for mid-January at which Jonathan Lennox’s
> hierarchy draft could be given substantial time and an MMUSIC virtual
> interim in the same time frame which could be devoted to one or two
> important topics (e.g. BUNDLE, SCTP).

I think this is a great idea!

Stefan

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 12 Dec 2012 11:37:24 +0100

Hi,

My Personal view on this topics.

> get things back on track.  We need a fundamental change of approach.

Fully agreed. One of the issues, is that not a single individual of use
across 5-6 WG have a complete picture of the issues we are stepping into
with the fundamental issues that are in the center of this. This will
require multiple individuals having knowledge on different aspects to
fill in details and educate the others on the diverse issues.

> a number of WGs other than RTCWEB.  Within these WGs, WebRTC is only a

I am not certain that is the fundamental issue here. I think the very
basic problem is that we are attempting for fork lift SDP into a clear
specification supporting multi-stream RTP sessions and dealing with the
diverse landscape of relationships that exists in multi-media
applications between a large number of terminologies that include
concepts such as:

- Multi-party
- Multiple media sources, i.e. camera microphones
- Media Mixes or Compositions
- Synchronization Contexts
- End-point concepts, virtual, distributed, etc.
- Diverse signalling models
- Simulcast
- Layered Encoding
- Transport robustification, i.e RTP Retransmission, Duplications, FEC.
- Different transports, aggregated over single unicast, multiple unicast
flows, multicast
- Different security mechanisms

This coupled with that the people putting in requirements on this are
working on different type of systems or applications, RTCWEB/WebRTC and
CLUE just being two. We also have existing users of RTP that made
different assumptions in extensions and signalling.

It was very evident in RTCWEB and AVTEXT that we are lacking common
terminology to even discuss the above and what it means in different
contexts.

Then we haven't even discussed what happens the minute you drag the word
"Legacy" into any of the above debates for actual solutions. But now I
am getting ahead of myself. I think the most important is to build a
good description of the different functionalities and their
relationships that we today believe are necessary to deal with currently
and in the near future.

> other items, getting a fraction of the attention that they need to move

Yes, bundle is something that covers parts of the above and clearly
related. I, however think more close to the core of the issues is the
multiple stream issues and how we deal with relationships. However, I
think failing to take the related topics into account and think that
this will be quickly resolved will only result in generating even more
mess.

I also believe that in the end we are going to have to take some though
decisions when it comes how to deal with existing definitions. Either
replace them or basically deprecate some behaviors.

> important topics (e.g. BUNDLE, SCTP).

Fully agreed. This takes preparations and hard work.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Mon, 24 Dec 2012 07:35:47 -0000

> I was looking over everything that needs to be completed to finish a fist
 cut of the WebRTC related work. There are a handful of big SDP problems that
 are currently blocking some of the WebRTC work and I'd like to figure out
 how to make some progress on them.
 lines.
 bundle problem)
 in SDP
> I don't want to speak for all the various chairs but I am under the
 impression that most of chairs of related groups in W3C and IETF believe these are
 issues that need to be resolved primarily in the MMUSIC WG and that they
 impact both WebRTC and CLUE as well as the general long term use of SDP in SIP
 and other protocols.
> I'd like to get some discussion going on how we can make some progress on
 these. I don't think we are going to solve these in 20 minutes of discussion
 at an IETF meeting so I think we probably need some interim (virtual or
 face to face) to sort this out.