Subject: Re: [rtcweb] Review of draft-ietf-rtcweb-jsep-02

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 10 Dec 2012 16:34:35 +0000

On  23 November 2012 10:45 Harald Alvestrand Wrote

> I think we're close to where we need to be on this doc. But still some
> work to be done.
> Nits will be sent to the authors - I thought I'd raise some bigger
> issues here.
> 
> First is the positioning of this draft.
> 
> I believe that the draft should reference the W3C API document and say
> "that one is the authoritative reference for what the API looks like;
> this document shows how the calls from that API are actually affecting
> the media configuration and media bits on the wire".
> This is important enough that it needs to be clear from the abstract
> and
> from the intro.
> 

I agree that it should state the W3C API Spec is the authoritative reference but does that mean that the W3C API has to clearly define the SDP Usage and that questions about SDP usage should be directed at the W3C mailing list, I assume not. 

I previously sent some comments on jsep-02 which were kindly placed in the tracker (See http://trac.tools.ietf.org/wg/rtcweb/trac/ticket/3#) some of which refer to how the API generates/uses SDP. I am not sure now how these will be addressed.

For example take comment 11 which relates to what SDP is generated by calling createOffer in an established dialog. Is this something that will be eventually described in the W3C API or will the W3C API also reference an IETF document which details the SDP usage (i.e. JSEP)?

Regards
Andy

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 10 Dec 2012 19:17:12 +0100

> For example take comment 11 which relates to what SDP is generated by calling createOffer in an established dialog. Is this something that will be eventually described in the W3C API or will the W3…
I believe the JSEP draft needs to position itself as authoritative for 
what SDP gets generated and parsed, how ICE is started, stopped and 
changed, and how RTP is configured.

The W3C API spec is authoritative for what the Javascript API calls mean.
Making sure they stay consistent .... well, that's why they have 
overlapping editor sets.