Subject: [rtcweb] Fax usecase in WebRTC [was FW: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))]

From: "Parthasarathi R" <[email-masked]>
Date: Mon, 26 Nov 2012 23:05:00 +0530

Hi all,

There is a long discussion in MMUSIC whether Fax usecase has to be added in
RTCWeb or not
(http://www.ietf.org/mail-archive/web/mmusic/current/msg09939.html). 

I’m forwarding this mail to this WG to see the actual interest for fax
usecase.

Thanks

Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of
DRAGE, Keith (Keith)
Sent: Monday, November 26, 2012 3:26 PM
To: Bernard Aboba; Stefan Håkansson LK
Cc: [email-masked]
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought:
Prioritization of codecs))

Be careful to address this issue from a worldwide context rather than a
North America specific one.

There are still plenty of people raising fax issues from the Asian
countries.

Keith

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bernard Aboba
Sent: 25 November 2012 19:44
To: Stefan Håkansson LK
Cc: [email-masked]
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought:
Prioritization of codecs))

Stefan said:

> I don't think this goes for fax, I think fax these days is only used by 
> certain (few) organizations and only for certain types of communication.
> 
> But if you think differently, please make a proposal on the rtcweb mail
list!

[BA]  Given the steep decline in landlines, POTS is on the road to becoming
economically non-viable by the end of the decade, if not sooner.   Once POTS
shuts down, the legal and regulatory requirements which prop up the use of
fax will need to be re-thought.  IMHO given the bleak future of fax,
supporting it in WebRTC is not worth the effort. 

BTW, support for RFC 4733 (DTMF) is now required in
draft-ietf-rtcweb-audio-01 instead of  RFC 4734 (Fax, Modem and Text
Telephony) which was cited (mistakenly) in -00.   

Bernard "Spent several hours debugging T.38 last week" Aboba

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 26 Nov 2012 17:33:50 -0500

Well first .. fax is a globally significant real time PSTN service that is
NOT going away any time soon no matter what anyone in the IETF thinks.   In
fact some of the current market statistics indicate low single digit growth
in the service irrespective of the decline in landlines. 

As Bernard correctly points out a good portion of the FAX traffic is
generated by national regulatory requirements and the fact that the
transaction cannot be repudiated since the call records kept by the carrier
are considered legally valid.  “All contract submissions must be delivered
by close of business XXX EST either by currier or FAX”   

Email is considered not secure and the SMTP transaction logs are not legally
valid in any jurisdiction I know of .  That’s the way it is.  Don’t like it?
You go try and change the laws here.   

The number of industries that rely on fax are endless and it a particularly
important service in nation states where non roman characters are used.
Asia,  Middle East etc.  

That said ..do you really want to go down this road? Probably not right now
since the non repudiation issue is the one requirement I doubt RTCWEB is
prepared to address. However if the RTCWEB transaction gateways into the
Public SIP Network than its another issue. 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Parthasarathi R
Sent: Monday, November 26, 2012 12:35 PM
To: 'DRAGE, Keith (Keith)'; 'Bernard Aboba'; 'Stefan Håkansson LK'
Cc: [email-masked]
Subject: [rtcweb] Fax usecase in WebRTC [was FW: [MMUSIC] T.38 (Re: M-line
philosophy (Re: Wisdom sought: Prioritization of codecs))]

Hi all,

Thanks

Partha

Keith

  _____  

list!

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 26 Nov 2012 14:49:53 -0800

Richard said:

"Probably not right now since the non repudiation issue is the one requirement I doubt RTCWEB is prepared to address. However if the RTCWEB transaction gateways into the Public SIP Network than its another issue."

[BA] Excellent point.  Converting an incoming fax to TIFF/JPEG/PDF for display on the Web or email is a useful feature, but those converted files will not be admissable.  Similarly, writing a Web application to send faxes from an uploaded file is also useful (and is doable without WebRTC), but the uploaded file also will not be admissable (though the received fax might be).  Given this, it is not even clear to me that implementing T.38 in the browser would actually help, because the received fax would need to be digitally stored and displayed in some way, and once the conversion is done, the non-repudiation property is lost.

---

From: [email-masked] (Dale R. Worley)
Date: Mon, 26 Nov 2012 18:01:54 -0500 (EST)

My experience is that fax is still used heavily, even over VoIP,
especially in the legal world.

Over PSTN, fax provides non-repudiation, and that isn't as easy to
provide in a VoIP or WebRTC context.  But I think other factors are
important:

- Unlike e-mail, fax provides real-time end-to-end confirmation to the
sender that the receiver's device received the document.

- Fax duplicates the structure of paper documents, with which users
are extremely familar.  In particular, fax images can include
signature images.  Of course, signature images are trivially easy to
forge, but in most legal disputes, forgery is not a question, but
instead, "deliberation" is -- Did the party formally consent to the
document?  Due to the immense cultural history of signatures, every
party can generally assume that every other party has the same
understanding of what affixing a signature implies.

Based on these considerations, I expect fax to be an important form of
communications for several more decades.

Dale

---

From: Steve Sokol <[email-masked]>
Date: Mon, 26 Nov 2012 17:56:36 -0600 (CST)

You describe fax as a "significant real time PSTN service" and you mention that the reason fax is considered sacrosanct is, in part, the chain of custody that carrier records represent. Since RTCWEB != PSTN and since there is no regulated entity charged with generating and retaining transactional records for WebRTC sessions, I don't see how any kind of fax solution built into/on RTCWEB would be "Fax" in the legal sense. 

More importantly, the entire RTCWEB/WebRTC project is focused on defining the future of communications. One of the greatest failings of every VoIP technology up to this point has been the tendency to recreate the PSTN rather than defining an new paradigm. H.323 was PSTN-over-IP-v1.0. SIP has become PSTN-over-IP-v2.0. Please don't distract us from building the future by requiring that we re-create the past. 

By actively deciding to not incorporate fax into any future protocol, we may help drive the "right" fix this problem: changes in legislation, improvements in authentication and encryption in email, or some other approach. 
----- Original Message -----

> Well first .. fax is a globally significant real time PSTN service
> that is NOT going away any time soon no matter what anyone in the
> IETF thinks. In fact some of the current market statistics indicate
> low single digit growth in the service irrespective of the decline
> in landlines.

> transaction cannot be repudiated since the call records kept by the
> carrier are considered legally valid. “All contract submissions must
> be delivered by close of business XXX EST either by currier or FAX”

> Email is considered not secure and the SMTP transaction logs are not
> legally valid in any jurisdiction I know of . That’s the way it is.
> Don’t like it? You go try and change the laws here.

> The number of industries that rely on fax are endless and it a
> particularly important service in nation states where non roman
> characters are used. Asia, Middle East etc.

> That said ..do you really want to go down this road? Probably not
> right now since the non repudiation issue is the one requirement I
> doubt RTCWEB is prepared to address. However if the RTCWEB
> transaction gateways into the Public SIP Network than its another
> issue.

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Parthasarathi R
> Subject: [rtcweb] Fax usecase in WebRTC [was FW: [MMUSIC] T.38 (Re:
> M-line philosophy (Re: Wisdom sought: Prioritization of codecs))]

> There is a long discussion in MMUSIC whether Fax usecase has to be
> added in RTCWeb or not (
> http://www.ietf.org/mail-archive/web/mmusic/current/msg09939.html ).

> I’m forwarding this mail to this WG to see the actual interest for
> fax usecase.

> From: [email-masked] [ mailto:[email-masked] ] On
> Behalf Of DRAGE, Keith (Keith)

> Be careful to address this issue from a worldwide context rather than
> a North America specific one.

> From: [email-masked] [ mailto:[email-masked] ] On
> Behalf Of Bernard Aboba

> > But if you think differently, please make a proposal on the rtcweb
> > mail list!

> [BA] Given the steep decline in landlines, POTS is on the road to
> becoming economically non-viable by the end of the decade, if not
> sooner. Once POTS shuts down, the legal and regulatory requirements
> which prop up the use of fax will need to be re-thought. IMHO given
> the bleak future of fax, supporting it in WebRTC is not worth the
> effort.

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Roman Shpount <[email-masked]>
Date: Mon, 26 Nov 2012 19:35:28 -0500

Totally agree with Steve.

I do not understand why we need T.38 fax. In the worst case send fax as an
image over a datachannel or a simple POST to the server. For all practical
purposes this would be no different then T.37 fax transmission. T.38 fax is
complicated, unreliable, and should not exist for anything except legacy
interop, which would be much better served by some sort of gateway. We
would really complicated WebRTC code base by a feature that has no real use
case.
_____________
Roman Shpount

On Mon, Nov 26, 2012 at 6:56 PM, Steve Sokol <[email-masked]> wrote:

> You describe fax as a "significant real time PSTN service" and you mention
> that the reason fax is considered sacrosanct is, in part, the chain of
> custody that carrier records represent. Since RTCWEB != PSTN and since
> there is no regulated entity charged with generating and retaining
> transactional records for WebRTC sessions, I don't see how any kind of fax
> solution built into/on RTCWEB would be "Fax" in the legal sense.
>
> More importantly, the entire RTCWEB/WebRTC project is focused on defining
> the future of communications. One of the greatest failings of every VoIP
> technology up to this point has been the tendency to recreate the PSTN
> rather than defining an new paradigm. H.323 was PSTN-over-IP-v1.0. SIP has
> become PSTN-over-IP-v2.0. Please don't distract us from building the future
> by requiring that we re-create the past.
>
> By actively deciding to not incorporate fax into any future protocol, we
> may help drive the "right" fix this problem: changes in legislation,
> improvements in authentication and encryption in email, or some other
> approach.
>
> ------------------------------
>
> legally valid in any jurisdiction I know of .  That’s the way it is.  Don’t
> like it?  You go try and change the laws here.
>
>
>
> particularly important service in nation states where non roman characters
> are used.  Asia,  Middle East etc.
>
>
>
> That said ..do you really want to go down this road? Probably not right
> now since the non repudiation issue is the one requirement I doubt RTCWEB
> is prepared to address. However if the RTCWEB transaction gateways into the
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Parthasarathi R
> *Sent:* Monday, November 26, 2012 12:35 PM
> *To:* 'DRAGE, Keith (Keith)'; 'Bernard Aboba'; 'Stefan Håkansson LK'
> *Cc:* [email-masked]
> *Subject:* [rtcweb] Fax usecase in WebRTC [was FW: [MMUSIC] T.38 (Re:
> There is a long discussion in MMUSIC whether Fax usecase has to be added
> in RTCWeb or not (
> http://www.ietf.org/mail-archive/web/mmusic/current/msg09939.html).
>
>
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *DRAGE, Keith (Keith)
> *Sent:* Monday, November 26, 2012 3:26 PM
> *To:* Bernard Aboba; Stefan Håkansson LK
> *Cc:* [email-masked]
> *Subject:* Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought:
> ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Bernard Aboba
> *Sent:* 25 November 2012 19:44
> *To:* Stefan Håkansson LK
> *Cc:* [email-masked]
> *Subject:* Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought:
> becoming economically non-viable by the end of the decade, if not sooner.
> Once POTS shuts down, the legal and regulatory requirements which prop up
> the use of fax will need to be re-thought.  IMHO given the bleak future of
> fax, supporting it in WebRTC is not worth the effort.
>

---

From: Francois Audet <[email-masked]>
Date: Tue, 27 Nov 2012 03:08:59 +0000

Fax on H.323 was ridiculous back then, even more so over SIP. Now, with RTCwebit's totally Steam Punk! Next stop Telegraph over rtcweb?

On Nov 26, 2012, at 16:35, "Roman Shpount" <[email-masked]<mailto:[email-masked]>> wrote:

I do not understand why we need T.38 fax. In the worst case send fax as an image over a datachannel or a simple POST to the server. For all practical purposes this would be no different then T.37 fax transmission. T.38 fax is complicated, unreliable, and should not exist for anything except legacy interop, which would be much better served by some sort of gateway. We would really complicated WebRTC code base by a feature that has no real use case.
_____________
Roman Shpount

On Mon, Nov 26, 2012 at 6:56 PM, Steve Sokol <[email-masked]<mailto:[email-masked]>> wrote:
You describe fax as a "significant real time PSTN service" and you mention that the reason fax is considered sacrosanct is, in part, the chain of custody that carrier records represent. Since RTCWEB != PSTN and since there is no regulated entity charged with generating and retaining transactional records for WebRTC sessions, I don't see how any kind of fax solution built into/on RTCWEB would be "Fax" in the legal sense.

________________________________
Well first .. fax is a globally significant real time PSTN service that is NOT going away any time soon no matter what anyone in the IETF thinks.   In fact some of the current market statistics indicate low single digit growth in the service irrespective of the decline in landlines.

As Bernard correctly points out a good portion of the FAX traffic is generated by national regulatory requirements and the fact that the transaction cannot be repudiated since the call records kept by the carrier are considered legally valid.  “All contract submissions must be delivered by close of business XXX EST either by currier or FAX”

Email is considered not secure and the SMTP transaction logs are not legally valid in any jurisdiction I know of .  That’s the way it is.  Don’t like it?  You go try and change the laws here.

The number of industries that rely on fax are endless and it a particularly important service in nation states where non roman characters are used.  Asia,  Middle East etc.

That said ..do you really want to go down this road? Probably not right now since the non repudiation issue is the one requirement I doubt RTCWEB is prepared to address. However if the RTCWEB transaction gateways into the Public SIP Network than its another issue.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Parthasarathi R
Sent: Monday, November 26, 2012 12:35 PM
To: 'DRAGE, Keith (Keith)'; 'Bernard Aboba'; 'Stefan Håkansson LK'
Cc: [email-masked]<mailto:[email-masked]>
Subject: [rtcweb] Fax usecase in WebRTC [was FW: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))]

Hi all,

There is a long discussion in MMUSIC whether Fax usecase has to be added in RTCWeb or not (http://www.ietf.org/mail-archive/web/mmusic/current/msg09939.html).

I’m forwarding this mail to this WG to see the actual interest for fax usecase.

Thanks
Partha

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: Monday, November 26, 2012 3:26 PM
To: Bernard Aboba; Stefan Håkansson LK
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))

Be careful to address this issue from a worldwide context rather than a North America specific one.

There are still plenty of people raising fax issues from the Asian countries.

Keith

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Bernard Aboba
Sent: 25 November 2012 19:44
To: Stefan Håkansson LK
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] T.38 (Re: M-line philosophy (Re: Wisdom sought: Prioritization of codecs))

Stefan said:
> But if you think differently, please make a proposal on the rtcweb mail list!

[BA]  Given the steep decline in landlines, POTS is on the road to becoming economically non-viable by the end of the decade, if not sooner.   Once POTS shuts down, the legal and regulatory requirements which prop up the use of fax will need to be re-thought.  IMHO given the bleak future of fax, supporting it in WebRTC is not worth the effort.

BTW, support for RFC 4733 (DTMF) is now required in draft-ietf-rtcweb-audio-01 instead of  RFC 4734 (Fax, Modem and Text Telephony) which was cited (mistakenly) in -00.

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Tue, 27 Nov 2012 04:28:10 +0000

> [BA] Excellent point.  Converting an incoming fax to TIFF/JPEG/PDF for display on the Web or email is a useful feature, but those converted files will not be admissable.  Similarly, writing a Web a…

I think this is arguing that T.37 fax is not admissible and T.38 is admissible. Can anyone point at any case law to support that? 

I would like to point out that fax is not a real time problem and thus may not need all the optimizations of making it work browser to browser. Legacy fax gets stored and buffered in all kinds of ways and no one notices. I already read my faxes in a browser, and with GetUserMedia, I think I could write a web page that could send faxes too from my camera. Yes, the fax would go through the web server, but since it is not a real time applications, that seems like it might be OK. 

I do believe that faxes will be around for a long time to come - the idea has been around for a long time. See the Bain patent from 169 years ago which describes a fax machine. 

My experience has been that VoIP fax deployments that use G.711 and mark it voice band data have higher success rate for faxes that deployments that use T.38.