Subject: Re: [rtcweb] Incoming liaison statement from MPEG

From: "David Benham (dbenham)" <[email-masked]>
Date: Mon, 5 Nov 2012 16:38:03 +0000

> Apple deserves to be commended for making a royalty-free commitment, but it's a lonely position.

They do deserve such, however not that lonely.    Cisco's declaration was submitted previously, but against the wrong numbers (admin error).   Re-submission is underway and will have the same, royalty-free commitment.  

The more pronounced observation is that most declarations have not been not submitted yet in this still relatively young effort.

From: Harald Alvestrand [mailto:[email-masked]] 
Sent: Wednesday, October 24, 2012 11:25 PM
To: [email-masked]
Subject: Re: [rtcweb] Incoming liaison statement from MPEG

On 10/24/2012 10:58 PM, David Benham (dbenham) wrote:
To further connect dots, this part 29 effort in MPEG/IEC/ISO towards a non-royalty bearing solution was mentioned in our draft below as a potential upside to selecting H264/AVC constrained baseline profile today.  Unfortunately, the outcome will not be known soon enough, but to the extent future surprises weigh on our decision ... this one is positive!
FWIW, there have been 11 IPR submissions into the ISO registry on MPEG-4 part 29 to date; 1 of them specifies that the IPR is available on a royalty free basis, 10 do not. Unless I miscounted.

Apple deserves to be commended for making a royalty-free commitment, but it's a lonely position.

The registry of IPR submissions is available at http://www.iso.org/iso/standards_development/patents

http://tools.ietf.org/html/draft-dbenham-webrtc-videomti-00
6.4.  Future IPR Status Consideration
   For additional informative purposes, the MPEG/IEC/ISO made a call for
   a royalty-free video coding solution for the Internet.  As of its
   98th meeting, two tracks forward are being pursued; one of which is
   based on the H.264/AVC constrained baseline profile [AVC06].  MPEG is
   presently collecting patent licensing declarations that would include
   patent holder's royalty expectations unbundled from other higher
   profile mechanisms.  Should this effort result in a royalty-free
   constrained baseline profile, this would benefit RTCweb in the future
   if H.264/AVC is selected as mandatory today.

From: Stephan Wenger [mailto:[email-masked]] 
Sent: Wednesday, October 24, 2012 2:40 AM
To: [email-masked]; [email-masked]
Subject: [rtcweb] Incoming liaison statement from MPEG

Hi all,
Please find attached an incoming liaison statement from MPEG.  It's short, and therefore attached.  For those not familiar with MPEG's terminology: "AVC" stands for "Advanced Video Codec" and is used in certain circles for what other people know as H.264, and sometimes, depending on context, only for the non-scalable and non-multiview profiles of H.264.  (H.264 is the ITU designation for the joint standard).  MPEG-4 part 29, or WebVC is, as described in the statement, what most people know as "constrained baseline H.264", i.e. H.264 baseline without the rarely used tools known as Arbitrary Slice Order, Flexible Macroblock Order, and Redundant Slices.
Also, in order to avoid possible confusion, let me emphasize that this liaison statement comes from the standardization body known as MPEG (ISO/IEC JTC1/SC29/WG11 ) and not from the licensing administrator known as MPEG-LA.
Regards,
Stephan

_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: David Singer <[email-masked]>
Date: Mon, 05 Nov 2012 17:45:22 +0100

> The more pronounced observation is that most declarations have not been not submitted yet in this still relatively young effort.

Thanks

Also, we are aware that some of the submissions were more nuanced, and the nuance is lost.  For example, at least one was 'RAND, but will be RF if compatibility with AVC/H.264 is preserved'.

Yes, MPEG is trying to get more details from the secretariat.

> Also, in order to avoid possible confusion, let me emphasize that this liaison statement comes from the standardization body known as MPEG (ISO/IEC JTC1/SC29/WG11 ) and not from the licensing admin…

David Singer
Multimedia and Software Standards, Apple Inc.

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 5 Nov 2012 21:51:27 +0000

On 11.5.2012 11:45 , "David Singer" <[email-masked]> wrote:

>> They do deserve such, however not that lonely.    Cisco's declaration
>>was submitted previously, but against the wrong numbers (admin error).
>>Re-submission is underway and will have the same, royalty-free
>>commitment.  
>> 
>> The more pronounced observation is that most declarations have not been
>>not submitted yet in this still relatively young effort.
>
>Thanks
>
>Also, we are aware that some of the submissions were more nuanced, and
>the nuance is lost.  For example, at least one was 'RAND, but will be RF
>if compatibility with AVC/H.264 is preserved'.

To put this in context, ISO's patent policy (which is the same as the
ITU's) does not allow free-format declarations (like the IETF) where one
could express such nuances.  Instead, it has a fixed format for patent
right declarations.  A declarer can either check RAND, or RAND-Z (both
with an additional checkbox requiring reciprocity).  No deviations are
allowed.  

>Yes, MPEG is trying to get more details from the secretariat.

There are many ways to communicate support for a business model, and I'm
sure that MPEG will find one.  The official ISO declaration process is not
one of them.  According to that process, at this point, it's still 11:1
(or 11:2, given David Benham's comment) for RAND.

Stephan

>> To further connect dots, this part 29 effort in MPEG/IEC/ISO towards a
>>non-royalty bearing solution was mentioned in our draft below as a
>>potential upside to selecting H264/AVC constrained baseline profile
>>today.  Unfortunately, the outcome will not be known soon enough, but to
>>the extent future surprises weigh on our decision ... this one is
>>positive!
>> FWIW, there have been 11 IPR submissions into the ISO registry on
>>MPEG-4 part 29 to date; 1 of them specifies that the IPR is available on
>>a royalty free basis, 10 do not. Unless I miscounted.
>> 
>> The registry of IPR submissions is available at
>>http://www.iso.org/iso/standards_development/patents
>> 
>> 
>> 
>> 
>> 
>> 
>> Please find attached an incoming liaison statement from MPEG.  It's
>>short, and therefore attached.  For those not familiar with MPEG's
>>terminology: "AVC" stands for "Advanced Video Codec" and is used in
>>certain circles for what other people know as H.264, and sometimes,
>>depending on context, only for the non-scalable and non-multiview
>>profiles of H.264.  (H.264 is the ITU designation for the joint
>>standard).  MPEG-4 part 29, or WebVC is, as described in the statement,
>>what most people know as "constrained baseline H.264", i.e. H.264
>>baseline without the rarely used tools known as Arbitrary Slice Order,
>>Flexible Macroblock Order, and Redundant Slices.
>> Also, in order to avoid possible confusion, let me emphasize that this
>>liaison statement comes from the standardization body known as MPEG
>>(ISO/IEC JTC1/SC29/WG11 ) and not from the licensing administrator known
>>as MPEG-LA.
>> Regards,
>> Stephan
>> 
>> 
>>

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 5 Nov 2012 22:18:09 +0000

On 11.5.2012 11:38 , "David Benham (dbenham)" <[email-masked]> wrote:

>They do deserve such, however not that lonely.    Cisco's declaration was
>submitted previously, but against the wrong numbers (admin error).

Yes, it's a young effort.  But:
First, declarations against 14496-29 have been received over the course of
half  year now, by at least one third of the suspected (by me) baseline
rightholders.  Second, this is not a majority vote game, nor consensus
driven.  One solid patent of a determined rightholder is all that is
needed to kill a royalty free effort (which obviously goes for all
standards, including RF H.264 and VP8 and whatnot).  Third, a number of
the RAND declarations came from companies with very large known H.264
related portfolios, some of which are known to monetarize their portfolio
through licensing, through MPEG-LA or otherwise.  Fourth, and that's to me
the scariest, some of the RAND declarations come from companies which have
(to the best of my knowledge) not contributed to the -29 effort and,
therefore and arguably, are not even under an obligation to declare.  They
declared voluntarily, and that is really bad new for the -29 effort, IMO.

It's possible that the -29 process is being resurrected, and I know that a
number of people are working very hard on that.  Only time will tell.
However, for now, I believe the characterization of H.264 constrained
baseline being a royalty bearing standard is the only correct and
supported one.

Stephan

>FWIW, there have been 11 IPR submissions into the ISO registry on MPEG-4
>part 29 to date; 1 of them specifies that the IPR is available on a
>royalty free basis, 10 do not. Unless I miscounted.
>

---

From: "David Benham (dbenham)" <[email-masked]>
Date: Mon, 5 Nov 2012 23:20:31 +0000

>characterization of H.264 constrained baseline being a royalty bearing standard is the only correct and supported one.

Yes, and it was stated in our draft that this MPEG/ITU effort is a potential "future" upside.    The reality is we are going to have make estimates about the future of the alternative's royalty/IPR status, so this in-progress effort is worth noting too.    Also, your reply sounds like you're assuming that a RAND declaration means said patent holder will be asking for money and will not offer royalty free if they like the result -- that assumption doesn't necessarily hold, which I think is the main point  of Singer's post.

Considering how well known the patent situation is for H264/AVC, it is easier to be pessimistic and when less well known as with the alternative proposed, it is easier to be optimistic.   Although, it was interesting to read 'narrow margin' in W3C/Philippe's email to us, "(RF for HTML5) proposal was turned down by a narrow margin within the MPEG-LA membership"?     

> -----Original Message-----
> Sent: Monday, November 05, 2012 2:18 PM
> To: David Benham (dbenham); Harald Alvestrand; [email-masked]
> the scariest, some of the RAND declarations come from companies which
> have (to the best of my knowledge) not contributed to the -29 effort and,
> >Apple deserves to be commended for making a royalty-free commitment,
> but
> >it's a lonely position.
> >

---

From: David Singer <[email-masked]>
Date: Tue, 06 Nov 2012 09:29:13 +0100

As an example of the patent statements received, I am pleased to be able to forward the following from Fraunhofer HHI (forwarded with permission):

Begin forwarded message:

> Date: November 5, 2012 23:37:57 GMT+01:00
> 
> Dear all,
> 
> we, Fraunhofer HHI, have submitted a statement for IVCT that declares our IPR under condition 2 (RAND) of the ISO patent policy. However, we have also submitted an additional statement to ISO with the following contents (and I believe others did as well):
> 
> "In the event that the Patent Holder holds granted and/or pending applications for patents, the use of which would be required to implement the Constrained Baseline Profile proposed in N 12733 and the Constrained Baseline Profile is approved as the new proposed IVCT royalty-free Standard, Patent Holder is prepared to grant a Type 1 license comparable to option 1, including reciprocity and reservation of rights suboptions therein, of the Patent Statement and Licensing Declaration for ITU-T /ITU-R Recommendation and ISO/IEC Deliverable (FORM: 1 March 2007) for use in an internet video codec that implements solely the Constrained Baseline Profile, provided that all other patent holders do the same. The license would not extend to other Profiles or other implementations."
> 
> Hence, we support the process of creating a royalty-free Baseline Profile of H.264/MPEG4-AVC and we are optimistic that further progress will be achieved as the process continues.
> 
> Best regards,
> Thomas Wiegand
> ---
> Prof. Dr.-Ing. Thomas Wiegand
> Chair, Image Communication, TU Berlin, Sekr. EN-16, Einsteinufer 17
> Head, Image Processing Department, Fraunhofer HHI, Einsteinufer 37
> D-10587 Berlin, Germany

David Singer

---

From: Ron <[email-masked]>
Date: Wed, 7 Nov 2012 19:18:31 +1030

On Tue, Nov 06, 2012 at 09:29:13AM +0100, David Singer wrote:
> As an example of the patent statements received, I am pleased to be able to
> forward the following from Fraunhofer HHI (forwarded with permission):
> 
> Begin forwarded message:
> 
> > we, Fraunhofer HHI, have submitted a statement for IVCT that declares our
> > IPR under condition 2 (RAND) of the ISO patent policy. However, we have
> > also submitted an additional statement to ISO with the following contents
> > (and I believe others did as well):
> > 
> > "In the event that the Patent Holder holds granted and/or pending
> > applications for patents, the use of which would be required to implement
> > the Constrained Baseline Profile proposed in N 12733 and the Constrained
> > Baseline Profile is approved as the new proposed IVCT royalty-free
> > Standard, Patent Holder is prepared to grant a Type 1 license comparable to
> > option 1, including reciprocity and reservation of rights suboptions
> > therein, of the Patent Statement and Licensing Declaration for ITU-T /ITU-R
> > Recommendation and ISO/IEC Deliverable (FORM: 1 March 2007) for use in an
> > internet video codec that implements solely the Constrained Baseline
> > Profile, provided that all other patent holders do the same. The license
> > would not extend to other Profiles or other implementations."

Does "The license would not extend to ... other implementations" really mean
that they would licence *just* the reference implementation produced by that
group, and that any other implementation would still need a separate licence?

Not extending to other Profiles seems obvious enough - but not permitting
other implementations seems ...  limiting.

I know legalese likes to be ambiguous where that is in its favour, so it's
not clear if that is really the intent -- but it's not clear from this that
it is not either.

Can anyone clarify the actual intent of that language one way or the other?

  Cheers,
  Ron

---

From: Lazar Bivolarski <[email-masked]>
Date: Fri, 9 Nov 2012 21:55:14 -0800 (PST)

Hi Ron,

The best interpretation would have to be from Fraunhofer HHI.

My understanding of this statement, as a participant in the ISO 
Internet Video Coding project, is that the license is given to the
MPEG-4 Part 29 (WebVC) standard only, which is a royalty-free
standard and is equivalent to MPEG-4 AVC / H.264 Constrained
Baseline Profile.  

The language used in the Fraunhofer HHI's statement specifically
excludes the possibility of licensing their IP in other standards.

Regards,

Lazar.   

________________________________
 From: Ron <[email-masked]>
To: [email-masked] 
Sent: Wednesday, November 7, 2012 12:48 AM
Subject: Re: [rtcweb] Incoming liaison statement from MPEG

  Cheers,
  Ron

---

From: Ron <[email-masked]>
Date: Sat, 10 Nov 2012 21:45:17 +1030

Hi Lazar,

> The best interpretation would have to be from Fraunhofer HHI.

Yeah, I wasn't expecting that David could elaborate on that himself,
he was clear about just being the messenger, but I figure if people
here are in contact with them, we might be able to get a more direct
clarification about that - for both their benefit and ours.

> excludes the possibility of licensing their IP in other standards.

Right, that's what I understood the "other Profiles" exclusion to mean.
It was the "other implementations" addition to that which isn't quite
so clear to me.

By listing it separately I assume they mean something different to
"other Profiles" -- and the only 'obvious' interpretation I see at
present is that they would only be licencing the specific reference
implementation that the IVC group produced and not any other.

I'm hoping to be wrong about that though, since that would seem to
preclude being able to port it to other architectures if needed,
fix bugs if found, or to further optimise the code for specific
architectures to achieve acceptable performance on them.

The latter seems kind of important since it was stressed by some
folk in the Video Codec group discussion that a reference codec is
often a "toy" implementation, that is easy to read and perform
conformance tests with, but not really suitable for real world
real-time deployment.  Even a reasonably optimised one couldn't
really hope to be optimal for every architecture present and
future - so the ability to make "other implementations" of the
licenced Profile does seem fairly essential to it being usefully
RF rather than just ostensibly, but not very practically so.

Unless of course they mean something entirely different by the
word "implementation", which is the bit I was hoping somebody
might be able to shed some more light on for us -- since I do
accept that's also quite possible, it's just not something
that we can guess for ourselves in any meaningful way without
Fraunhofer HHI telling us what _they_ intended it to mean.

  Thanks,
  Ron

---

From: Harald Alvestrand <[email-masked]>
Date: Sat, 10 Nov 2012 22:17:06 +0100

> Fraunhofer HHI telling us what _they_ intended it to mean.

It wouldn't be totally unreasonable to assume that "implementation" 
refers to the phrase a little earlier: "for use in an internet video 
codec that implements solely the Constrained Baseline Profile" - that 
is, if the codec implements (for instance) full Baseline, you need a 
license from Fraunhofer, even if the difference between constrained 
Baseline and full Baseline is not covered by Fraunhofer's patents.

Of course, this is uninformed speculation. I have no idea what 
Fraunhofer's patents are; if they want to tell us more about what the 
license means, they'll tell us.

---

From: Lazar Bivolarski <[email-masked]>
Date: Sat, 10 Nov 2012 15:52:07 -0800 (PST)

Hi Harald,

Your interpretation is correct. The license is given to an "implementation" with  in this 

case means the new Internet Video Coding standard or MPEG-4:Part 29 (WebVC).

Just to clarify the license in IEC/ISO policies is not given to a reference software that
implements a particular standard's specification, but to the technology that is part of the 

text of the standard. Software implementing the standard should be developed and 

optimized from manufacturers implementing the standard. Reference code is provided
for a reference only. Common practice at IEC/ISO is bugs found in the reference code 

tobe fixed and accepted in the reference code by the participants.

Regards,

Lazar.    

________________________________
 From: Harald Alvestrand <[email-masked]>
To: [email-masked] 
Sent: Saturday, November 10, 2012 1:17 PM
Subject: Re: [rtcweb] Incoming liaison statement from MPEG