Subject: Re: [rtcweb] SVC

From: Bernard Aboba <[email-masked]>
Date: Tue, 16 Oct 2012 10:35:19 -0700

Some chipsets do support temporal scaling (search 'soc support for H.264/SVC'), and there are sw implementations that support temporal, quality and spatial scaling ( http://www.polycom.com/company/news/press-releases/2012/20121004.html).

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 18 Oct 2012 15:44:40 +0200

> Some chipsets do support temporal scaling (search 'soc support for H.264/SVC'), and there are sw implementations that support temporal, quality and spatial scaling ( http://www.polycom.com/company/…
I did search for what you suggested, but what came up seemed to be 
software running on System-on-a-chip processors (eInfochips' C library 
from 2009, an IEEE Explore article detailing an implementation running 
on a Linux system with a DSP). Your search results may be different.

These may have satisfactory performance - using DSPs for video codec 
tasks kind of blurs the distinction between "hardware implementation" 
and "software implementation". But I guess that the more the processors 
are general purpose, the less it matters which particular codec you 
choose to implement on them - so they become irrelevant to whether a 
particular codec has "hardware support".

                  Harald