Subject: [rtcweb] JSEP-02: Clone comments

From: Christer Holmberg <[email-masked]>
Date: Thu, 4 Oct 2012 13:25:56 +0200

Hi,

A couple of comments on the cloning stuff in JSEP:

Q1. The document doesn't say how the cloning is performed. If that is outside the scope of JSEP, and belongs to the W3C API spec, I think it should be mentioned.

Q2. The text in section 4.7.2 says:

                "As a result of this cloning, the application will end up with N
                parallel sessions, each with a local and remote description and their
                own local and remote addresses."

I think the "own local addresses" wording is a little misleading, as each clone will share the same local address.

Regards,

Christer

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 04 Oct 2012 13:32:31 +0200

On 10/04/2012 01:25 PM, Christer Holmberg wrote:
> Q1. The document doesn't say how the cloning is performed. If that is 
> outside the scope of JSEP, and belongs to the W3C API spec, I think it 
> should be mentioned.
>
> I think the "own local addresses" wording is a little misleading, as 
> each clone will share the same local address.
>

Not sure what to say here.

I can see multiple ways to implement this - some will end up with 
different local ports, some won't.

If the non-local (reflexive?) candidates are allocated using STUN on a 
per-port basis, addresses could be different too.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 4 Oct 2012 13:57:26 +0200

Hi,

>> Q1. The document doesn’t say how the cloning is performed. If that is outside the scope of JSEP, and belongs to the W3C API spec, I think it should be mentioned.
>>
>>                “As a result of this cloning, the application will end up with N
>>                own local and remote addresses.”
≫
>> I think the “own local addresses” wording is a little misleading, as each clone will share the same local address.
>
> I can see multiple ways to implement this - some will end up with different local ports, some won't.

Earlier in the same section, the text says:

        “Since the clone uses the same local description as its
        parent, creating a clone will fail if it is not possible to reserve
        the same resources for the clone as have already been reserved by the
        parent.”

> If the non-local (reflexive?) candidates are allocated using STUN on a per-port basis, addresses could be different too.

My assumption, and understanding of the text, is that a clone is a… eeeeh… clone - meaning that the local address is the same :)

Regards,

Christer

---

From: "Jim Barnett" <[email-masked]>
Date: Thu, 4 Oct 2012 05:47:30 -0700

If the local address isn’t the same, we shouldn’t call it a ‘clone’.  I think that people will expect everything to be the same on a ‘clone’.  

-          Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Thursday, October 04, 2012 7:57 AM
To: Harald Alvestrand; [email-masked]
Subject: Re: [rtcweb] JSEP-02: Clone comments

Hi,

≫

         parent.”

Regards,

Christer

---

From: Justin Uberti <[email-masked]>
Date: Thu, 11 Oct 2012 22:59:44 -0700

The preceding paragraph of 4.7.2 mentions that each clone may end up with
its own peer-reflexive candidates (as would be the case if the local NAT
was endpoint-dependent). So while the local addresses and
server-reflexive/relay addresses should be the same, the overall set of
local candidates for each clone may be different.

I will try to clarify this for the next draft.

On Thu, Oct 4, 2012 at 5:47 AM, Jim Barnett <[email-masked]>wrote:

> If the local address isn’t the same, we shouldn’t call it a ‘clone’.  I
> think that people will expect everything to be the same on a ‘clone’.  ***
> *
>
> ** **
>
> **-          **Jim******
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Christer Holmberg
> *Sent:* Thursday, October 04, 2012 7:57 AM
> *To:* Harald Alvestrand; [email-masked]
> *Subject:* Re: [rtcweb] JSEP-02: Clone comments****
>
> ** **
>
> Hi,****
>
>  ****
>
> >> A couple of comments on the cloning stuff in JSEP:****
>
> >>** **
>
> >> Q1. The document doesn’t say how the cloning is performed. If that is
> should be mentioned.****
> >> ****
> >> Q2. The text in section 4.7.2 says:****
>
> **>> ****
>
> >>                “As a result of this cloning, the application will end
> up with N****
>
> >>                parallel sessions, each with a local and remote
> description and their****
>
> >>                own local and remote addresses.”****
>
> ≫****
>
> >> I think the “own local addresses” wording is a little misleading, as
> each clone will share the same local address.****
>
> >** **
>
> > Not sure what to say here.****
>
> >** **
>
> different local ports, some won't.****
>
>  ****
>
> Earlier in the same section, the text says:****
>
>  ****
>
>         “Since the *clone uses the same local description as its*****
>
> *      &nb! sp;  parent*, creating a clone will fail if it is not
> possible to reserve****
>
>          the same resources for the clone as have already been reserved by
> the****
>
>          parent.”****
>
>  ****
>
> per-port basis, addresses could be different too.****
>
>  ****
>
> My assumption, and understanding of the text, is that a clone is a… eeeeh…
> clone – meaning that the local address is the same :)****
>
>  ****
>
> Regards,****
>
>  ****
>
> Christer****
>
>  ****
>
>  ****
>
>  ****
>
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>