Subject: Re: [rtcweb] Microsoft tells W3C and IETF what we are doing no signs of offering real world interoperability

From: Alexey Aylarov <[email-masked]>
Date: Mon, 06 Aug 2012 21:11:19 +0400

It was easy to expect from company which tries to build its own standards all the time instead of team work on open technologies. If they want to live in their own universe - it's their choice. We need to continue team work on the future of open web communications.

"Cullen Jennings (fluffy)" <[email-masked]> wrote:

>
>I see that Microsoft decided to wait until the W3C and IETF were close to done before putting together a proposal that, if accepted, would explode most the current works and create maximal delay on this work. 
>
>http://blogs.skype.com/en/2012/08/customizable_ubiquitous_real_t.html
>
>
>
>

---

From: Tim Panton <[email-masked]>
Date: Tue, 7 Aug 2012 11:57:39 +0200

Ok, the timing is unfortunate, but can you honestly say that we didn't know that this was skype/microsofts opinion? We just chose to ignore it because it was inconvenient. 

Now that it is out there, are we seriously going to ignore a document with _those_ authors from a major browser maker and a team with extensive experience in the field jus because it is late!?!? 

Tim, speaking for himself. 

Sent from my iPhone

On 6 Aug 2012, at 19:11, Alexey Aylarov <[email-masked]> wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Lorenzo Miniero <[email-masked]>
Date: Tue, 7 Aug 2012 14:21:58 +0200

On Tue, 7 Aug 2012 11:57:39 +0200

> Now that it is out there, are we seriously going to ignore a document with _those_ authors from a major browser maker and a team with extensive experience in the field jus because it is late!?!? 

An "unfortunately major" browser maker, I'd say, especially considering its well known history of poor adherence to standards (go tell the poor web developers out there), and this latest untimely post of theirs doesn't seem to change that. RTCWEB wasn't born yesterday, they've had more than a year to contribute, and claiming that a team at Microsoft can do better than 100s people contributing here and in the W3C seems a bit pretentious. I agree that the post probably contains some useful feedback, and ignoring it is unwise, but not it if that means changing too much on what we already have.

L.

-- 
Lorenzo Miniero, COB

Meetecho s.r.l.
Web Conferencing and Collaboration Tools
http://www.meetecho.com

---

From: "Jim Barnett" <[email-masked]>
Date: Tue, 7 Aug 2012 05:59:20 -0700

It seems to me that this proposal is a continuation of a discussion that
the group has been having for a while over how much to bake into the
browser.  JSEP leaves more to the application than ROAP did, and now
this proposal suggests moving even more into the application.  It seems
to me that the trade-off is clear, and doesn't  involve "openness": the
less we bake into the browser, the more flexibility the app developer
has, and the more work he has to do.  (To link this back to another
discussion we've been having, it has been suggested that thoughtless
developers might miss-use constraints. It seems to me that a developer
who can't use constraints correctly is unlikely to code the ICE state
machine correctly. So, are we worried about that kind of developer or
not?)  

Justin suggests that JSEP can provide the same flexibility that this
proposal does, at least to a sophisticated developer who understands how
to tweak it. Let's find out. I agree with Stefan that we should  draw up
a detailed list of differences and analyze them. At first glance, it
seems to me that many of the differences are independent of each other,
so that it is not a question of simply accepting or rejecting the entire
Microsoft proposal.

- Jim  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Alexey Aylarov
Sent: Monday, August 06, 2012 1:11 PM
To: Cullen Jennings (fluffy)
Cc: [email-masked] ; [email-masked]
Subject: Re: [rtcweb] Microsoft tells W3C and IETF what we are doing no
signs of offering real world interoperability

It was easy to expect from company which tries to build its own
standards all the time instead of team work on open technologies. If
they want to live in their own universe - it's their choice. We need to
continue team work on the future of open web communications.

"Cullen Jennings (fluffy)" <[email-masked]> wrote:

>
>I see that Microsoft decided to wait until the W3C and IETF were close
to done before putting together a proposal that, if accepted, would
explode most the current works and create maximal delay on this work.

---

From: Anant Narayanan <[email-masked]>
Date: Tue, 07 Aug 2012 17:43:02 -0700

> Now that it is out there, are we seriously going to ignore a document with _those_ authors from a major browser maker and a team with extensive experience in the field jus because it is late!?!?

I absolutely don't want to discount the extensive collective experience 
and knowledge of how RTC works that went behind the document - but I 
have a hard time treating this proposal as coming from a major browser 
vendor. A proposal from the team behind Skype or Lync is different from 
a proposal that comes from the IE team.

In particular, I strongly disagree with the statement that the existing 
proposal does not honor "key web tenets". As ekr wrote in his analysis, 
the web has moved away from a completely stateless model for a while 
now. In fact, PeerConnection is already more low-level than I would have 
preferred, especially when compared to the original proposal from Ian 
Hickson.

I don't fully grasp how the significantly more complex Javascript API 
proposed in the document is actually beneficial to the modern web as a 
whole.

-Anant

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 08 Aug 2012 17:57:19 +0200

> Now that it is out there, are we seriously going to ignore a document with _those_ authors from a major browser maker and a team with extensive experience in the field jus because it is late!?!?
Speaking with WG chair hat on:

At the time of previous "what is the appropriate level" discussion, the 
WG chairs concluded that there was a rough WG consensus to stay with a 
higher-level API rather than trying to move the level of the API 
downwards towards a "low level API".

Since that time and until this week, there has been no specific proposal 
to be evaluated, and the main proponents of such an  API have been 
silent. Normal behaviour is to assume that a previous consensus 
declaration stands until there is new technical evidence to be 
evaluated, and proceed with further work on that basis.

So I can't agree that "because it was inconvenient" is an appropriate 
characterization.

               Harald

---

From: Tim Panton <[email-masked]>
Date: Fri, 17 Aug 2012 20:22:42 +0100

Harald, I see from reviewing the archives that my reply to this didn't go in for some reason,
so I just want to put on the record that you are (of course) right. There was no specific proposal to
action, so there was nothing for the chairs to ignore.

The point I failed to make politely was that many of us knew informally that Skype/MS were not 
happy with the situation, so a document like this should not have been unexpected.

My apologies for my rudeness.

Tim.

On 8 Aug 2012, at 16:57, Harald Alvestrand wrote:

> At the time of previous "what is the appropriate level" discussion, the WG chairs concluded that there was a rough WG consensus to stay with a higher-level API rather than trying to move the level of the API downwards towards a "low level API".
> 
> Since that time and until this week, there has been no specific proposal to be evaluated, and the main proponents of such an  API have been silent. Normal behaviour is to assume that a previous consensus declaration stands until there is new technical evidence to be evaluated, and proceed with further work on that basis.
> 
> So I can't agree that "because it was inconvenient" is an appropriate characterization.
> 
>              Harald
> 
>

---

From: Tim Panton <[email-masked]>
Date: Fri, 17 Aug 2012 20:34:43 +0100

Tim.