Subject: [rtcweb] RTCWEB needs an Internet Codec

From: Alan Johnston <[email-masked]>
Date: Tue, 28 Aug 2012 22:41:48 -0500

The RTCWEB effort needs an Internet codec.  This is why Opus is the
right choice.  RTCWEB also needs one codec for backwards compatibility
with the VoIP world.  This is why G.711 is also the right choice.

Any G.mumble codec is NOT an Internet codec and will not have the same
performance on the Internet as one that was designed for the Internet!
 If anyone doesn't understand what that means, go back and examine the
CODEC Working Group archives to get educated.

If someone wants another codec instead of Opus, then they need to
propose another Internet codec.  Otherwise, we are not serving the
Internet.

- Alan -

---

From: Roman Shpount <[email-masked]>
Date: Wed, 29 Aug 2012 00:13:55 -0400

Not that I have anything against Opus, but what exactly makes Opus an
internet codec? What is internet codec anyway? Makes this all kind of a
meaningless argument.

I would argue that for my broadband internet connection G.722 is a perfect
internet codec. I do not care about bandwidth savings of Opus, and quality
wise, for the voice conversation, I cannot hear any difference.

I would argue G.711 should be the MTI codec. The rest can be left up to
browser implementers. We can argue all we want, but the best royalty free
low bitrate codec available will be the one everybody supports. We can
force it to be Opus, but even if we don't, it will still be Opus on its
merit alone. G.722 will probably end up being supported as well, since it
is free, pretty good quality, and easy to implement.

P.S. Not that I am arguing for it, I am surprised no one made a case for
iSAC, since it is also royalty free, low bit rate, and very high quality.
It is event named "internet Speech Audio Codec".
_____________
Roman Shpount

On Tue, Aug 28, 2012 at 11:41 PM, Alan Johnston
<[email-masked]>wrote:

> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>

---

From: Martin Taylor <[email-masked]>
Date: Wed, 29 Aug 2012 11:26:36 +0000

An Internet codec is one which was designed specifically to handle a significant level of packet loss.  The G.xxx series codecs were designed for circuit-switched environments where packet loss is a non-issue.

If you are not experiencing voice quality issues with G.722, then you are lucky enough to have a very low loss Internet connection.  We see frequent issues with G.722 when used for VoIP, especially over WiFi and upstream over ADSL.  Data traffic that competes with voice for bandwidth frequently causes choppy voice on these types of connection.  We have chosen to use SILK to deal with this issue, and this has resulted in major improvements in subjective voice quality.  SILK is one of the "ingredients" of Opus.

I believe that WebRTC applications which use Opus will deliver a far better user experience in general than those that use G.711 or G.722.  Whether that means Opus should be mandatory to implement is another matter.  In my view, it is only necessary to specify one MTI codec to ensure that there is a baseline for interop.  The market can decide what codecs it wishes to use to improve on this baseline interop.

Martin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roman Shpount
Sent: 29 August 2012 05:14
To: Alan Johnston
Cc: [email-masked]
Subject: Re: [rtcweb] RTCWEB needs an Internet Codec

Not that I have anything against Opus, but what exactly makes Opus an internet codec? What is internet codec anyway? Makes this all kind of a meaningless argument.

I would argue that for my broadband internet connection G.722 is a perfect internet codec. I do not care about bandwidth savings of Opus, and quality wise, for the voice conversation, I cannot hear any difference.

I would argue G.711 should be the MTI codec. The rest can be left up to browser implementers. We can argue all we want, but the best royalty free low bitrate codec available will be the one everybody supports. We can force it to be Opus, but even if we don't, it will still be Opus on its merit alone. G.722 will probably end up being supported as well, since it is free, pretty good quality, and easy to implement.

P.S. Not that I am arguing for it, I am surprised no one made a case for iSAC, since it is also royalty free, low bit rate, and very high quality. It is event named "internet Speech Audio Codec".
_____________
Roman Shpount

On Tue, Aug 28, 2012 at 11:41 PM, Alan Johnston <[email-masked]<mailto:[email-masked]>> wrote:
The RTCWEB effort needs an Internet codec.  This is why Opus is the
right choice.  RTCWEB also needs one codec for backwards compatibility
with the VoIP world.  This is why G.711 is also the right choice.

- Alan -
_______________________________________________
rtcweb mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Harald Alvestrand <[email-masked]>
Date: Wed, 29 Aug 2012 14:10:49 +0200

On 08/29/2012 06:13 AM, Roman Shpount wrote:
> internet codec? What is internet codec anyway? Makes this all kind of 
> a meaningless argument.
>
> I would argue that for my broadband internet connection G.722 is a 
> perfect internet codec. I do not care about bandwidth savings of Opus, 
> and quality wise, for the voice conversation, I cannot hear any 
> difference.
>
> I would argue G.711 should be the MTI codec. The rest can be left up 
> to browser implementers. We can argue all we want, but the best 
> royalty free low bitrate codec available will be the one everybody 
> supports. We can force it to be Opus, but even if we don't, it will 
> still be Opus on its merit alone. G.722 will probably end up being 
> supported as well, since it is free, pretty good quality, and easy to 
> implement.
>
> P.S. Not that I am arguing for it, I am surprised no one made a case 
> for iSAC, since it is also royalty free, low bit rate, and very high 
> quality. It is event named "internet Speech Audio Codec".

Google, after considering both, would prefer that Opus be the standard.

At high bandwidth / bitrate, Opus is operating in CELT mode, which 
outperforms iSAC.

---

From: <[email-masked]>
Date: Thu, 30 Aug 2012 14:11:56 +0000

>An Internet codec is one which was designed specifically to handle a significant level of packet loss.  The G.xxx series codecs were designed for circuit-switched environments where packet loss is a…

Looking at the draft "Summary of Opus listening test results" which is supposed to "examine listening test results obtained for the Opus codec and how they relate to the requirements" I cannot see unfortunately any result on OPUS performance with packet losses and jitter nor any other result on any real measured usage over internet, especially for the intended usage in "full band"... So, I don't know exactly to what extent and with respect to what test results and what related requirement OPUS would be more an "internet codec" than other G.xxx codecs that have been already and successfully experienced over internet for years (at least with respect to this "packet loss" robustness criterion). Furthermore, some key features that enhance any voice codec performance for usage over internet are anyway outside the codec itself.

Stephane

De : [email-masked] [mailto:[email-masked]] De la part de Martin Taylor
Envoyé : mercredi 29 août 2012 13:27
À : [email-masked]
Objet : Re: [rtcweb] RTCWEB needs an Internet Codec

Martin

On Tue, Aug 28, 2012 at 11:41 PM, Alan Johnston <[email-masked]> wrote:

- Alan -

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Martin Taylor <[email-masked]>
Date: Thu, 30 Aug 2012 14:35:55 +0000

> I cannot see unfortunately any result on OPUS performance with packet losses

I suggest you read section 2.1 of http://tools.ietf.org/html/draft-valin-codec-results-00

Admittedly this test related to SILK rather than to Opus, but Opus inherits the characteristics of SILK as it relates to performance under conditions of packet loss.

Martin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: 30 August 2012 15:12
To: Martin Taylor; [email-masked]
Subject: RE: [rtcweb] RTCWEB needs an Internet Codec

Stephane

De : [email-masked] [mailto:[email-masked]] De la part de Martin Taylor Envoyé : mercredi 29 août 2012 13:27 À : [email-masked] Objet : Re: [rtcweb] RTCWEB needs an Internet Codec

Martin

P.S. Not that I am arguing for it, I am surprised no one made a case for iSAC, since it is also royalty free, low bit rate, and very high quality. It is event named "internet Speech Audio Codec".
_____________
Roman Shpount
On Tue, Aug 28, 2012 at 11:41 PM, Alan Johnston <[email-masked]> wrote:
The RTCWEB effort needs an Internet codec.  This is why Opus is the right choice.  RTCWEB also needs one codec for backwards compatibility with the VoIP world.  This is why G.711 is also the right choice.

Any G.mumble codec is NOT an Internet codec and will not have the same performance on the Internet as one that was designed for the Internet!
 If anyone doesn't understand what that means, go back and examine the CODEC Working Group archives to get educated.

If someone wants another codec instead of Opus, then they need to propose another Internet codec.  Otherwise, we are not serving the Internet.

- Alan -

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.