Subject: Re: [rtcweb] Confirmation of consensus on audio codecs

From: Lorenzo Miniero <[email-masked]>
Date: Fri, 17 Aug 2012 07:12:50 +0300

+1 on this.

Lorenzo

Bernard Aboba <[email-masked]> ha scritto:

>I also support the selection of OPUS and G.711 as MTI. G.722 can be a SHOULD; it is widely supported.
>
>
>
>On Aug 16, 2012, at 4:24 PM, "Richard Shockey" <[email-masked]> wrote:
>
>> Reading this list is occasionally an act of torture banned by several
>> conventions ..but since you ask.
>> 
>> I completely support the selection of Opus and G.711 as mandatory to
>> implement audio codec's ..however I'm very very open minded about supporting
>> G.722. It has it merits.  It should be totally obvious to most that if you
>> even think about interconnecting to public E.164 networks the default option
>> for VoLTE and Enterprise Voice networks is going to be G.722. 
>> 
>> If it is your goal to create globally useful stove pipes fine,  but
>> interconnection with existing carrier real time networks is IMHO a rational
>> goal. 
>> 
>> As for Video .. for goodness sakes just get over it people. H.264 is totally
>> implemented everywhere on the planet Earth. So what about the intellectual
>> property problems. It's not like VP8 doesn't have problems either. 
>> 
>> I'll save my comments about the SDP offer/answer issue for another day. 
>> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf Of
>> Cullen Jennings (fluffy)
>> Sent: Thursday, August 16, 2012 1:16 PM
>> To: [email-masked]
>> Subject: [rtcweb] Confirmation of consensus on audio codecs
>> 
>> 
>> At the last meeting we took a hum on selecting Opus and G.711 as the
>> mediatory to implement audio codecs. If there is any new opinions please
>> send them to the list by August 30th, after which the chairs will make a
>> determination of consensus.
>> 
>> Thanks,
>> Cullen
>> 
>> Please note that the following IPR disclosure have been made on these
>> codecs. They can be found at 
>> 
>> http://datatracker.ietf.org/ipr/
>> 
>> 
>> 2010-11-07    
>> . ID # 1445
>> "Broadcom Corporation's Statement about IPR related to
>> draft-ietf-codec-opus-00 and draft-ietf-codec-description-00 (1)"
>> 2010-11-07    
>> . ID # 1446
>> "Xiph.Org Foundation's Statement about IPR related to
>> draft-ietf-codec-opus-00"
>> 2010-11-12    
>> . ID # 1447
>> "Broadcom Corporation's Statement about IPR related to
>> draft-ietf-codec-opus-00 and draft-ietf-codec-description-00 (2)"
>> 2011-03-23    
>> . ID # 1520
>> "Qualcomm Incorporated's Statement about IPR related to
>> draft-ietf-codec-opus-05"
>> 2011-03-27    
>> . ID # 1524
>> "Xiph.Org Foundation's Statement about IPR related to
>> draft-ietf-codec-opus-05"
>> 2011-03-29    
>> . ID # 1526
>> "Broadcom Corporation's Statement about IPR related to
>> draft-ietf-codec-opus-05"
>> 2011-03-29    
>> . ID # 1525
>> "Skype Limited's Statement about IPR related to draft-ietf-codec-opus-05"
>> 2011-07-23    
>> . ID # 1602
>> "Skype Limited's Statement about IPR related to draft-ietf-codec-opus-07"
>> 2012-01-25    
>> . ID # 1670
>> "Microsoft Corporation's Statement about IPR related to
>> draft-ietf-codec-opus-10"
>> 2012-03-12    
>> . ID # 1712
>> "Huawei Technologies Co.,Ltd's Statement about IPR related to
>> draft-ietf-codec-opus-11 (1)"
>> 2012-04-02    
>> . ID # 1741
>> "Huawei Technologies Co.,Ltd's Statement about IPR related to
>> draft-ietf-codec-opus-11 (2)"
>> 
>> 
>> 
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
>> 
>> _______________________________________________
>> rtcweb mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtcweb
>_______________________________________________
>rtcweb mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Randall Gellens <[email-masked]>
Date: Wed, 29 Aug 2012 09:25:53 -0700

At 7:26 PM +0000 8/28/12, <[email-masked]>
wrote:

We do not recommend Opus to be taken as a
mandatory codec for RTCWeb at this point. From high quality low bit
rate and mobile applications point of view the 3GPP AMR-WB codec (also
known as ITU-T G.722.2) is the most preferable for us. For
interoperability with implementations restricted to unencumbered
codecs, we prefer G.711 and G.722.

Mandating only G.711 provides a floor to prevent total failure to
negotiate codecs, while allowing implementations to support whichever
codecs make sense in their environments.

At 8:39 PM -0700 8/21/12, Ted Hardie <ted.ietf at gmail.com>
wrote:

the fundamental design of RTCWEB allows
for the

negotiation of any codec mutually
supported.  The decision to chose a

Mandatory-to-implement was not made to eliminate other choices, but
to

eliminate interoperability failures by ensuring that at least
one

common codec is always
available.

I think this is a key point.  Codecs should be mandated only
to prevent negotiation failure, not to guarantee ideal performance,
especially in light of Ted's next statement:

At 8:39 PM -0700 8/21/12, Ted Hardie <ted.ietf at gmail.com>
wrote:

the group presumes that codec support
does not

come from the downloadable Javascript
application, but from the

application environment into which it is
downloaded (commonly a

browser or mobile environment using similar technology).
Promoting

support for those environments to have access to codecs supported
by

the underlying hardware is the best way to further this goal, at
least

in my personal opinion.

This makes a lot of sense. Especially on mobile devices, natively
supported codecs are likely to have optimized performance within the
operating environment (e.g., mobile device and cellular
channel).

--

Randall Gellens

Opinions are personal;    facts are
suspect;    I speak for myself only

-------------- Randomly selected tag: ---------------

#Random Tag

--

Randall Gellens

Opinions are personal;    facts are
suspect;    I speak for myself only

-------------- Randomly selected tag: ---------------

When you're young, you look at television and think, There's a

conspiracy. The networks have conspired to dumb us down. But when

you get a little older, you realize that's not true. The networks

are in business to give people exactly what they want. That's a

far more depressing thought. Conspiracy is optimistic! You can

shoot the bastards! We can have a revolution! But the networks

are really in business to give people what they want. It's the

truth.              --Steve Jobs, Wired Magazine, February 1996