Subject: [rtcweb] Ericsson's position on codecs

From: Bo Burman <[email-masked]>
Date: Tue, 24 Jul 2012 11:42:12 +0200

Hi,

The question of which codecs that should be supported in WebRTC [RTCWEB WG] has been discussed a long time with good opinions from different viewpoints. It will again be a subject in the Vancouver meeting and therefore we feel a need to recap Ericsson's position.

We believe that H.264 video codec should be a mandatory codec (at least one of what may be several): it is a good video codec, backed by a large vendor community and with a considerable footprint in end points. The patent landscape and the licensing situation is well known by now, which is nice in itself. Also, H.264 support is a requirement in some regulatory frameworks, such as emergency services, and we feel it would be preferable if WebRTC media framework can step-by-step consider such requirements, starting with the video codec.

Looking into the future a bit, we see H.265/HEVC video codec as a strong candidate to include in the default set, but we think it is too early to mandate it at this point. 

For audio, the situation is that we believe G.719 has a role for high quality audio in areas with no bandwidth restrictions or limited/no risk of blocking (packet loss or dropped connection). AMR narrow-band is playing a key role in mobile telephony and has a huge footprint. This makes it a candidate for being a default codec (one of them) for audio streams in mobile WebRTC implementations.

There is also a need for a high quality voice codec for situations with varying bandwidth, and we recognize that Opus is a candidate. We would however for the future also like to recommend that IETF include AMR-WB and EVS, since we expect them to be available in mobile chipsets.

This is written in absence of my colleagues who are more close to the codec technologies and who, had they been available and not on vacation, surely would have written the above in a better way. However, we hope it serves the intended purpose, namely to clarify Ericsson's position in the IETF WebRTC codec selection discussion.

Best Regards

Bo Burman

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7141311
Färögatan 6                 | Mobile +46 73 0949021
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 24 Jul 2012 12:47:27 +0200

Hi,

Regarding the video codec, do we have a "plan B"? For example:

- "No mandatory video codec"
- "VP8 ONLY as mandatory"
- "VP8 AND H264 as mandatory"
- ...

The reason I ask is because, at this moment, I don't think making only H.264 mandatory will fly. At least I have not seen any new input which would raise the odds for being able to agree on such way forward.

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Bo Burman [[email-masked]]
Sent: Tuesday, July 24, 2012 12:42 PM
To: [email-masked]
Subject: [rtcweb] Ericsson's position on codecs

Hi,

Best Regards

Bo Burman

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7141311
Färögatan 6                 | Mobile +46 73 0949021
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------
_______________________________________________
rtcweb mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtcweb

---

From: Roman Shpount <[email-masked]>
Date: Tue, 24 Jul 2012 08:40:30 -0400

I would like to note that AMR, EVS, and AMR-WB would require royalty
payments for their use. G.719 has a license agreement that is not always
acceptable for open source projects. I am not sure that either would
provide better quality then OPUS at similar bandwidths. Because of this I
would sincerely hope that none of those codecs are required.
_____________
Roman Shpount

On Tue, Jul 24, 2012 at 5:42 AM, Bo Burman <[email-masked]> wrote:

> Hi,
>
> The question of which codecs that should be supported in WebRTC [RTCWEB
> WG] has been discussed a long time with good opinions from different
> viewpoints. It will again be a subject in the Vancouver meeting and
> therefore we feel a need to recap Ericsson's position.
>
> We believe that H.264 video codec should be a mandatory codec (at least
> one of what may be several): it is a good video codec, backed by a large
> vendor community and with a considerable footprint in end points. The
> patent landscape and the licensing situation is well known by now, which is
> nice in itself. Also, H.264 support is a requirement in some regulatory
> frameworks, such as emergency services, and we feel it would be preferable
> if WebRTC media framework can step-by-step consider such requirements,
> starting with the video codec.
>
> Looking into the future a bit, we see H.265/HEVC video codec as a strong
> candidate to include in the default set, but we think it is too early to
> mandate it at this point.
>
> For audio, the situation is that we believe G.719 has a role for high
> quality audio in areas with no bandwidth restrictions or limited/no risk of
> blocking (packet loss or dropped connection). AMR narrow-band is playing a
> key role in mobile telephony and has a huge footprint. This makes it a
> candidate for being a default codec (one of them) for audio streams in
> mobile WebRTC implementations.
>
> There is also a need for a high quality voice codec for situations with
> varying bandwidth, and we recognize that Opus is a candidate. We would
> however for the future also like to recommend that IETF include AMR-WB and
> EVS, since we expect them to be available in mobile chipsets.
>
> This is written in absence of my colleagues who are more close to the
> codec technologies and who, had they been available and not on vacation,
> surely would have written the above in a better way. However, we hope it
> serves the intended purpose, namely to clarify Ericsson's position in the
> IETF WebRTC codec selection discussion.
>
> Best Regards
>
> Bo Burman
>

---

From: Maire Reavy <[email-masked]>
Date: Tue, 24 Jul 2012 13:35:05 -0400

On 7/24/2012 8:40 AM, Roman Shpount wrote:
> payments for their use. G.719 has a license agreement that is not 
> always acceptable for open source projects. I am not sure that either 
> would provide better quality then OPUS at similar bandwidths. Because 
> of this I would sincerely hope that none of those codecs are required.
+1.  OPUS is a better solution and the only one I hope we mandate (other 
than G.711).

Regarding video: H.264 requires royalty payments and agreements as well, 
and so mandating H.264 is *extremely* problematic for open-source groups 
and distributions (not just open-source browsers). It makes open-source 
use of WebRTC virtually impossible without violating the spec (by not 
implementing a mandatory codec).

-Maire

>
>
> On Tue, Jul 24, 2012 at 5:42 AM, Bo Burman <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     The question of which codecs that should be supported in WebRTC
>     [RTCWEB WG] has been discussed a long time with good opinions from
>     different viewpoints. It will again be a subject in the Vancouver
>     meeting and therefore we feel a need to recap Ericsson's position.
>
>     We believe that H.264 video codec should be a mandatory codec (at
>     least one of what may be several): it is a good video codec,
>     backed by a large vendor community and with a considerable
>     footprint in end points. The patent landscape and the licensing
>     situation is well known by now, which is nice in itself. Also,
>     H.264 support is a requirement in some regulatory frameworks, such
>     as emergency services, and we feel it would be preferable if
>     WebRTC media framework can step-by-step consider such
>     requirements, starting with the video codec.
>
>     Looking into the future a bit, we see H.265/HEVC video codec as a
>     strong candidate to include in the default set, but we think it is
>     too early to mandate it at this point.
>
>     For audio, the situation is that we believe G.719 has a role for
>     high quality audio in areas with no bandwidth restrictions or
>     limited/no risk of blocking (packet loss or dropped connection).
>     AMR narrow-band is playing a key role in mobile telephony and has
>     a huge footprint. This makes it a candidate for being a default
>     codec (one of them) for audio streams in mobile WebRTC
>     implementations.
>
>     There is also a need for a high quality voice codec for situations
>     with varying bandwidth, and we recognize that Opus is a candidate.
>     We would however for the future also like to recommend that IETF
>     include AMR-WB and EVS, since we expect them to be available in
>     mobile chipsets.
>
>     This is written in absence of my colleagues who are more close to
>     the codec technologies and who, had they been available and not on
>     vacation, surely would have written the above in a better way.
>     However, we hope it serves the intended purpose, namely to clarify
>     Ericsson's position in the IETF WebRTC codec selection discussion.
>
>     Best Regards
>
>     Bo Burman
>
>     <tel:%2B46%2010%207141311>
>     <tel:%2B46%2073%200949021>
>     <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

-- 
Maire Reavy<[email-masked]>, <[email-masked]>
Sr Product Manager, Media
Mozilla