Subject: [rtcweb] FW: New Version Notification for draft-isomaki-rtcweb-mobile-00.txt

From: <[email-masked]>
Date: Mon, 9 Jul 2012 15:14:01 +0000

Hi,

I have for time to time raised particular issues for WebRTC related to mobile networks. Now I found some time to collect most of them into a single document. The draft below discusses what are in my opinion the most notable topics for WebRTC adoption in mobile devices and networks (especially cellular). The -00 version misses all references and was written in a haste, but I hope it is useful to make sure these topics do get enough attention. 

The main topics covered are related to power consumption (for both "signaling" and "media"), interface switching and congestion avoidance.

Regards,
	Markus 

>-----Original Message-----
>From: ext [email-masked] [mailto:[email-masked]]
>Sent: 09 July, 2012 17:48
>To: Isomaki Markus (Nokia-CIC/Espoo)
>Subject: New Version Notification for draft-isomaki-rtcweb-mobile-00.txt
>
>
>A new version of I-D, draft-isomaki-rtcweb-mobile-00.txt
>has been successfully submitted by Markus Isomaki and posted to the IETF
>repository.
>
>Filename:	 draft-isomaki-rtcweb-mobile
>Revision:	 00
>Title:		 RTCweb Considerations for Mobile Devices
>Creation date:	 2012-07-09
>WG ID:		 Individual Submission
>Number of pages: 10
>URL:             http://www.ietf.org/internet-drafts/draft-isomaki-rtcweb-mobile-
>00.txt
>Status:          http://datatracker.ietf.org/doc/draft-isomaki-rtcweb-mobile
>Htmlized:        http://tools.ietf.org/html/draft-isomaki-rtcweb-mobile-00
>
>
>Abstract:
>   Web Real-time Communications (WebRTC) aims to provide web-based
>   applications real-time and peer-to-peer communication capabilities.
>   In many cases those applications are run in mobile devices connected
>   to different types of mobile networks.  This document gives an
>   overview of the issues and challenges in implementing and deploying
>   WebRTC in mobile environments.  It also gives guidance on how to
>   overcome those challenges.
>
>
>
>
>The IETF Secretariat

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 9 Jul 2012 14:09:59 -0700

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Monday, July 09, 2012 8:14 AM
> To: [email-masked]
> Subject: [rtcweb] FW: New Version Notification for draft-isomaki-
> rtcweb-mobile-00.txt
> 
> Hi,
> 
> I have for time to time raised particular issues for WebRTC related to
> mobile networks. Now I found some time to collect most of them into a
> single document. The draft below discusses what are in my opinion the
> most notable topics for WebRTC adoption in mobile devices and networks
> (especially cellular). The -00 version misses all references and was
> written in a haste, but I hope it is useful to make sure these topics
> do get enough attention.
> 
> The main topics covered are related to power consumption (for both
> "signaling" and "media"), interface switching and congestion avoidance.

Both Section 3.1, "Persistent connectivity to the Calling Site", and
Section 3.2, "Media and Data channels", discuss the problem of frequent
TCP or UDP messages that are sent solely to keep firewall pinholes 
or NAT mappings alive.  

PCP (draft-ietf-pcp-base) would be useful to reduce those messages.

Section 3.3, "Recovery from interface switching" discusses RTP flows
(and other things).  RTP and SCTP-over-UDP flows can benefit from
MICE, http://tools.ietf.org/html/draft-wing-mmusic-ice-mobility

-d

---

From: Martin Thomson <[email-masked]>
Date: Mon, 9 Jul 2012 14:13:16 -0700

On 9 July 2012 14:09, Dan Wing <[email-masked]> wrote:
> [...]  RTP and SCTP-over-UDP flows can benefit from

That draft is light on detail in the critical section.  I assume that
the conclusion is that there is no need to do anything special, just
to do something right (i.e., ICE).

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 9 Jul 2012 14:18:10 -0700

> From: Martin Thomson [mailto:[email-masked]]
> Sent: Monday, July 09, 2012 2:13 PM
> To: Dan Wing
> Cc: [email-masked]; [email-masked]
> Subject: Re: [rtcweb] FW: New Version Notification for draft-isomaki-
> rtcweb-mobile-00.txt
> 
> That draft is light on detail in the critical section. 

Yes, we wrote the TURN section first and it has the most detail.
We will add detail for ICE in -01.  Our apologies.

> I assume that

Correct.

ICE already allows the endpoints to have SDP m=/c=/a=candidate lines
that disagree regarding their IP addresses and ports.  ICE allows that
because some network topologies cause the endpoint to be unaware of 
how packets are forwarded and the location of NATs corresponding to
location of STUN servers (or however else the endpoint learns public
mappings, e.g., UPnP IGD, PCP, or proprietary mechanisms).  

So, "just do that" is what the ICE section of 
draft-wing-mmusic-ice-mobility will say.

-d

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 16 Jul 2012 15:26:22 -0700

...
> draft-wing-mmusic-ice-mobility will say.

We just submitted http://tools.ietf.org/html/draft-wing-mmusic-ice-mobility-01 which has a more detailed Section 3 on mobility with ICE.

-d