Subject: [rtcweb] Should we also make G.722 a mandatory to implement codec?

From: Roman Shpount <[email-masked]>
Date: Mon, 30 Jul 2012 13:21:58 -0400

Should we consider adding G.722 as a mandatory to implement audio codec? It
is low complexity and carries no royalty or license restrictions, it is
very good quality for voice audio communications at the same bandwidths as
G.711, and it is very widely implemented by the desktop IP phones.
_____________
Roman Shpount

On Sun, Jul 29, 2012 at 11:14 PM, Cameron Byrne <[email-masked]> wrote:

>
> On Jul 29, 2012 8:13 PM, "Ralph Giles" <[email-masked]> wrote:
> >
> > On 12-07-29 6:44 PM, Maire Reavy wrote:
> >
> > > Mandating encumbered codecswould force open-source projects to violate
> > > the spec (by not implementing a mandatory codec).  For this reason and
> > > the reasons Justin cites, we believe Opus, G.711 and VP8 are the best
> > > mandatory-to-implement choices for the spec.
> >
> > +1
> >
> >  -r
> >
>
> +1
>
> CB
>
> >
> > _______________________________________________
> > rtcweb mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/rtcweb
>
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>
>

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Mon, 30 Jul 2012 13:48:52 -0500

On 07/30/2012 12:21 PM, Roman Shpount wrote:
> Should we consider adding G.722 as a mandatory to implement audio codec?
> It is low complexity and carries no royalty or license restrictions, it
> is very good quality for voice audio communications at the
> same bandwidths as G.711, and it is very widely implemented by the
> desktop IP phones.

I would certainly support making G.722 mandatory to implement.

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
Jabber: [email-masked] | SIP: [email-masked] | Skype: kpfleming
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at www.digium.com & www.asterisk.org