Subject: [rtcweb] Reg retransmissions using JSEP approach.

From: kiran kumar <[email-masked]>
Date: Sat, 9 Jun 2012 16:56:06 +0530

Hi all,

I am new to this list, so please don't mind if I am repeating the same
question, if it has already discussed in this list.

My doubt is regarding how JSEP style of implementation will differentiate
the retransmission of messges with out ROAP.

According to few mails and discussion lists, It is specified that ROAP is
going to be replaced by JSEP.
But in updated JSEP draft an example with ROAP is also provided.

If ROAP is going to be replaced by JSEP, which part of JSEP will
differentiate the retransmitted offers.
ROAP is having "seq" field to differentiate it.
Is that part going to be completely left to the application protocol ?

Thanks,
Kiran.

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Sat, 9 Jun 2012 18:34:51 +0000

Hi Kiran,

As per JSEP, it is left to the application protocol. The application protocol shall have "seq" field equivalent to differentiate the retransmitted offers.

Thanks
Partha

From: [email-masked] [mailto:[email-masked]] On Behalf Of kiran kumar
Sent: Saturday, June 09, 2012 4:56 PM
To: [email-masked]
Subject: [rtcweb] Reg retransmissions using JSEP approach.

Hi all,

I am new to this list, so please don't mind if I am repeating the same question, if it has already discussed in this list.

My doubt is regarding how JSEP style of implementation will differentiate the retransmission of messges with out ROAP.

According to few mails and discussion lists, It is specified that ROAP is going to be replaced by JSEP.
But in updated JSEP draft an example with ROAP is also provided.

If ROAP is going to be replaced by JSEP, which part of JSEP will differentiate the retransmitted offers.
ROAP is having "seq" field to differentiate it.
Is that part going to be completely left to the application protocol ?

Thanks,
Kiran.

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 10 Jun 2012 10:21:47 -0400

> Is that part going to be completely left to the application protocol ?

Yes, I think the idea i the application would have to deal with that. It probably needs to keep track of the keeping between the offer / answers to the seq number too so that if an offer is rejected and it rolls back to reg previous offer, it has that offer so it can roll back. At the same time browser implementation  also need to keep track of the various offers so they can roll back. More text is needed in the drafts on all this.

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 10 Jun 2012 23:47:00 +0200

An implementation of ROAP on top of JSEP (-00) is available here:

http://code.google.com/p/webrtc-samples/source/browse/#svn%2Ftrunk%2Froap-jsep

One of the areas in which it is incomplete is retransmissions....

On 06/10/2012 04:21 PM, Cullen Jennings wrote:
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: kiran kumar <[email-masked]>
Date: Mon, 11 Jun 2012 09:59:36 +0530

Thanks for your quick respnse,

Thanks,
Kiran.

On Sun, Jun 10, 2012 at 7:51 PM, Cullen Jennings <[email-masked]> wrote:

> > My doubt is regarding how JSEP style of implementation will
> differentiate the retransmission of messges with out ROAP.
> >
> Yes, I think the idea i the application would have to deal with that. It
> probably needs to keep track of the keeping between the offer / answers to
> the seq number too so that if an offer is rejected and it rolls back to reg
> previous offer, it has that offer so it can roll back. At the same time
> browser implementation  also need to keep track of the various offers so
> they can roll back. More text is needed in the drafts on all this.
>
>

---

From: kiran kumar <[email-masked]>
Date: Mon, 11 Jun 2012 09:59:59 +0530

Thanks for your quick response,

Thanks,
Kiran.

On Sun, Jun 10, 2012 at 12:04 AM, Ravindran, Parthasarathi <
[email-masked]> wrote:

>  Hi Kiran,****
>
> ** **
>
> As per JSEP, it is left to the application protocol. The application
> protocol shall have “seq” field equivalent to differentiate the
> retransmitted offers.****
>
> ** **
>
> Thanks****
>
> Partha****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *kiran kumar
> *Sent:* Saturday, June 09, 2012 4:56 PM
> *To:* [email-masked]
> *Subject:* [rtcweb] Reg retransmissions using JSEP approach.****
>
> ** **
>
> Hi all,****
>
>  ****
>
> question, if it has already discussed in this list.****
>
>  ****
>
> the retransmission of messges with out ROAP.****
>
>  ****
>
> going to be replaced by JSEP.****
>
> But in updated JSEP draft an example with ROAP is also provided.****
>
>  ****
>
> differentiate the retransmitted offers.****
>
> ROAP is having "seq" field to differentiate it.****
>
> Is that part going to be completely left to the application protocol ?****
>
>  ****
>
>  ****
>
> Thanks,****
>
> Kiran.****
>
>  ****
>