Subject: Re: [rtcweb] authenticating against IMS HSS/HLR

From: Cullen Jennings <[email-masked]>
Date: Fri, 1 Jun 2012 10:39:35 -0600

I'm interested in this use case. 

It seems like if the the use of the work happening in [email-masked] to access things like SIM cards, combined with the Identity Proxy work here, might be able to solve a use case like this without any private information leaving the SIIM card. I've got no concrete idea on how to do this but seems like it might be possible...

Cullen

On May 29, 2012, at 11:02 AM, Cameron Byrne wrote:

> Is there yet a pointer on how a SIM / IMS based identity will work
> with the webRTC web server for authentication?
> 
> I think the obvious approach is for the SIM secret key to be bound to
> a username / password on the web server, and the web server proxies
> the authentication and registration into IMS (if you give me the right
> username credentials via the web, i will register you into IMS with
> the secret key), but that requires the undesirable step of exposing
> the SIM secret key to the web server or someplace outside the HSS/HLR
> for binding with the username password.
> 
> Thoughts?  Pointers?
> 
> Thanks,
> 
> CB
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 1 Jun 2012 13:40:42 -0400

+1 

WebCrypto is accepting use cases now, and this would be a good one.

--Richard